<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png">
<link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/" />
<link rel="pingback" href="https://ostechnix.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->

<title>How To List The Members Of A Group In Linux - OSTechNix</title><link rel="stylesheet" href="https://ostechnix.com/wp-content/cache/min/1/915e3013d71b2d39401c34c18da52b9f.css" media="all" data-minify="1" />
<meta name="description" content="This tutorial explains different ways to find and list all groups and list the members of a group in Linux and Unix-like operating systems." />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How To List The Members Of A Group In Linux - OSTechNix" />
<meta property="og:description" content="This tutorial explains different ways to find and list all groups and list the members of a group in Linux and Unix-like operating systems." />
<meta property="og:url" content="https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/" />
<meta property="og:site_name" content="OSTechNix" />
<meta property="article:publisher" content="https://www.facebook.com/ostechnix/" />
<meta property="article:author" content="ostechnix" />
<meta property="article:published_time" content="2021-02-26T13:02:34+00:00" />
<meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2021/02/List-The-Members-Of-A-Group-In-Linux.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@ostechnix" />
<meta name="twitter:site" content="@ostechnix" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="sk">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="7 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ostechnix.com/#organization","name":"OSTechNix","url":"https://ostechnix.com/","sameAs":["https://www.facebook.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","@id":"https://ostechnix.com/#logo","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2016/10/OSTechNix_280915-01.png","width":3333,"height":1667,"caption":"OSTechNix"},"image":{"@id":"https://ostechnix.com/#logo"}},{"@type":"WebSite","@id":"https://ostechnix.com/#website","url":"https://ostechnix.com/","name":"OSTechNix","description":"Open Source | Technology | Linux And Unix","publisher":{"@id":"https://ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://ostechnix.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#primaryimage","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2021/02/List-The-Members-Of-A-Group-In-Linux.png","width":1200,"height":800,"caption":"How To List The Members Of A Group In Linux"},{"@type":"WebPage","@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#webpage","url":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/","name":"How To List The Members Of A Group In Linux - OSTechNix","isPartOf":{"@id":"https://ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#primaryimage"},"datePublished":"2021-02-26T13:02:34+00:00","dateModified":"2021-02-26T13:02:34+00:00","description":"This tutorial explains different ways to find and list all groups and list the members of a group in Linux and Unix-like operating systems.","breadcrumb":{"@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/"]}]},{"@type":"BreadcrumbList","@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://ostechnix.com/","url":"https://ostechnix.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/","url":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/","name":"How To List The Members Of A Group In Linux"}}]},{"@type":"Article","@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#article","isPartOf":{"@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#webpage"},"author":{"@id":"https://ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a"},"headline":"How To List The Members Of A Group In Linux","datePublished":"2021-02-26T13:02:34+00:00","dateModified":"2021-02-26T13:02:34+00:00","mainEntityOfPage":{"@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#webpage"},"commentCount":0,"publisher":{"@id":"https://ostechnix.com/#organization"},"image":{"@id":"https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#primaryimage"},"keywords":"Group members,Linux,Linux basics,Linux commands,Linux Groups,Linux howto","articleSection":"Linux,Linux Administration,Linux Basics,Linux Commands,Linux Tips &amp; Tricks,Linux User Management,Unix/Linux Beginners","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/#respond"]}]},{"@type":"Person","@id":"https://ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a","name":"sk","image":{"@type":"ImageObject","@id":"https://ostechnix.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=96&d=mm&r=g","caption":"sk"},"description":"I am Senthil Kumar, more commonly known as SK to my friends, from India. I love to read, write and explore topics on Linux, Unix and all other technology related stuff.","sameAs":["https://ostechnix.com/","ostechnix","https://www.linkedin.com/in/ostechnix/","https://twitter.com/ostechnix"]}]}</script>

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To List The Members Of A Group In Linux Comments Feed" href="https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap&#038;ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/29913" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ostechnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ostechnix.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://ostechnix.com/?p=29913' />
<link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style><style id="penci-custom-style" type="text/css">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</style>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To List The Members Of A Group In Linux",
    "description": "All users in a Linux system must be a member of at least one&hellip;",
    "datePublished": "2021-02-26",
    "datemodified": "2021-02-26",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/how-to-list-the-members-of-a-group-in-linux\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2021\/02\/List-The-Members-Of-A-Group-In-Linux.png",
        "width": 1200,
        "height": 800
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/linux-commands\/",
                "name": "Linux Commands"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/how-to-list-the-members-of-a-group-in-linux\/",
                "name": "How To List The Members Of A Group In Linux"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" />
<link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" />
<meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body data-rsssl=1 class="post-template-default single single-post postid-29913 single-format-standard penci-fawesome-ver5">
<a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fas fa-times"></i></a>
<nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://ostechnix.com/"><img class="penci-lazy" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" alt="OSTechNix" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a href="https://twitter.com/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a>
<a href="https://in.linkedin.com/in/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a>
<a href="/cdn-cgi/l/email-protection#d3babdb5bc93bca0a7b6b0bbbdbaabfdb0bcbe"><i class="penci-faicon fas fa-envelope"></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fas fa-rss"></i></a>
</div> </div>
<ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li>
<li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li id="menu-item-943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-943"><a target="_blank" href="https://ostechnix.com/category/cloud/">Cloud</a></li>
<li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li>
<li id="menu-item-942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-942"><a target="_blank" href="https://ostechnix.com/category/directory-servers/">Directory servers</a></li>
<li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
<li id="menu-item-945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-945"><a href="https://ostechnix.com/category/android/">Android</a></li>
</ul>
</li>
<li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a>
<ul class="sub-menu">
<li id="menu-item-936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-936"><a href="https://ostechnix.com/category/encryption-decryption/">Encryption / Decryption</a></li>
<li id="menu-item-938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-938"><a href="https://ostechnix.com/category/monitoring-tools/">Monitoring Tools</a></li>
</ul>
</li>
<li id="menu-item-933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-933"><a target="_blank" href="https://ostechnix.com/category/tips-and-tricks/">Tips and Tricks</a>
<ul class="sub-menu">
<li id="menu-item-937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-937"><a href="https://ostechnix.com/category/internet-hacks/">Internet hacks</a></li>
</ul>
</li>
<li id="menu-item-934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-934"><a target="_blank" href="https://ostechnix.com/category/trouble-shooting/">Trouble shooting</a></li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-3 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar topbar-menu">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a>
<ul class="sub-menu">
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14"><a href="https://ostechnix.com/category/linux-basics/">Linux Basics</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15"><a href="https://ostechnix.com/category/linux_distributions/">Linux Distributions</a>
<ul class="sub-menu">
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://ostechnix.com/category/linux_distributions/arch-linux/">Arch Linux</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://ostechnix.com/category/linux_distributions/centos/">CentOS</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://ostechnix.com/category/linux_distributions/debian/">Debian</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://ostechnix.com/category/linux_distributions/fedora/">Fedora</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://ostechnix.com/category/linux_distributions/linuxmint/">Linux Mint</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://ostechnix.com/category/linux_distributions/mageia/">Mageia</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://ostechnix.com/category/linux_distributions/mandrake/">Mandrake</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://ostechnix.com/category/linux_distributions/mandriva/">Mandriva</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://ostechnix.com/category/linux_distributions/opensuse/">openSUSE</a></li>
<li id="menu-item-929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929"><a href="https://ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/">Red Hat Enterprise Linux</a></li>
<li id="menu-item-930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930"><a href="https://ostechnix.com/category/linux_distributions/scientific-linux/">Scientific Linux</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a>
<ul class="sub-menu">
<li id="menu-item-931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-931"><a href="https://ostechnix.com/category/unix/freebsd/">FreeBSD</a></li>
</ul>
</li>
<li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li>
<li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li>
<li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li>
</ul></div><div class="pctopbar-item penci-topbar-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a href="https://twitter.com/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a>
<a href="https://in.linkedin.com/in/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a>
<a href="/cdn-cgi/l/email-protection#2e474048416e415d5a4b4d46404756004d4143"><i class="penci-faicon fas fa-envelope"></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fas fa-rss"></i></a>
</div></div> </div>
</div>
</div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container align-left-logo has-banner">
<div id="logo">
<a href="https://ostechnix.com/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="OSTechNix" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" /><noscript><img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix"/></noscript></a> </div>
<div class="header-banner header-style-3">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6701402139964678" data-ad-slot="3845274536"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div>
</div>
<nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container">
<div class="button-menu-mobile header-3"><i class="penci-faicon fas fa-bars"></i></div>
<ul id="menu-header-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-943"><a target="_blank" href="https://ostechnix.com/category/cloud/">Cloud</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-942"><a target="_blank" href="https://ostechnix.com/category/directory-servers/">Directory servers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-945"><a href="https://ostechnix.com/category/android/">Android</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-936"><a href="https://ostechnix.com/category/encryption-decryption/">Encryption / Decryption</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-938"><a href="https://ostechnix.com/category/monitoring-tools/">Monitoring Tools</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-933"><a target="_blank" href="https://ostechnix.com/category/tips-and-tricks/">Tips and Tricks</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-937"><a href="https://ostechnix.com/category/internet-hacks/">Internet hacks</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-934"><a target="_blank" href="https://ostechnix.com/category/trouble-shooting/">Trouble shooting</a></li>
</ul><div id="top-search" class="penci-top-search">
<a class="search-click"><i class="penci-faicon fas fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fas fa-times"></i></a>
</div>
</div><div class="penci-menuhbg-wapper penci-menu-toggle-wapper">
<a href="#pencimenuhbgtoggle" class="penci-menuhbg-toggle">
<span class="penci-menuhbg-inner">
<i class="lines-button lines-button-double">
<i class="penci-lines"></i>
</i>
<i class="lines-button lines-button-double penci-hover-effect">
<i class="penci-lines"></i>
</i>
</span>
</a>
</div>
</div>
</nav>
</header>
</div>
<div class="container penci-breadcrumb single-breadcrumb">
<span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fas fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/linux/">Linux</a></span><i class="penci-faicon fas fa-angle-right"></i></i> <span>How To List The Members Of A Group In Linux</span>
</div>
<div class="container container-single container-single-magazine penci_sidebar  penci-enable-lightbox">
<div id="main" class="penci-main-sticky-sidebar">
<div class="theiaStickySidebar">
<article id="post-29913" class="post type-post status-publish">
<div class="post-image">
<a href="https://ostechnix.com/wp-content/uploads/2021/02/List-The-Members-Of-A-Group-In-Linux.png" data-rel="penci-gallery-image-content"> <img class="attachment-penci-full-thumb size-penci-full-thumb penci-lazy wp-post-image" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" alt="How To List The Members Of A Group In Linux" title="List The Members Of A Group In Linux" data-src="https://ostechnix.com/wp-content/uploads/2021/02/List-The-Members-Of-A-Group-In-Linux-1170x780.png">
</a> </div>
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/" rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-27" href="https://ostechnix.com/category/linux-basics/" rel="category tag">Linux Basics</a><a class="penci-cat-name penci-cat-1055" href="https://ostechnix.com/category/linux-commands/" rel="category tag">Linux Commands</a><a class="penci-cat-name penci-cat-4573" href="https://ostechnix.com/category/linux-tips-tricks/" rel="category tag">Linux Tips &amp; Tricks</a><a class="penci-cat-name penci-cat-4994" href="https://ostechnix.com/category/linux-user-management/" rel="category tag">Linux User Management</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/" rel="category tag">Unix/Linux Beginners</a></span></div>
<h1 class="post-title single-post-title entry-title">How To List The Members Of A Group In Linux</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/sk/">sk</a></span>
<time class="entry-date published" datetime="2021-02-26T18:32:34+05:30">February 26, 2021</time> </div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/sk/">sk</a></span></span>
<span><time class="entry-date published" datetime="2021-02-26T18:32:34+05:30">February 26, 2021</time></span>
<span><i class="penci-post-countview-number">146</i> Views</span>
</div>
</div>
<div class="tags-share-box tags-share-box-top center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">2</span><a class="penci-post-like single-like-button" data-post_id="29913" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux%20-%20https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;title=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;title=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" target="_blank" rel="nofollow" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;text=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#ebd4989e89818e889fd6a3849cced9dbbf84ced9dba782989fced9dbbf838eced9dba68e86898e9998ced9dba48dced9dbaaced9dbac99849e9bced9dba285ced9dba782859e93cdc8dbd8d3d0a9a4afb2d6839f9f9b98d1c4c484989f8e8883858293c5888486c483849cc69f84c68782989fc69f838ec6868e86898e9998c6848dc68ac68c99849e9bc68285c68782859e93c4"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-entry blockquote-style-2">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p>All users in a Linux system must be a member of at least one group. This group is known as Primary group. If an user doesn't have a primary group, he/she can't able to login. Apart from the primary group, the users can be a member of additional groups as well. The primary group setting is stored in <strong>"/etc/passwd file"</strong>. The primary group's name is specified in the 4th field of this file. The settings of other (secondary) groups are stored in <strong>"/etc/group"</strong> file. This tutorial explains different ways to find and list all groups and list the members of a group in Linux and Unix-like operating systems.</p>
<h2>List all groups in Linux</h2>
<p>Before listing all users belongs to a group, let us first find the list of available groups using <strong>"compgen"</strong> command. <strong>Compgen</strong> is BASH built-in to  manipulate the programmable completion facilities.</p>
<div><div class="penci-custom-html-inside-content"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><p>To list all available groups in a Linux system, run <strong>"compgen"</strong> command with <strong>-g</strong> option like below:</p>
<pre>$ compgen -g</pre>
<p>
</p>
<p><strong>Sample output:</strong></p>
<pre>root<br>daemon<br>bin<br>sys<br>adm<br>tty<br>disk<br>lp<br>mail<br>news<br>uucp<br>man<br>proxy<br>.<br>.<br>.<br>nova<br>rdma<br>libvirt<br>libvirt-qemu<br>libvirt-dnsmasq<br>cockpit-ws<br>cockpit-wsinstance<br>libvirtdbus<br>root<br>nogroup</pre>
<div id="attachment_29928" style="width: 1376px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29928" class="wp-image-29928 size-full" title="List all groups in Linux using compgen command" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201366%20691'%3E%3C/svg%3E" alt="List all groups in Linux using compgen command" width="1366" height="691" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command.png 1366w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-1170x592.png 1170w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-585x296.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command.png"><noscript><img aria-describedby="caption-attachment-29928" class="wp-image-29928 size-full" title="List all groups in Linux using compgen command" src="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command.png" alt="List all groups in Linux using compgen command" width="1366" height="691" srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command.png 1366w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-1170x592.png 1170w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-compgen-command-585x296.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"></noscript></a><p id="caption-attachment-29928" class="wp-caption-text">List all groups in Linux using compgen command</p></div>
<p>You can also get the list of all groups using <strong>"getent"</strong> command:</p>
<pre>$ getent group</pre>
<p><strong>Sample output:</strong></p>
<pre>root:x:0:<br>daemon:x:1:<br>bin:x:2:<br>sys:x:3:<br>adm:x:4:syslog,sk<br>tty:x:5:syslog<br>disk:x:6:sk<br>lp:x:7:<br>mail:x:8:<br>news:x:9:<br>.<br>.<br>.<br>nova:x:134:<br>rdma:x:135:<br>libvirt:x:136:sk,libvirtdbus<br>libvirt-qemu:x:64055:libvirt-qemu<br>libvirt-dnsmasq:x:137:<br>cockpit-ws:x:138:<br>cockpit-wsinstance:x:139:<br>libvirtdbus:x:998:<br>root:x:0:<br>nogroup:x:65534:</pre>
<div id="attachment_29931" style="width: 1376px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29931" class="wp-image-29931 size-full" title="List all groups in Linux using getent command" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201366%20691'%3E%3C/svg%3E" alt="List all groups in Linux using getent command" width="1366" height="691" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command.png 1366w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-1170x592.png 1170w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-585x296.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command.png"><noscript><img aria-describedby="caption-attachment-29931" class="wp-image-29931 size-full" title="List all groups in Linux using getent command" src="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command.png" alt="List all groups in Linux using getent command" width="1366" height="691" srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command.png 1366w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-1170x592.png 1170w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-groups-in-Linux-using-getent-command-585x296.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"></noscript></a><p id="caption-attachment-29931" class="wp-caption-text">List all groups in Linux using getent command</p></div>
<p>The first field in the "/etc/group" file is the name of the group. So, we can use <strong>"awk"</strong> or <strong>"cut"</strong> commands to print only the first field that contains the group's name like below:</p>
<pre>$ getent group | awk -F: '{ print $1}'</pre>
<pre>$ getent group | cut -d: -f1</pre>
<p>If you want to view the groups page by page, use <a href="https://ostechnix.com/the-difference-between-more-less-and-most-commands/" target="_blank" rel="noopener"><strong>"more" </strong>or<strong> "less"</strong></a> command like below:</p>
<pre>$ more /etc/group </pre>
<pre>$ less /etc/group </pre>
<p>Now, let us check the members of a group.</p>
<h2>List the members of a Group in Linux</h2>
<p>There are a few ways to find the group members in Linux. The methods we used here to identify the members of a group are given below:</p>
<ol>
<li>using "/etc/group" file,</li>
<li>using "getent" command,</li>
<li>using "groupmems" command,</li>
<li>using "members" command,</li>
<li>using "lid" command.</li>
</ol>
<h3>1. List the members of a group using /etc/group file</h3>
<p>When a group is created, the group's information is stored in the <strong>"/etc/group"</strong> file. Let us take a look at the contents of this file using <strong>"cat"</strong> command:</p>
<pre>$ cat /etc/group</pre>
<p><strong>Sample output:</strong></p>
<pre>root:x:0:<br>daemon:x:1:<br>bin:x:2:<br>sys:x:3:<br>adm:x:4:syslog,sk<br>tty:x:5:syslog<br>disk:x:6:sk<br>lp:x:7:<br>mail:x:8:<br>news:x:9:<br>.<br>.<br>.<br>systemd-coredump:x:999:<br>nova:x:134:<br>rdma:x:135:<br>libvirt:x:136:sk,libvirtdbus<br>libvirt-qemu:x:64055:libvirt-qemu<br>libvirt-dnsmasq:x:137:<br>cockpit-ws:x:138:<br>cockpit-wsinstance:x:139:<br>libvirtdbus:x:998:</pre>
<div id="attachment_29927" style="width: 1376px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29927" class="wp-image-29927 size-full" title="View Linux groups information" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201366%20691'%3E%3C/svg%3E" alt="View Linux groups information" width="1366" height="691" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information.png 1366w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-1170x592.png 1170w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-585x296.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information.png"><noscript><img aria-describedby="caption-attachment-29927" class="wp-image-29927 size-full" title="View Linux groups information" src="https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information.png" alt="View Linux groups information" width="1366" height="691" srcset="https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information.png 1366w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-1170x592.png 1170w, https://ostechnix.com/wp-content/uploads/2021/02/View-Linux-groups-information-585x296.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"></noscript></a><p id="caption-attachment-29927" class="wp-caption-text">View Linux groups information</p></div>
<p>As I mentioned earlier, the first field in "/etc/group" is reserved for the name of the group. As you can see in the above output, a Linux system may contain several groups.</p>
<p>To view the members of a specific Group in a Linux machine, use <a href="https://ostechnix.com/the-grep-command-tutorial-with-examples-for-beginners/" target="_blank" rel="noopener"><strong>"grep"</strong></a> command to filter the group details from the "/etc/group" file like below:</p>
<pre>$ grep '^sudo' /etc/group</pre>
<p>Or,</p>
<pre>$ grep -w sudo /etc/group</pre>
<p>The above commands displays the users belongs to the group named <strong>"sudo"</strong><b>.</b></p>
<pre>sudo:x:27:sk</pre>
<div id="attachment_29929" style="width: 748px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29929" class="wp-image-29929 size-full" title="List the members of a Group in Linux using grep command" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20738%20485'%3E%3C/svg%3E" alt="List the group members in Linux using grep command" width="738" height="485" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command-585x384.png 585w" data-lazy-sizes="(max-width: 738px) 100vw, 738px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command.png"><noscript><img aria-describedby="caption-attachment-29929" class="wp-image-29929 size-full" title="List the members of a Group in Linux using grep command" src="https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command.png" alt="List the group members in Linux using grep command" width="738" height="485" srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-the-members-of-a-Group-in-Linux-using-grep-command-585x384.png 585w" sizes="(max-width: 738px) 100vw, 738px"></noscript></a><p id="caption-attachment-29929" class="wp-caption-text">List the members of a Group in Linux using grep command</p></div>
<p>As you see in the above output, the "sudo" group contains only one member named "sk".</p>
<h3>2. View the members of a group using "getent" command</h3>
<p>The <strong>"getent"</strong> command displays entries from databases supported by the Name Service Switch libraries, which are configured in <strong>"/etc/nsswitch.conf"</strong> file.</p>
<p>To find the members of a given group in Linux using "getent" command, run:</p>
<pre>$ getent group sudo</pre>
<p>This command displays members of the "sudo" group.</p>
<div id="attachment_29934" style="width: 748px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29934" class="wp-image-29934 size-full" title="Find the members of a group in Linux using getent command" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20738%20485'%3E%3C/svg%3E" alt="View group members in Linux using getent command" width="738" height="485" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command-585x384.png 585w" data-lazy-sizes="(max-width: 738px) 100vw, 738px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command.png"><noscript><img aria-describedby="caption-attachment-29934" class="wp-image-29934 size-full" title="Find the members of a group in Linux using getent command" src="https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command.png" alt="View group members in Linux using getent command" width="738" height="485" srcset="https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/Find-the-members-of-a-group-in-Linux-using-getent-command-585x384.png 585w" sizes="(max-width: 738px) 100vw, 738px"></noscript></a><p id="caption-attachment-29934" class="wp-caption-text">Find the members of a group in Linux using getent command</p></div>
<p>One notable advantage of getent command is it not only lists the local users but all users in all configured userdb backends, for example LDAP, on a given system.</p>
<h3>3. Print users in a group using "groupmems" command</h3>
<p>The <strong>"groupmems"</strong> command allows a user to administer their own group membership list without superuser privileges. It is part of the shadow utils package.</p>
<p>To print the members of a group using "groupmems" command, run:</p>
<pre>$ sudo groupmems -g sudo -l</pre>
<div id="attachment_29935" style="width: 748px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29935" class="wp-image-29935 size-full" title="Print the members of a group using groupmems command in Linux" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20738%20485'%3E%3C/svg%3E" alt="Print the group members using groupmems command in Linux" width="738" height="485" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux-585x384.png 585w" data-lazy-sizes="(max-width: 738px) 100vw, 738px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux.png"><noscript><img aria-describedby="caption-attachment-29935" class="wp-image-29935 size-full" title="Print the members of a group using groupmems command in Linux" src="https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux.png" alt="Print the group members using groupmems command in Linux" width="738" height="485" srcset="https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/Print-the-members-of-a-group-using-groupmems-command-in-Linux-585x384.png 585w" sizes="(max-width: 738px) 100vw, 738px"></noscript></a><p id="caption-attachment-29935" class="wp-caption-text">Print the members of a group using groupmems command in Linux</p></div>
<p>This command has two drawbacks. It only deals with groups in "/etc/group" file but not the ones in LDAP or other user databases. It also requires superuser privileges as it tries to open <strong>"/etc/gshadow"</strong> file.</p>
<h3>4. Display group members using "members" command</h3>
<p>As the name explicitly says, the "members" commands basically displays the members of a Group in Linux. The "members" command is not available by default in most Linux distributions. You need to install it using your distribution's package manager. For example, on Debian-based systems, you can install it using command:</p>
<pre>$ sudo apt install members</pre>
<p>Once installed, you can display the members of a given group in Linux using "members" command like below:</p>
<pre>$ members sudo</pre>
<div id="attachment_29936" style="width: 748px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29936" class="wp-image-29936 size-full" title="Display group members using members command in Linux" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20738%20485'%3E%3C/svg%3E" alt="Display group members using members command in Linux" width="738" height="485" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux-585x384.png 585w" data-lazy-sizes="(max-width: 738px) 100vw, 738px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux.png"><noscript><img aria-describedby="caption-attachment-29936" class="wp-image-29936 size-full" title="Display group members using members command in Linux" src="https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux.png" alt="Display group members using members command in Linux" width="738" height="485" srcset="https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/Display-group-members-using-22members22-command-in-Linux-585x384.png 585w" sizes="(max-width: 738px) 100vw, 738px"></noscript></a><p id="caption-attachment-29936" class="wp-caption-text">Display group members using members command in Linux</p></div>
<p>By default, the "members" command displays all users. Use <strong>-p</strong> or <strong>-s</strong> to display only the members of a primary group or secondary group.</p>
<h3>5. List all users belongs to a group using "libuser-lid" command</h3>
<p>The <strong>"libuser-lid"</strong> command used to displays information about groups containing user name, or users contained in group name.</p>
<p>The "libuser-lid" command is also not available by default in many Linux distributions. The <strong>"libuser"</strong> provides this command, so you need to install it using your distribution's package manager. For example, on Debian, Ubuntu, install "libuser" package using command:</p>
<pre>$ sudo apt install libuser</pre>
<p>To list all users in a group, run:</p>
<pre>$ sudo libuser-lid -g sudo</pre>
<p>Please note that this command requires <strong>superuser</strong> privileges to run.</p>
<p><strong>Sample output:</strong></p>
<pre> sk(uid=1000)</pre>
<div id="attachment_29937" style="width: 748px" class="wp-caption aligncenter"><a href="https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command.png" data-rel="penci-gallery-image-content"><img aria-describedby="caption-attachment-29937" class="wp-image-29937 size-full" title="List all users in a group in Linux using libuser-lid command" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20738%20485'%3E%3C/svg%3E" alt="List all users in a group in Linux using libuser-lid command" width="738" height="485" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command-585x384.png 585w" data-lazy-sizes="(max-width: 738px) 100vw, 738px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command.png"><noscript><img aria-describedby="caption-attachment-29937" class="wp-image-29937 size-full" title="List all users in a group in Linux using libuser-lid command" src="https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command.png" alt="List all users in a group in Linux using libuser-lid command" width="738" height="485" srcset="https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command.png 738w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command-300x197.png 300w, https://ostechnix.com/wp-content/uploads/2021/02/List-all-users-in-a-group-in-Linux-using-libuser-lid-command-585x384.png 585w" sizes="(max-width: 738px) 100vw, 738px"></noscript></a><p id="caption-attachment-29937" class="wp-caption-text">List all users in a group in Linux using libuser-lid command</p></div>
<p>For more details, refer the manual pages of the respective command.</p>
<p>That's all for now. These are a few different methods to find the list of users in a Group in Linux. Hope this helps.</p>
<p><strong>Related read:</strong></p>
<ul>
<li><a href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/" target="_blank" rel="noopener"><strong>How To Find Out Which Groups A User Belongs To In Linux</strong></a></li>
<li><a href="https://ostechnix.com/how-to-list-all-users-in-linux/" target="_blank" rel="noopener"><strong>How To List All Users In Linux</strong></a></li>
</ul>
<p></p>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://ostechnix.com/tag/group-members/" rel="tag">Group members</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-basics/" rel="tag">Linux basics</a><a href="https://ostechnix.com/tag/linux-commands/" rel="tag">Linux commands</a><a href="https://ostechnix.com/tag/linux-groups/" rel="tag">Linux Groups</a><a href="https://ostechnix.com/tag/linux-howto/" rel="tag">Linux howto</a> </div>
</div>
</div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">2</span><a class="penci-post-like single-like-button" data-post_id="29913" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux%20-%20https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;title=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;title=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" target="_blank" rel="nofollow" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fhow-to-list-the-members-of-a-group-in-linux%2F&#038;text=How%20To%20List%20The%20Members%20Of%20A%20Group%20In%20Linux"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#fdc28e889f97989e89c0b5928ad8cfcda992d8cfcdb1948e89d8cfcda99598d8cfcdb098909f988f8ed8cfcdb29bd8cfcdbcd8cfcdba8f92888dd8cfcdb493d8cfcdb194938885dbdecdcec5c6bfb2b9a4c09589898d8ec7d2d2928e89989e95939485d39e9290d295928ad08992d091948e89d0899598d09098909f988f8ed0929bd09cd09a8f92888dd09493d09194938885d2"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="penci-flag-rlt-popup"></div>
<div class="post-author">
<div class="author-img">
<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' data-lazy-src="https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></noscript> </div>
<div class="author-content">
<h5><a href="https://ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></h5>
<p>I am Senthil Kumar, more commonly known as SK to my friends, from India. I love to read, write and explore topics on Linux, Unix and all other technology related stuff.</p>
<a rel="nofollow" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fas fa-globe"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://facebook.com/ostechnix"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://twitter.com/ostechnix"><i class="penci-faicon fab fa-twitter"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fab fa-linkedin-in"></i></a>
</div>
</div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>Previous post</span>
</div>
<a href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/">
<div class="pagi-text">
<h5 class="prev-title">How To Find Out Which Groups A User Belongs To In Linux</h5>
</div>
</a>
</div>
</div>
<div class="next-post">
<div class="next-post-inner">
<div class="prev-post-title next-post-title">
<span>Next post</span>
</div>
<a href="https://ostechnix.com/copy-file-contents-into-clipboard-without-displaying-them/">
<div class="pagi-text">
<h5 class="next-title">Copy File Contents Into Clipboard Without Displaying Them</h5>
</div>
</a>
</div>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true">
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2021/02/Copy-File-Contents-Into-Clipboard-Without-Displaying-Them-In-Linux-585x390.png" href="https://ostechnix.com/copy-file-contents-into-clipboard-without-displaying-them/" title="Copy File Contents Into Clipboard Without Displaying Them">
</a>
<h3><a href="https://ostechnix.com/copy-file-contents-into-clipboard-without-displaying-them/">Copy File Contents Into Clipboard Without Displaying Them</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-02-27T18:39:47+05:30">February 27, 2021</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2019/05/Expand-And-Unexpand-Commands.png" href="https://ostechnix.com/expand-and-unexpand-commands-tutorial-with-examples/" title="Expand And Unexpand Commands Tutorial With Examples">
</a>
<h3><a href="https://ostechnix.com/expand-and-unexpand-commands-tutorial-with-examples/">Expand And Unexpand Commands Tutorial With Examples</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-05-29T19:37:42+05:30">May 29, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2018/04/Find-Out-Which-Groups-A-User-Belongs-To-In-Linux-585x390.png" href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/" title="How To Find Out Which Groups A User Belongs To In Linux">
</a>
<h3><a href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/">How To Find Out Which Groups A User...</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-02-24T18:00:28+05:30">February 24, 2021</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2020/05/List-All-Users-In-Linux.png" href="https://ostechnix.com/how-to-list-all-users-in-linux/" title="How To List All Users In Linux">
</a>
<h3><a href="https://ostechnix.com/how-to-list-all-users-in-linux/">How To List All Users In Linux</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-05-16T19:51:07+05:30">May 16, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2017/08/cpu-core-1.jpg" href="https://ostechnix.com/find-number-cpu-cores-commandline-linux/" title="How To Find Number Of CPU Cores From Commandline In Linux">
</a>
<h3><a href="https://ostechnix.com/find-number-cpu-cores-commandline-linux/">How To Find Number Of CPU Cores From...</a></h3>
<span class="date"><time class="entry-date published" datetime="2017-08-23T17:11:09+05:30">August 23, 2017</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2019/08/mktemp-Command-Tutorial-With-Examples.png" href="https://ostechnix.com/the-mktemp-command-tutorial-with-examples-for-beginners/" title="The mktemp Command Tutorial With Examples For Beginners">
</a>
<h3><a href="https://ostechnix.com/the-mktemp-command-tutorial-with-examples-for-beginners/">The mktemp Command Tutorial With Examples For Beginners</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-05-14T13:30:17+05:30">May 14, 2020</time></span>
</div>
</div></div>
<div class="post-comments no-comment-yet penci-comments-hide-0" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-list-the-members-of-a-group-in-linux/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p>
<div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='29913' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cd0af917a2" /></p><input type="hidden" id="ak_js" name="ak_js" value="170" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> 
<div class="penci-flag-rlt-popup"></div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left penci-sticky-sidebar">
<div class="theiaStickySidebar">
<aside id="penci_social_widget-1" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Networks</span></h4>
<div class="widget-social pc_aligncenter show-text remove-circle penci-social-textcolored">
<a href="https://www.facebook.com/ostechnix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 14px"></i><span style="font-size: 14px">Facebook</span></a>
<a href="https://twitter.com/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 14px"></i><span style="font-size: 14px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 14px"></i><span style="font-size: 14px">Linkedin</span></a>
<a href="https://www.reddit.com/r/OSTechNix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 14px"></i><span style="font-size: 14px">Reddit</span></a>
</div>
</aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>
<aside id="recent-posts-1" class="widget widget_recent_entries">
<h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Posts</span></h4>
<ul>
<li>
<a href="https://ostechnix.com/copy-file-contents-into-clipboard-without-displaying-them/">Copy File Contents Into Clipboard Without Displaying Them</a>
</li>
<li>
 <a href="https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/" aria-current="page">How To List The Members Of A Group In Linux</a>
</li>
<li>
<a href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/">How To Find Out Which Groups A User Belongs To In Linux</a>
</li>
<li>
<a href="https://ostechnix.com/create-persistent-bootable-usb-using-ventoy-in-linux/">Create Persistent Bootable USB Using Ventoy In Linux</a>
</li>
<li>
<a href="https://ostechnix.com/enable-conda-forge-channel-for-conda-package-manager/">Enable Conda-forge Channel For Conda Package Manager</a>
</li>
</ul>
</aside><aside id="penci_popular_news_widget-1" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-6523" class="side-newsfeed display-order-numbers">
<li class="penci-feed featured-news">
<span class="order-border-number">
<span class="number-post">1</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners">
Youtube-dl Tutorial With Examples For Beginners </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">2</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2017/12/Find-The-Size-Of-A-Directory-In-Linux-263x175.png" href="https://ostechnix.com/find-size-directory-linux/" title="How To Find The Size Of A Directory In Linux"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/find-size-directory-linux/" rel="bookmark" title="How To Find The Size Of A Directory In Linux">
How To Find The Size Of A Directory In Linux </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2017-12-26T03:40:46+05:30">December 26, 2017</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">3</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2020/07/Install-And-Configure-KVM-In-CentOS-8.png" href="https://ostechnix.com/install-and-configure-kvm-in-centos-8-server/" title="Install And Configure KVM In CentOS 8 Server"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/install-and-configure-kvm-in-centos-8-server/" rel="bookmark" title="Install And Configure KVM In CentOS 8 Server">
 Install And Configure KVM In CentOS 8 Server </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-07-15T18:05:23+05:30">July 15, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside><aside id="penci_latest_tweets_widget-1" class="widget penci_latest_tweets_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Tweets</span></h4> <div class="penci-tweets-widget-content pc_aligncenter">
<span class="icon-tweets"><i class="penci-faicon fab fa-twitter"></i></span>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-tweets-slider" data-dots="true" data-nav="false" data-auto="false">
<div class="penci-tweet">
<div class="tweet-text">
How To List The Members Of A Group In Linux #Linuxgroups #Linuxcommands #Linuxbasics #Linuxusers #Linux - <a href="https://t.co/HP20ezTWT7" target="_blank">https://t.co/HP20ezTWT7</a> </div>
<p class="tweet-date">26-Feb-2021</p>
<div class="tweet-intents">
<div class="tweet-intents-inner">
<span><a target="_blank" class="reply" href="https://twitter.com/intent/tweet?in_reply_to=1365289530245275649">Reply</a></span>
<span><a target="_blank" class="retweet" href="https://twitter.com/intent/retweet?tweet_id=1365289530245275649">Retweet</a></span>
<span><a target="_blank" class="favorite" href="https://twitter.com/intent/favorite?tweet_id=1365289530245275649">Favorite</a></span>
</div>
</div>
</div>
<div class="penci-tweet">
<div class="tweet-text">
How To Find Number Of CPU Cores From Commandline In Linux #CPU #CPUCores #LinuxCommands #Linuxtips #Linuxbasics… <a href="https://t.co/15VGQeeDQ2" target="_blank">https://t.co/15VGQeeDQ2</a> </div>
<p class="tweet-date">25-Feb-2021</p>
<div class="tweet-intents">
<div class="tweet-intents-inner">
<span><a target="_blank" class="reply" href="https://twitter.com/intent/tweet?in_reply_to=1364977771345182721">Reply</a></span>
<span><a target="_blank" class="retweet" href="https://twitter.com/intent/retweet?tweet_id=1364977771345182721">Retweet</a></span>
<span><a target="_blank" class="favorite" href="https://twitter.com/intent/favorite?tweet_id=1364977771345182721">Favorite</a></span>
</div>
</div>
</div>
<div class="penci-tweet">
<div class="tweet-text">
How To Find Out Which Groups A User Belongs To In Linux #Linuxuser #Linuxgroups #Linuxcommands #Linuxbasics… <a href="https://t.co/XhG4jkOAYx" target="_blank">https://t.co/XhG4jkOAYx</a> </div>
<p class="tweet-date">24-Feb-2021</p>
<div class="tweet-intents">
<div class="tweet-intents-inner">
<span><a target="_blank" class="reply" href="https://twitter.com/intent/tweet?in_reply_to=1364558414945288192">Reply</a></span>
<span><a target="_blank" class="retweet" href="https://twitter.com/intent/retweet?tweet_id=1364558414945288192">Retweet</a></span>
<span><a target="_blank" class="favorite" href="https://twitter.com/intent/favorite?tweet_id=1364558414945288192">Favorite</a></span>
</div>
</div>
</div>
<div class="penci-tweet">
<div class="tweet-text">
How To Delete A Repository And GPG Key In Ubuntu Linux #SoftwareRepository #GPG #Ubuntu #Linux #PackageManagement… <a href="https://t.co/SveV1gcwjN" target="_blank">https://t.co/SveV1gcwjN</a> </div>
<p class="tweet-date">23-Feb-2021</p>
<div class="tweet-intents">
<div class="tweet-intents-inner">
<span><a target="_blank" class="reply" href="https://twitter.com/intent/tweet?in_reply_to=1364131293655560194">Reply</a></span>
<span><a target="_blank" class="retweet" href="https://twitter.com/intent/retweet?tweet_id=1364131293655560194">Retweet</a></span>
<span><a target="_blank" class="favorite" href="https://twitter.com/intent/favorite?tweet_id=1364131293655560194">Favorite</a></span>
</div>
</div>
</div>
<div class="penci-tweet">
<div class="tweet-text">
AlmaLinux 8.3 RC Release Notes.
<a href="https://t.co/UMO5Qe9lC6" target="_blank">https://t.co/UMO5Qe9lC6</a>
#AlmaLinux #RHEL #Linux </div>
<p class="tweet-date">23-Feb-2021</p>
<div class="tweet-intents">
<div class="tweet-intents-inner">
<span><a target="_blank" class="reply" href="https://twitter.com/intent/tweet?in_reply_to=1364093287603183621">Reply</a></span>
<span><a target="_blank" class="retweet" href="https://twitter.com/intent/retweet?tweet_id=1364093287603183621">Retweet</a></span>
<span><a target="_blank" class="favorite" href="https://twitter.com/intent/favorite?tweet_id=1364093287603183621">Favorite</a></span>
</div>
</div>
</div>
</div>
</div>
</aside><aside id="categories-3" class="widget widget_categories"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Categories</span></h4><form action="https://ostechnix.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name='cat' id='cat' class='postform'>
<option value='-1'>Select Category</option>
<option class="level-0" value="2">Active Directory Domain Controller&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4990">Anaconda Distribution&nbsp;&nbsp;(1)</option>
<option class="level-0" value="3">Android&nbsp;&nbsp;(32)</option>
<option class="level-0" value="4">Antergos&nbsp;&nbsp;(38)</option>
<option class="level-0" value="4833">Apple&nbsp;&nbsp;(2)</option>
<option class="level-1" value="4834">&nbsp;&nbsp;&nbsp;macOS&nbsp;&nbsp;(2)</option>
<option class="level-0" value="5">Audio/Video Converters&nbsp;&nbsp;(5)</option>
<option class="level-0" value="4863">Audio/Video Encoders&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4345">Audio/Video Tools&nbsp;&nbsp;(1)</option>
<option class="level-0" value="6">Backup tools&nbsp;&nbsp;(13)</option>
<option class="level-0" value="4314">BASH&nbsp;&nbsp;(17)</option>
<option class="level-1" value="4580">&nbsp;&nbsp;&nbsp;Bash Tips&nbsp;&nbsp;(8)</option>
<option class="level-0" value="2825">Blockchain&nbsp;&nbsp;(15)</option>
<option class="level-1" value="4087">&nbsp;&nbsp;&nbsp;Ethereum&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4686">Bootable USB&nbsp;&nbsp;(4)</option>
<option class="level-0" value="4404">Browser Addons/Extensions&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4093">Browsers&nbsp;&nbsp;(7)</option>
<option class="level-1" value="4095">&nbsp;&nbsp;&nbsp;Chromium&nbsp;&nbsp;(5)</option>
<option class="level-1" value="4094">&nbsp;&nbsp;&nbsp;Google chrome&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4856">&nbsp;&nbsp;&nbsp;Microsoft Edge&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4096">&nbsp;&nbsp;&nbsp;Mozilla Firefox&nbsp;&nbsp;(5)</option>
<option class="level-0" value="7">Cloud&nbsp;&nbsp;(8)</option>
<option class="level-0" value="4850">Cloud storage&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4851">&nbsp;&nbsp;&nbsp;Dropbox&nbsp;&nbsp;(1)</option>
<option class="level-0" value="8">CMS&nbsp;&nbsp;(1)</option>
<option class="level-1" value="65">&nbsp;&nbsp;&nbsp;Wordpress&nbsp;&nbsp;(1)</option>
<option class="level-0" value="1569">Command line fun&nbsp;&nbsp;(21)</option>
<option class="level-0" value="9">Command line utilities&nbsp;&nbsp;(414)</option>
<option class="level-0" value="2827">Cryptocurrency&nbsp;&nbsp;(12)</option>
<option class="level-0" value="2826">Cryptography&nbsp;&nbsp;(15)</option>
<option class="level-0" value="4755">Data recovery&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4391">Data science&nbsp;&nbsp;(4)</option>
<option class="level-0" value="11">Database&nbsp;&nbsp;(25)</option>
<option class="level-1" value="4669">&nbsp;&nbsp;&nbsp;MariaDB&nbsp;&nbsp;(1)</option>
<option class="level-1" value="38">&nbsp;&nbsp;&nbsp;MySQL&nbsp;&nbsp;(20)</option>
<option class="level-0" value="4793">DevOps&nbsp;&nbsp;(9)</option>
<option class="level-0" value="12">Directory servers&nbsp;&nbsp;(1)</option>
<option class="level-1" value="66">&nbsp;&nbsp;&nbsp;389 Directory server&nbsp;&nbsp;(1)</option>
<option class="level-1" value="19">&nbsp;&nbsp;&nbsp;Fedora Directory Server&nbsp;&nbsp;(1)</option>
<option class="level-0" value="13">DNS&nbsp;&nbsp;(3)</option>
<option class="level-0" value="14">Download managers&nbsp;&nbsp;(3)</option>
<option class="level-0" value="4447">DuckDuckGo&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4846">Ebooks&nbsp;&nbsp;(2)</option>
<option class="level-0" value="16">Emulators&nbsp;&nbsp;(12)</option>
<option class="level-0" value="17">Encryption / Decryption&nbsp;&nbsp;(24)</option>
<option class="level-0" value="4555">Facebook&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4556">&nbsp;&nbsp;&nbsp;WhatsApp&nbsp;&nbsp;(1)</option>
<option class="level-0" value="18">FAQ&nbsp;&nbsp;(656)</option>
<option class="level-0" value="4671">File system&nbsp;&nbsp;(6)</option>
<option class="level-1" value="4672">&nbsp;&nbsp;&nbsp;Stacked filesystem&nbsp;&nbsp;(1)</option>
<option class="level-2" value="4673">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;eCryptfs&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4456">File Transfer&nbsp;&nbsp;(12)</option>
<option class="level-0" value="20">Fileserver&nbsp;&nbsp;(12)</option>
<option class="level-0" value="4905">Fish shell&nbsp;&nbsp;(5)</option>
<option class="level-0" value="4880">Fonts&nbsp;&nbsp;(1)</option>
<option class="level-0" value="21">Frameworks&nbsp;&nbsp;(2)</option>
<option class="level-0" value="22">FTP Server&nbsp;&nbsp;(7)</option>
<option class="level-0" value="1568">Games&nbsp;&nbsp;(12)</option>
<option class="level-0" value="4501">Github&nbsp;&nbsp;(2)</option>
<option class="level-1" value="4502">&nbsp;&nbsp;&nbsp;git&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4826">GNOME&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4445">Google&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4766">&nbsp;&nbsp;&nbsp;Google Drive&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4252">Groupware&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4776">Image editors&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4773">Internet&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4814">&nbsp;&nbsp;&nbsp;Email&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4774">&nbsp;&nbsp;&nbsp;Web-based software&nbsp;&nbsp;(2)</option>
<option class="level-0" value="23">Internet hacks&nbsp;&nbsp;(19)</option>
<option class="level-0" value="4257">Internet Of Things (IoT)&nbsp;&nbsp;(1)</option>
<option class="level-0" value="574">Interview&nbsp;&nbsp;(1)</option>
<option class="level-0" value="3774">Java&nbsp;&nbsp;(1)</option>
<option class="level-0" value="24">Kali Linux&nbsp;&nbsp;(3)</option>
<option class="level-0" value="4987">KernelCare&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4416">LAMP Stack&nbsp;&nbsp;(3)</option>
<option class="level-0" value="25">LDAP server&nbsp;&nbsp;(3)</option>
<option class="level-0" value="4665">LEMP Stack&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4472">Letsencrypt&nbsp;&nbsp;(1)</option>
<option class="level-0" value="26">Linux&nbsp;&nbsp;(956)</option>
<option class="level-1" value="29">&nbsp;&nbsp;&nbsp;Linux Kernel&nbsp;&nbsp;(36)</option>
<option class="level-2" value="4664">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Kernel Live Patching&nbsp;&nbsp;(3)</option>
<option class="level-0" value="1145">Linux Administration&nbsp;&nbsp;(443)</option>
<option class="level-0" value="27">Linux Basics&nbsp;&nbsp;(517)</option>
<option class="level-0" value="1055">Linux Commands&nbsp;&nbsp;(392)</option>
<option class="level-0" value="902">Linux Containers&nbsp;&nbsp;(13)</option>
<option class="level-0" value="28">Linux Distributions&nbsp;&nbsp;(389)</option>
<option class="level-1" value="4977">&nbsp;&nbsp;&nbsp;Almalinux&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4926">&nbsp;&nbsp;&nbsp;Alpine Linux&nbsp;&nbsp;(4)</option>
<option class="level-1" value="68">&nbsp;&nbsp;&nbsp;Arch Linux&nbsp;&nbsp;(80)</option>
<option class="level-1" value="69">&nbsp;&nbsp;&nbsp;CentOS&nbsp;&nbsp;(70)</option>
<option class="level-1" value="4931">&nbsp;&nbsp;&nbsp;CloudLinux&nbsp;&nbsp;(3)</option>
<option class="level-1" value="71">&nbsp;&nbsp;&nbsp;Debian&nbsp;&nbsp;(64)</option>
<option class="level-1" value="4495">&nbsp;&nbsp;&nbsp;Elementary OS&nbsp;&nbsp;(5)</option>
<option class="level-1" value="73">&nbsp;&nbsp;&nbsp;Fedora&nbsp;&nbsp;(46)</option>
<option class="level-1" value="30">&nbsp;&nbsp;&nbsp;Linux Mint&nbsp;&nbsp;(94)</option>
<option class="level-1" value="31">&nbsp;&nbsp;&nbsp;Mageia&nbsp;&nbsp;(2)</option>
<option class="level-1" value="33">&nbsp;&nbsp;&nbsp;Mandrake&nbsp;&nbsp;(3)</option>
<option class="level-1" value="34">&nbsp;&nbsp;&nbsp;Mandriva&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4137">&nbsp;&nbsp;&nbsp;NixOS&nbsp;&nbsp;(1)</option>
<option class="level-1" value="43">&nbsp;&nbsp;&nbsp;openSUSE&nbsp;&nbsp;(12)</option>
<option class="level-1" value="4921">&nbsp;&nbsp;&nbsp;Oracle Linux&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4358">&nbsp;&nbsp;&nbsp;Pop OS&nbsp;&nbsp;(12)</option>
<option class="level-1" value="45">&nbsp;&nbsp;&nbsp;Red Hat Enterprise Linux&nbsp;&nbsp;(49)</option>
<option class="level-1" value="49">&nbsp;&nbsp;&nbsp;Scientific Linux&nbsp;&nbsp;(33)</option>
<option class="level-1" value="54">&nbsp;&nbsp;&nbsp;SUSE&nbsp;&nbsp;(11)</option>
<option class="level-1" value="58">&nbsp;&nbsp;&nbsp;Ubuntu&nbsp;&nbsp;(226)</option>
<option class="level-0" value="4081">Linux Foundation&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4082">&nbsp;&nbsp;&nbsp;Hyperledger&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4108">&nbsp;&nbsp;&nbsp;Hyperledger Fabric&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4119">&nbsp;&nbsp;&nbsp;Hyperledger Sawtooth&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4207">Linux Networking&nbsp;&nbsp;(14)</option>
<option class="level-0" value="4573">Linux Tips &amp; Tricks&nbsp;&nbsp;(141)</option>
<option class="level-0" value="4994">Linux User Management&nbsp;&nbsp;(3)</option>
<option class="level-0" value="994">Log server&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4392">Machine Learning&nbsp;&nbsp;(3)</option>
<option class="level-0" value="4832">MacOS&nbsp;&nbsp;(2)</option>
<option class="level-0" value="32">Mailserver&nbsp;&nbsp;(5)</option>
<option class="level-0" value="4723">Management Tools&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4724">&nbsp;&nbsp;&nbsp;Cockpit&nbsp;&nbsp;(3)</option>
<option class="level-0" value="4801">Manual pages&nbsp;&nbsp;(2)</option>
<option class="level-0" value="3667">Messengers&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4335">Microsoft&nbsp;&nbsp;(5)</option>
<option class="level-1" value="4756">&nbsp;&nbsp;&nbsp;Windows&nbsp;&nbsp;(4)</option>
<option class="level-0" value="35">Microsoft Windows&nbsp;&nbsp;(14)</option>
<option class="level-0" value="36">Mobile&nbsp;&nbsp;(13)</option>
<option class="level-0" value="37">Monitoring Tools&nbsp;&nbsp;(15)</option>
<option class="level-0" value="4069">Music/media players&nbsp;&nbsp;(1)</option>
<option class="level-0" value="39">Network attached storage&nbsp;&nbsp;(2)</option>
<option class="level-0" value="42">Opensource&nbsp;&nbsp;(435)</option>
<option class="level-0" value="44">Package management&nbsp;&nbsp;(108)</option>
<option class="level-0" value="4852">Password manager&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4666">Phpmyadmin&nbsp;&nbsp;(1)</option>
<option class="level-0" value="849">Programming&nbsp;&nbsp;(77)</option>
<option class="level-1" value="4701">&nbsp;&nbsp;&nbsp;Golang&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4707">&nbsp;&nbsp;&nbsp;Java&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4539">&nbsp;&nbsp;&nbsp;Nim&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4321">&nbsp;&nbsp;&nbsp;Nodejs&nbsp;&nbsp;(8)</option>
<option class="level-1" value="4393">&nbsp;&nbsp;&nbsp;Perl&nbsp;&nbsp;(2)</option>
<option class="level-1" value="4415">&nbsp;&nbsp;&nbsp;PHP&nbsp;&nbsp;(5)</option>
<option class="level-1" value="4154">&nbsp;&nbsp;&nbsp;Python&nbsp;&nbsp;(22)</option>
<option class="level-1" value="4387">&nbsp;&nbsp;&nbsp;R Language&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4376">&nbsp;&nbsp;&nbsp;Racket&nbsp;&nbsp;(2)</option>
<option class="level-1" value="4461">&nbsp;&nbsp;&nbsp;Rust&nbsp;&nbsp;(10)</option>
<option class="level-0" value="4513">Protection&nbsp;&nbsp;(2)</option>
<option class="level-1" value="4514">&nbsp;&nbsp;&nbsp;Coronavirus (COVID-19)&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4112">Raspberry Pi&nbsp;&nbsp;(3)</option>
<option class="level-0" value="46">Releases&nbsp;&nbsp;(23)</option>
<option class="level-0" value="47">Remote desktop connection&nbsp;&nbsp;(4)</option>
<option class="level-0" value="48">Reviews&nbsp;&nbsp;(60)</option>
<option class="level-0" value="4353">Rust&nbsp;&nbsp;(5)</option>
<option class="level-0" value="50">Scripting&nbsp;&nbsp;(36)</option>
<option class="level-1" value="4712">&nbsp;&nbsp;&nbsp;Shell Scripts&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4157">Secure Shell (SSH)&nbsp;&nbsp;(12)</option>
<option class="level-0" value="51">Security&nbsp;&nbsp;(55)</option>
<option class="level-0" value="4819">Self-host&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4820">&nbsp;&nbsp;&nbsp;File sharing&nbsp;&nbsp;(3)</option>
<option class="level-0" value="52">Social Networking&nbsp;&nbsp;(3)</option>
<option class="level-0" value="4214">Storages&nbsp;&nbsp;(2)</option>
<option class="level-1" value="4218">&nbsp;&nbsp;&nbsp;DAS&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4219">&nbsp;&nbsp;&nbsp;JBOD&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4217">&nbsp;&nbsp;&nbsp;NAS&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4215">&nbsp;&nbsp;&nbsp;RAID&nbsp;&nbsp;(1)</option>
<option class="level-1" value="4216">&nbsp;&nbsp;&nbsp;SAN&nbsp;&nbsp;(1)</option>
<option class="level-0" value="53">Streaming media servers&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4690">&nbsp;&nbsp;&nbsp;Jellyfin&nbsp;&nbsp;(1)</option>
<option class="level-0" value="55">Technology&nbsp;&nbsp;(94)</option>
<option class="level-1" value="75">&nbsp;&nbsp;&nbsp;News&nbsp;&nbsp;(70)</option>
<option class="level-0" value="4304">Terminal Emulators&nbsp;&nbsp;(4)</option>
<option class="level-0" value="4434">Terminal hacks&nbsp;&nbsp;(7)</option>
<option class="level-0" value="4431">Terminal multiplexers&nbsp;&nbsp;(4)</option>
<option class="level-1" value="4433">&nbsp;&nbsp;&nbsp;GNU Screen&nbsp;&nbsp;(3)</option>
<option class="level-1" value="4432">&nbsp;&nbsp;&nbsp;Tmux&nbsp;&nbsp;(2)</option>
<option class="level-0" value="4311">Text editors&nbsp;&nbsp;(5)</option>
<option class="level-1" value="4312">&nbsp;&nbsp;&nbsp;Vim&nbsp;&nbsp;(5)</option>
<option class="level-2" value="4483">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Vim Tips&nbsp;&nbsp;(3)</option>
<option class="level-0" value="56">Tips and Tricks&nbsp;&nbsp;(505)</option>
<option class="level-0" value="4139">Tor&nbsp;&nbsp;(1)</option>
<option class="level-0" value="57">Trouble shooting&nbsp;&nbsp;(135)</option>
<option class="level-0" value="1">Uncategorized&nbsp;&nbsp;(2)</option>
<option class="level-0" value="59">Unix&nbsp;&nbsp;(55)</option>
<option class="level-1" value="74">&nbsp;&nbsp;&nbsp;FreeBSD&nbsp;&nbsp;(22)</option>
<option class="level-0" value="1206">Unix/Linux Beginners&nbsp;&nbsp;(396)</option>
<option class="level-0" value="60">Utilities&nbsp;&nbsp;(467)</option>
<option class="level-0" value="4322">Version Control System&nbsp;&nbsp;(2)</option>
<option class="level-0" value="61">Virtual drives&nbsp;&nbsp;(2)</option>
<option class="level-0" value="779">Virtual Private Servers&nbsp;&nbsp;(1)</option>
<option class="level-0" value="62">Virtualization&nbsp;&nbsp;(71)</option>
<option class="level-1" value="4301">&nbsp;&nbsp;&nbsp;Containers&nbsp;&nbsp;(8)</option>
<option class="level-1" value="72">&nbsp;&nbsp;&nbsp;Docker&nbsp;&nbsp;(21)</option>
<option class="level-1" value="4825">&nbsp;&nbsp;&nbsp;Gnome Boxes&nbsp;&nbsp;(1)</option>
<option class="level-1" value="593">&nbsp;&nbsp;&nbsp;KVM&nbsp;&nbsp;(23)</option>
<option class="level-1" value="77">&nbsp;&nbsp;&nbsp;Oracle VirtualBox&nbsp;&nbsp;(29)</option>
<option class="level-1" value="4752">&nbsp;&nbsp;&nbsp;QEMU&nbsp;&nbsp;(8)</option>
<option class="level-1" value="4787">&nbsp;&nbsp;&nbsp;Vagrant&nbsp;&nbsp;(8)</option>
<option class="level-0" value="1040">VPN&nbsp;&nbsp;(4)</option>
<option class="level-0" value="4156">Web browsers&nbsp;&nbsp;(1)</option>
<option class="level-0" value="969">Web hosting&nbsp;&nbsp;(3)</option>
<option class="level-0" value="63">Webserver&nbsp;&nbsp;(23)</option>
<option class="level-1" value="67">&nbsp;&nbsp;&nbsp;Apache&nbsp;&nbsp;(14)</option>
<option class="level-1" value="76">&nbsp;&nbsp;&nbsp;Nginx&nbsp;&nbsp;(8)</option>
<option class="level-0" value="4800">Wikipedia&nbsp;&nbsp;(1)</option>
<option class="level-0" value="64">Windows Networking&nbsp;&nbsp;(1)</option>
<option class="level-0" value="4148">YouTube&nbsp;&nbsp;(4)</option>
<option class="level-0" value="4902">Zsh&nbsp;&nbsp;(1)</option>
</select>
</form>
</aside><aside id="archives-4" class="widget widget_archive"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Blog Archive</span></h4> <label class="screen-reader-text" for="archives-dropdown-4">Blog Archive</label>
<select id="archives-dropdown-4" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://ostechnix.com/2021/02/'> February 2021 &nbsp;(17)</option>
<option value='https://ostechnix.com/2021/01/'> January 2021 &nbsp;(15)</option>
<option value='https://ostechnix.com/2020/12/'> December 2020 &nbsp;(18)</option>
<option value='https://ostechnix.com/2020/11/'> November 2020 &nbsp;(14)</option>
<option value='https://ostechnix.com/2020/10/'> October 2020 &nbsp;(18)</option>
<option value='https://ostechnix.com/2020/09/'> September 2020 &nbsp;(15)</option>
<option value='https://ostechnix.com/2020/08/'> August 2020 &nbsp;(15)</option>
<option value='https://ostechnix.com/2020/07/'> July 2020 &nbsp;(18)</option>
<option value='https://ostechnix.com/2020/06/'> June 2020 &nbsp;(24)</option>
<option value='https://ostechnix.com/2020/05/'> May 2020 &nbsp;(27)</option>
<option value='https://ostechnix.com/2020/04/'> April 2020 &nbsp;(32)</option>
<option value='https://ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option>
<option value='https://ostechnix.com/2020/02/'> February 2020 &nbsp;(19)</option>
<option value='https://ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option>
<option value='https://ostechnix.com/2019/12/'> December 2019 &nbsp;(12)</option>
<option value='https://ostechnix.com/2019/11/'> November 2019 &nbsp;(9)</option>
<option value='https://ostechnix.com/2019/10/'> October 2019 &nbsp;(10)</option>
<option value='https://ostechnix.com/2019/09/'> September 2019 &nbsp;(11)</option>
<option value='https://ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option>
<option value='https://ostechnix.com/2019/07/'> July 2019 &nbsp;(17)</option>
<option value='https://ostechnix.com/2019/06/'> June 2019 &nbsp;(10)</option>
<option value='https://ostechnix.com/2019/05/'> May 2019 &nbsp;(13)</option>
<option value='https://ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option>
<option value='https://ostechnix.com/2019/03/'> March 2019 &nbsp;(9)</option>
<option value='https://ostechnix.com/2019/02/'> February 2019 &nbsp;(10)</option>
<option value='https://ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option>
<option value='https://ostechnix.com/2018/12/'> December 2018 &nbsp;(6)</option>
<option value='https://ostechnix.com/2018/11/'> November 2018 &nbsp;(12)</option>
<option value='https://ostechnix.com/2018/10/'> October 2018 &nbsp;(18)</option>
<option value='https://ostechnix.com/2018/09/'> September 2018 &nbsp;(19)</option>
<option value='https://ostechnix.com/2018/08/'> August 2018 &nbsp;(18)</option>
<option value='https://ostechnix.com/2018/07/'> July 2018 &nbsp;(15)</option>
<option value='https://ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option>
<option value='https://ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option>
<option value='https://ostechnix.com/2018/04/'> April 2018 &nbsp;(20)</option>
<option value='https://ostechnix.com/2018/03/'> March 2018 &nbsp;(22)</option>
<option value='https://ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option>
<option value='https://ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option>
<option value='https://ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option>
<option value='https://ostechnix.com/2017/11/'> November 2017 &nbsp;(22)</option>
<option value='https://ostechnix.com/2017/10/'> October 2017 &nbsp;(17)</option>
<option value='https://ostechnix.com/2017/09/'> September 2017 &nbsp;(25)</option>
<option value='https://ostechnix.com/2017/08/'> August 2017 &nbsp;(24)</option>
<option value='https://ostechnix.com/2017/07/'> July 2017 &nbsp;(23)</option>
<option value='https://ostechnix.com/2017/06/'> June 2017 &nbsp;(15)</option>
<option value='https://ostechnix.com/2017/05/'> May 2017 &nbsp;(22)</option>
<option value='https://ostechnix.com/2017/04/'> April 2017 &nbsp;(25)</option>
<option value='https://ostechnix.com/2017/03/'> March 2017 &nbsp;(33)</option>
<option value='https://ostechnix.com/2017/02/'> February 2017 &nbsp;(34)</option>
<option value='https://ostechnix.com/2017/01/'> January 2017 &nbsp;(24)</option>
<option value='https://ostechnix.com/2016/12/'> December 2016 &nbsp;(20)</option>
<option value='https://ostechnix.com/2016/11/'> November 2016 &nbsp;(15)</option>
<option value='https://ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option>
<option value='https://ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option>
<option value='https://ostechnix.com/2016/08/'> August 2016 &nbsp;(23)</option>
<option value='https://ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option>
<option value='https://ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option>
<option value='https://ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option>
<option value='https://ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option>
<option value='https://ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option>
<option value='https://ostechnix.com/2016/02/'> February 2016 &nbsp;(22)</option>
<option value='https://ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option>
<option value='https://ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option>
<option value='https://ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option>
<option value='https://ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option>
<option value='https://ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option>
<option value='https://ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option>
<option value='https://ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option>
<option value='https://ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option>
<option value='https://ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option>
<option value='https://ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option>
<option value='https://ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option>
<option value='https://ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h4><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
<p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p>
<p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..." /><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p>
<input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /></form></div></aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div id="widget-area">
<div class="container">
<div class="footer-widget-wrapper footer-widget-style-1">
<aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4> <div class="textwidget"><p><a href="https://ostechnix.com/"><img class="aligncenter wp-image-25308 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20340%2068'%3E%3C/svg%3E" alt="Ostechnix Footer Logo" width="340" height="68" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-lazy-sizes="(max-width: 340px) 100vw, 340px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" /><noscript><img class="aligncenter wp-image-25308 size-full" src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px" /></noscript></a></p>
<p>&nbsp;</p>
<p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p>
</div>
</aside><aside id="penci_social_widget-2" class="widget penci_social_widget">
<div class="widget-social pc_aligncenter remove-circle">
<a href="https://www.facebook.com/ostechnix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-youtube" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="/cdn-cgi/l/email-protection#721b1c141d321d010617111a1c1b0a5c111d1f"><i class="penci-faicon fas fa-envelope" style="font-size: 18px"></i><span style="font-size: 13px">Email</span></a>

<a href="https://www.reddit.com/r/OSTechNix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 18px"></i><span style="font-size: 13px">Reddit</span></a>
<a href="https://feeds.feedburner.com/Ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fas fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">RSS</span></a>
</div>
</aside> </div>
<div class="footer-widget-wrapper footer-widget-style-1">
<aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-6705" class="side-newsfeed display-order-numbers">
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">1</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners">
Youtube-dl Tutorial With Examples For Beginners </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">2</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2017/12/Find-The-Size-Of-A-Directory-In-Linux-263x175.png" href="https://ostechnix.com/find-size-directory-linux/" title="How To Find The Size Of A Directory In Linux"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/find-size-directory-linux/" rel="bookmark" title="How To Find The Size Of A Directory In Linux">
How To Find The Size Of A Directory In Linux </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2017-12-26T03:40:46+05:30">December 26, 2017</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">3</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2020/07/Install-And-Configure-KVM-In-CentOS-8.png" href="https://ostechnix.com/install-and-configure-kvm-in-centos-8-server/" title="Install And Configure KVM In CentOS 8 Server"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/install-and-configure-kvm-in-centos-8-server/" rel="bookmark" title="Install And Configure KVM In CentOS 8 Server">
Install And Configure KVM In CentOS 8 Server </a>
</h4>
 <span class="side-item-meta"><time class="entry-date published" datetime="2020-07-15T18:05:23+05:30">July 15, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
<div class="footer-widget-wrapper footer-widget-style-1 last">
<aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Editor&#8217;s Picks</span></h4> <ul id="penci-latestwg-4573" class="side-newsfeed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2021/02/Copy-File-Contents-Into-Clipboard-Without-Displaying-Them-In-Linux-263x175.png" href="https://ostechnix.com/copy-file-contents-into-clipboard-without-displaying-them/" title="Copy File Contents Into Clipboard Without Displaying Them"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/copy-file-contents-into-clipboard-without-displaying-them/" rel="bookmark" title="Copy File Contents Into Clipboard Without Displaying Them">
Copy File Contents Into Clipboard Without Displaying Them </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-27T18:39:47+05:30">February 27, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2021/02/List-The-Members-Of-A-Group-In-Linux-263x175.png" href="https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/" title="How To List The Members Of A Group In Linux"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-list-the-members-of-a-group-in-linux/" rel="bookmark" title="How To List The Members Of A Group In Linux">
How To List The Members Of A Group In Linux </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-26T18:32:34+05:30">February 26, 2021</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2018/04/Find-Out-Which-Groups-A-User-Belongs-To-In-Linux-263x175.png" href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/" title="How To Find Out Which Groups A User Belongs To In Linux"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/" rel="bookmark" title="How To Find Out Which Groups A User Belongs To In Linux">
How To Find Out Which Groups A User Belongs To In Linux </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2021-02-24T18:00:28+05:30">February 24, 2021</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="penci-flag-rlt-popup"></div> <div class="footer-logo-copyright footer-not-logo footer-not-gotop">
<div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li>
<li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li>
<li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li>
<li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul> </div>
<div id="footer-copyright">
<p>OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p>
</div>
</div>
<div class="penci-go-to-top-floating"><i class="penci-faicon fas fa-angle-up"></i></div>
</div>
</footer>
</div>
<div class="penci-menu-hbg-overlay"></div>
<div class="penci-menu-hbg penci-vernav-hide penci-menu-hbg-left">
<div class="penci-menu-hbg-inner">
<a id="penci-close-hbg"><i class="penci-faicon fas fa-times"></i></a>
<div class="penci-hbg-header">
<div class="penci-hbg-logo site-branding">
<a href="https://ostechnix.com/"><img class="penci-lazy" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" /></a>
</div>
</div>
<div class="penci-hbg-content penci-sidebar-content style-2 pcalign-left">
<ul id="menu-top-menu-1" class="menu menu-hgb-main"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14"><a href="https://ostechnix.com/category/linux-basics/">Linux Basics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15"><a href="https://ostechnix.com/category/linux_distributions/">Linux Distributions</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://ostechnix.com/category/linux_distributions/arch-linux/">Arch Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://ostechnix.com/category/linux_distributions/centos/">CentOS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://ostechnix.com/category/linux_distributions/debian/">Debian</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://ostechnix.com/category/linux_distributions/fedora/">Fedora</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://ostechnix.com/category/linux_distributions/linuxmint/">Linux Mint</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://ostechnix.com/category/linux_distributions/mageia/">Mageia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://ostechnix.com/category/linux_distributions/mandrake/">Mandrake</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://ostechnix.com/category/linux_distributions/mandriva/">Mandriva</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://ostechnix.com/category/linux_distributions/opensuse/">openSUSE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929"><a href="https://ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/">Red Hat Enterprise Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930"><a href="https://ostechnix.com/category/linux_distributions/scientific-linux/">Scientific Linux</a></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-931"><a href="https://ostechnix.com/category/unix/freebsd/">FreeBSD</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li>
</ul> </div>
<div class="penci-hbg-footer">
<div class="penci_menu_hbg_ftext">OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</div> <div class="header-social sidebar-nav-social penci-hbg-social-style-4 penci-social-colored">
<div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a href="https://twitter.com/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a>
<a href="https://in.linkedin.com/in/ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a>
<a href="/cdn-cgi/l/email-protection#9af3f4fcf5daf5e9eefff9f2f4f3e2b4f9f5f7"><i class="penci-faicon fas fa-envelope"></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" rel="nofollow" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" rel="nofollow" target="_blank"><i class="penci-faicon fas fa-rss"></i></a>
</div> </div>
</div>
</div>
</div> <aside class="penci-rlt-popup penci-rltpopup-left">
<h3 class="rtlpopup-heading">Read Also<a class="penci-close-rltpopup">x<span></span><span></span></a></h3>
<div class="penci-rtlpopup-content">
<div class="rltpopup-item" style="transition-delay: 400ms; -webkit-transition-delay: 400ms;">
<div class="rltpopup-item-inner">
<figure class="rltpopup-thumbnail">
<a class="rltpopup-thumb penci-image-holder penci-lazy" data-src="https://ostechnix.com/wp-content/uploads/2020/04/Upgrade-To-Ubuntu-20.04-LTS-Server.png" href="https://ostechnix.com/how-to-upgrade-to-ubuntu-20-04-lts-server/" title="How To Upgrade To Ubuntu 20.04 LTS Server"></a>
</figure>
<div class="rltpopup-meta">
<h4><a class="rltpopup-title" href="https://ostechnix.com/how-to-upgrade-to-ubuntu-20-04-lts-server/">How To Upgrade To Ubuntu 20.04 LTS...</a></h4>
<span class="date"><time class="entry-date published" datetime="2020-04-25T16:37:34+05:30">April 25, 2020</time></span>
</div>
</div>
</div>
<div class="rltpopup-item" style="transition-delay: 480ms; -webkit-transition-delay: 480ms;">
<div class="rltpopup-item-inner">
<figure class="rltpopup-thumbnail">
<a class="rltpopup-thumb penci-image-holder penci-lazy" data-src="https://ostechnix.com/wp-content/uploads/2016/12/Install-Linux-Kernel-4.9.png" href="https://ostechnix.com/install-linux-kernel-4-9-centos-ubuntu/" title="Install Linux Kernel 4.9 In CentOS and Ubuntu"></a>
</figure>
<div class="rltpopup-meta">
<h4><a class="rltpopup-title" href="https://ostechnix.com/install-linux-kernel-4-9-centos-ubuntu/">Install Linux Kernel 4.9 In CentOS and...</a></h4>
<span class="date"><time class="entry-date published" datetime="2016-12-21T13:52:17+05:30">December 21, 2016</time></span>
</div>
</div>
</div>
<div class="rltpopup-item" style="transition-delay: 560ms; -webkit-transition-delay: 560ms;">
<div class="rltpopup-item-inner">
<figure class="rltpopup-thumbnail">
<a class="rltpopup-thumb penci-image-holder penci-lazy" data-src="https://ostechnix.com/wp-content/uploads/2020/12/Speed-Up-DNF-Package-Manager-In-Fedora-263x175.png" href="https://ostechnix.com/how-to-speed-up-dnf-package-manager-in-fedora/" title="How To Speed Up DNF Package Manager In Fedora"></a>
</figure>
<div class="rltpopup-meta">
<h4><a class="rltpopup-title" href="https://ostechnix.com/how-to-speed-up-dnf-package-manager-in-fedora/">How To Speed Up DNF Package Manager...</a></h4>
<span class="date"><time class="entry-date published" datetime="2020-12-04T20:17:55+05:30">December 4, 2020</time></span>
</div>
</div>
</div>
</div></aside>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a> </p>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='https://ostechnix.com/wp-includes/js/dist/i18n.min.js?ver=ac389435e7fd4ded01cf603f3aaba6a6' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://ostechnix.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "452770950e" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://ostechnix.com/wp-admin/admin-ajax.php?action=rest-nonce";
</script>
<script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"08cd36a5dd","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"08cd36a5dd","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"08cd36a5dd","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcAcbUZAAAAAKCObyok1ZJ0qXtwTdNZSZfDPcNO&#038;ver=3.0' id='google-recaptcha-js'></script>
<script src='https://stats.wp.com/e-202108.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4',blog:'84551477',post:'29913',tz:'5.5',srv:'ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '29913' ]);
</script>
<script type="text/javascript">
	function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(29913, 'https://ostechnix.com');
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ostechnix.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>

<script data-no-minify="1" async src="https://ostechnix.com/wp-content/cache/busting/1/gtm-e438e3b95704b9acdf81b265010a31f0.js"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-75259810-1');
</script>
<script src="https://ostechnix.com/wp-content/cache/min/1/0836b6b77733d3d9d6cad18b136680ac.js" data-minify="1"></script></body>
</html>
