<!DOCTYPE html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script> <meta charset="UTF-8"><style id="litespeed-ccss">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://ostechnix.com/wp-content/litespeed/ucss/a894e6f5c48877e899ef9bcbff9cdc74.css?ver=2fefe" /><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/css_async.min.js"></script> <meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"/><link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"
type="image/x-icon"/><link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"><link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed"
href="https://ostechnix.com/feed/"/><link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed"
href="https://ostechnix.com/feed/atom/"/><link rel="pingback" href="https://ostechnix.com/xmlrpc.php"/>
<!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><title>How To Perform Arithmetic Operations In Bash - OSTechNix</title><meta name="description" content="This guide explains the different ways and tools to perform arithmetic operations in Bash shell scripting with examples." /><link rel="canonical" href="https://ostechnix.com/bash-arithmetic-operations/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How To Perform Arithmetic Operations In Bash - OSTechNix" /><meta property="og:description" content="This guide explains the different ways and tools to perform arithmetic operations in Bash shell scripting with examples." /><meta property="og:url" content="https://ostechnix.com/bash-arithmetic-operations/" /><meta property="og:site_name" content="OSTechNix" /><meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /><meta property="article:published_time" content="2022-09-05T11:32:32+00:00" /><meta property="article:modified_time" content="2022-09-05T12:29:35+00:00" /><meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2022/09/Bash-Arithmetic-Operations.png" /><meta property="og:image:width" content="1280" /><meta property="og:image:height" content="720" /><meta property="og:image:type" content="image/png" /><meta name="author" content="Karthick" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@ostechnix" /><meta name="twitter:site" content="@ostechnix" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Karthick" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="8 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://ostechnix.com/bash-arithmetic-operations/#article","isPartOf":{"@id":"https://ostechnix.com/bash-arithmetic-operations/"},"author":{"name":"Karthick","@id":"https://ostechnix.com/#/schema/person/6a244ab2f41f7b0c256c4c7f41df2c03"},"headline":"How To Perform Arithmetic Operations In Bash","datePublished":"2022-09-05T11:32:32+00:00","dateModified":"2022-09-05T12:29:35+00:00","mainEntityOfPage":{"@id":"https://ostechnix.com/bash-arithmetic-operations/"},"wordCount":1084,"commentCount":0,"publisher":{"@id":"https://ostechnix.com/#organization"},"image":{"@id":"https://ostechnix.com/bash-arithmetic-operations/#primaryimage"},"thumbnailUrl":"https://ostechnix.com/wp-content/uploads/2022/09/Bash-Arithmetic-Operations.png","keywords":["BASH","Bash Arithmetic Operations","Bash Mathematical Operations","Bash Script","Bash scripting","Bash Shell Scripting","Bash tutorial","Learn Shell scripting","Linux","Linux basics","Linux commands","Shell scripting"],"articleSection":["BASH","Bash scripting","Bash Tips","Linux","Linux Basics","Linux Commands","Linux Tips &amp; Tricks","Scripting","Shell Scripts","Unix/Linux Beginners"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ostechnix.com/bash-arithmetic-operations/#respond"]}]},{"@type":"WebPage","@id":"https://ostechnix.com/bash-arithmetic-operations/","url":"https://ostechnix.com/bash-arithmetic-operations/","name":"How To Perform Arithmetic Operations In Bash - OSTechNix","isPartOf":{"@id":"https://ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://ostechnix.com/bash-arithmetic-operations/#primaryimage"},"image":{"@id":"https://ostechnix.com/bash-arithmetic-operations/#primaryimage"},"thumbnailUrl":"https://ostechnix.com/wp-content/uploads/2022/09/Bash-Arithmetic-Operations.png","datePublished":"2022-09-05T11:32:32+00:00","dateModified":"2022-09-05T12:29:35+00:00","description":"This guide explains the different ways and tools to perform arithmetic operations in Bash shell scripting with examples.","breadcrumb":{"@id":"https://ostechnix.com/bash-arithmetic-operations/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ostechnix.com/bash-arithmetic-operations/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ostechnix.com/bash-arithmetic-operations/#primaryimage","url":"https://ostechnix.com/wp-content/uploads/2022/09/Bash-Arithmetic-Operations.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2022/09/Bash-Arithmetic-Operations.png","width":1280,"height":720,"caption":"Do Mathematical Operations In Bash"},{"@type":"BreadcrumbList","@id":"https://ostechnix.com/bash-arithmetic-operations/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://ostechnix.com/"},{"@type":"ListItem","position":2,"name":"How To Perform Arithmetic Operations In Bash"}]},{"@type":"WebSite","@id":"https://ostechnix.com/#website","url":"https://ostechnix.com/","name":"OSTechNix","description":"Open Source | Technology | Linux And Unix","publisher":{"@id":"https://ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ostechnix.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://ostechnix.com/#organization","name":"OSTechNix","url":"https://ostechnix.com/","sameAs":["https://www.instagram.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://www.facebook.com/ostechnix/","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ostechnix.com/#/schema/logo/image/","url":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","width":350,"height":73,"caption":"OSTechNix"},"image":{"@id":"https://ostechnix.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://ostechnix.com/#/schema/person/6a244ab2f41f7b0c256c4c7f41df2c03","name":"Karthick","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ostechnix.com/#/schema/person/image/","url":"https://ostechnix.com/wp-content/litespeed/avatar/78086842889856b0034d89277f6895d9.jpg?ver=1662193675","contentUrl":"https://ostechnix.com/wp-content/litespeed/avatar/78086842889856b0034d89277f6895d9.jpg?ver=1662193675","caption":"Karthick"},"description":"Karthick is a passionate software engineer who loves to explore new technologies. He is a public speaker and loves writing about technology especially about Linux and opensource.","sameAs":["https://ostechnix.com/"],"url":"https://ostechnix.com/author/karthick/"}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To Perform Arithmetic Operations In Bash Comments Feed" href="https://ostechnix.com/bash-arithmetic-operations/feed/" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><style id='wp-block-library-theme-inline-css' type='text/css'>.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}</style><style id='global-styles-inline-css' type='text/css'>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</style><style id='fixedtoc-style-inline-css' type='text/css'>.ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); }</style> <script type="litespeed/javascript" data-src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/42589" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ostechnix.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ostechnix.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://ostechnix.com/?p=42589' /><link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F" /><link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;format=xml" /><style>img#wpstats{display:none}</style> <script type="litespeed/javascript">var penciBlocksArray=[];var portfolioDataJs=portfolioDataJs||[];var PENCILOCALCACHE={};(function(){"use strict";PENCILOCALCACHE={data:{},remove:function(ajaxFilterItem){delete PENCILOCALCACHE.data[ajaxFilterItem]},exist:function(ajaxFilterItem){return PENCILOCALCACHE.data.hasOwnProperty(ajaxFilterItem)&&PENCILOCALCACHE.data[ajaxFilterItem]!==null},get:function(ajaxFilterItem){return PENCILOCALCACHE.data[ajaxFilterItem]},set:function(ajaxFilterItem,cachedData){PENCILOCALCACHE.remove(ajaxFilterItem);PENCILOCALCACHE.data[ajaxFilterItem]=cachedData}}})();function penciBlock(){this.atts_json='';this.content=''}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To Perform Arithmetic Operations In Bash",
    "description": "In this article, we will focus on how to do mathematical operations in bash&hellip;",
    "datePublished": "2022-09-05",
    "datemodified": "2022-09-05",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/bash-arithmetic-operations\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2022\/09\/Bash-Arithmetic-Operations.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-Karthick",
        "name": "Karthick",
        "url": "https:\/\/ostechnix.com\/author\/karthick\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/bash\/",
                "name": "BASH"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/bash\/bash-scripting\/",
                "name": "Bash scripting"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/ostechnix.com\/bash-arithmetic-operations\/",
                "name": "How To Perform Arithmetic Operations In Bash"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /><meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /></head><body data-rsssl=1 class="post-template-default single single-post postid-42589 single-format-standard soledad-ver-8-2-5 pclight-mode pcmn-drdw-style-slide_down pchds-default has-ftoc">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"><div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"><div class="container"><div class="penci-headline" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li><li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li><li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></div><div class="pctopbar-item penci-topbar-social"><div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
<a href="mailto:info@ostechnix.com" aria-label="Email"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" ></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" ></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div></div></div></div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="inner-header penci-header-second"><div class="container align-left-logo has-banner"><div id="logo">
<a href="https://ostechnix.com/"><img
class="penci-mainlogo penci-limg"             src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix"
width="350"
height="73"></a></div><div class="header-banner header-style-3"> <script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="9496719407"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script> </div></div></div><div class="sticky-wrapper"><nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="container"><div class="button-menu-mobile header-3"><svg width=18px height=18px viewBox="0 0 512 384" version=1.1 xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink><g stroke=none stroke-width=1 fill-rule=evenodd><g transform="translate(0.000000, 0.250080)"><rect x=0 y=0 width=512 height=62></rect><rect x=0 y=161 width=512 height=62></rect><rect x=0 y=321 width=512 height=62></rect></g></g></svg></div><ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li><li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li><li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li><li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li><li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li><li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li><li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li><li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li></ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes">
<a class="search-click">
<i class="penciicon-magnifiying-glass"></i>
</a><div class="show-search"><div class="penci-search-form penci-search-form"><form autocomplete="off" role="search" method="get" class="searchform  penci-ajax-search"
action="https://ostechnix.com/"  data-thumbnail="1" data-price="1" data-post_type="post" data-count="10" data-sku="1" data-symbols_count="3"><input type="text" class="s search-input" placeholder="Type and hit enter..."
value="" name="s"
aria-label="Search"
title="Type and hit enter..."/>
<input type="hidden" name="post_type" value="post">
<button type="submit" class="searchsubmit">
<span>
Search						</span>
</button></form><div class="search-results-wrapper"><div class="penci-dropdown-results penci-scroll penci-dropdown penci-search-results"><div class="penci-search-results-wrapper"></div></div></div></div>
<a class="search-click close-search"><i class="penciicon-close-button"></i></a></div></div></div></nav></div></header></div><div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt;
&lt;!-- New Horizontal Responsive Adv --&gt;
&lt;ins class=&quot;adsbygoogle&quot;
style=&quot;display:block&quot;
data-ad-client=&quot;ca-pub-6701402139964678&quot;
data-ad-slot=&quot;9496719407&quot;
data-ad-format=&quot;auto&quot;
data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt;
&lt;script&gt;
(adsbygoogle = window.adsbygoogle || []).push({});
&lt;/script&gt;&lt;/div&gt;"><div class="penci-single-block"         data-prev-url="https://ostechnix.com/convert-arch-linux-packages-to-appimage/"
data-current-url="https://ostechnix.com/bash-arithmetic-operations/"
data-post-title="How To Perform Arithmetic Operations In Bash"
data-edit-post=""
data-postid="42589"><div class="container penci-breadcrumb single-breadcrumb">
<span><a class="crumb"
href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fa fa-angle-right" ></i>					<span><a class="crumb" href="https://ostechnix.com/category/bash/bash-scripting/">Bash scripting</a></span><i class="penci-faicon fa fa-angle-right" ></i>                    <span>How To Perform Arithmetic Operations In Bash</span></div><div class="container container-single penci_sidebar  penci-enable-lightbox"><div id="main" class="penci-main-sticky-sidebar"><div class="theiaStickySidebar"><article id="post-42589" class="post type-post status-publish"><div class="header-standard header-classic single-header"><div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-5361" href="https://ostechnix.com/category/bash/bash-scripting/"  rel="category tag">Bash scripting</a><a class="penci-cat-name penci-cat-4314" href="https://ostechnix.com/category/bash/"  rel="category tag">BASH</a><a class="penci-cat-name penci-cat-4580" href="https://ostechnix.com/category/bash/bash-tips/"  rel="category tag">Bash Tips</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/"  rel="category tag">Linux</a><a class="penci-cat-name penci-cat-27" href="https://ostechnix.com/category/linux-basics/"  rel="category tag">Linux Basics</a><a class="penci-cat-name penci-cat-1055" href="https://ostechnix.com/category/linux-commands/"  rel="category tag">Linux Commands</a><a class="penci-cat-name penci-cat-4573" href="https://ostechnix.com/category/linux-tips-tricks/"  rel="category tag">Linux Tips &amp; Tricks</a><a class="penci-cat-name penci-cat-50" href="https://ostechnix.com/category/scripting/"  rel="category tag">Scripting</a><a class="penci-cat-name penci-cat-4712" href="https://ostechnix.com/category/scripting/shell-scripts/"  rel="category tag">Shell Scripts</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/"  rel="category tag">Unix/Linux Beginners</a></span></div><h1 class="post-title single-post-title entry-title">How To Perform Arithmetic Operations In Bash</h1><h2 class="penci-psub-title ">Different Ways To Do Mathematical Operations In Bash</h2><div class="penci-hide-tagupdated">
<span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/karthick/">Karthick</a></span>
<time class="entry-date published" datetime="2022-09-05T17:02:32+05:30">September 5, 2022</time></div><div class="post-box-meta-single">
<span class="author-post byline"><span
class="author vcard">Written by <a
class="author-url url fn n"
href="https://ostechnix.com/author/karthick/">Karthick</a></span></span>
<span><time class="entry-date published" datetime="2022-09-05T17:02:32+05:30">September 5, 2022</time></span>
<span><i class="penci-post-countview-number">189</i> views</span></div></div><div class="sstyle-style-1 tags-share-box tags-share-box-top single-post-share tags-share-box-s1  center-box  social-align-default post-share">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>0 comment</span>
<span class="post-share-item post-share-plike"><span class="count-number-like">4</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="42589" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a></span><a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank"  rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/bash-arithmetic-operations/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank"  rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash%20-%20https://ostechnix.com/bash-arithmetic-operations/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank"  rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;title=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank"  rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;title=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash"><i class="penci-faicon fa fa-reddit-alien" ></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank"  rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash %0A%0A https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F"><i class="penci-faicon fa fa-whatsapp" ></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank"  rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;text=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash"><i class="penci-faicon fa fa-telegram" ></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email"  rel="noreferrer" href="mailto:?subject=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash&#038;BODY=https://ostechnix.com/bash-arithmetic-operations/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#"><i class="penci-faicon penciicon-add" ></i></a></div><div class="post-entry blockquote-style-2"><div class="inner-post-entry entry-content" id="penci-post-entry-inner"><div id="ftwp-postcontent"><p>In this article, we will focus on how to <strong>do mathematical operations in bash scripts</strong>. We can <strong>perform arithmetic operations in Bash</strong> using the built-in and external tools. First, we will learn about the built-in tools.</p><p class="has-black-color has-luminous-vivid-amber-background-color has-text-color has-background"><strong>Note:</strong> Unlike other programming languages, bash arithmetic operations are not straight-forward(at least for me). There are multiple bash built-in and external programs to perform the same operations. If you want to perform any complex mathematical computation, then a shell is not a recommended way to do it.</p><div><div class="penci-custom-html-inside-content"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></div><div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item"><a class="ftwp-anchor" href="#do-mathematical-operations-in-bash-using-let-command"><span class="ftwp-text">Do Mathematical Operations In Bash Using The Built-in "let" Command</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#do-arithmetic-operations-in-bash-using-the-built-in-double-brackets"><span class="ftwp-text">Do Arithmetic Operations In Bash Using The Built-in Double Brackets</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#perform-arithmetic-operations-in-bash-using-expr"><span class="ftwp-text">Perform Arithmetic Operations In Bash Using Expr Utility</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#perform-bash-arithmetic-operations-using-bc"><span class="ftwp-text">Perform Bash Arithmetic Operations Using bc Utility</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#perform-mathematical-operations-with-awk"><span class="ftwp-text">Perform Mathematical Operations With AWK</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="do-mathematical-operations-in-bash-using-let-command" class="ftwp-heading">Do Mathematical Operations In Bash Using The Built-in "let" Command</h2><p>Using the <code><strong>let</strong></code> command, you can perform arithmetic, incremental, bitwise, and conditional operations. The drawback with the let command is it cannot handle floating point values.</p><p>The <code>let</code> command in bash is a built-in command. You can verify that by running the following command in the terminal.</p><pre class="wp-block-preformatted">$ type -a let<br>let is a shell builtin</pre><p>Run the following command to get the help section where you can find the list of operators supported by the ‘let’ command.</p><pre class="wp-block-preformatted">$ let -help</pre><p><strong>Sample output:</strong></p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/09/Display-let-Command-Help-Section.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI3MDYiIGhlaWdodD0iMzc5IiB2aWV3Qm94PSIwIDAgNzA2IDM3OSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="706" height="379" data-src="https://ostechnix.com/wp-content/uploads/2022/09/Display-let-Command-Help-Section.png" alt="Display let Command Help Section" class="wp-image-42590" title="Display let Command Help Section" data-srcset="https://ostechnix.com/wp-content/uploads/2022/09/Display-let-Command-Help-Section.png 706w, https://ostechnix.com/wp-content/uploads/2022/09/Display-let-Command-Help-Section-300x161.png 300w, https://ostechnix.com/wp-content/uploads/2022/09/Display-let-Command-Help-Section-585x314.png 585w" data-sizes="(max-width: 706px) 100vw, 706px"></a><figcaption>Display let Command Help Section</figcaption></figure></div><p>There are a few essential points to note when working with the let command.</p><ul><li>The output of any operation should be assigned to a variable and then printed. The ‘let’ command will not allow you to print the outputs straight away.</li><li>No space is allowed between the operator and the operand.</li></ul><p>Create a shell script, copy and paste the below example code and try running the script. In the code given below, I am performing arithmetic operations. As mentioned already, the output of the expression should be assigned to a variable before printing it out.</p><pre class="wp-block-preformatted">#!/usr/bin/env bash

let NUMBER1=10
let NUMBER2=3

# Addition =&gt; + operator
let ADD=$NUMBER1+$NUMBER2
echo "Addition of two numbers : ${ADD}"

# Subtraction =&gt; - operator
let SUB=$NUMBER1-$NUMBER2
echo "Subtraction of two numbers : ${SUB}"

# Multiply =&gt; * operator
let MUL=$NUMBER1*$NUMBER2
echo "Multiply two numbers : ${MUL}"

# Divide =&gt; / operator
let DIV=$NUMBER1/$NUMBER2
echo "Division of two numbers : ${DIV}"

# Remainder =&gt; % operator
let REM=$NUMBER1%$NUMBER2
echo "Remainder of two numbers : ${REM}"

# Exponent =&gt; ** operator
let EXPO=$NUMBER1**$NUMBER2
echo "Exponent of two numbers : ${EXPO}"</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDYwIiBoZWlnaHQ9IjUwMiIgdmlld0JveD0iMCAwIDEwNjAgNTAyIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" width="1060" height="502" data-src="https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts.png" alt="Do Mathematical Operations In Bash Scripts" class="wp-image-42591" title="Do Mathematical Operations In Bash Scripts" data-srcset="https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts.png 1060w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts-300x142.png 300w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts-1024x485.png 1024w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts-768x364.png 768w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Mathematical-Operations-In-Bash-Scripts-585x277.png 585w" data-sizes="(max-width: 1060px) 100vw, 1060px"></a><figcaption>Do Mathematical Operations In Bash Scripts</figcaption></figure></div><p>You can also do post increment and post decrement operations too. This operation will be mostly used when we are running loops in the script.</p><ul><li>The post increment operation will increase the variable value to <strong>VARIABLE + 1</strong>.</li><li>The pre-increment operation will increase the variable value to <strong>VARIABLE - 1</strong>.</li></ul><pre class="wp-block-preformatted">let variable++<br>let variable--</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/09/Do-Post-Increment-And-Post-Decrement-Operations.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI5ODkiIGhlaWdodD0iMjQyIiB2aWV3Qm94PSIwIDAgOTg5IDI0MiI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="989" height="242" data-src="https://ostechnix.com/wp-content/uploads/2022/09/Do-Post-Increment-And-Post-Decrement-Operations.png" alt="Do Post Increment And Post Decrement Operations" class="wp-image-42592" title="Do Post Increment And Post Decrement Operations" data-srcset="https://ostechnix.com/wp-content/uploads/2022/09/Do-Post-Increment-And-Post-Decrement-Operations.png 989w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Post-Increment-And-Post-Decrement-Operations-300x73.png 300w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Post-Increment-And-Post-Decrement-Operations-768x188.png 768w, https://ostechnix.com/wp-content/uploads/2022/09/Do-Post-Increment-And-Post-Decrement-Operations-585x143.png 585w" data-sizes="(max-width: 989px) 100vw, 989px"></a><figcaption>Do Post Increment And Post Decrement Operations</figcaption></figure></div><p>You can also do other comparison operations like checking for equality, inequality, greater than, less than, etc. I would strongly recommend not using the <code>let</code> command to do any comparison operations as there are better ways to handle it.</p><h2 id="do-arithmetic-operations-in-bash-using-the-built-in-double-brackets" class="ftwp-heading">Do Arithmetic Operations In Bash Using The Built-in Double Brackets</h2><p>As an alternative to the <code>let</code> command, you can use the <strong>double brackets</strong> method where you have to place the operator and the operand within the double brackets.</p><p>The advantage of this method over the <code>let</code> command is that the result can be straightaway printed or stored in a variable and you can add spaces between the operator and the operand. Similar to the <code>let</code> command, you cannot do any floating point operations.</p><p>The example given below is pretty much the same as the examples shown in the <code>let</code> command. All you have to do is put your expression inside double brackets. There is no need to prepend the variables with the <strong><code>$</code></strong> symbol inside the double brackets. Just give the variable name and the value will be interpreted.</p><p>From the below image, if you can see lines 12 and 13 you will see a difference in how the expression is handled. Anything within the brackets will be first evaluated and the result of it will be computed against other operands. You can see this behavior in the output of <strong>"Multiply"</strong> and <strong>"Multiply1"</strong>.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Scripts-Using-Double-Brackets.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI5NDIiIGhlaWdodD0iMjQ2IiB2aWV3Qm94PSIwIDAgOTQyIDI0NiI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="942" height="246" data-src="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Scripts-Using-Double-Brackets.png" alt="Perform Arithmetic Operations In Bash Scripts Using Double Brackets" class="wp-image-42593" title="Perform Arithmetic Operations In Bash Scripts Using Double Brackets" data-srcset="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Scripts-Using-Double-Brackets.png 942w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Scripts-Using-Double-Brackets-300x78.png 300w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Scripts-Using-Double-Brackets-768x201.png 768w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Scripts-Using-Double-Brackets-585x153.png 585w" data-sizes="(max-width: 942px) 100vw, 942px"></a><figcaption>Perform Arithmetic Operations In Bash Scripts Using Double Brackets</figcaption></figure></div><p>Similar to the <code>let</code> command, you can also do post increment and decrement operations.</p><pre class="wp-block-preformatted">((NUMBER2++)<br>((NUMBER1--))</pre><p>You can also perform shorthand operations.</p><pre class="wp-block-preformatted">(( NUMBER2 = NUMBER2 + 10 ))<br>(( NUMBER2 += 10 )) # Shorthand</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Post-Increment-And-Decrement-Operations.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MjciIGhlaWdodD0iMTI2IiB2aWV3Qm94PSIwIDAgNDI3IDEyNiI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="427" height="126" data-src="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Post-Increment-And-Decrement-Operations.png" alt="Perform Post Increment And Decrement Operations" class="wp-image-42594" title="Perform Post Increment And Decrement Operations" data-srcset="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Post-Increment-And-Decrement-Operations.png 427w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Post-Increment-And-Decrement-Operations-300x89.png 300w" data-sizes="(max-width: 427px) 100vw, 427px"></a><figcaption>Perform Post Increment And Decrement Operations</figcaption></figure></div><h2 id="perform-arithmetic-operations-in-bash-using-expr" class="ftwp-heading">Perform Arithmetic Operations In Bash Using Expr Utility</h2><p>In the previous sections, we have seen about built-in functionality and in this section, we will take a look at <strong>"expr"</strong>, which is an external program.</p><p>Not only the mathematical operations, the expr utility can also do operations on strings like finding the index of a character, length of a string, substring etc.</p><p>Before using the expr program, go through the man page which will give you a fair bit of understanding about this utility.</p><pre class="wp-block-preformatted">$ man expr<br>$ expr -help</pre><p>Following is the syntax for the <code>expr</code> command:</p><pre class="wp-block-preformatted">$ expr</pre><p>The basic arithmetic operation is the same as what we have seen in the previous sections. The only difference here is when using <strong>*</strong> to do a multiplication operation you have to escape it with <strong>"<code>\</code>"</strong> otherwise it will throw an error.</p><pre class="wp-block-preformatted">expr 10 + 3 # Addition<br>expr 10 - 3 # Subtraction<br>expr 10 * 3 # Multiply<br>expr 10 / 3 # Divide<br>expr 10 % 3 # Remainder</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDcyIiBoZWlnaHQ9IjMxNSIgdmlld0JveD0iMCAwIDEwNzIgMzE1Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" width="1072" height="315" data-src="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility.png" alt="Perform Arithmetic Operations In Bash Using Expr Utility" class="wp-image-42595" title="Perform Arithmetic Operations In Bash Using Expr Utility" data-srcset="https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility.png 1072w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility-300x88.png 300w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility-1024x301.png 1024w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility-768x226.png 768w, https://ostechnix.com/wp-content/uploads/2022/09/Perform-Arithmetic-Operations-In-Bash-Using-Expr-Utility-585x172.png 585w" data-sizes="(max-width: 1072px) 100vw, 1072px"></a><figcaption>Perform Arithmetic Operations In Bash Using Expr Utility</figcaption></figure></div><p>Till now we have seen about three different ways to do basic arithmetic and incremental operation. Compared to the <code>let</code> and <code>expr</code>, the <strong>recommended approach is to use double parentheses</strong>.</p><p>A commonality with these three approaches is that they cannot handle floating point operations. You have to rely on external utilities like <code>awk</code> and <code>bc</code> to do floating point operations.</p><h2 id="perform-bash-arithmetic-operations-using-bc" class="ftwp-heading">Perform Bash Arithmetic Operations Using bc Utility</h2><p>The <strong>bc</strong> utility is an external program that can be used to do basic as well as complex mathematical operations. <strong>Floating point operation is also supported</strong> by the bc utility.</p><p>You can view the type of the bc utility and its manual page using the following commands:</p><pre class="wp-block-preformatted">$ type -a bc<br>$ man bc</pre><p>Following examples show simple mathematical operations with Integer and floating values.</p><pre class="wp-block-preformatted"># Add
$ echo "10 + 100" | bc
=&gt; 110

$ echo "10.15 + 11.20" | bc
21.35

# Subtract
$ echo "100 - 25" | bc
=&gt; 75

$ echo "100 - 25.5" | bc
=&gt; 74.5

# Multiply
$ echo "10 * 5" | bc
=&gt; 50

$ echo "10.10 * 4" | bc
=&gt; 40.40</pre><p>When doing division operation you have to set the scale value for the result to be printed in floating point value otherwise the result will be an integer value. The value set in the scale decides how many digits to be printed after the decimal.</p><pre class="wp-block-preformatted"># without scale
echo "10.10 / 4" | bc
=&gt; 2</pre><pre id="block-d3d1248a-b565-4643-9b7e-c9870c5b0484" class="wp-block-preformatted"># with scale<br>echo "scale=2;10.10 / 4" | bc<br>=&gt; 2.52</pre><p>You can also do exponent operation.</p><pre class="wp-block-preformatted">$ echo "2.2^4" | bc<br>=&gt; 23.4</pre><h2 id="perform-mathematical-operations-with-awk" class="ftwp-heading">Perform Mathematical Operations With AWK</h2><p><strong>Awk</strong> offers more functionality to do mathematical computation compared to other utilities. It has a couple of built-in functions which will make our life easy.</p><p>Below is the syntax to do mathematical computation.</p><pre class="wp-block-preformatted">$ awk "BEGIN {print expression }"</pre><p>To perform a simple multiplication, run:</p><pre class="wp-block-preformatted">$ awk "BEGIN {print 23 * 4.5 }"<br>=&gt; 103.5</pre><p>From a floating point value, you can get the integer value alone using the <code>int</code> function.</p><pre class="wp-block-preformatted">$ awk "BEGIN{print int(10.111) }"<br>=&gt; 10</pre><p>You can also calculate the square root of a given number using the <code>sqrt</code> function.</p><pre class="wp-block-preformatted">$ awk "BEGIN{print sqrt(10) }"<br>=&gt; 3.16228</pre><p>Particularly when working with CSV files I often end up in situations to compute the average of a column. You can simply calculate the average of a column with the following code.</p><p>Since this is a CSV file, I am setting the field separator to(-F “,”). Here the entire second column is first added and divided by the NR(number of records).</p><pre class="wp-block-preformatted">$ awk -F <mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color">"," '{sum+=$2} END { print "average value from column 2 = ",sum/NR}' </mark>data.csv</pre><p>We will post a detailed guide about <strong>awk</strong> in the days to come.</p><h2 id="conclusion" class="ftwp-heading">Conclusion</h2><p>In this article, I have shown you various methods to perform simple mathematical operations in Bash. If you are performing very simple arithmetic operations, stick with the double bracket approach and for more complex operations use awk.</p></div><div class="penci-single-link-pages"></div><div class="post-tags">
<a href="https://ostechnix.com/tag/bash/" rel="tag">BASH</a><a href="https://ostechnix.com/tag/bash-arithmetic-operations/" rel="tag">Bash Arithmetic Operations</a><a href="https://ostechnix.com/tag/bash-mathematical-operations/" rel="tag">Bash Mathematical Operations</a><a href="https://ostechnix.com/tag/bash-script/" rel="tag">Bash Script</a><a href="https://ostechnix.com/tag/bash-scripting/" rel="tag">Bash scripting</a><a href="https://ostechnix.com/tag/bash-shell-scripting/" rel="tag">Bash Shell Scripting</a><a href="https://ostechnix.com/tag/bash-tutorial/" rel="tag">Bash tutorial</a><a href="https://ostechnix.com/tag/learn-shell-scripting/" rel="tag">Learn Shell scripting</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-basics/" rel="tag">Linux basics</a><a href="https://ostechnix.com/tag/linux-commands/" rel="tag">Linux commands</a><a href="https://ostechnix.com/tag/shell-scripting/" rel="tag">Shell scripting</a></div></div></div><div class="tags-share-box single-post-share tags-share-box-s1  center-box  social-align-default post-share">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>0 comment</span>
<span class="post-share-item post-share-plike">
<span class="count-number-like">4</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="42589" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a>					</span>
<a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank"  rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/bash-arithmetic-operations/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank"  rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash%20-%20https://ostechnix.com/bash-arithmetic-operations/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank"  rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;title=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank"  rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;title=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash"><i class="penci-faicon fa fa-reddit-alien" ></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank"  rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash %0A%0A https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F"><i class="penci-faicon fa fa-whatsapp" ></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank"  rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fbash-arithmetic-operations%2F&#038;text=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash"><i class="penci-faicon fa fa-telegram" ></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email"  rel="noreferrer" href="mailto:?subject=How%20To%20Perform%20Arithmetic%20Operations%20In%20Bash&#038;BODY=https://ostechnix.com/bash-arithmetic-operations/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#"><i class="penci-faicon penciicon-add" ></i></a></div><div class="post-author abio-style-1 bioimg-round"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/ac25d6c54a0ce1137c818bdd431ec0d6.jpg?ver=1662193675' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/c0007d0ac1b7a2bd8f4959567722c0fc.jpg?ver=1662193675 2x' class='avatar avatar-100 photo' height='100' width='100' /></div><div class="author-content"><h5><a href="https://ostechnix.com/author/karthick/" title="Author Karthick" rel="author">Karthick</a></h5><p>Karthick is a passionate software engineer who loves to explore new technologies. He is a public speaker and loves writing about technology especially about Linux and opensource.</p><div class="bio-social">
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://ostechnix.com/"><i class="penci-faicon fa fa-globe" ></i></a></div></div></div><div class="post-pagination"><div class="prev-post"><div class="prev-post-inner"><div class="prev-post-title">
<span>Previous post</span></div>
<a href="https://ostechnix.com/convert-arch-linux-packages-to-appimage/"><div class="pagi-text"><h5 class="prev-title">How To Convert Arch Linux Packages To AppImage Using Arch2appimage</h5></div>
</a></div></div></div><div class="post-related"><div class="post-title-box"><h4
class="post-box-title">You May Also Like</h4></div><div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel"
data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2"
data-auto="false"
data-speed="300" data-dots="true"><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/10/Bash-Printf-Command-585x390.jpg"
href="https://ostechnix.com/bash-printf-command/" title="Bash Scripting &#8211; Printf Command Explained With Examples">
</a><h3>
<a href="https://ostechnix.com/bash-printf-command/">Bash Scripting &#8211; Printf Command Explained With Examples</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-10-11T17:31:40+05:30">October 11, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/12/Parse-Arguments-in-Bash-Scripts-Using-getopts-585x390.png"
href="https://ostechnix.com/parse-arguments-in-bash-scripts-using-getopts/" title="Bash Scripting &#8211; Parse Arguments In Bash Scripts Using getopts">
</a><h3>
<a href="https://ostechnix.com/parse-arguments-in-bash-scripts-using-getopts/">Bash Scripting &#8211; Parse Arguments In Bash Scripts...</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-12-18T20:47:21+05:30">December 18, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/09/Bash-While-And-Until-Loop-Explained-With-Examples-585x390.png"
href="https://ostechnix.com/bash-while-until-loop-shell-scripting/" title="Bash Scripting &#8211; While And Until Loop Explained With Examples">
</a><h3>
<a href="https://ostechnix.com/bash-while-until-loop-shell-scripting/">Bash Scripting &#8211; While And Until Loop Explained...</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-09-22T17:16:25+05:30">September 22, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/10/Zenity-Create-GUI-Dialog-Boxes-In-Bash-Scripts-585x390.png"
href="https://ostechnix.com/zenity-create-gui-dialog-boxes-in-bash-scripts/" title="How To Create GUI Dialog Boxes In Bash Scripts With Zenity In Linux And Unix">
</a><h3>
<a href="https://ostechnix.com/zenity-create-gui-dialog-boxes-in-bash-scripts/">How To Create GUI Dialog Boxes In Bash...</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-10-28T15:10:07+05:30">October 28, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/10/Bash-String-Manipulation-585x390.png"
href="https://ostechnix.com/bash-string-manipulation/" title="Bash Scripting &#8211; String Manipulation">
</a><h3>
<a href="https://ostechnix.com/bash-string-manipulation/">Bash Scripting &#8211; String Manipulation</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-10-20T15:39:55+05:30">October 20, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/10/Bash-Case-Statement-585x390.png"
href="https://ostechnix.com/bash-case-statement/" title="Bash Scripting &#8211; Case Statement">
</a><h3>
<a href="https://ostechnix.com/bash-case-statement/">Bash Scripting &#8211; Case Statement</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-10-26T17:13:40+05:30">October 26, 2021</time></span></div></div></div><div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/bash-arithmetic-operations/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p><p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p><div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='42589' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c84bfdc570" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="201"/><script type="litespeed/javascript">document.getElementById("ak_js_1").setAttribute("value",(new Date()).getTime())</script></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></article></div></div><div id="sidebar"
class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left  pciconp-right pcicon-right penci-sticky-sidebar"><div class="theiaStickySidebar"><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="5990223580"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p><p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..."/><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p>
<input type="hidden" value="Ostechnix" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="6186167963"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></aside></div></div></div></div></div><div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div><div class="clear-footer"></div><div id="widget-area"><div class="container"><div class="footer-widget-wrapper footer-widget-style-1"><aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4><div class="textwidget"><p><a href="https://ostechnix.com/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzNDAiIGhlaWdodD0iNjgiIHZpZXdCb3g9IjAgMCAzNDAgNjgiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" class="aligncenter wp-image-25308 size-full" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-sizes="(max-width: 340px) 100vw, 340px" /></a></p><p>&nbsp;</p><p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><div class="widget-social pc_aligncenter remove-circle">
<a href="https://www.facebook.com/ostechnix/"
aria-label="Facebook"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-facebook"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/ostechnix"
aria-label="Twitter"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-twitter"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix"
aria-label="Linkedin"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-linkedin"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"
aria-label="Youtube"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-youtube-play"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Youtube</span></a>
<a href="mailto:info@ostechnix.com"
aria-label="Email"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-envelope"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Email</span></a>
<a href="https://www.reddit.com/r/OSTechNix/"
aria-label="Reddit"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-reddit-alien"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Reddit</span></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Rss</span></a></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1"><aside id="block-4" class="widget widget_block widget_archive"><div class=" wp-block-archives-dropdown wp-block-archives"><label for="wp-block-archives-1">Archives</label>
<select id="wp-block-archives-1" name="archive-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;"><option value="">Select Month</option><option value='https://ostechnix.com/2022/09/'> September 2022 &nbsp;(2)</option><option value='https://ostechnix.com/2022/08/'> August 2022 &nbsp;(12)</option><option value='https://ostechnix.com/2022/07/'> July 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/06/'> June 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/05/'> May 2022 &nbsp;(20)</option><option value='https://ostechnix.com/2022/04/'> April 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/03/'> March 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/02/'> February 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2022/01/'> January 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2021/12/'> December 2021 &nbsp;(17)</option><option value='https://ostechnix.com/2021/11/'> November 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/10/'> October 2021 &nbsp;(12)</option><option value='https://ostechnix.com/2021/09/'> September 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/08/'> August 2021 &nbsp;(19)</option><option value='https://ostechnix.com/2021/07/'> July 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/06/'> June 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/05/'> May 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/04/'> April 2021 &nbsp;(11)</option><option value='https://ostechnix.com/2021/03/'> March 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/02/'> February 2021 &nbsp;(16)</option><option value='https://ostechnix.com/2021/01/'> January 2021 &nbsp;(13)</option><option value='https://ostechnix.com/2020/12/'> December 2020 &nbsp;(16)</option><option value='https://ostechnix.com/2020/11/'> November 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/10/'> October 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/09/'> September 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/08/'> August 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/07/'> July 2020 &nbsp;(17)</option><option value='https://ostechnix.com/2020/06/'> June 2020 &nbsp;(24)</option><option value='https://ostechnix.com/2020/05/'> May 2020 &nbsp;(23)</option><option value='https://ostechnix.com/2020/04/'> April 2020 &nbsp;(31)</option><option value='https://ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option><option value='https://ostechnix.com/2020/02/'> February 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option><option value='https://ostechnix.com/2019/12/'> December 2019 &nbsp;(12)</option><option value='https://ostechnix.com/2019/11/'> November 2019 &nbsp;(7)</option><option value='https://ostechnix.com/2019/10/'> October 2019 &nbsp;(10)</option><option value='https://ostechnix.com/2019/09/'> September 2019 &nbsp;(10)</option><option value='https://ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option><option value='https://ostechnix.com/2019/07/'> July 2019 &nbsp;(16)</option><option value='https://ostechnix.com/2019/06/'> June 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/05/'> May 2019 &nbsp;(11)</option><option value='https://ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option><option value='https://ostechnix.com/2019/03/'> March 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/02/'> February 2019 &nbsp;(8)</option><option value='https://ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2018/12/'> December 2018 &nbsp;(6)</option><option value='https://ostechnix.com/2018/11/'> November 2018 &nbsp;(11)</option><option value='https://ostechnix.com/2018/10/'> October 2018 &nbsp;(17)</option><option value='https://ostechnix.com/2018/09/'> September 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2018/08/'> August 2018 &nbsp;(18)</option><option value='https://ostechnix.com/2018/07/'> July 2018 &nbsp;(14)</option><option value='https://ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option><option value='https://ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/04/'> April 2018 &nbsp;(20)</option><option value='https://ostechnix.com/2018/03/'> March 2018 &nbsp;(21)</option><option value='https://ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/11/'> November 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/10/'> October 2017 &nbsp;(16)</option><option value='https://ostechnix.com/2017/09/'> September 2017 &nbsp;(24)</option><option value='https://ostechnix.com/2017/08/'> August 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/07/'> July 2017 &nbsp;(22)</option><option value='https://ostechnix.com/2017/06/'> June 2017 &nbsp;(13)</option><option value='https://ostechnix.com/2017/05/'> May 2017 &nbsp;(20)</option><option value='https://ostechnix.com/2017/04/'> April 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/03/'> March 2017 &nbsp;(33)</option><option value='https://ostechnix.com/2017/02/'> February 2017 &nbsp;(31)</option><option value='https://ostechnix.com/2017/01/'> January 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2016/12/'> December 2016 &nbsp;(19)</option><option value='https://ostechnix.com/2016/11/'> November 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option><option value='https://ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option><option value='https://ostechnix.com/2016/08/'> August 2016 &nbsp;(22)</option><option value='https://ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option><option value='https://ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option><option value='https://ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option><option value='https://ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option><option value='https://ostechnix.com/2016/02/'> February 2016 &nbsp;(21)</option><option value='https://ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option><option value='https://ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option><option value='https://ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option><option value='https://ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option><option value='https://ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option><option value='https://ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option><option value='https://ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option><option value='https://ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option>
</select></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1 last"><aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4><ul id="penci-popularwg-1129"
class="side-newsfeed display-order-numbers"><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">1</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png"
href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/"
title="Youtube-dl Tutorial With Examples For Beginners"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners">
Youtube-dl Tutorial With Examples For Beginners                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span></div></div></div></li><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">2</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png"
href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/"
title="How To Fix Busybox Initramfs Error On Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu">
How To Fix Busybox Initramfs Error On Ubuntu                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span></div></div></div></li><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">3</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2018/08/Switch-Between-Multiple-PHP-Versions-In-Ubuntu-263x175.png"
href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/"
title="How To Switch Between Multiple PHP Versions In Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/" rel="bookmark" title="How To Switch Between Multiple PHP Versions In Ubuntu">
How To Switch Between Multiple PHP Versions In Ubuntu                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2018-08-09T16:20:32+05:30">August 9, 2018</time></span></div></div></div></li></ul></aside></div></div></div><footer id="footer-section"
class="penci-footer-social-media penci-lazy"		        itemscope itemtype="https://schema.org/WPFooter"><div class="container"><div class="footer-logo-copyright footer-not-logo footer-not-gotop"><div class="footer-menu-wrap" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li><li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li><li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li><li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li></ul></div><div id="footer-copyright"><p>OSTechNix © 2022. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p></div></div></div></footer></div><div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div>
<a id="close-sidebar-nav"
class="header-3"><i class="penci-faicon fa fa-close" ></i></a><nav id="sidebar-nav" class="header-3" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><div id="sidebar-nav-logo">
<a href="https://ostechnix.com/"><img class="penci-lazy sidebar-nav-logo penci-limg"                                                                     src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E"
width="250"
height="52"
data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png"
data-lightlogo="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png"
alt="OSTechNix"/></a></div><div class="header-social sidebar-nav-social"><div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
<a href="mailto:info@ostechnix.com" aria-label="Email"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" ></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" ></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div><div class="penci-hbg-search-box penci-vernav-search-box"><form role="search" method="get" class="pc-searchform penci-hbg-search-form"
action="https://ostechnix.com/"><div class="inner-hbg-search-form">
<input type="text" class="search-input"
placeholder="Type and hit enter..." name="s"/>
<i class="penciicon-magnifiying-glass"></i></div></form></div><ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></nav><div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"><div class="penci-gprd-law"><p>
This website uses cookies to improve your experience. By using this site, we will assume that you're OK with it.				<a class="penci-gprd-accept" href="#">Accept</a>				<a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a></p></div></div><!--[if lte IE 9]> <script>'use strict';
            (function($) {
                $(document).ready(function() {
                    $('#ftwp-container').addClass('ftwp-ie9');
                });
            })(jQuery);</script> <![endif]--> <script id='main-scripts-js-extra' type="litespeed/javascript">var ajax_var_more={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"62797810d9","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script id='penci_ajax_like_post-js-extra' type="litespeed/javascript">var ajax_var={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"62797810d9","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script type='text/javascript' src='https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/instant_click.min.js' id='litespeed-cache-js'></script> <script id='fixedtoc-js-js-extra' type="litespeed/javascript">var fixedtocOption={"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""}</script> <script id='penci-ajaxsearch-js-extra' type="litespeed/javascript">var penci_ajsr={"ajaxUrl":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","searchUrl":"https:\/\/ostechnix.com\/search\/","minchar":"2","maxitems":"10","citems":"","thumbnail":"1","date":"1","allresults":"Show all results","nonce":"17c228fed9"}</script> <script src='https://stats.wp.com/e-202236.js' defer></script> <script type="litespeed/javascript">_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:11.2',blog:'84551477',post:'42589',tz:'5.5',srv:'ostechnix.com'}]);_stq.push(['clickTrackerInit','84551477','42589'])</script> <script type="litespeed/javascript">function PenciSimplePopularPosts_AddCount(id,endpoint){var xmlhttp;var params="/?penci_spp_count=1&penci_spp_post_id="+id+"&cachebuster="+Math.floor((Math.random()*100000));if(window.XMLHttpRequest){xmlhttp=new XMLHttpRequest()}else{xmlhttp=new ActiveXObject("Microsoft.XMLHTTP")}
xmlhttp.onreadystatechange=function(){if(xmlhttp.readyState==4&&xmlhttp.status==200){var data=JSON.parse(xmlhttp.responseText);document.getElementsByClassName("penci-post-countview-number")[0].innerHTML=data.visits}}
xmlhttp.open("GET",endpoint+params,!0);xmlhttp.send()}
PenciSimplePopularPosts_AddCount(42589,'https://ostechnix.com')</script>  <script type="litespeed/javascript" data-src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="litespeed/javascript">window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag('js',new Date());gtag('config','UA-75259810-1')</script> <script data-no-optimize="1" defer>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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/litespeed/js/cd898addc6c42a07efff5a500aa61579.js?ver=2fefe"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"74670f99bd0257a6","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2022.8.1","si":100}' crossorigin="anonymous"></script>
</body></html>
<!-- Page optimized by LiteSpeed Cache @2022-09-06 17:24:06 -->
<!-- Page generated by LiteSpeed Cache 5.2 on 2022-09-06 17:24:06 -->
<!-- Guest Mode -->