<!DOCTYPE html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script> <meta charset="UTF-8"><style id="litespeed-ccss">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://ostechnix.com/wp-content/litespeed/css/ae40089e5e7c6027270a8db851da518c.css?ver=27dda" /><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/css_async.min.js"></script> <meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"/><link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"
type="image/x-icon"/><link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"><link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed"
href="https://ostechnix.com/feed/"/><link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed"
href="https://ostechnix.com/feed/atom/"/><link rel="pingback" href="https://ostechnix.com/xmlrpc.php"/>
<!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><title>Find WiFi Password Of Connected Networks In Linux - OSTechNix</title><meta name="description" content="Did you forget your WiFi password? This guide explains a few different ways to find WiFi password of connected networks in Linux." /><link rel="canonical" href="https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Find WiFi Password Of Connected Networks In Linux - OSTechNix" /><meta property="og:description" content="Did you forget your WiFi password? This guide explains a few different ways to find WiFi password of connected networks in Linux." /><meta property="og:url" content="https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/" /><meta property="og:site_name" content="OSTechNix" /><meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /><meta property="article:author" content="ostechnix" /><meta property="article:published_time" content="2022-12-26T12:56:28+00:00" /><meta property="article:modified_time" content="2022-12-26T13:33:46+00:00" /><meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-In-Linux.png" /><meta property="og:image:width" content="800" /><meta property="og:image:height" content="450" /><meta property="og:image:type" content="image/png" /><meta name="author" content="sk" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@ostechnix" /><meta name="twitter:site" content="@ostechnix" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="sk" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="10 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Find WiFi Password Of Connected Networks In Linux Comments Feed" href="https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/feed/" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><style id='wp-block-library-theme-inline-css' type='text/css'>.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-audio{margin:0 0 1em}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.wp-block-embed{margin:0 0 1em}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-image{margin:0 0 1em}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-search__button{border:1px solid #ccc;padding:.375em .625em}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table{margin:"0 0 1em 0"}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video{margin:0 0 1em}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}</style><style id='global-styles-inline-css' type='text/css'>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</style><style id='fixedtoc-style-inline-css' type='text/css'>.ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); }</style> <script type="litespeed/javascript" data-src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/23387" /><link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F" /><link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;format=xml" /><style>img#wpstats{display:none}</style> <script type="litespeed/javascript">var penciBlocksArray=[];var portfolioDataJs=portfolioDataJs||[];var PENCILOCALCACHE={};(function(){"use strict";PENCILOCALCACHE={data:{},remove:function(ajaxFilterItem){delete PENCILOCALCACHE.data[ajaxFilterItem]},exist:function(ajaxFilterItem){return PENCILOCALCACHE.data.hasOwnProperty(ajaxFilterItem)&&PENCILOCALCACHE.data[ajaxFilterItem]!==null},get:function(ajaxFilterItem){return PENCILOCALCACHE.data[ajaxFilterItem]},set:function(ajaxFilterItem,cachedData){PENCILOCALCACHE.remove(ajaxFilterItem);PENCILOCALCACHE.data[ajaxFilterItem]=cachedData}}})();function penciBlock(){this.atts_json='';this.content=''}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Find WiFi Password Of Connected Networks In Linux",
    "description": "Did you forget your WiFi password? This guide explains a few different ways to find WiFi password of connected networks in Linux.",
    "datePublished": "2022-12-26",
    "datemodified": "2022-12-26",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/find-wifi-password-of-connected-networks-in-linux\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/05\/Find-WiFi-Password-Of-Connected-Networks-In-Linux.png",
        "width": 800,
        "height": 450
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk",
        "url": "https:\/\/ostechnix.com\/author\/sk\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/wifi\/",
                "name": "WiFi"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/find-wifi-password-of-connected-networks-in-linux\/",
                "name": "Find WiFi Password Of Connected Networks In Linux"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /><meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /></head><body data-rsssl=1 class="post-template-default single single-post postid-23387 single-format-standard soledad-ver-8-2-9 pclight-mode pcmn-drdw-style-slide_down pchds-default has-ftoc">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"><div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"><div class="container"><div class="penci-headline" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li><li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li><li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></div><div class="pctopbar-item penci-topbar-social"><div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
<a href="mailto:info@ostechnix.com" aria-label="Email"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" ></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" ></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div></div></div></div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="inner-header penci-header-second"><div class="container align-left-logo has-banner"><div id="logo">
<a href="https://ostechnix.com/"><img
class="penci-mainlogo penci-limg"             src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix"
width="350"
height="73"></a></div><div class="header-banner header-style-3"> <script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="9496719407"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script> </div></div></div><div class="sticky-wrapper"><nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="container"><div class="button-menu-mobile header-3"><svg width=18px height=18px viewBox="0 0 512 384" version=1.1 xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink><g stroke=none stroke-width=1 fill-rule=evenodd><g transform="translate(0.000000, 0.250080)"><rect x=0 y=0 width=512 height=62></rect><rect x=0 y=161 width=512 height=62></rect><rect x=0 y=321 width=512 height=62></rect></g></g></svg></div><ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li><li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li><li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li><li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li><li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li><li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li><li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li><li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li></ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes">
<a href="#" class="search-click">
<i class="penciicon-magnifiying-glass"></i>
</a><div class="show-search pcbds-default"><form role="search" method="get" class="pc-searchform"
action="https://ostechnix.com/"><div class="pc-searchform-inner">
<input type="text" class="search-input"
placeholder="Type and hit enter..." name="s"/>
<i class="penciicon-magnifiying-glass"></i>
<button type="submit"
class="searchsubmit">Search</button></div></form>
<a href="#" class="search-click close-search"><i class="penciicon-close-button"></i></a></div></div></div></nav></div></header></div><div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt;
&lt;!-- New Horizontal Responsive Adv --&gt;
&lt;ins class=&quot;adsbygoogle&quot;
style=&quot;display:block&quot;
data-ad-client=&quot;ca-pub-6701402139964678&quot;
data-ad-slot=&quot;9496719407&quot;
data-ad-format=&quot;auto&quot;
data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt;
&lt;script&gt;
(adsbygoogle = window.adsbygoogle || []).push({});
&lt;/script&gt;&lt;/div&gt;"><div class="penci-single-block"         data-prev-url="https://ostechnix.com/install-microsoft-visual-studio-code-linux/"
data-current-url="https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"
data-post-title="Find WiFi Password Of Connected Networks In Linux"
data-edit-post=""
data-postid="23387"><div class="container penci-breadcrumb single-breadcrumb">
<span><a class="crumb"
href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fa fa-angle-right" ></i>					<span><a class="crumb" href="https://ostechnix.com/category/wifi/">WiFi</a></span><i class="penci-faicon fa fa-angle-right" ></i>                    <span>Find WiFi Password Of Connected Networks In Linux</span></div><div class="container container-single penci_sidebar  penci-enable-lightbox"><div id="main" class="penci-main-sticky-sidebar"><div class="theiaStickySidebar"><article id="post-23387" class="post type-post status-publish"><div class="header-standard header-classic single-header"><div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-5043" href="https://ostechnix.com/category/wifi/"  rel="category tag">WiFi</a><a class="penci-cat-name penci-cat-9" href="https://ostechnix.com/category/command-line-utilities/"  rel="category tag">Command line utilities</a><a class="penci-cat-name penci-cat-18" href="https://ostechnix.com/category/faq/"  rel="category tag">FAQ</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/"  rel="category tag">Linux</a><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/"  rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-27" href="https://ostechnix.com/category/linux-basics/"  rel="category tag">Linux Basics</a><a class="penci-cat-name penci-cat-1055" href="https://ostechnix.com/category/linux-commands/"  rel="category tag">Linux Commands</a><a class="penci-cat-name penci-cat-4207" href="https://ostechnix.com/category/linux-networking/"  rel="category tag">Linux Networking</a><a class="penci-cat-name penci-cat-4573" href="https://ostechnix.com/category/linux-tips-tricks/"  rel="category tag">Linux Tips &amp; Tricks</a><a class="penci-cat-name penci-cat-42" href="https://ostechnix.com/category/opensource/"  rel="category tag">Opensource</a><a class="penci-cat-name penci-cat-56" href="https://ostechnix.com/category/tips-and-tricks/"  rel="category tag">Tips and Tricks</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/"  rel="category tag">Unix/Linux Beginners</a><a class="penci-cat-name penci-cat-60" href="https://ostechnix.com/category/utilities/"  rel="category tag">Utilities</a></span></div><h1 class="post-title single-post-title entry-title">Find WiFi Password Of Connected Networks In Linux</h1><h2 class="penci-psub-title ">Different Ways To View Saved WiFi Password In Linux</h2><div class="penci-hide-tagupdated">
<span class="author-italic author vcard">By                                         <a class="author-url url fn n"
href="https://ostechnix.com/author/sk/">sk</a>
</span>
<time class="entry-date published" datetime="2022-12-26T18:26:28+05:30">December 26, 2022</time></div><div class="post-box-meta-single">
<span class="author-post byline"><span
class="author vcard">Written by                                     <a class="author-url url fn n"
href="https://ostechnix.com/author/sk/">sk</a>
</span></span>
<span><time class="entry-date published" datetime="2022-12-26T18:26:28+05:30">December 26, 2022</time></span>
<span><i class="penci-post-countview-number">46.8k</i> views</span></div></div><div class="sstyle-style-1 tags-share-box tags-share-box-top single-post-share tags-share-box-s1  center-box  social-align-default post-share">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>4 comments</span>
<span class="post-share-item post-share-plike"><span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="23387" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a></span><a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank"  rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank"  rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux%20-%20https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank"  rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;title=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank"  rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;title=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux"><i class="penci-faicon fa fa-reddit-alien" ></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank"  rel="noreferrer" href="https://api.whatsapp.com/send?text=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F"><i class="penci-faicon fa fa-whatsapp" ></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank"  rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;text=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux"><i class="penci-faicon fa fa-telegram" ></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email"  rel="noreferrer" href="mailto:?subject=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux&#038;BODY=https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#" aria-label="Share Expand"><i class="penci-faicon penciicon-add" ></i></a></div><div class="post-entry blockquote-style-2"><div class="inner-post-entry entry-content" id="penci-post-entry-inner"><div id="ftwp-postcontent"><p>As you may already know, when you connect to a wireless network for the first time, the WiFi password is saved in your Linux machine. So you don't need to enter the password of your wireless network every time. In the subsequent times, the available WiFi network will be automatically connected. Over the time, you might have forgotten the WiFi password. One day you want to add a new device to the same WiFi network, but you don't remember the password. What are you going to do? No worries! I know a few ways to <strong>find WiFi password of connected networks in Linux</strong>.</p><div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#find-wifi-password-of-connected-networks-in-linux"><span class="ftwp-text">Find WiFi Password Of Connected Networks In Linux</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#1-view-saved-wifi-password-of-connected-networks-from-command-line"><span class="ftwp-text">1. View Saved WiFi Password Of Connected Networks From Command line</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#2-show-saved-wifi-password-using-nmcli"><span class="ftwp-text">2. Show Saved WiFi Password using Nmcli</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#3-find-wifi-password-of-connected-networks-from-network-manager-gui"><span class="ftwp-text">3. Find WiFi Password Of Connected Networks From Network Manager (GUI)</span></a></li><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#4-get-saved-wifi-password-of-connected-networks-using-wifresti"><span class="ftwp-text">4. Get Saved WiFi Password Of Connected Networks Using Wifresti</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#install-wifresti-in-linux"><span class="ftwp-text">Install Wifresti In Linux</span></a></li></ol></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="find-wifi-password-of-connected-networks-in-linux" class="ftwp-heading">Find WiFi Password Of Connected Networks In Linux</h2><p>We can get the Wi-Fi password of the saved networks either from Command line or GUI or using any third-party password recovery tools.</p><div><div class="penci-custom-html-inside-content"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></div><p>The following steps were tested in Ubuntu 20.04 LTS desktop (GNOME), and Debian 11 Cinnamon editions. However, these steps are almost same for other Linux distributions.</p><p>Let us first see how to reveal a wireless network password from the command line.</p><h3 id="1-view-saved-wifi-password-of-connected-networks-from-command-line" class="ftwp-heading">1. View Saved WiFi Password Of Connected Networks From Command line</h3><p>In Ubuntu and its variants, the wireless network configuration files are saved in the <strong><code>/etc/NetworkManager/system-connections/</code></strong> directory. Let us take a look at the saved or connected WiFi network config files:</p><pre class="wp-block-preformatted">$ ls /etc/NetworkManager/system-connections/</pre><p><strong>Sample output:</strong></p><pre class="wp-block-preformatted">'HP 7 VoiceTab Network' JioFi4_12E9FE sktab</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/View-Connected-Wifi-Networks-From-Command-line-In-Linux.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI3MTQiIGhlaWdodD0iNDIzIiB2aWV3Qm94PSIwIDAgNzE0IDQyMyI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="714" height="423" data-src="https://ostechnix.com/wp-content/uploads/2020/05/View-Connected-Wifi-Networks-From-Command-line-In-Linux.png" alt="View Connected Wifi Networks From Command line In Linux" class="wp-image-23395" title="View Connected Wifi Networks From Command line In Linux" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/View-Connected-Wifi-Networks-From-Command-line-In-Linux.png 714w, https://ostechnix.com/wp-content/uploads/2020/05/View-Connected-Wifi-Networks-From-Command-line-In-Linux-300x178.png 300w, https://ostechnix.com/wp-content/uploads/2020/05/View-Connected-Wifi-Networks-From-Command-line-In-Linux-520x308.png 520w, https://ostechnix.com/wp-content/uploads/2020/05/View-Connected-Wifi-Networks-From-Command-line-In-Linux-320x190.png 320w" data-sizes="(max-width: 714px) 100vw, 714px"></a><figcaption class="wp-element-caption">View Connected Wifi Networks From Command line In Linux</figcaption></figure></div><p>As you see, I have config files of 3 saved networks in my Ubuntu system. These files will have various details of each network, such as wifi id, mac address, SSID, authentication method, wifi password etc. Just open this file using cat command or text editors to view the password.</p><p>For instance, I am going to view the details of <strong>"<code>JioFi4_12E9FE</code>"</strong> WiFi using <code>cat</code> command:</p><pre class="wp-block-preformatted">$ sudo cat /etc/NetworkManager/system-connections/JioFi4_12E9FE</pre><p><strong>Sample output:</strong></p><pre class="wp-block-preformatted">[...]
[wifi]
mac-address=XX:XX:XX:XX:XX:XX
mac-address-blacklist=
mode=infrastructure
<strong><mark style="background-color:#fcb900" class="has-inline-color">ssid=JioFi4_12E9FE</mark></strong>

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
<strong><mark style="background-color:#fcb900" class="has-inline-color">psk=xxxxxxxxxxx</mark></strong>

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Command-line-In-Linux.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI2OTAiIGhlaWdodD0iNTQyIiB2aWV3Qm94PSIwIDAgNjkwIDU0MiI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="690" height="542" data-src="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Command-line-In-Linux.png" alt="Find WiFi Password Of Connected Networks From Command line In Linux" class="wp-image-23396" title="Find WiFi Password Of Connected Networks From Command line In Linux" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Command-line-In-Linux.png 690w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Command-line-In-Linux-300x236.png 300w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Command-line-In-Linux-520x408.png 520w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Command-line-In-Linux-320x251.png 320w" data-sizes="(max-width: 690px) 100vw, 690px"></a><figcaption class="wp-element-caption">Find WiFi Password Of Connected Networks From Command line In Linux</figcaption></figure></div><p>In the above output, the <strong>psk</strong> value is the password of the given Wifi network (i.e. <strong><code>JioFi4_12E9FE</code></strong>).</p><blockquote class="wp-block-quote"><p>💡 For those wondering, <strong>PSK</strong> (Pre-Shared Key) is a client authentication method. It uses a string of 64 hexadecimal digits, or as a passphrase of 8 to 63 printable ASCII characters, to generate unique encryption keys for each wireless client. PSK is one of two available authentication methods used for WPA and WPA2 encryption on Juniper Networks wireless networks.</p></blockquote><p>Alternatively, you can use <a href="https://ostechnix.com/the-grep-command-tutorial-with-examples-for-beginners/" target="_blank" rel="noopener noreferrer"><strong>grep command</strong></a> to quickly find the password of saved or connected WiFi networks like below:</p><pre class="wp-block-preformatted">$ sudo grep -r '^psk=' /etc/NetworkManager/system-connections/</pre><p>This command will display the psk (password) of all connected Wireless networks.</p><p><strong>Sample output:</strong></p><pre class="wp-block-preformatted">/etc/NetworkManager/system-connections/sktab:psk=xxxxxxxx
/etc/NetworkManager/system-connections/JioFi4_12E9FE:psk=xxxxxxxx</pre><p>You can also use:</p><pre class="wp-block-preformatted">$ sudo grep psk= /etc/NetworkManager/system-connections/*</pre><p>If you don't want to see the WiFi SSID names, but only the passwords, use <strong>-h</strong> flag:</p><pre class="wp-block-preformatted">$ sudo grep -hr '^psk=' /etc/NetworkManager/system-connections/</pre><p><strong>Sample output:</strong></p><pre class="wp-block-preformatted">psk=xxxxxxxx
psk=xxxxxxxx</pre><p>One problem of the above command is you don't know which password is for which SSID. So, it is better not to use <code>-h</code> flag.</p><h3 id="2-show-saved-wifi-password-using-nmcli" class="ftwp-heading">2. Show Saved WiFi Password using Nmcli</h3><p>Instead of looking into configuration files, we can use <strong><code>nmcli</code></strong>, a command-line tool for controlling NetworkManager.</p><p>First, let us find the list of available wireless network connections using the following command:</p><pre class="wp-block-preformatted">$ nmcli device wifi list</pre><p><strong>Sample output from my Debian 11 system</strong></p><pre class="wp-block-preformatted">IN-USE  BSSID              SSID                          MODE   CHAN  RATE        SIGNAL  BARS  SECURITY  
        xx:xx:xx:xx:xx:49  Ostechnix_jio_4g              Infra  6     130 Mbit/s  100     ▂▄▆█  WPA2      
<strong><mark style="background-color:#fcb900" class="has-inline-color">*       xx:xx:xx:xx:xx:4A  Ostechnix_jio_5g              Infra  149   270 Mbit/s  94      ▂▄▆█  WPA2</mark></strong>      
        xx:xx:xx:xx:xx:69  Wifi network1                  Infra  11    130 Mbit/s  44      ▂▄__  WPA2      
        xx:xx:xx:xx:xx:6A  WiFi network2                       Infra  36    270 Mbit/s  44      ▂▄__  WPA2      
        xx:xx:xx:xx:xx:44  HP-Print-44-LaserJet Pro MFP  Infra  2     65 Mbit/s   27      ▂___  WPA1 WPA2 </pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxOTIwIiBoZWlnaHQ9IjM4MyIgdmlld0JveD0iMCAwIDE5MjAgMzgzIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1920" height="383" data-src="https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command.png" alt="Find the List of Available Wireless Network Connections using nmcli Command" class="wp-image-46212" title="Find the List of Available Wireless Network Connections using nmcli Command" data-srcset="https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command.png 1920w, https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command-300x60.png 300w, https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command-1024x204.png 1024w, https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command-768x153.png 768w, https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command-1536x306.png 1536w, https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command-1170x233.png 1170w, https://ostechnix.com/wp-content/uploads/2022/12/Find-the-List-of-Available-Wireless-Network-Connections-using-nmcli-Command-585x117.png 585w" data-sizes="(max-width: 1920px) 100vw, 1920px"></a><figcaption class="wp-element-caption">Find the List of Available Wireless Network Connections using nmcli Command</figcaption></figure></div><p>As shown in the above output, you will get the following details:</p><ul><li>BSSID address (MAC physical address of the access point or wireless router),</li><li>SSID name,</li><li>Mode,</li><li>Channel,</li><li>Connection speed,</li><li>Signal strength,</li><li>and Wireless Security protocol (E.g. WPA2)</li></ul><p>The <strong>currently connected WiFi network is marked with an Asterisk (*)</strong>. As per the above output, the currently connected WiFi network is <strong>Ostechnix_Jio_5g</strong>.</p><p class="has-black-color has-text-color has-background" style="background-color:#ffffcc"><strong>Heads Up:</strong> Please note that the <code>nmcli</code> commands can be shortened, so <code>nmcli d w l</code> command will also display the list of WiFi networks.</p><p>Now, let us display the get the password of the currently connected WiFi network using command:</p><pre class="wp-block-preformatted">$ nmcli device wifi show-password </pre><p><strong>Sample output:</strong></p><pre class="wp-block-preformatted"><strong><mark style="background-color:#fcb900" class="has-inline-color">SSID: Ostechnix_jio_5g</mark></strong>
Security: WPA
<strong><mark style="background-color:#fcb900" class="has-inline-color">Password: xxxxxxxxxxxx</mark></strong>

  █████████████████████████████████
  ██ ▄▄▄▄▄ █▄▄██████▄▄▀█ █ ▄▄▄▄▄ ██
  ██ █   █ █ ▀█ ▄  ▀█▀▄ ▀█ █   █ ██
  ██ █▄▄▄█ █▄ ▄▄▀▄▄▄▄▀█ ▀█ █▄▄▄█ ██
  ██▄▄▄▄▄▄▄█▄▀▄▀▄█ ▀ ▀▄█ █▄▄▄▄▄▄▄██
  ██▄▄  ▀▀▄▀ ▀████▄▄   ▀▀▄▀█ ▄ ▀▄██
  ██ ▄ █▀ ▄▄▀██▀▀  ▀▀▄▀█ █▄█▄ ▄▄███
  ██▀▄█ ▄▄▄ █▄▀ ██   ▄█ ███▄▄▄▄████
  ███▀▄ ▄▄▄▀▀█▄█ ▄█▀▀▄▄▄█▄▀▄▄ ▄▄▄██
  ████  ▀▄▄▄ ▀▄▄▀  ██  ▄  ██▄▄▄█ ██
  ██▄█▄▀██▄█▀ ▀▄ ██ █ ▀▀  ▀ ▄█▀▀▀██
  ███▄█▄▄▄▄█▀ █▄ ▀▀▄█▄█▄ ▄▄▄ █ ▄▄██
  ██ ▄▄▄▄▄ ██ ▀▄▄  █▀▄ ▄ █▄█ ██ ███
  ██ █   █ █▀▀ ▀  █▄  █▀  ▄ ▄ ▀▄ ██
  ██ █▄▄▄█ █  █ ██▀██▄▄█▀▄█▄▀▀▄▀▄██
  ██▄▄▄▄▄▄▄█▄▄▄███▄▄▄██▄▄██▄█▄▄▄███
  █████████████████████████████████</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDc0IiBoZWlnaHQ9IjY3OCIgdmlld0JveD0iMCAwIDEwNzQgNjc4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1074" height="678" data-src="https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command.png" alt="View currently connected WiFi Network Password using nmcli command" class="wp-image-46213" title="View currently connected WiFi Network Password using nmcli command" data-srcset="https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command.png 1074w, https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command-300x189.png 300w, https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command-1024x646.png 1024w, https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command-768x485.png 768w, https://ostechnix.com/wp-content/uploads/2022/12/View-currently-connected-WiFi-Network-Password-using-nmcli-command-585x369.png 585w" data-sizes="(max-width: 1074px) 100vw, 1074px"></a><figcaption class="wp-element-caption">View currently connected WiFi Network Password using nmcli command</figcaption></figure></div><p>The above command will only get the WiFi network details. If you want to show both wired and wireless connections, use the following command variants as well.</p><pre class="wp-block-preformatted">$ nmcli -g NAME connection show</pre><p><strong>Sample output from my Ubuntu 20.04 system:</strong></p><pre class="wp-block-preformatted">JioFi4_12E9FE
mpqemubr0
tap-d8f1eebb39f
HP 7 VoiceTab Network
sktab
Wired connection 1</pre><p>Now find the password of a WiFi network, for example <strong>"<code>JioFi4_12E9FE</code>"</strong>, like below:</p><pre class="wp-block-preformatted">$ nmcli -s -g 802-11-wireless-security.psk connection show JioFi4_12E9FE</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI5MDMiIGhlaWdodD0iMjkxIiB2aWV3Qm94PSIwIDAgOTAzIDI5MSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="903" height="291" data-src="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli.png" alt="Find WiFi Password Of Connected Networks From Commandline Using Nmcli" class="wp-image-23429" title="Find WiFi Password Of Connected Networks From Commandline Using Nmcli" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli.png 903w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli-300x97.png 300w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli-768x247.png 768w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli-720x232.png 720w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli-520x168.png 520w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Commandline-Using-Nmcli-320x103.png 320w" data-sizes="(max-width: 903px) 100vw, 903px"></a><figcaption class="wp-element-caption">Find WiFi Password Of Connected Networks From Commandline Using Nmcli</figcaption></figure></div><p>To get all details of the given network, simply remove the option "<code>-g 802-11-wireless-security.psk</code>" from the above command:</p><pre class="wp-block-preformatted">$ nmcli -s connection show JioFi4_12E9FE</pre><h3 id="3-find-wifi-password-of-connected-networks-from-network-manager-gui" class="ftwp-heading">3. Find WiFi Password Of Connected Networks From Network Manager (GUI)</h3><p>If you are not comfortable with command line way, here is how to do it graphically in Ubuntu GNOME.</p><p>Click on the WiFi icon on the top panel. A drop-down menu will appear. Click on the connected WiFi SSID and again click <strong>"WiFi Settings"</strong>.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-In-Linux.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0OTAiIGhlaWdodD0iNTM0IiB2aWV3Qm94PSIwIDAgNDkwIDUzNCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="490" height="534" data-src="https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-In-Linux.png" alt="Edit Wifi Network Settings In Linux" class="wp-image-23397" title="Edit Wifi Network Settings In Linux" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-In-Linux.png 490w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-In-Linux-275x300.png 275w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-In-Linux-320x349.png 320w" data-sizes="(max-width: 490px) 100vw, 490px"></a><figcaption class="wp-element-caption">Edit Wifi Network Settings In Linux</figcaption></figure></div><p>In the next window, you will see a list of currently connected networks. Click on the gear icon next to your preferred wifi network.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI5ODAiIGhlaWdodD0iNjkxIiB2aWV3Qm94PSIwIDAgOTgwIDY5MSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="980" height="691" data-src="https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings.png" alt="Edit Wifi Network Settings" class="wp-image-23398" title="Edit Wifi Network Settings" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings.png 980w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-300x212.png 300w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-768x542.png 768w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-720x508.png 720w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-520x367.png 520w, https://ostechnix.com/wp-content/uploads/2020/05/Edit-Wifi-Network-Settings-320x226.png 320w" data-sizes="(max-width: 980px) 100vw, 980px"></a><figcaption class="wp-element-caption">Edit Wifi Network Settings</figcaption></figure></div><p>Now the selected WiFi network settings window will open. Under the <strong>"Security"</strong> tab, you will see the password in asterisks. To reveal the password, simply uncheck <strong>"Show password"</strong> check box.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Network-Manager-GUI-In-Linux.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI1ODAiIGhlaWdodD0iMjI4IiB2aWV3Qm94PSIwIDAgNTgwIDIyOCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="580" height="228" data-src="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Network-Manager-GUI-In-Linux.png" alt="Find WiFi Password Of Connected Networks From Network Manager (GUI) In Linux" class="wp-image-23400" title="Find WiFi Password Of Connected Networks From Network Manager (GUI) In Linux" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Network-Manager-GUI-In-Linux.png 580w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Network-Manager-GUI-In-Linux-300x118.png 300w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Network-Manager-GUI-In-Linux-520x204.png 520w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-From-Network-Manager-GUI-In-Linux-320x126.png 320w" data-sizes="(max-width: 580px) 100vw, 580px"></a><figcaption class="wp-element-caption">Find WiFi Password Of Connected Networks From Network Manager (GUI) In Linux</figcaption></figure></div><p><strong>On Debian Cinnamon:</strong></p><p>Click the WiFi Network icon and choose <strong>"Network Settings"</strong> from the taskbar.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/12/Open-Network-Settings.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0NzYiIGhlaWdodD0iMzgwIiB2aWV3Qm94PSIwIDAgNDc2IDM4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="476" height="380" data-src="https://ostechnix.com/wp-content/uploads/2022/12/Open-Network-Settings.png" alt="Open Network Settings" class="wp-image-46214" title="Open Network Settings" data-srcset="https://ostechnix.com/wp-content/uploads/2022/12/Open-Network-Settings.png 476w, https://ostechnix.com/wp-content/uploads/2022/12/Open-Network-Settings-300x239.png 300w" data-sizes="(max-width: 476px) 100vw, 476px"></a><figcaption class="wp-element-caption">Open Network Settings</figcaption></figure></div><p>Click the gear button next to the connected WiFi network.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/12/Click-Gear-Button-of-the-Connected-WiFi-Network.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI4MjAiIGhlaWdodD0iNjk4IiB2aWV3Qm94PSIwIDAgODIwIDY5OCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="820" height="698" data-src="https://ostechnix.com/wp-content/uploads/2022/12/Click-Gear-Button-of-the-Connected-WiFi-Network.png" alt="Click Gear Button of the Connected WiFi Network" class="wp-image-46215" title="Click Gear Button of the Connected WiFi Network" data-srcset="https://ostechnix.com/wp-content/uploads/2022/12/Click-Gear-Button-of-the-Connected-WiFi-Network.png 820w, https://ostechnix.com/wp-content/uploads/2022/12/Click-Gear-Button-of-the-Connected-WiFi-Network-300x255.png 300w, https://ostechnix.com/wp-content/uploads/2022/12/Click-Gear-Button-of-the-Connected-WiFi-Network-768x654.png 768w, https://ostechnix.com/wp-content/uploads/2022/12/Click-Gear-Button-of-the-Connected-WiFi-Network-585x498.png 585w" data-sizes="(max-width: 820px) 100vw, 820px"></a><figcaption class="wp-element-caption">Click Gear Button of the Connected WiFi Network</figcaption></figure></div><p>Under the <strong>"Security"</strong> tab, uncheck the <strong>"Show password"</strong> checkbox to view the password.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/12/Find-WiFi-Password-of-Connected-WiFi-Networks-From-Network-Manager.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI2NjAiIGhlaWdodD0iNTI0IiB2aWV3Qm94PSIwIDAgNjYwIDUyNCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="660" height="524" data-src="https://ostechnix.com/wp-content/uploads/2022/12/Find-WiFi-Password-of-Connected-WiFi-Networks-From-Network-Manager.png" alt="Find WiFi Password of Connected WiFi Networks From Network Manager" class="wp-image-46216" title="Find WiFi Password of Connected WiFi Networks From Network Manager" data-srcset="https://ostechnix.com/wp-content/uploads/2022/12/Find-WiFi-Password-of-Connected-WiFi-Networks-From-Network-Manager.png 660w, https://ostechnix.com/wp-content/uploads/2022/12/Find-WiFi-Password-of-Connected-WiFi-Networks-From-Network-Manager-300x238.png 300w, https://ostechnix.com/wp-content/uploads/2022/12/Find-WiFi-Password-of-Connected-WiFi-Networks-From-Network-Manager-585x464.png 585w" data-sizes="(max-width: 660px) 100vw, 660px"></a><figcaption class="wp-element-caption">Find WiFi Password of Connected WiFi Networks From Network Manager</figcaption></figure></div><p><strong>On KDE systems:</strong></p><p>If you're using KDE, the network connections pop-up has a button for it:</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/12/Network-Connections-in-KDE.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI5MjgiIGhlaWdodD0iNDg1IiB2aWV3Qm94PSIwIDAgOTI4IDQ4NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" decoding="async" width="928" height="485" data-src="https://ostechnix.com/wp-content/uploads/2022/12/Network-Connections-in-KDE.png" alt="Network Connections in KDE" class="wp-image-46224" title="Network Connections in KDE" data-srcset="https://ostechnix.com/wp-content/uploads/2022/12/Network-Connections-in-KDE.png 928w, https://ostechnix.com/wp-content/uploads/2022/12/Network-Connections-in-KDE-300x157.png 300w, https://ostechnix.com/wp-content/uploads/2022/12/Network-Connections-in-KDE-768x401.png 768w, https://ostechnix.com/wp-content/uploads/2022/12/Network-Connections-in-KDE-585x306.png 585w" data-sizes="(max-width: 928px) 100vw, 928px"></a><figcaption class="wp-element-caption">Network Connections in KDE</figcaption></figure></div><h3 id="4-get-saved-wifi-password-of-connected-networks-using-wifresti" class="ftwp-heading">4. Get Saved WiFi Password Of Connected Networks Using Wifresti</h3><p><strong>Wifresti</strong> is a simple Python script to find the password of saved or connected WiFi networks. It works on Linux, Mac OS and Windows. This script is created by the same developer who created <a href="https://ostechnix.com/install-kali-linux-tools-using-katoolin-linux/" target="_blank" rel="noopener noreferrer"><strong>"Katoolin"</strong></a>.</p><h4 id="install-wifresti-in-linux" class="ftwp-heading">Install Wifresti In Linux</h4><p>Git clone the Wifresti GitHub repository using command:</p><pre class="wp-block-preformatted">$ git clone https://github.com/LionSec/wifresti.git</pre><p>This command will download the contents of Wifresti repository in a local folder named "<code>wifresti</code>".</p><p>Cd into this directory:</p><pre class="wp-block-preformatted">$ cd wifresti/</pre><p>Copy the wifresti.py to your $PATH:</p><pre class="wp-block-preformatted">$ sudo cp wifresti/wifresti.py /usr/bin/wifresti</pre><p>Make it executable:</p><pre class="wp-block-preformatted">$ chmod +x /usr/bin/wifresti</pre><p>Next, run wifresti as sudo user to list all available WiFi networks:</p><pre class="wp-block-preformatted">$ sudo wifresti</pre><p>Choose the operating system you use:</p><pre class="wp-block-preformatted">               /$  /$$                                /$     /$
              |__/ /$__  $                              | $    |__/
 /$  /$  /$ /$| $  \__//$$   /$$   /$$ /$$   /$
| $ | $ | $| $| $   /$__  $ /$__  $ /$_____/|_  $_/  | $
| $ | $ | $| $| $_/  | $  \__/| $$|  $$   | $    | $
| $ | $ | $| $| $    | $      | $_____/ \____  $  | $ /$| $
|  $$/$/| $| $    | $      |  $$ /$$/  |  $/| $
 \_____/\___/ |__/|__/    |__/       \_______/|_______/    \___/  |__/
 
    Author: LionSec | Website: www.neodrix.com | @lionsec1  V1.0            
 
Please choose your operating system.
 
 1) linux
 2) Windows
 3) Mac OS
 
&gt; <span style="color: #ff0000;"><strong>1
</strong></span>[...]
</pre><p>You will see the list of available Wifi networks. Enter the network name to view its password. To view all WiFi networks' password, type "a" and hit ENTER.</p><pre class="wp-block-preformatted">[...]
All wireless networks :
 
HP 7 VoiceTab Network
JioFi4_12E9FE
sktab
 
Insert the network name , or press (a) to see information about all networks.
 
&gt; <span style="color: #ff0000;"><strong>JioFi4_12E9FE</strong></span>
###################################### - JioFi4_12E9FE - ######################################
 
key-mgmt=wpa-psk
<span style="color: #ff0000;"><strong>psk=xxxxxxxx</strong></span>
 
#############################################################################################
[...]</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzY2IiBoZWlnaHQ9IjY5MSIgdmlld0JveD0iMCAwIDEzNjYgNjkxIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1366" height="691" data-src="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti.png" alt="Find WiFi Password Of Connected Networks Using Wifresti" class="wp-image-23401" title="Find WiFi Password Of Connected Networks Using Wifresti" data-srcset="https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti.png 1366w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti-1024x518.png 1024w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti-768x388.png 768w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti-720x364.png 720w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti-520x263.png 520w, https://ostechnix.com/wp-content/uploads/2020/05/Find-WiFi-Password-Of-Connected-Networks-Using-Wifresti-320x162.png 320w" data-sizes="(max-width: 1366px) 100vw, 1366px"></a><figcaption class="wp-element-caption">Find WiFi Password Of Connected Networks Using Wifresti</figcaption></figure></div><p>To quit, press <strong>CTRL+C</strong>.</p><h2 id="conclusion" class="ftwp-heading">Conclusion</h2><p>These are a few ways to find the saved password of a WiFi networks in Linux. Please note that these methods will help only to find the password of the connected WiFi networks. The won't help you to crack a WiFi password.</p><p>If you want to crack a WiFi, there are many password recovery tools available in Kali Linux. You don't have to install Kali Linux. Just install the Kali Linux tools on your Ubuntu system and use the password recovery tools of your choice. To know how to install Kali Linux tools on Ubuntu, refer the following guide.</p><ul><li><a href="https://ostechnix.com/install-kali-linux-tools-using-katoolin3-in-ubuntu-20-04-lts/" target="_blank" rel="noopener noreferrer"><strong>Install Kali Linux Tools Using Katoolin3 In Ubuntu 20.04 LTS</strong></a></li></ul><p><strong>Resource:</strong></p><ul><li><a href="https://github.com/LionSec/wifresti" target="_blank" rel="noopener noreferrer"><strong>Wifresti GitHub Repository</strong></a></li></ul><div class="is-layout-constrained wp-block-group has-black-color has-text-color has-background" style="background-color:#ffdddd"><div class="wp-block-group__inner-container"><p><strong>Related read:</strong></p><ul><li><a href="https://ostechnix.com/update-wifi-network-password-terminal-arch-linux/" target="_blank" rel="noopener noreferrer"><strong>How To Update Wifi Network Password From Terminal In Arch Linux</strong></a></li><li><a href="https://ostechnix.com/monitor-wifi-connection-command-line-linux/" target="_blank" rel="noopener noreferrer"><strong>How To Monitor WiFi Connection From Command Line In Linux</strong></a></li></ul></div></div><p><em>Featured <span class="attribution_field hide-sm vertical">Image by <a href="https://pixabay.com/users/ivke32-2526695/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=1480926" target="_blank" rel="noopener noreferrer">ivke32</a> from <a href="https://pixabay.com/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=1480926" target="_blank" rel="noopener noreferrer">Pixabay</a></span>.</em></p></div><div class="penci-single-link-pages"></div><div class="post-tags">
<a href="https://ostechnix.com/tag/commandline/" rel="tag">Commandline</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-commands/" rel="tag">Linux commands</a><a href="https://ostechnix.com/tag/network-manager/" rel="tag">Network Manager</a><a href="https://ostechnix.com/tag/networking/" rel="tag">Networking</a><a href="https://ostechnix.com/tag/nmcli/" rel="tag">nmcli</a><a href="https://ostechnix.com/tag/nmtui/" rel="tag">nmtui</a><a href="https://ostechnix.com/tag/password-recovery/" rel="tag">Password Recovery</a><a href="https://ostechnix.com/tag/python/" rel="tag">Python</a><a href="https://ostechnix.com/tag/wifi/" rel="tag">Wifi</a><a href="https://ostechnix.com/tag/wifresti/" rel="tag">Wifresti</a><a href="https://ostechnix.com/tag/wireless/" rel="tag">Wireless</a></div></div></div><div class="tags-share-box single-post-share tags-share-box-s1  center-box  social-align-default post-share">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>4 comments</span>
<span class="post-share-item post-share-plike">
<span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="23387" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a>					</span>
<a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank"  rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank"  rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux%20-%20https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank"  rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;title=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank"  rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;title=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux"><i class="penci-faicon fa fa-reddit-alien" ></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank"  rel="noreferrer" href="https://api.whatsapp.com/send?text=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F"><i class="penci-faicon fa fa-whatsapp" ></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank"  rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Ffind-wifi-password-of-connected-networks-in-linux%2F&#038;text=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux"><i class="penci-faicon fa fa-telegram" ></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email"  rel="noreferrer" href="mailto:?subject=Find%20WiFi%20Password%20Of%20Connected%20Networks%20In%20Linux&#038;BODY=https://ostechnix.com/find-wifi-password-of-connected-networks-in-linux/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#" aria-label="Share Expand"><i class="penci-faicon penciicon-add" ></i></a></div><div class="post-author abio-style-1 bioimg-round"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/2a1a812a637f5dffead29d74f9de9f12.jpg?ver=1671870512' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/c28e075f78374921e69fc52da9aab01a.jpg?ver=1671870512 2x' class='avatar avatar-100 photo' height='100' width='100' decoding='async'/></div><div class="author-content"><h5><a href="https://ostechnix.com/author/sk/" title="Author sk" rel="author">sk</a></h5><p>Senthilkumar Palani (aka SK) is the Founder and Editor in chief of OSTechNix. He is a Linux/Unix enthusiast and FOSS supporter. He lives in Tamilnadu, India.</p><div class="bio-social">
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://ostechnix.com/"><i class="penci-faicon fa fa-globe" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://facebook.com/ostechnix"><i class="penci-faicon fa fa-facebook" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://twitter.com/@ostechnix"><i class="penci-faicon fa fa-twitter" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"><i class="penci-faicon fa fa-youtube-play" ></i></a></div></div></div><div class="post-pagination"><div class="prev-post"><div class="prev-post-inner"><div class="prev-post-title">
<span>Previous post</span></div>
<a href="https://ostechnix.com/install-microsoft-visual-studio-code-linux/"><div class="pagi-text"><h5 class="prev-title">Install Microsoft Visual Studio Code In Linux</h5></div>
</a></div></div></div><div class="post-related"><div class="post-title-box"><h4
class="post-box-title">You May Also Like</h4></div><div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel"
data-lazy="true" data-loop="false" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2"
data-auto="false"
data-speed="300" data-dots="true"><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/04/Install-TP-Link-AC600-Archer-T2U-Nano-WiFi-USB-Adapter-In-Linux-585x390.png"
href="https://ostechnix.com/install-tp-link-ac600-archer-t2u-nano-wifi-usb-adapter-in-linux/" title="Install TP-Link AC600 Archer T2U Nano WiFi USB Adapter In Linux">
</a><h3>
<a href="https://ostechnix.com/install-tp-link-ac600-archer-t2u-nano-wifi-usb-adapter-in-linux/">Install TP-Link AC600 Archer T2U Nano WiFi USB...</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-04-21T17:14:13+05:30">April 21, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/07/How-To-Print-QR-Code-Card-For-Connecting-To-Your-WiFi-With-WiFi-Card-App-585x390.jpg"
href="https://ostechnix.com/how-to-print-qr-code-card-for-connecting-to-your-wifi/" title="How To Print QR Code Card For Connecting To Your WiFi">
</a><h3>
<a href="https://ostechnix.com/how-to-print-qr-code-card-for-connecting-to-your-wifi/">How To Print QR Code Card For Connecting...</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-07-17T19:59:31+05:30">July 17, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2016/11/Update-Wifi-Network-Password-From-Terminal-In-Arch-Linux.png"
href="https://ostechnix.com/update-wifi-network-password-terminal-arch-linux/" title="How To Update Wifi Network Password From Terminal In Arch Linux">
</a><h3>
<a href="https://ostechnix.com/update-wifi-network-password-terminal-arch-linux/">How To Update Wifi Network Password From Terminal...</a></h3>
<span class="date"><time class="entry-date published" datetime="2016-11-10T14:11:02+05:30">November 10, 2016</time></span></div></div></div><div class="post-comments penci-comments-hide-1" id="comments"><div class="post-title-box"><h4 class="post-box-title">4 comments</h4></div><div class='comments'><div class="comment even thread-even depth-1" id="comment-77780" itemprop="" itemscope="itemscope" itemtype="https://schema.org/UserComments"><meta itemprop="discusses" content="Find WiFi Password Of Connected Networks In Linux"/><link itemprop="url" href="#comment-77780"><div class="thecomment"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/d4f8e3ee2b8a8e9d7181b34f1f02d9d3.jpg?ver=1671878412' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/bcf4df7c5808e13661475bb0b2ceade8.jpg?ver=1671878412 2x' class='avatar avatar-100 photo' height='100' width='100' decoding='async'/></div><div class="comment-text">
<span class="author" itemprop="creator" itemtype="https://schema.org/Person"><span itemprop="name">Hiram Ballard</span></span>
<span class="date" datetime="2020-05-09T09:19:42+05:30"title="Saturday, May 9, 2020, 9:19 am"itemprop="commentTime"><i class="penci-faicon fa fa-clock-o" ></i>May 9, 2020 - 9:19 am</span><div class="comment-content" itemprop="commentText"><p>wifiresti is written in Python 2 which is now obsolete and no longer officially supported.</p><p>Somebody needs to update and convert it to Python 3.</p></div>
<span class="reply">
<a rel='nofollow' class='comment-reply-link' href='#comment-77780' data-commentid="77780" data-postid="23387" data-belowelement="comment-77780" data-respondelement="respond" data-replyto="Reply to Hiram Ballard" aria-label='Reply to Hiram Ballard'>Reply</a>											</span></div></div></div><div class="comment odd alt thread-odd thread-alt depth-1" id="comment-77798" itemprop="" itemscope="itemscope" itemtype="https://schema.org/UserComments"><meta itemprop="discusses" content="Find WiFi Password Of Connected Networks In Linux"/><link itemprop="url" href="#comment-77798"><div class="thecomment"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/feaa7fa6d497071de5361dc0c1c95f0b.jpg?ver=1671877801' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/b3d4ea34bdc2e6dae5806a9db4a6f055.jpg?ver=1671877803 2x' class='avatar avatar-100 photo' height='100' width='100' decoding='async'/></div><div class="comment-text">
<span class="author" itemprop="creator" itemtype="https://schema.org/Person"><span itemprop="name">Stef</span></span>
<span class="date" datetime="2020-05-09T23:03:40+05:30"title="Saturday, May 9, 2020, 11:03 pm"itemprop="commentTime"><i class="penci-faicon fa fa-clock-o" ></i>May 9, 2020 - 11:03 pm</span><div class="comment-content" itemprop="commentText"><p>There is also a curses interface for NetworkManager called nmtui.<br />
And of course, instead of looking directly into the config files (as root),  one can use nmcli</p><p>(bash) nmcli -g NAME connection show<br />
HP 7 VoiceTab Network<br />
JioFi4_12E9FE<br />
sktab</p><p>To obtain the password for JioFi4_12E9FE do<br />
(bash)  nmcli -s -g 802-11-wireless-security.psk connection show JioFi4_12E9FE<br />
xxxxxxxxxxx</p><p>And to get all values, remove the option -g 802-11-wireless-security.psk</p></div>
<span class="reply">
<a rel='nofollow' class='comment-reply-link' href='#comment-77798' data-commentid="77798" data-postid="23387" data-belowelement="comment-77798" data-respondelement="respond" data-replyto="Reply to Stef" aria-label='Reply to Stef'>Reply</a>											</span></div></div><div class="comment byuser comment-author-sk bypostauthor even depth-2" id="comment-77818" itemprop="" itemscope="itemscope" itemtype="https://schema.org/UserComments"><meta itemprop="discusses" content="Find WiFi Password Of Connected Networks In Linux"/><link itemprop="url" href="#comment-77818"><div class="thecomment"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/2a1a812a637f5dffead29d74f9de9f12.jpg?ver=1671870512' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/c28e075f78374921e69fc52da9aab01a.jpg?ver=1671870512 2x' class='avatar avatar-100 photo' height='100' width='100' decoding='async'/></div><div class="comment-text">
<span class="author" itemprop="creator" itemtype="https://schema.org/Person"><span itemprop="name"><a href='https://ostechnix.com/' rel='external nofollow ugc' class='url'>sk</a></span></span>
<span class="date" datetime="2020-05-10T11:51:17+05:30"title="Sunday, May 10, 2020, 11:51 am"itemprop="commentTime"><i class="penci-faicon fa fa-clock-o" ></i>May 10, 2020 - 11:51 am</span><div class="comment-content" itemprop="commentText"><p>Thanks for the suggestion. I will add your inputs in the article.</p></div>
<span class="reply">
<a rel='nofollow' class='comment-reply-link' href='#comment-77818' data-commentid="77818" data-postid="23387" data-belowelement="comment-77818" data-respondelement="respond" data-replyto="Reply to sk" aria-label='Reply to sk'>Reply</a>											</span></div></div></div></div><div class="comment odd alt thread-even depth-1" id="comment-77869" itemprop="" itemscope="itemscope" itemtype="https://schema.org/UserComments"><meta itemprop="discusses" content="Find WiFi Password Of Connected Networks In Linux"/><link itemprop="url" href="#comment-77869"><div class="thecomment"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/067803327f8291c9fb241bd6b6592606.jpg?ver=1671875639' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/aecc856fb6ecb070e5578cf48360ab6f.jpg?ver=1671875639 2x' class='avatar avatar-100 photo' height='100' width='100' decoding='async'/></div><div class="comment-text">
<span class="author" itemprop="creator" itemtype="https://schema.org/Person"><span itemprop="name">Rod</span></span>
<span class="date" datetime="2020-05-11T15:19:34+05:30"title="Monday, May 11, 2020, 3:19 pm"itemprop="commentTime"><i class="penci-faicon fa fa-clock-o" ></i>May 11, 2020 - 3:19 pm</span><div class="comment-content" itemprop="commentText"><p>seems to be applicable to Mint and Fedora, but not on Raspbian which does not have an /etc/NetworkManager directory.</p></div>
<span class="reply">
<a rel='nofollow' class='comment-reply-link' href='#comment-77869' data-commentid="77869" data-postid="23387" data-belowelement="comment-77869" data-respondelement="respond" data-replyto="Reply to Rod" aria-label='Reply to Rod'>Reply</a>											</span></div></div></div></div><div id='comments_pagination'></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/find-wifi-password-of-connected-networks-in-linux/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p><p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p><div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='23387' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="35b581c3d0" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="39"/><script type="litespeed/javascript">document.getElementById("ak_js_1").setAttribute("value",(new Date()).getTime())</script></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></article></div></div><div id="sidebar"
class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left  pciconp-right pcicon-right penci-sticky-sidebar"><div class="theiaStickySidebar"><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="5990223580"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p><p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..."/><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p>
<input type="hidden" value="Ostechnix" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="6186167963"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></aside></div></div></div></div></div><div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div><div class="clear-footer"></div><div id="widget-area"><div class="container"><div class="footer-widget-wrapper footer-widget-style-1"><aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4><div class="textwidget"><p><a href="https://ostechnix.com/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzNDAiIGhlaWdodD0iNjgiIHZpZXdCb3g9IjAgMCAzNDAgNjgiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" decoding="async" class="aligncenter wp-image-25308 size-full" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-sizes="(max-width: 340px) 100vw, 340px" /></a></p><p>&nbsp;</p><p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><div class="widget-social pc_aligncenter remove-circle">
<a href="https://www.facebook.com/ostechnix/"
aria-label="Facebook"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-facebook"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/ostechnix"
aria-label="Twitter"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-twitter"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix"
aria-label="Linkedin"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-linkedin"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"
aria-label="Youtube"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-youtube-play"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Youtube</span></a>
<a href="mailto:info@ostechnix.com"
aria-label="Email"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-envelope"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Email</span></a>
<a href="https://www.reddit.com/r/OSTechNix/"
aria-label="Reddit"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-reddit-alien"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Reddit</span></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Rss</span></a></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1"><aside id="block-4" class="widget widget_block widget_archive"><div class=" wp-block-archives-dropdown wp-block-archives"><label for="wp-block-archives-3" class="wp-block-archives__label">Archives</label>
<select id="wp-block-archives-3" name="archive-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;"><option value="">Select Month</option><option value='https://ostechnix.com/2022/12/'> December 2022 &nbsp;(8)</option><option value='https://ostechnix.com/2022/11/'> November 2022 &nbsp;(8)</option><option value='https://ostechnix.com/2022/10/'> October 2022 &nbsp;(6)</option><option value='https://ostechnix.com/2022/09/'> September 2022 &nbsp;(12)</option><option value='https://ostechnix.com/2022/08/'> August 2022 &nbsp;(12)</option><option value='https://ostechnix.com/2022/07/'> July 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/06/'> June 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/05/'> May 2022 &nbsp;(18)</option><option value='https://ostechnix.com/2022/04/'> April 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/03/'> March 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/02/'> February 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2022/01/'> January 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2021/12/'> December 2021 &nbsp;(17)</option><option value='https://ostechnix.com/2021/11/'> November 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/10/'> October 2021 &nbsp;(12)</option><option value='https://ostechnix.com/2021/09/'> September 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/08/'> August 2021 &nbsp;(19)</option><option value='https://ostechnix.com/2021/07/'> July 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/06/'> June 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/05/'> May 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/04/'> April 2021 &nbsp;(10)</option><option value='https://ostechnix.com/2021/03/'> March 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/02/'> February 2021 &nbsp;(16)</option><option value='https://ostechnix.com/2021/01/'> January 2021 &nbsp;(13)</option><option value='https://ostechnix.com/2020/12/'> December 2020 &nbsp;(16)</option><option value='https://ostechnix.com/2020/11/'> November 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/10/'> October 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/09/'> September 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/08/'> August 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/07/'> July 2020 &nbsp;(17)</option><option value='https://ostechnix.com/2020/06/'> June 2020 &nbsp;(23)</option><option value='https://ostechnix.com/2020/05/'> May 2020 &nbsp;(22)</option><option value='https://ostechnix.com/2020/04/'> April 2020 &nbsp;(31)</option><option value='https://ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option><option value='https://ostechnix.com/2020/02/'> February 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option><option value='https://ostechnix.com/2019/12/'> December 2019 &nbsp;(11)</option><option value='https://ostechnix.com/2019/11/'> November 2019 &nbsp;(6)</option><option value='https://ostechnix.com/2019/10/'> October 2019 &nbsp;(10)</option><option value='https://ostechnix.com/2019/09/'> September 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option><option value='https://ostechnix.com/2019/07/'> July 2019 &nbsp;(16)</option><option value='https://ostechnix.com/2019/06/'> June 2019 &nbsp;(8)</option><option value='https://ostechnix.com/2019/05/'> May 2019 &nbsp;(11)</option><option value='https://ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option><option value='https://ostechnix.com/2019/03/'> March 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/02/'> February 2019 &nbsp;(8)</option><option value='https://ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2018/12/'> December 2018 &nbsp;(5)</option><option value='https://ostechnix.com/2018/11/'> November 2018 &nbsp;(11)</option><option value='https://ostechnix.com/2018/10/'> October 2018 &nbsp;(17)</option><option value='https://ostechnix.com/2018/09/'> September 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2018/08/'> August 2018 &nbsp;(18)</option><option value='https://ostechnix.com/2018/07/'> July 2018 &nbsp;(14)</option><option value='https://ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option><option value='https://ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/04/'> April 2018 &nbsp;(20)</option><option value='https://ostechnix.com/2018/03/'> March 2018 &nbsp;(21)</option><option value='https://ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/11/'> November 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/10/'> October 2017 &nbsp;(16)</option><option value='https://ostechnix.com/2017/09/'> September 2017 &nbsp;(24)</option><option value='https://ostechnix.com/2017/08/'> August 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/07/'> July 2017 &nbsp;(22)</option><option value='https://ostechnix.com/2017/06/'> June 2017 &nbsp;(12)</option><option value='https://ostechnix.com/2017/05/'> May 2017 &nbsp;(19)</option><option value='https://ostechnix.com/2017/04/'> April 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/03/'> March 2017 &nbsp;(31)</option><option value='https://ostechnix.com/2017/02/'> February 2017 &nbsp;(31)</option><option value='https://ostechnix.com/2017/01/'> January 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2016/12/'> December 2016 &nbsp;(19)</option><option value='https://ostechnix.com/2016/11/'> November 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option><option value='https://ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option><option value='https://ostechnix.com/2016/08/'> August 2016 &nbsp;(22)</option><option value='https://ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option><option value='https://ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option><option value='https://ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option><option value='https://ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option><option value='https://ostechnix.com/2016/02/'> February 2016 &nbsp;(21)</option><option value='https://ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option><option value='https://ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option><option value='https://ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option><option value='https://ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option><option value='https://ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option><option value='https://ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option><option value='https://ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option><option value='https://ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option>
</select></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1 last"><aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4><ul id="penci-popularwg-1066"
data-settings='{"title":"Popular Posts","hide_thumb":"","movemeta":"","dotstyle":"","ptype":"","taxonomy":"","tax_ids":"","sticky":"on","show_author":"","show_comment":"","show_postviews":"","showborder":"","row_gap":"","imgwidth":"","ptfsfe":"","ptfs":"","pmfs":"","image_type":"default","type":"week","title_length":"","number":"3","offset":"","categories":"","featured":"","allfeatured":"","thumbright":"","twocolumn":"","featured2":"","ordernum":"","postdate":"","icon":"","cats_id":false,"tags_id":false}' data-paged="1"
data-action="penci_popular_news_ajax"
data-mes="Sorry, No more posts"
data-max="443"
class="side-newsfeed display-order-numbers"><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">1</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2018/08/Switch-Between-Multiple-PHP-Versions-In-Ubuntu-263x175.png"
href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/"
title="How To Switch Between Multiple PHP Versions In Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/" rel="bookmark" title="How To Switch Between Multiple PHP Versions In Ubuntu">
How To Switch Between Multiple PHP Versions In Ubuntu                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2018-08-09T16:20:32+05:30">August 9, 2018</time></span></div></div></div></li><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">2</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2017/02/invalid-or-corrupted-package-PGP-signature.png"
href="https://ostechnix.com/fix-invalid-corrupted-package-pgp-signature-error-arch-linux/"
title="How To Fix &#8220;invalid or corrupted package (PGP signature)&#8221; Error In Arch Linux"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/fix-invalid-corrupted-package-pgp-signature-error-arch-linux/" rel="bookmark" title="How To Fix &#8220;invalid or corrupted package (PGP signature)&#8221; Error In Arch Linux">
How To Fix &#8220;invalid or corrupted package (PGP signature)&#8221; Error In Arch Linux                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2017-02-17T15:36:39+05:30">February 17, 2017</time></span></div></div></div></li><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">3</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png"
href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/"
title="How To Fix Busybox Initramfs Error On Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu">
How To Fix Busybox Initramfs Error On Ubuntu                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span></div></div></div></li></ul></aside></div></div></div><footer id="footer-section"
class="penci-footer-social-media penci-lazy"		        itemscope itemtype="https://schema.org/WPFooter"><div class="container"><div class="footer-logo-copyright footer-not-logo footer-not-gotop"><div class="footer-menu-wrap" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li><li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li><li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li><li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li></ul></div><div id="footer-copyright"><p>OSTechNix © 2022. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p></div></div></div></footer></div><div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div>
<a href="#" id="close-sidebar-nav"
class="header-3"><i class="penci-faicon fa fa-close" ></i></a><nav id="sidebar-nav" class="header-3" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><div id="sidebar-nav-logo">
<a href="https://ostechnix.com/"><img class="penci-lazy sidebar-nav-logo penci-limg"                                                                     src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E"
width="250"
height="52"
data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png"
data-lightlogo="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png"
alt="OSTechNix"/></a></div><div class="header-social sidebar-nav-social"><div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
<a href="mailto:info@ostechnix.com" aria-label="Email"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" ></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" ></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div><div class="penci-hbg-search-box penci-vernav-search-box"><form role="search" method="get" class="pc-searchform penci-hbg-search-form"
action="https://ostechnix.com/"><div class="inner-hbg-search-form">
<input type="text" class="search-input"
placeholder="Type and hit enter..." name="s"/>
<i class="penciicon-magnifiying-glass"></i></div></form></div><ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></nav><div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"><div class="penci-gprd-law"><p>
This website uses cookies to improve your experience. By using this site, we will assume that you're OK with it.				<a aria-label="GPRD Accept" class="penci-gprd-accept" href="#">Accept</a>				<a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a></p></div></div><!--[if lte IE 9]> <script>'use strict';
            (function($) {
                $(document).ready(function() {
                    $('#ftwp-container').addClass('ftwp-ie9');
                });
            })(jQuery);</script> <![endif]--> <script id='main-scripts-js-extra' type="litespeed/javascript">var ajax_var_more={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"98471897f5","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script id='penci_ajax_like_post-js-extra' type="litespeed/javascript">var ajax_var={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"98471897f5","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script type='text/javascript' src='https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/instant_click.min.js' id='litespeed-cache-js'></script> <script id='fixedtoc-js-js-extra' type="litespeed/javascript">var fixedtocOption={"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""}</script> <script src='https://stats.wp.com/e-202252.js' defer></script> <script type="litespeed/javascript">_stq=window._stq||[];_stq.push(['view',{v:'ext',blog:'84551477',post:'23387',tz:'5.5',srv:'ostechnix.com',j:'1:11.6'}]);_stq.push(['clickTrackerInit','84551477','23387'])</script><script type="litespeed/javascript">function PenciSimplePopularPosts_AddCount(id,endpoint){var xmlhttp;var params="/?penci_spp_count=1&penci_spp_post_id="+id+"&cachebuster="+Math.floor((Math.random()*100000));if(window.XMLHttpRequest){xmlhttp=new XMLHttpRequest()}else{xmlhttp=new ActiveXObject("Microsoft.XMLHTTP")}
xmlhttp.onreadystatechange=function(){if(xmlhttp.readyState==4&&xmlhttp.status==200){var data=JSON.parse(xmlhttp.responseText);document.getElementsByClassName("penci-post-countview-number")[0].innerHTML=data.visits}}
xmlhttp.open("GET",endpoint+params,!0);xmlhttp.send()}
PenciSimplePopularPosts_AddCount(23387,'https://ostechnix.com')</script>  <script type="litespeed/javascript" data-src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="litespeed/javascript">window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag('js',new Date());gtag('config','UA-75259810-1')</script> <script data-no-optimize="1">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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/litespeed/js/7ae41f76c8f4bd777fb7bcc51fc2fa33.js?ver=27dda"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/vaafb692b2aea4879b33c060e79fe94621666317369993" integrity="sha512-0ahDYl866UMhKuYcW078ScMalXqtFJggm7TmlUtp0UlD4eQk0Ixfnm5ykXKvGJNFjLMoortdseTfsRT8oCfgGA==" data-cf-beacon='{"rayId":"77fb09a3793520d0","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2022.11.3","si":100}' crossorigin="anonymous"></script>
</body></html>
<!-- Page optimized by LiteSpeed Cache @2022-12-26 19:04:03 -->
<!-- Page generated by LiteSpeed Cache 5.3.1 on 2022-12-26 19:04:02 -->
<!-- Guest Mode -->