<!DOCTYPE html> <html lang="en-US"> <head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name="viewport" content="width=device-width, initial-scale=1"> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon" /> <link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"> <link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/" /> <link rel="pingback" href="https://ostechnix.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--> <link rel='preconnect' href='https://fonts.googleapis.com' /> <link rel='preconnect' href='https://fonts.gstatic.com' /> <meta http-equiv='x-dns-prefetch-control' content='on'> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//fonts.gstatic.com' /> <link rel='dns-prefetch' href='//s.gravatar.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <link rel='preload' as='image' href='https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png' type='image/png'> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/fonts/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/fonts/weathericons.woff2' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/webfonts/fa-brands-400.woff2' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/webfonts/fa-regular-400.woff2' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/webfonts/fa-solid-900.woff2' type='font/woff2' crossorigin='anonymous' /> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <title>Migrate CentOS 7 To AlmaLinux 8, CentOS 8, Rocky Linux 8 - OSTechNix</title><style id="rocket-critical-css">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</style><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="preload" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'"/></noscript> <meta name="description" content="This guide explains how to migrate CentOS 7 to AlmaLinux 8, CentOS Stream 8, Rocky Linux 8, and Oracle Linux 8 using AlmaLinux ELvate tool." /> <link rel="canonical" href="https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/" /> <meta property="og:locale" content="en_US" /> <meta property="og:type" content="article" /> <meta property="og:title" content="Migrate CentOS 7 To AlmaLinux 8, CentOS 8, Rocky Linux 8 - OSTechNix" /> <meta property="og:description" content="This guide explains how to migrate CentOS 7 to AlmaLinux 8, CentOS Stream 8, Rocky Linux 8, and Oracle Linux 8 using AlmaLinux ELvate tool." /> <meta property="og:url" content="https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/" /> <meta property="og:site_name" content="OSTechNix" /> <meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /> <meta property="article:author" content="ostechnix" /> <meta property="article:published_time" content="2021-11-01T10:12:20+00:00" /> <meta property="article:modified_time" content="2021-11-01T14:51:58+00:00" /> <meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2021/11/Migrate-CentOS-7-To-AlmaLinux-8-CentOS-8-Rocky-Linux-8-Oracle-Linux-8.png" /> <meta property="og:image:width" content="1280" /> <meta property="og:image:height" content="720" /> <meta name="twitter:card" content="summary" /> <meta name="twitter:creator" content="@ostechnix" /> <meta name="twitter:site" content="@ostechnix" /> <meta name="twitter:label1" content="Written by" /> <meta name="twitter:data1" content="sk" /> <meta name="twitter:label2" content="Est. reading time" /> <meta name="twitter:data2" content="8 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//s.w.org' /> <link rel='dns-prefetch' href='//ajax.cloudflare.com' /> <link rel='dns-prefetch' href='//static.cloudflareinsights.com' /> <link rel='dns-prefetch' href='//stats.wp.com' /> <link rel='dns-prefetch' href='//pixel.wp.com' /> <link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.googletagmanager.com' /> <link rel='dns-prefetch' href='//googleads.g.doubleclick.net' /> <link rel='dns-prefetch' href='//partner.googleadservices.com' /> <link rel='dns-prefetch' href='//adservice.google.com' /> <link rel='dns-prefetch' href='//www.googletagservices.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <link rel='dns-prefetch' href='//tpc.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To Migrate CentOS 7 To AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, Rocky Linux 8 Using ELevate Utility Comments Feed" href="https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/feed/" /> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ostechnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=ec25dd5b9fcf0d6992c474477cef5bb1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script> <style type="text/css"> img.wp-smiley, img.emoji { display: inline !important; border: none !important; box-shadow: none !important; height: 1em !important; width: 1em !important; margin: 0 .07em !important; vertical-align: -0.1em !important; background: none !important; padding: 0 !important; } </style> <link rel='preload' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css?ver=ec25dd5b9fcf0d6992c474477cef5bb1' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <style id='wp-block-library-inline-css' type='text/css'> .has-text-align-justify{text-align:justify;} </style> <style id='wp-block-library-theme-inline-css' type='text/css'> #start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none} </style> <link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=ec25dd5b9fcf0d6992c474477cef5bb1' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad/style.css?ver=ec25dd5b9fcf0d6992c474477cef5bb1' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <noscript></noscript> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/weather-icon.swap.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css?ver=8.0.2' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/social-counter.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1634284900' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <style id='fixedtoc-style-inline-css' type='text/css'> .ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); } </style> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1634284898' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/35186" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ostechnix.com/xmlrpc.php?rsd" /> <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ostechnix.com/wp-includes/wlwmanifest.xml" /> <link rel='shortlink' href='https://ostechnix.com/?p=35186' /> <link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;format=xml" /> <meta name="generator" content="Site Kit by Google 1.44.0" /><style type='text/css'>img#wpstats{display:none}</style> <style id="penci-custom-style" type="text/css">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</style><script type="rocketlazyloadscript">
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To Migrate CentOS 7 To AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, Rocky Linux 8 Using ELevate Utility",
    "description": "This guide explains how to migrate CentOS 7 to AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, and Rocky Linux 8 using AlmaLinux ELvate tool.",
    "datePublished": "2021-11-01",
    "datemodified": "2021-11-01",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2021\/11\/Migrate-CentOS-7-To-AlmaLinux-8-CentOS-8-Rocky-Linux-8-Oracle-Linux-8.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk",
        "url": "https:\/\/ostechnix.com\/author\/sk\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/linux_distributions\/",
                "name": "Linux Distributions"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/linux_distributions\/centos\/",
                "name": "CentOS"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/ostechnix.com\/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8\/",
                "name": "How To Migrate CentOS 7 To AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, Rocky Linux 8 Using ELevate Utility"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /> <link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /> <link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script> </head> <body data-rsssl=1 class="post-template-default single single-post postid-35186 single-format-standard soledad-ver-8-0-2 pclight-mode penci-fawesome-ver5 has-ftoc"> <div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"> <div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"> <div class="container"> <div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li> <li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li> <li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li> <li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li> <li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul></div><div class="pctopbar-item penci-topbar-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#f69f989099b699858293959e989f8ed895999b" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div></div> </div> </div> </div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"> <div class="inner-header penci-header-second"> <div class="container align-left-logo has-banner"> <div id="logo"> <a href="https://ostechnix.com/"><picture class="penci-mainlogo">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" alt="OSTechNix" width="350" height="73" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" />
</picture>
<noscript><picture class="penci-mainlogo">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" width="350" height="73"/>
</picture>
</noscript></a> </div> <div class="header-banner header-style-3"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="9496719407" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </div> </div> <div class="sticky-wrapper"> <nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="container"> <div class="button-menu-mobile header-3"><i class="penci-faicon fas fa-bars"></i></div> <ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes"> <a class="search-click"> <i class="penciicon-magnifiying-glass"></i> </a> <div class="show-search"> <form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/"> <div class="pc-searchform-inner"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> <input type="submit" class="searchsubmit" value="Search" /> </div> </form> <a class="search-click close-search"><i class="penciicon-close-button"></i></a> </div> </div> <div class="penci-menuhbg-wapper penci-menu-toggle-wapper"> <a href="#pencimenuhbgtoggle" class="penci-menuhbg-toggle"> <span class="penci-menuhbg-inner"> <i class="lines-button lines-button-double"> <i class="penci-lines"></i> </i> <i class="lines-button lines-button-double penci-hover-effect"> <i class="penci-lines"></i> </i> </span> </a> </div> </div> </nav> </div> </header> </div> <div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt; &lt;!-- New Horizontal Responsive Adv --&gt; &lt;ins class=&quot;adsbygoogle&quot; style=&quot;display:block&quot; data-ad-client=&quot;ca-pub-6701402139964678&quot; data-ad-slot=&quot;9496719407&quot; data-ad-format=&quot;auto&quot; data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt; &lt;script&gt; (adsbygoogle = window.adsbygoogle || []).push({}); &lt;/script&gt;&lt;/div&gt;"> <div class="penci-single-block" data-prev-url="https://ostechnix.com/install-opensuse-leap/" data-current-url="https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/" data-post-title="How To Migrate CentOS 7 To AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, Rocky Linux 8 Using ELevate Utility" data-edit-post="" data-postid="35186"> <div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fas fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/linux_distributions/centos/">CentOS</a></span><i class="penci-faicon fas fa-angle-right"></i> <span>How To Migrate CentOS 7 To AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, Rocky Linux 8 Using ELevate Utility</span> </div> <div class="container container-single penci_sidebar penci-enable-lightbox"> <div id="main" class="penci-main-sticky-sidebar"> <div class="theiaStickySidebar"> <style type="text/css">.post-image img{ aspect-ratio: 1170/658 }</style><article id="post-35186" class="post type-post status-publish"> <div class="header-standard header-classic single-header"> <div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-69" href="https://ostechnix.com/category/linux_distributions/centos/" rel="category tag">CentOS</a><a class="penci-cat-name penci-cat-4977" href="https://ostechnix.com/category/linux_distributions/almalinux/" rel="category tag">Almalinux</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/" rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-28" href="https://ostechnix.com/category/linux_distributions/" rel="category tag">Linux Distributions</a><a class="penci-cat-name penci-cat-4921" href="https://ostechnix.com/category/linux_distributions/oracle-linux/" rel="category tag">Oracle Linux</a><a class="penci-cat-name penci-cat-45" href="https://ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/" rel="category tag">Red Hat Enterprise Linux</a><a class="penci-cat-name penci-cat-5155" href="https://ostechnix.com/category/linux_distributions/rocky-linux/" rel="category tag">Rocky Linux</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/" rel="category tag">Unix/Linux Beginners</a></span></div> <h1 class="post-title single-post-title entry-title">How To Migrate CentOS 7 To AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, Rocky Linux 8 Using ELevate Utility</h1> <h2 class="penci-psub-title ">Upgrade CentOS 7 to AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, and Rocky Linux 8</h2> <div class="penci-hide-tagupdated"> <span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/sk/">sk</a></span> <time class="entry-date published" datetime="2021-11-01T15:42:20+05:30">November 1, 2021</time> </div> <div class="post-box-meta-single"> <span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/sk/">sk</a></span></span> <span><time class="entry-date published" datetime="2021-11-01T15:42:20+05:30">November 1, 2021</time></span> <span><i class="penci-post-countview-number">241</i> Views</span> </div> </div> <div class="tags-share-box tags-share-box-top center-box tags-share-box-s1"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="35186" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility%20-%20https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;title=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;title=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility %0A%0A https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;text=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#142b6761767e717760295c7b63312624407b312624597d736675607131262457717a605b4731262423312624407b31262455787975587d7a616c3126242c3831262457717a605b473126244760667175793126242c383126245b6675777871312624587d7a616c3126242c38312624467b777f6d312624587d7a616c3126242c31262441677d7a733126245158716275607131262441607d787d606d323724272c2f565b504d297c606064672e3b3b7b676071777c7a7d6c3a777b793b797d73667560713977717a607b67392339607b3975787975787d7a616c392c3977717a607b67392c39667b777f6d39787d7a616c392c3b"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-entry blockquote-style-2"> <div class="inner-post-entry entry-content" id="penci-post-entry-inner"> <div id="ftwp-postcontent"><p>As you may already know, it was not possible to migrate between major version of RHEL-derivatives. Meaning - you can't directly upgrade from CentOS 7.x to CentOS 8.x version. The only way was fresh installation. Not anymore! You can now easily migrate from CentOS 7.x to any 8.x of your choice using <strong>ELevate</strong> tool. This guide explains how to migrate CentOS 7 to AlmaLinux 8, CentOS Stream 8, Oracle Linux 8, and Rocky Linux 8 using AlmaLinux ELvate tool.</p> <p class="has-black-color has-text-color has-background" style="background-color: #ffdddd;">For those wondering, the letters "EL" from ELevate stands for <strong><span style="text-decoration: underline;">E</span>nterprise <span style="text-decoration: underline;">L</span>inux</strong>.</p> <div><div class="penci-custom-html-inside-content"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item"><a class="ftwp-anchor" href="#what-is-elevate"><span class="ftwp-text">What is ELevate?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#things-to-remember-before-starting-centos-7-migration"><span class="ftwp-text">Things to remember before starting CentOS 7 migration</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#update-centos-7-system"><span class="ftwp-text">Update CentOS 7 system</span></a></li><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8-oracle-linux-8"><span class="ftwp-text">Migrate CentOS 7 To AlmaLinux 8, CentOS 8, Rocky Linux 8, And Oracle Linux 8</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#clear-cache-optional"><span class="ftwp-text">Clear cache (Optional)</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#update-hostname"><span class="ftwp-text">Update hostname</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="what-is-elevate" class="ftwp-heading">What is ELevate?</h2> <p>ELevate is an open source migration tool developed by AlmaLinux team. It allows you to easily and smoothly migrate between major versions of RHEL-based distributions from 7.x to 8.x version.</p> <p>ELevate combines Red Hat's Leapp framework with a community created library and service for the migration metadata set required for it.</p> <p>It currently supports migration from CentOS 7 to the following OSes:</p> <ul> <li>AlmaLinux OS 8</li> <li>CentOS Stream 8</li> <li>Oracle Linux 8</li> <li>Rocky Linux 8</li> </ul> <p>It will not touch the user data. All the installed applications and settings and data will remain intact. However, the users are <strong>HIGHLY ENCOURAGED</strong> to <strong>backup</strong> the important data before starting the migration.</p> <h2 id="things-to-remember-before-starting-centos-7-migration" class="ftwp-heading">Things to remember before starting CentOS 7 migration</h2> <ul> <li>As stated earlier, it is strongly recommended to <strong><a href="https://ostechnix.com/category/backup-tools/" target="_blank" rel="noreferrer noopener">backup</a></strong> your important data and settings.</li> <li>Live migration is not supported. Your system will reboot twice. Make sure any important jobs (E.g. Scheduled backups) are not running.</li> <li>ELevate is still under development. So I suggest you to test it thoroughly in a virtual system or a sandbox environment before trying it in production.</li> </ul> <p>I tested ELevate tool on a freshly installed CentOS 7 Virtual machine. The migration was smooth and error-free. If you encounter with any issues, report them to the <a href="https://bugs.almalinux.org/my_view_page.php" target="_blank" rel="noreferrer noopener">AlmaLinux Bug Tracker</a> and/or <a href="https://chat.almalinux.org/almalinux/channels/migration" target="_blank" rel="noreferrer noopener">AlmaLinux Chat Migration Channel</a>.</p> <h2 id="update-centos-7-system" class="ftwp-heading">Update CentOS 7 system</h2> <p>Make sure you're running the latest CentOS 7.x branch. If not, update your CentOS system using command:</p> <pre class="wp-block-preformatted">$ sudo yum update</pre> <pre class="wp-block-preformatted">$ sudo yum upgrade</pre> <p>Reboot your system to apply the changes:</p> <pre class="wp-block-preformatted">$ sudo reboot</pre> <p>Check the currently installed CentOS 7 version using command:</p> <pre class="wp-block-preformatted"><strong>$ cat /etc/centos-release</strong>
CentOS Linux release 7.9.2009 (Core)</pre> <pre class="wp-block-preformatted"><strong>$ cat /etc/os-release </strong>
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"</pre> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png" data-rel="penci-gallery-image-content"><picture class="wp-image-35216" title="Check CentOS version">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-585x298.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20697&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="697" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20697&#039;%3E%3C/svg%3E" alt="Check CentOS version" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-585x298.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png" />
</picture>
<noscript><picture class="wp-image-35216" title="Check CentOS version">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-585x298.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="697" src="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png" alt="Check CentOS version" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version.png 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Check-CentOS-version-585x298.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a> <figcaption>Check CentOS version</figcaption> </figure> </div> <p>As you can see, my system is running with CentOS 7.9 version. This is the latest version in the 7.x branch.</p> <h2 id="migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8-oracle-linux-8" class="ftwp-heading">Migrate CentOS 7 To AlmaLinux 8, CentOS 8, Rocky Linux 8, And Oracle Linux 8</h2> <p><strong>Step 1: Install ELevate</strong></p> <p>Install <code>elevate-release</code> package in your CentOS 7 system using command:</p> <pre class="wp-block-preformatted">$ sudo yum install http://repo.almalinux.org/elevate/elevate-release-latest-el7.noarch.rpm</pre> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png" data-rel="penci-gallery-image-content"><picture class="wp-image-35217" title="Install ELevate program in CentOS 7">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-585x298.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20697&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="697" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20697&#039;%3E%3C/svg%3E" alt="Install ELevate program in CentOS 7" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-585x298.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png" />
</picture>
<noscript><picture class="wp-image-35217" title="Install ELevate program in CentOS 7">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-585x298.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="697" src="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png" alt="Install ELevate program in CentOS 7" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7.png 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Install-ELevate-program-in-CentOS-7-585x298.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a> <figcaption>Install ELevate program in CentOS 7</figcaption> </figure> </div> <p><strong>Step 2: Install Leapp and migration data</strong></p> <p>The <code>elevate-release</code> package provides the <strong>Leapp</strong> utility and the necessary data to migrate Enterprise Linux 7.x to any Enterprise Linux 8.x versions of our choice.</p> <p>Depending upon the distribution you want to upgrade, you need to install any one of the following packages:</p> <ul> <li>leapp-data-almalinux</li> <li>leapp-data-centos</li> <li>leapp-data-oraclelinux</li> <li>leapp-data-rocky</li> </ul> <p>For instance, if you want to <strong>migrate CentOS 7 to AlmaLinux 8</strong>, you need to install the following packages:</p> <pre class="wp-block-preformatted">$ sudo yum install -y leapp-upgrade leapp-data-almalinux</pre> <p>To <strong>migrate CentOS 7 to CentOS 8</strong>, install the following packages:</p> <pre class="wp-block-preformatted">$ sudo yum install -y leapp-upgrade leapp-data-centos</pre> <p>To <strong>migrate CentOS 7 to Oracle Linux 8</strong>, install the following packages:</p> <pre class="wp-block-preformatted">$ sudo yum install -y leapp-upgrade leapp-data-oraclelinux</pre> <p>To <strong>migrate CentOS 7 to Rocky Linux 8</strong>, install the following packages:</p> <pre class="wp-block-preformatted">$ sudo yum install -y leapp-upgrade leapp-data-rocky</pre> <p>We have now installed the <code>leap-upgrade</code> package and the migration data for the OS we want to upgrade.</p> <p>For the purpose of this guide, I am going to upgrade CentOS 7 to AlmaLinux 8.</p> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-large"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8.png" data-rel="penci-gallery-image-content"><picture class="alignnone wp-image-35218" title="Upgrade CentOS 7 to AlmaLinux 8">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-585x298.png.webp 585w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8.png.webp 1366w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201024%20522&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201024%20522&#039;%3E%3C/svg%3E" alt="" width="1024" height="522" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-585x298.png 585w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8.png 1366w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1024x522.png" />
</picture>
<noscript><picture class="alignnone wp-image-35218" title="Upgrade CentOS 7 to AlmaLinux 8">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-585x298.png.webp 585w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8.png.webp 1366w" sizes="(max-width: 1024px) 100vw, 1024px"/>
<img src="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1024x522.png" alt="" width="1024" height="522" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8-585x298.png 585w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-AlmaLinux-8.png 1366w" sizes="(max-width: 1024px) 100vw, 1024px"/>
</picture>
</noscript></a> <figcaption>Upgrade CentOS 7 to AlmaLinux 8</figcaption> </figure> </div> <p><strong>Step 3: Start preupgrade check</strong></p> <p>Next run the following command to check if upgrade is possible or not:</p> <pre class="wp-block-preformatted">$ sudo leap preupgrade</pre> <p>This will perform a series of actions and verify if it is possible to perform the upgrade.</p> <pre class="wp-block-preformatted">==&gt; Processing phase `configuration_phase`
====&gt; * ipu_workflow_config
        IPU workflow config actor
==&gt; Processing phase `FactsCollection`
====&gt; * scanmemory
        Scan Memory of the machine.
====&gt; * source_boot_loader_scanner
        Scans the boot loader configuration on the source system.
.
.
.
============================================================
                     UPGRADE INHIBITED                      
============================================================

Upgrade has been inhibited due to the following problems:
    1. Inhibitor: Detected loaded kernel drivers which have been removed in RHEL 8. Upgrade cannot proceed.
    2. Inhibitor: Multiple devel kernels installed
    3. Inhibitor: Possible problems with remote login using root account
    4. Inhibitor: Missing required answers in the answer file
Consult the pre-upgrade report for details and possible remediation.

============================================================
                     UPGRADE INHIBITED                      
============================================================

Debug output written to /var/log/leapp/leapp-preupgrade.log

============================================================
                           REPORT                           
============================================================

A report has been generated at /var/log/leapp/leapp-report.json
A report has been generated at /var/log/leapp/leapp-report.txt

============================================================
                       END OF REPORT                        
============================================================

Answerfile has been generated at /var/log/leapp/answerfile</pre> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-large"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check.png" data-rel="penci-gallery-image-content"><picture class="alignnone wp-image-35219" title="Start preupgrade check">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-585x298.png.webp 585w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check.png.webp 1366w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201024%20522&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201024%20522&#039;%3E%3C/svg%3E" alt="" width="1024" height="522" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-585x298.png 585w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check.png 1366w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1024x522.png" />
</picture>
<noscript><picture class="alignnone wp-image-35219" title="Start preupgrade check">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-585x298.png.webp 585w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check.png.webp 1366w" sizes="(max-width: 1024px) 100vw, 1024px"/>
<img src="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1024x522.png" alt="" width="1024" height="522" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check-585x298.png 585w, https://ostechnix.com/wp-content/uploads/2021/11/Start-preupgrade-check.png 1366w" sizes="(max-width: 1024px) 100vw, 1024px"/>
</picture>
</noscript></a> <figcaption>Start preupgrade check</figcaption> </figure> </div> <p>At the end of the preupgrade check, the Leapp utility will generate a report in <code>/var/log/leapp/leapp-report.txt</code> file. This file contains possible problems and recommended solutions. No rpm packages will be installed at this phase.</p> <div class="wp-block-group has-black-color has-text-color has-background" style="background-color: #fdf4cf;"><div class="wp-block-group__inner-container"> <p><strong><span class="has-inline-color has-vivid-red-color">WARNING:</span></strong></p> <p>Preupgrade check will fail if the default CentOS 7 doesn't meet all requirements for migration. In that case, you need to fix all the problems and try again.</p> </div></div> <p>The following fixes from the <code>/var/log/leapp/leapp-report.txt</code> file are <strong>mandatory</strong>, but you can also review the rest of them if needed.</p> <p>In my case, I fixed the following issues:</p> <pre>$ sudo rmmod pata_acpi</pre> <pre>$ echo PermitRootLogin yes | sudo tee -a /etc/ssh/sshd_config</pre> <pre>$ sudo leapp answer --section remove_pam_pkcs11_module_check.confirm=True</pre> <p>I also had to remove the extra kernel devels.</p> <p><a href="https://ostechnix.com/list-or-check-all-installed-linux-kernels-from-commandline/" target="_blank" rel="noreferrer noopener">List the installed kernels</a> in CentOS:</p> <pre class="wp-block-preformatted"><strong>$ rpm -qa kernel</strong>
kernel-3.10.0-1160.45.1.el7.x86_64
kernel-3.10.0-1160.42.2.el7.x86_64</pre> <p>As you see above, there are currently two kernels installed in my system.</p> <p>Remove the old kernel and kernel-devels and keep only the currently active Kernel using command:</p> <pre class="wp-block-preformatted">$ sudo package-cleanup --oldkernels --count=1</pre> <p>Once you fixed all the problems, run the following command to migrate CentOS 7 to any Enterprise Linux 8.x of you choice:</p> <pre class="wp-block-preformatted">$ sudo leapp upgrade</pre> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png" data-rel="penci-gallery-image-content"><picture class="wp-image-35221" title="Upgrade CentOS 7 to RHEL 8 derivatives such as AlmaLinux, CentOS Stream, Oracle, and Rocky Linux">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-585x298.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20697&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="697" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20697&#039;%3E%3C/svg%3E" alt="Upgrade CentOS 7 to RHEL 8 derivatives such as AlmaLinux, CentOS Stream, Oracle, and Rocky Linux" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-585x298.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png" />
</picture>
<noscript><picture class="wp-image-35221" title="Upgrade CentOS 7 to RHEL 8 derivatives such as AlmaLinux, CentOS Stream, Oracle, and Rocky Linux">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1024x522.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-768x392.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1170x597.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-585x298.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="697" src="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png" alt="Upgrade CentOS 7 to RHEL 8 derivatives such as AlmaLinux, CentOS Stream, Oracle, and Rocky Linux" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux.png 1366w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1024x522.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-1170x597.png 1170w, https://ostechnix.com/wp-content/uploads/2021/11/Upgrade-CentOS-7-to-RHEL-8-derivatives-such-as-AlmaLinux-CentOS-Stream-Oracle-and-Rocky-Linux-585x298.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a> <figcaption>Upgrade CentOS 7 to RHEL 8 derivatives such as AlmaLinux, CentOS Stream, Oracle, and Rocky Linux</figcaption> </figure> </div> <p>Once the upgrade is completed, reboot your system:</p> <pre class="wp-block-preformatted">$ sudo reboot</pre> <p>A new entry called <code>ELevate-Upgrade-Initramfs</code> in the GRUB menu will appear. The system will be automatically booted into it. You can view the how the update process goes in the console.</p> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-full is-resized"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png" data-rel="penci-gallery-image-content"><picture class="wp-image-35223" title="Migrating CentOS 7 to AlmaLinux 8">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-300x225.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-768x576.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-585x439.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20780%20585&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 780px) 100vw, 780px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20780%20585&#039;%3E%3C/svg%3E" alt="Migrating CentOS 7 to AlmaLinux 8" width="780" height="585" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-300x225.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-768x576.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-585x439.png 585w" data-lazy-sizes="(max-width: 780px) 100vw, 780px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png" />
</picture>
<noscript><picture class="wp-image-35223" title="Migrating CentOS 7 to AlmaLinux 8">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-300x225.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-768x576.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-585x439.png.webp 585w" sizes="(max-width: 780px) 100vw, 780px"/>
<img src="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png" alt="Migrating CentOS 7 to AlmaLinux 8" width="780" height="585" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-300x225.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-768x576.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Migrating-CentOS-7-to-AlmaLinux-8-585x439.png 585w" sizes="(max-width: 780px) 100vw, 780px"/>
</picture>
</noscript></a> <figcaption>Migrating CentOS 7 to AlmaLinux 8</figcaption> </figure> </div> <p>System will automatically reboot once the upgrade is completed. The GRUB menu entries will be automatically updated depending upon the OS.</p> <p>Login to the system and verify that the current OS is the one you need.</p> <pre class="wp-block-preformatted">$ cat /etc/os-release</pre> <p><strong>Sample output:</strong></p> <pre class="wp-block-preformatted">NAME="AlmaLinux"
VERSION="8.4 (Electric Cheetah)"
ID="almalinux"
ID_LIKE="rhel centos fedora"
VERSION_ID="8.4"
PLATFORM_ID="platform:el8"
PRETTY_NAME="AlmaLinux 8.4 (Electric Cheetah)"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:almalinux:almalinux:8.4:GA"
HOME_URL="https://almalinux.org/"
DOCUMENTATION_URL="https://wiki.almalinux.org/"
BUG_REPORT_URL="https://bugs.almalinux.org/"

ALMALINUX_MANTISBT_PROJECT="AlmaLinux-8"
ALMALINUX_MANTISBT_PROJECT_VERSION="8.4"</pre> <div class="wp-block-image is-style-default"> <figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png" data-rel="penci-gallery-image-content"><picture class="wp-image-35224" title="Check AlmaLinux version">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-300x225.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-768x576.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-585x439.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201024%20768&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" />
<img width="1024" height="768" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201024%20768&#039;%3E%3C/svg%3E" alt="Check AlmaLinux version" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-300x225.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-768x576.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-585x439.png 585w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png" />
</picture>
<noscript><picture class="wp-image-35224" title="Check AlmaLinux version">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-300x225.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-768x576.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-585x439.png.webp 585w" sizes="(max-width: 1024px) 100vw, 1024px"/>
<img width="1024" height="768" src="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png" alt="Check AlmaLinux version" srcset="https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version.png 1024w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-300x225.png 300w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-768x576.png 768w, https://ostechnix.com/wp-content/uploads/2021/11/Check-AlmaLinux-version-585x439.png 585w" sizes="(max-width: 1024px) 100vw, 1024px"/>
</picture>
</noscript></a> <figcaption>Check AlmaLinux version</figcaption> </figure> </div> <p>Great! We've successfully upgraded CentOS 7 to AlmaLinux 8.4 version.</p> <h3 id="clear-cache-optional" class="ftwp-heading">Clear cache (Optional)</h3> <p>All the downloaded packages during the migration will be saved in cache until the next successful transaction. You can remove cached packages by executing the following command as <code>sudo</code> or <code>root</code> user:</p> <pre class="wp-block-preformatted">$ sudo dnf clean packages</pre> <h3 id="update-hostname" class="ftwp-heading">Update hostname</h3> <p>Finally, update the hostname, username to match with AlmaLinux.</p> <pre class="wp-block-preformatted">$ sudo hostnamectl set-hostname almalinux8</pre> <p>All done! Reboot your system to take effect the changes.</p> <h2 id="conclusion" class="ftwp-heading">Conclusion</h2> <p>In this guide, we have seen how to upgrade CentOS 7 to RHEL 8 derivatives such as AlmaLinux, CentOS Stream, Oracle Linux, and Rocky Linux with the help of ELevate project from AlmaLinux developers.</p> <p>I didn't expect that CentOS 7 migration to RHEL 8 derivatives was going to be this much easier! AlmaLinux devs have done a commendable job. Be it a bug fix, or a feature addition, they quickly step in and work on it. They were the first one to release a stable alternative to CentOS 8. They also provided a Bash script to easily convert existing CentOS 8 systems to AlmaLinux 8. For more details, refer the following guide.</p> <ul> <li><strong><a href="https://ostechnix.com/migrate-to-almalinux-from-centos-8-using-almalinux-deploy-script/" target="_blank" rel="noreferrer noopener">Migrate To AlmaLinux From CentOS 8 Using Almalinux-deploy Script</a></strong></li> </ul> <p><strong>Resource:</strong></p> <ul> <li><strong><a href="https://almalinux.org/elevate" target="_blank" rel="noreferrer noopener">AlmaLinux ELevate</a></strong></li> </ul> </div> <div class="penci-single-link-pages"> </div> <div class="post-tags"> <a href="https://ostechnix.com/tag/almalinux-8/" rel="tag">Almalinux 8</a><a href="https://ostechnix.com/tag/centos-7/" rel="tag">CentOS 7</a><a href="https://ostechnix.com/tag/centos-7-migration/" rel="tag">CentOS 7 migration</a><a href="https://ostechnix.com/tag/centos-8/" rel="tag">CentOS 8</a><a href="https://ostechnix.com/tag/centos-stream/" rel="tag">CentOS Stream</a><a href="https://ostechnix.com/tag/elevate/" rel="tag">ELevate</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-administration/" rel="tag">Linux administration</a><a href="https://ostechnix.com/tag/linux-howto/" rel="tag">Linux howto</a><a href="https://ostechnix.com/tag/oracle-linux-8/" rel="tag">Oracle Linux 8</a><a href="https://ostechnix.com/tag/rhel-8/" rel="tag">RHEL 8</a><a href="https://ostechnix.com/tag/rocky-linux-8/" rel="tag">Rocky Linux 8</a><a href="https://ostechnix.com/tag/upgrade-centos-7-to-8/" rel="tag">Upgrade CentOS 7 to 8</a> </div> </div> </div> <div class="tags-share-box single-post-share tags-share-box-s1 center-box social-align-default"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="35186" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility%20-%20https://ostechnix.com/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;title=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;title=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility %0A%0A https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fmigrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8%2F&#038;text=How%20To%20Migrate%20CentOS%207%20To%20AlmaLinux%208%2C%20CentOS%20Stream%208%2C%20Oracle%20Linux%208%2C%20Rocky%20Linux%208%20Using%20ELevate%20Utility"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#f0cf8385929a959384cdb89f87d5c2c0a49fd5c2c0bd999782918495d5c2c0b3959e84bfa3d5c2c0c7d5c2c0a49fd5c2c0b19c9d91bc999e8588d5c2c0c8dcd5c2c0b3959e84bfa3d5c2c0a3848295919dd5c2c0c8dcd5c2c0bf8291939c95d5c2c0bc999e8588d5c2c0c8dcd5c2c0a29f939b89d5c2c0bc999e8588d5c2c0c8d5c2c0a583999e97d5c2c0b5bc9586918495d5c2c0a584999c998489d6d3c0c3c8cbb2bfb4a9cd9884848083cadfdf9f83849593989e9988de939f9ddf9d999782918495dd93959e849f83ddc7dd849fdd919c9d919c999e8588ddc8dd93959e849f83ddc8dd829f939b89dd9c999e8588ddc8df"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-author abio-style-1 bioimg-round"> <div class="author-img"> <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' data-lazy-src="https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100'/></noscript> </div> <div class="author-content"> <h5><a href="https://ostechnix.com/author/sk/" title="Author sk" rel="author">sk</a></h5> <p>I am Senthil Kumar, more commonly known as SK to my friends, from India. I love to read, write and explore topics on Linux, Unix and all other technology related stuff.</p> <div class="bio-social"> <a rel="noreferrer" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fas fa-globe"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://facebook.com/ostechnix"><i class="penci-faicon fab fa-facebook-f"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://twitter.com/ostechnix"><i class="penci-faicon fab fa-twitter"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fab fa-linkedin-in"></i></a> </div> </div> </div> <div class="post-pagination"> <div class="prev-post"> <div class="prev-post-inner"> <div class="prev-post-title"> <span>Previous post</span> </div> <a href="https://ostechnix.com/install-opensuse-leap/"> <div class="pagi-text"> <h5 class="prev-title">How To Install openSUSE Leap 15.3 Desktop &#8211; A Step By Step Guide</h5> </div> </a> </div> </div> </div> <div class="post-related"> <div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div> <div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"> <div class="item-related"> <a data-bg="" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/install-linux-kernel-4-4-1-lts-in-centos-and-ubuntu/" title="Install Linux Kernel 4.4.1 LTS in CentOS and Ubuntu"> </a> <h3><a href="https://ostechnix.com/install-linux-kernel-4-4-1-lts-in-centos-and-ubuntu/">Install Linux Kernel 4.4.1 LTS in CentOS and...</a></h3> <span class="date"><time class="entry-date published" datetime="2016-02-10T11:18:04+05:30">February 10, 2016</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2016/02/semanage-command-not-found-in-CentOS-78-And-RHEL-78.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/linux-troubleshooting-semanage-command-not-found-in-centos-7rhel-7/" title="Linux Troubleshooting &#8211; semanage command not found in CentOS 7/8 And RHEL 7/8"> </a> <h3><a href="https://ostechnix.com/linux-troubleshooting-semanage-command-not-found-in-centos-7rhel-7/">Linux Troubleshooting &#8211; semanage command not found in...</a></h3> <span class="date"><time class="entry-date published" datetime="2020-02-08T14:00:02+05:30">February 8, 2020</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/12/Keep-CentOS-6-Servers-Safe-From-OpenSSL-Vulnerability-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/keep-centos-6-servers-safe-from-a-new-openssl-vulnerability/" title="Keep CentOS 6 Servers Safe From A New OpenSSL Vulnerability"> </a> <h3><a href="https://ostechnix.com/keep-centos-6-servers-safe-from-a-new-openssl-vulnerability/">Keep CentOS 6 Servers Safe From A New...</a></h3> <span class="date"><time class="entry-date published" datetime="2020-12-23T14:56:19+05:30">December 23, 2020</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2017/09/Install-Linux-Kernel-4.13.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/install-linux-kernel-4-13-centos-ubuntu/" title="Install Linux Kernel 4.13 In CentOS and Ubuntu"> </a> <h3><a href="https://ostechnix.com/install-linux-kernel-4-13-centos-ubuntu/">Install Linux Kernel 4.13 In CentOS and Ubuntu</a></h3> <span class="date"><time class="entry-date published" datetime="2017-09-07T17:00:40+05:30">September 7, 2017</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/12/Migrate-To-CentOS-Stream-8-From-CentOS-Linux-8-1-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/how-to-migrate-to-centos-stream-8-from-centos-linux-8/" title="How To Migrate To CentOS Stream 8 From CentOS Linux 8"> </a> <h3><a href="https://ostechnix.com/how-to-migrate-to-centos-stream-8-from-centos-linux-8/">How To Migrate To CentOS Stream 8 From...</a></h3> <span class="date"><time class="entry-date published" datetime="2020-12-09T19:05:55+05:30">December 9, 2020</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2016/12/ftp.jpg" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/ftp_manager-simple-script-install-manage-ftp-server-centos/" title="FTP_Manager : A Simple Script To Install And Manage FTP Server In CentOS"> </a> <h3><a href="https://ostechnix.com/ftp_manager-simple-script-install-manage-ftp-server-centos/">FTP_Manager : A Simple Script To Install And...</a></h3> <span class="date"><time class="entry-date published" datetime="2016-12-24T12:19:38+05:30">December 24, 2016</time></span> </div> </div></div> <div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"> <div id="respond" class="comment-respond"> <h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/migrate-centos-7-to-almalinux-8-centos-8-rocky-linux-8/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" placeholder="Name*" size="30" aria-required='true' /></p> <p class="comment-form-email"><input id="email" name="email" type="text" placeholder="Email*" size="30" aria-required='true' /></p> <p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p> <div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='35186' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2c949c8fe6" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="102" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript">document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div> <p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> </article> </div> </div> <div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right penci-sticky-sidebar"> <div class="theiaStickySidebar"> <aside id="penci_social_widget-1" class="widget penci_social_widget"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Networks</span></h3> <div class="widget-social pc_aligncenter show-text remove-circle penci-social-textcolored"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 14px"></i> <span style="font-size: 14px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 14px"></i> <span style="font-size: 14px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 14px"></i> <span style="font-size: 14px">Linkedin</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 14px"></i> <span style="font-size: 14px">Reddit</span></a> </div> </aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"> <p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p> <p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..." /><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p> <input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6186167963" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside> </div> </div> </div> </div> </div> <div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div> <div class="clear-footer"></div> <div id="widget-area"> <div class="container"> <div class="footer-widget-wrapper footer-widget-style-10"> <aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4> <div class="textwidget"><p><a href="https://ostechnix.com/"><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 340px) 100vw, 340px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" alt="Ostechnix Footer Logo" width="340" height="68" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-lazy-sizes="(max-width: 340px) 100vw, 340px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" />
</picture>
<noscript><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" sizes="(max-width: 340px) 100vw, 340px"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px"/>
</picture>
</noscript></a></p> <p>&nbsp;</p> <p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p> </div> </aside><aside id="penci_social_widget-2" class="widget penci_social_widget"> <div class="widget-social pc_aligncenter remove-circle"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 18px"></i> <span style="font-size: 13px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 18px"></i> <span style="font-size: 13px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 18px"></i> <span style="font-size: 13px">Linkedin</span></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube" style="font-size: 18px"></i> <span style="font-size: 13px">Youtube</span></a> <a href="/cdn-cgi/l/email-protection#6e070008012e011d1a0b0d06000716400d0103" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope" style="font-size: 18px"></i> <span style="font-size: 13px">Email</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 18px"></i> <span style="font-size: 13px">Reddit</span></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss" style="font-size: 18px"></i> <span style="font-size: 13px">Rss</span></a> </div> </aside> </div> <div class="footer-widget-wrapper footer-widget-style-10 last"> <aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-3912" class="side-newsfeed display-order-numbers"> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">1</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/10/Run-MacOS-Software-On-Linux-Using-Darling-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/run-macos-software-on-linux-using-darling/" title="Run MacOS Software On Linux Using Darling"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/run-macos-software-on-linux-using-darling/" rel="bookmark" title="Run MacOS Software On Linux Using Darling"> Run MacOS Software On Linux Using Darling </a> </h4> <div class="grid-post-box-meta penci-side-item-meta"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-10-05T20:47:45+05:30">October 5, 2020</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners"> Youtube-dl Tutorial With Examples For Beginners </a> </h4> <div class="grid-post-box-meta penci-side-item-meta"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/10/Zenity-Create-GUI-Dialog-Boxes-In-Bash-Scripts-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/zenity-create-gui-dialog-boxes-in-bash-scripts/" title="How To Create GUI Dialog Boxes In Bash Scripts With Zenity In Linux And Unix"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/zenity-create-gui-dialog-boxes-in-bash-scripts/" rel="bookmark" title="How To Create GUI Dialog Boxes In Bash Scripts With Zenity In Linux And Unix"> How To Create GUI Dialog Boxes In Bash Scripts With Zenity In Linux And Unix </a> </h4> <div class="grid-post-box-meta penci-side-item-meta"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2021-10-28T15:10:07+05:30">October 28, 2021</time></span> </div> </div> </div> </li> </ul> </aside> </div> </div> </div> <footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter"> <div class="container"> <div class="footer-logo-copyright footer-not-logo footer-not-gotop"> <div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li> <li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> <li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li> <li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li> <li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li> </ul> </div> <div id="footer-copyright"> <p>OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p> </div> </div> <div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div> </div> </footer> </div> <a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fas fa-times"></i></a> <nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div id="sidebar-nav-logo"> <a href="https://ostechnix.com/"><picture>
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" width="250" height="52" alt="OSTechNix" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" />
</picture>
<noscript><picture>
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" width="250" height="52" alt="OSTechNix"/>
</picture>
</noscript></a> </div> <div class="header-social sidebar-nav-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#731a1d151c331c000716101b1d1a0b5d101c1e" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> <div class="penci-hbg-search-box penci-vernav-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <ul id="menu-header-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul> </nav> <div class="penci-menu-hbg-overlay"></div> <div class="penci-menu-hbg penci-vernav-hide penci-menu-hbg-left"> <div class="penci-menu-hbg-inner"> <a id="penci-close-hbg"><i class="penci-faicon fas fa-times"></i></a> <div class="penci-hbg-header"> <div class="penci-hbg-logo site-branding"> <a href="https://ostechnix.com/"><picture class="penci-lazy">
<source type="image/webp" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" />
<img width="350" height="73" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" />
</picture>
</a> </div> </div> <div class="penci-hbg-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <div class="penci-hbg-content penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right"> <ul id="menu-top-menu-1" class="menu menu-hgb-main"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul> </div> <div class="penci-hbg-footer"> <div class="penci_menu_hbg_ftext">OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</div> <div class="header-social sidebar-nav-social penci-hbg-social-style-4 penci-social-colored"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#1871767e7758776b6c7d7b70767160367b7775" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> </div> </div> </div> <div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"> <div class="penci-gprd-law"> <p> This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a> </p> </div> </div> <!--[if lte IE 9]> <script> 'use strict'; (function($) { $(document).ready(function() { $('#ftwp-container').addClass('ftwp-ie9'); }); })(jQuery); </script> <![endif]--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script> <script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/ullavidu\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/ostechnix.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/themes/soledad/js/libs-script.min.js?ver=8.0.2' id='penci-libs-js-js' defer></script> <script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"bf0d3528a5","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/main.js?ver=1634284898' id='main-scripts-js' defer></script> <script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"bf0d3528a5","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/post-like.js?ver=1634284898' id='penci_ajax_like_post-js' defer></script> <script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"bf0d3528a5","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/more-post.js?ver=1634284898' id='penci_ajax_more_posts-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/comment-reply.min.js?ver=ec25dd5b9fcf0d6992c474477cef5bb1' id='comment-reply-js' defer></script> <script type='text/javascript' id='fixedtoc-js-js-extra'>
/* <![CDATA[ */
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js?ver=3.1.22' id='fixedtoc-js-js' defer></script> <script type='text/javascript' src='https://ostechnix.com/wp-includes/js/wp-embed.min.js?ver=ec25dd5b9fcf0d6992c474477cef5bb1' id='wp-embed-js' defer></script> <script src='https://stats.wp.com/e-202144.js' defer></script> <script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2.1',blog:'84551477',post:'35186',tz:'5.5',srv:'ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '35186' ]);
</script> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">
	function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(35186, 'https://ostechnix.com');
</script> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">!function(a){"use strict";var b=function(b,c,d){function j(a){if(e.body)return a();setTimeout(function(){j(a)})}function l(){f.addEventListener&&f.removeEventListener("load",l),f.media=d||"all"}var g,e=a.document,f=e.createElement("link");if(c)g=c;else{var h=(e.body||e.getElementsByTagName("head")[0]).childNodes;g=h[h.length-1]}var i=e.styleSheets;f.rel="stylesheet",f.href=b,f.media="only x",j(function(){g.parentNode.insertBefore(f,c?g:g.nextSibling)});var k=function(a){for(var b=f.href,c=i.length;c--;)if(i[c].href===b)return a();setTimeout(function(){k(a)})};return f.addEventListener&&f.addEventListener("load",l),f.onloadcssdefined=k,k(l),f};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this); !function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(a){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ostechnix.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script> <script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-75259810-1');
</script> <script type="rocketlazyloadscript">"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"/><link rel='stylesheet' id='wp-block-library-css' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css?ver=ec25dd5b9fcf0d6992c474477cef5bb1' type='text/css' media='all'/><link rel='stylesheet' id='mediaelement-css' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all'/><link rel='stylesheet' id='wp-mediaelement-css' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=ec25dd5b9fcf0d6992c474477cef5bb1' type='text/css' media='all'/><link rel='stylesheet' id='penci-soledad-parent-style-css' href='https://ostechnix.com/wp-content/themes/soledad/style.css?ver=ec25dd5b9fcf0d6992c474477cef5bb1' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-main-style-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1634284898' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-awesomeold-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1634284898' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-iweather-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/weather-icon.swap.css?ver=1634284898' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-awesome-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1634284898' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci_icon-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1634284898' type='text/css' media='all'/><link rel='stylesheet' id='penci_style-css' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css?ver=8.0.2' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci_social_counter-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/social-counter.css?ver=1634284898' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='fixedtoc-style-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1634284900' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='jetpack_css-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1634284898' type='text/css' media='all'/></noscript><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6a7652c45ea2c1e3","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2021.10.0","si":100}'></script>
</body> </html>
