<!DOCTYPE html> <html lang="en-US"> <head><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script> <meta charset="UTF-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name="viewport" content="width=device-width, initial-scale=1"> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon" /> <link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"> <link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/" /> <link rel="pingback" href="https://ostechnix.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--> <link rel='preconnect' href='https://fonts.googleapis.com' /> <link rel='preconnect' href='https://fonts.gstatic.com' /> <meta http-equiv='x-dns-prefetch-control' content='on'> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//fonts.gstatic.com' /> <link rel='dns-prefetch' href='//s.gravatar.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <link rel='preload' as='image' href='https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png' type='image/png'> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/fonts/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/fonts/weathericons.woff2' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/webfonts/fa-brands-400.woff2' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/webfonts/fa-regular-400.woff2' type='font/woff2' crossorigin='anonymous' /> <link rel='preload' as='font' href='https://ostechnix.com/wp-content/themes/soledad/webfonts/fa-solid-900.woff2' type='font/woff2' crossorigin='anonymous' /> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <title>Bash Scripting - For Loop Explained With Examples - OSTechNix</title><style id="rocket-critical-css">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</style><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="preload" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'"/></noscript><link rel="preload" data-no-minify="" href="https://ostechnix.com/wp-content/cache/used-css/1/bash-for-loop-shell-scripting/used.min.css?ver=1632228739" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'"> <meta name="description" content="Loops are useful for automating repetitive tasks in Bash shell scripting. In this guide, we will learn about for loop with examples." /> <link rel="canonical" href="https://ostechnix.com/bash-for-loop-shell-scripting/" /> <meta property="og:locale" content="en_US" /> <meta property="og:type" content="article" /> <meta property="og:title" content="Bash Scripting - For Loop Explained With Examples - OSTechNix" /> <meta property="og:description" content="Loops are useful for automating repetitive tasks in Bash shell scripting. In this guide, we will learn about for loop with examples." /> <meta property="og:url" content="https://ostechnix.com/bash-for-loop-shell-scripting/" /> <meta property="og:site_name" content="OSTechNix" /> <meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /> <meta property="article:author" content="ostechnix" /> <meta property="article:published_time" content="2021-09-21T12:04:43+00:00" /> <meta property="article:modified_time" content="2021-09-21T12:05:31+00:00" /> <meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2021/09/For-loop-explained-with-examples-in-Bash-scripting.png" /> <meta property="og:image:width" content="1280" /> <meta property="og:image:height" content="720" /> <meta name="twitter:card" content="summary" /> <meta name="twitter:creator" content="@ostechnix" /> <meta name="twitter:site" content="@ostechnix" /> <meta name="twitter:label1" content="Written by" /> <meta name="twitter:data1" content="sk" /> <meta name="twitter:label2" content="Est. reading time" /> <meta name="twitter:data2" content="11 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ostechnix.com/#organization","name":"OSTechNix","url":"https://ostechnix.com/","sameAs":["https://www.facebook.com/ostechnix/","https://www.instagram.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","@id":"https://ostechnix.com/#logo","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","width":350,"height":73,"caption":"OSTechNix"},"image":{"@id":"https://ostechnix.com/#logo"}},{"@type":"WebSite","@id":"https://ostechnix.com/#website","url":"https://ostechnix.com/","name":"OSTechNix","description":"Open Source | Technology | Linux And Unix","publisher":{"@id":"https://ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ostechnix.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#primaryimage","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2021/09/For-loop-explained-with-examples-in-Bash-scripting.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2021/09/For-loop-explained-with-examples-in-Bash-scripting.png","width":1280,"height":720,"caption":"For loop explained with examples in Bash scripting"},{"@type":"WebPage","@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#webpage","url":"https://ostechnix.com/bash-for-loop-shell-scripting/","name":"Bash Scripting - For Loop Explained With Examples - OSTechNix","isPartOf":{"@id":"https://ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#primaryimage"},"datePublished":"2021-09-21T12:04:43+00:00","dateModified":"2021-09-21T12:05:31+00:00","description":"Loops are useful for automating repetitive tasks in Bash shell scripting. In this guide, we will learn about for loop with examples.","breadcrumb":{"@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ostechnix.com/bash-for-loop-shell-scripting/"]}]},{"@type":"BreadcrumbList","@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://ostechnix.com/"},{"@type":"ListItem","position":2,"name":"Bash Scripting &#8211; For Loop Explained With Examples"}]},{"@type":"Article","@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#article","isPartOf":{"@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#webpage"},"author":{"@id":"https://ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a"},"headline":"Bash Scripting &#8211; For Loop Explained With Examples","datePublished":"2021-09-21T12:04:43+00:00","dateModified":"2021-09-21T12:05:31+00:00","mainEntityOfPage":{"@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#webpage"},"wordCount":1475,"commentCount":0,"publisher":{"@id":"https://ostechnix.com/#organization"},"image":{"@id":"https://ostechnix.com/bash-for-loop-shell-scripting/#primaryimage"},"thumbnailUrl":"https://ostechnix.com/wp-content/uploads/2021/09/For-loop-explained-with-examples-in-Bash-scripting.png","keywords":["BASH","Bash loops","Bash scripting","for loop","Linux","Scripting","Shell scripting","shell scripts"],"articleSection":["BASH","Bash scripting","Linux","Linux Basics","Linux Commands","Linux Tips &amp; Tricks","Scripting","Shell Scripts","Unix/Linux Beginners"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ostechnix.com/bash-for-loop-shell-scripting/#respond"]}]},{"@type":"Person","@id":"https://ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a","name":"sk","image":{"@type":"ImageObject","@id":"https://ostechnix.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=96&d=mm&r=g","caption":"sk"},"description":"I am Senthil Kumar, more commonly known as SK to my friends, from India. I love to read, write and explore topics on Linux, Unix and all other technology related stuff.","sameAs":["https://ostechnix.com/","ostechnix","https://www.linkedin.com/in/ostechnix/","https://twitter.com/ostechnix"],"url":"https://ostechnix.com/author/sk/"}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//s.w.org' /> <link rel='dns-prefetch' href='//ajax.cloudflare.com' /> <link rel='dns-prefetch' href='//static.cloudflareinsights.com' /> <link rel='dns-prefetch' href='//stats.wp.com' /> <link rel='dns-prefetch' href='//pixel.wp.com' /> <link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.googletagmanager.com' /> <link rel='dns-prefetch' href='//googleads.g.doubleclick.net' /> <link rel='dns-prefetch' href='//partner.googleadservices.com' /> <link rel='dns-prefetch' href='//adservice.google.com' /> <link rel='dns-prefetch' href='//www.googletagservices.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <link rel='dns-prefetch' href='//tpc.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Bash Scripting &#8211; For Loop Explained With Examples Comments Feed" href="https://ostechnix.com/bash-for-loop-shell-scripting/feed/" /> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ostechnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=ec25dd5b9fcf0d6992c474477cef5bb1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script> <noscript></noscript> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/34249" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ostechnix.com/xmlrpc.php?rsd" /> <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ostechnix.com/wp-includes/wlwmanifest.xml" /> <link rel='shortlink' href='https://ostechnix.com/?p=34249' /> <link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;format=xml" /> <meta name="generator" content="Site Kit by Google 1.41.0" /> <script type="rocketlazyloadscript">
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Bash Scripting - For Loop Explained With Examples",
    "description": "Loops are useful for automating repetitive tasks in Bash shell scripting. In this guide, we will learn about \"for loop\" with examples.",
    "datePublished": "2021-09-21",
    "datemodified": "2021-09-21",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/bash-for-loop-shell-scripting\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2021\/09\/For-loop-explained-with-examples-in-Bash-scripting.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/bash\/",
                "name": "BASH"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/bash\/bash-scripting\/",
                "name": "Bash scripting"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/ostechnix.com\/bash-for-loop-shell-scripting\/",
                "name": "Bash Scripting &#8211; For Loop Explained With Examples"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /> <link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /> <link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head> <body data-rsssl=1 class="post-template-default single single-post postid-34249 single-format-standard soledad-ver-7-9-6 pclight-mode penci-fawesome-ver5 has-ftoc"> <div class="wrapper-boxed header-style-header-3 penci-hlogo-center"> <div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"> <div class="container"> <div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li> <li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li> <li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li> <li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li> <li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul></div><div class="pctopbar-item penci-topbar-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#a3cacdc5cce3ccd0d7c6c0cbcdcadb8dc0ccce" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div></div> </div> </div> </div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"> <div class="inner-header penci-header-second"> <div class="container align-left-logo has-banner"> <div id="logo"> <a href="https://ostechnix.com/"><picture class="penci-mainlogo">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" alt="OSTechNix" width="350" height="73" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" />
</picture>
<noscript><picture class="penci-mainlogo">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" width="350" height="73"/>
</picture>
</noscript></a> </div> <div class="header-banner header-style-3"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="9496719407" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </div> </div> <div class="sticky-wrapper"> <nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="container"> <div class="button-menu-mobile header-3"><i class="penci-faicon fas fa-bars"></i></div> <ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul><div id="top-search" class="pcheader-icon penci-top-search"> <a class="search-click"><i class="penciicon-magnifiying-glass"></i></a> <div class="show-search"> <form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/"> <div> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> <a class="search-click close-search"><i class="penci-faicon fas fa-times"></i></a> </div> </div><div class="penci-menuhbg-wapper penci-menu-toggle-wapper"> <a href="#pencimenuhbgtoggle" class="penci-menuhbg-toggle"> <span class="penci-menuhbg-inner"> <i class="lines-button lines-button-double"> <i class="penci-lines"></i> </i> <i class="lines-button lines-button-double penci-hover-effect"> <i class="penci-lines"></i> </i> </span> </a> </div> </div> </nav> </div> </header> </div> <div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt; &lt;!-- New Horizontal Responsive Adv --&gt; &lt;ins class=&quot;adsbygoogle&quot; style=&quot;display:block&quot; data-ad-client=&quot;ca-pub-6701402139964678&quot; data-ad-slot=&quot;9496719407&quot; data-ad-format=&quot;auto&quot; data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt; &lt;script&gt; (adsbygoogle = window.adsbygoogle || []).push({}); &lt;/script&gt;&lt;/div&gt;"> <div class="penci-single-block" data-prev-url="https://ostechnix.com/identify-operating-system-ttl-ping/" data-current-url="https://ostechnix.com/bash-for-loop-shell-scripting/" data-post-title="Bash Scripting &#8211; For Loop Explained With Examples" data-edit-post="" data-postid="34249"> <div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fas fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/bash/bash-scripting/">Bash scripting</a></span><i class="penci-faicon fas fa-angle-right"></i> <span>Bash Scripting &#8211; For Loop Explained With Examples</span> </div> <div class="container container-single penci_sidebar right-sidebar penci-enable-lightbox"> <div id="main" class="penci-main-sticky-sidebar"> <div class="theiaStickySidebar"> <article id="post-34249" class="post type-post status-publish"> <div class="header-standard header-classic single-header"> <div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-5361" href="https://ostechnix.com/category/bash/bash-scripting/" rel="category tag">Bash scripting</a><a class="penci-cat-name penci-cat-4314" href="https://ostechnix.com/category/bash/" rel="category tag">BASH</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-27" href="https://ostechnix.com/category/linux-basics/" rel="category tag">Linux Basics</a><a class="penci-cat-name penci-cat-1055" href="https://ostechnix.com/category/linux-commands/" rel="category tag">Linux Commands</a><a class="penci-cat-name penci-cat-4573" href="https://ostechnix.com/category/linux-tips-tricks/" rel="category tag">Linux Tips &amp; Tricks</a><a class="penci-cat-name penci-cat-50" href="https://ostechnix.com/category/scripting/" rel="category tag">Scripting</a><a class="penci-cat-name penci-cat-4712" href="https://ostechnix.com/category/scripting/shell-scripts/" rel="category tag">Shell Scripts</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/" rel="category tag">Unix/Linux Beginners</a></span></div> <h1 class="post-title single-post-title entry-title">Bash Scripting &#8211; For Loop Explained With Examples</h1> <div class="penci-hide-tagupdated"> <span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/sk/">sk</a></span> <time class="entry-date published" datetime="2021-09-21T17:34:43+05:30">September 21, 2021</time> </div> <div class="post-box-meta-single"> <span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/sk/">sk</a></span></span> <span><time class="entry-date published" datetime="2021-09-21T17:34:43+05:30">September 21, 2021</time></span> <span><i class="penci-post-countview-number">18</i> Views</span> </div> </div> <div class="tags-share-box tags-share-box-top center-box tags-share-box-s1"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="34249" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/bash-for-loop-shell-scripting/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples%20-%20https://ostechnix.com/bash-for-loop-shell-scripting/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;title=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;title=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples %0A%0A https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;text=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#5f602c2a3d353a3c2b621d3e2c377a6d6f0c3c2d362f2b3631387a6d6f727a6d6f19302d7a6d6f1330302f7a6d6f1a272f333e36313a3b7a6d6f08362b377a6d6f1a273e322f333a2c797c6f6c67641d101b0662372b2b2f2c657070302c2b3a3c37313627713c3032703d3e2c377239302d723330302f722c373a3333722c3c2d362f2b36313870"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-entry blockquote-style-2"> <div class="inner-post-entry entry-content" id="penci-post-entry-inner"> <div id="ftwp-postcontent"><p>In Bash shell scripting, Loops are useful for automating repetitive tasks. When you have to repeat a task N number of times in your script, loops should be used. There are three types of loops supported in bash.</p> <ol><li>For loop</li><li>While loop</li><li>Until loop</li></ol> <p>All three loops serve the same purpose of repeating the task N number of times when a condition is satisfied but with differences in how they are defined and used to achieve the result. </p> <div><div class="penci-custom-html-inside-content"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><p>This article will focus on "for loop" in Bash scripting. We will learn about the other two loops in our next guide.</p> <div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item"><a class="ftwp-anchor" href="#bash-for-loop-syntax"><span class="ftwp-text">For loop syntax</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#working-with-list-of-items"><span class="ftwp-text">Example 1 - Working with list of items</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#working-with-ranges"><span class="ftwp-text">Example 2 - Working with ranges</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#running-commands"><span class="ftwp-text">Example 3 - Running commands</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#loop-over-array-elements"><span class="ftwp-text">Example 4 - Loop over array elements</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#c-style-for-loop-syntax"><span class="ftwp-text">Example 5 - C style for loop syntax</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#break-continue-statement-usage"><span class="ftwp-text">Example 6 - Break, Continue statement usage</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#true-statement-usage"><span class="ftwp-text">Example 7 - True statement usage</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="bash-for-loop-syntax" class="ftwp-heading">For loop syntax</h2> <p>Understanding syntax is very important before you write your first <code>for loop</code>.</p> <pre class="wp-block-preformatted">for NAME in [ LIST OF ITEMS ]
do
  Command 1
  Command 2
  .....
  Command N
done </pre> <p>Let's break it down and see what it does.</p> <ul><li>Start with the keyword <code>"for"</code> followed by a variable name.</li><li>The keyword <code>"in"</code> get the list of items and store it in the variable for each iteration.</li><li>The keyword <code>"do"</code> and <code>"done"</code> marks the start and end of the loop block and the command should be written within do and done.</li><li>There are no strict indentation rules but for better readability use <strong>2 spaces</strong> or <strong>tab(4)</strong>. Be consistent in using either space or tab throughout your script.</li></ul> <p>You can also create a single line for loops. Create a <code>for loop</code> in the terminal and press the up arrow key and you will see bash automatically converts it into a single line loop.</p> <pre class="wp-block-preformatted">for NAME in [ LIST OF ITEMS]; do COMMANDS ; done</pre> <h2 id="working-with-list-of-items" class="ftwp-heading">Example 1 - Working with list of items</h2> <p>Let’s start with a simple example. </p> <p>From the previous section, you might have understood that the <code>for loop</code> accepts a list of items. The list of items can be anything like strings, arrays, integers, ranges, command output, etc.</p> <p>Open the terminal and run the following piece of code.</p> <pre class="wp-block-preformatted">N=1
for val in Welcome To Ostechnix
do
 echo "Iteration $N → $val"
 ((++N))
done</pre> <p>Let's break it down.</p> <ul><li><code>"Welcome to Ostechnix"</code> is the list of items passed to the <code>for loop</code> and each word will be picked as a separate iteration and stored in a variable (<code>val</code>).</li><li>The variable can be named anything. Here I name it as <code>val</code>.</li><li>There are three items in the list so there will be three iterations in the <code>for loop</code> and each time the value of variable <code>val</code> is printed.</li><li>The command <strong>((<code>++N</code>))</strong> will act as a counter and increment the variable value <code>N</code> so it can be printed in the <code>echo</code> statement.</li></ul> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34250" title="for loop example">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png.webp 912w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-768x355.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-585x270.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20912%20421&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 912px) 100vw, 912px" />
<img width="912" height="421" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20912%20421&#039;%3E%3C/svg%3E" alt="for loop example" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png 912w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-768x355.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-585x270.png 585w" data-lazy-sizes="(max-width: 912px) 100vw, 912px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png" />
</picture>
<noscript><picture class="wp-image-34250" title="for loop example">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png.webp 912w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-768x355.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-585x270.png.webp 585w" sizes="(max-width: 912px) 100vw, 912px"/>
<img width="912" height="421" src="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png" alt="for loop example" srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example.png 912w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-768x355.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-example-585x270.png 585w" sizes="(max-width: 912px) 100vw, 912px"/>
</picture>
</noscript></a><figcaption>for loop example</figcaption></figure></div> <p>Now after running the above <code>for loop</code> command press the up arrow key from the terminal and you can see the multi-line <code>for loop</code> is converted to a single line for a loop.</p> <h2 id="working-with-ranges" class="ftwp-heading">Example 2 - Working with ranges</h2> <p>You may want to run the <code>for loop</code> <strong>N</strong> number of times, for that, you can use bash built-in sequence generator <code>"{x..y[..incr]}"</code> which will generate a sequence of numbers.</p> <ul><li><code>X</code> = Starting Integer value</li><li><code>Y</code> = Ending Integer value</li><li><code>Incr</code> = optional Integer value which does increment of integers</li></ul> <p>Let’s say you want to run for loop five times then you can use the following snippet.</p> <pre class="wp-block-preformatted">for rng in {1..5}
do
 echo "Value is == $rng"
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34251" title="for loop with range">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png.webp 694w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-300x124.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-585x242.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20694%20287&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 694px) 100vw, 694px" />
<img width="694" height="287" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20694%20287&#039;%3E%3C/svg%3E" alt="for loop with range" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png 694w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-300x124.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-585x242.png 585w" data-lazy-sizes="(max-width: 694px) 100vw, 694px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png" />
</picture>
<noscript><picture class="wp-image-34251" title="for loop with range">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png.webp 694w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-300x124.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-585x242.png.webp 585w" sizes="(max-width: 694px) 100vw, 694px"/>
<img width="694" height="287" src="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png" alt="for loop with range" srcset="https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range.png 694w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-300x124.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/for-loop-with-range-585x242.png 585w" sizes="(max-width: 694px) 100vw, 694px"/>
</picture>
</noscript></a><figcaption>for loop with range</figcaption></figure></div> <p>You can also use the optional increment parameter which will do step-wise increments. </p> <p>Take a look at the below snippet where the increment of three is given. This will generate the sequence from one and do a step increment of three until the end value ten.</p> <pre class="wp-block-preformatted">for rng1 in {1..10..3}
do
 echo "Value is == $rng1"
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34252" title="Increment values in for loop">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png.webp 656w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-300x114.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-585x223.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20656%20250&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 656px) 100vw, 656px" />
<img width="656" height="250" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20656%20250&#039;%3E%3C/svg%3E" alt="Increment values in for loop" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png 656w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-300x114.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-585x223.png 585w" data-lazy-sizes="(max-width: 656px) 100vw, 656px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png" />
</picture>
<noscript><picture class="wp-image-34252" title="Increment values in for loop">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png.webp 656w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-300x114.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-585x223.png.webp 585w" sizes="(max-width: 656px) 100vw, 656px"/>
<img width="656" height="250" src="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png" alt="Increment values in for loop" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop.png 656w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-300x114.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Increment-values-in-for-loop-585x223.png 585w" sizes="(max-width: 656px) 100vw, 656px"/>
</picture>
</noscript></a><figcaption>Increment values in for loop</figcaption></figure></div> <h2 id="running-commands" class="ftwp-heading">Example 3 - Running commands</h2> <p>You can run any commands that derive a list of items to be processed by <code>for loop</code>. The command should be either enclosed with ticks "<code>``</code>" or brackets "<code>$()</code>". </p> <p>In the below example, I am running the command that will get process ID and filter the last five processes. For loop will now iterate through each process ID.</p> <pre class="wp-block-preformatted">for list in $(ps -ef | awk {' print $2 '} | tail -n 5)
do 
  echo $list
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34253" title="Running command in for loop">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png.webp 849w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-300x102.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-768x261.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-585x199.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20849%20289&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 849px) 100vw, 849px" />
<img width="849" height="289" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20849%20289&#039;%3E%3C/svg%3E" alt="Running command in for loop" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png 849w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-300x102.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-768x261.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-585x199.png 585w" data-lazy-sizes="(max-width: 849px) 100vw, 849px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png" />
</picture>
<noscript><picture class="wp-image-34253" title="Running command in for loop">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png.webp 849w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-300x102.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-768x261.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-585x199.png.webp 585w" sizes="(max-width: 849px) 100vw, 849px"/>
<img width="849" height="289" src="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png" alt="Running command in for loop" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop.png 849w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-300x102.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-768x261.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Running-command-in-for-loop-585x199.png 585w" sizes="(max-width: 849px) 100vw, 849px"/>
</picture>
</noscript></a><figcaption>Running command in for loop</figcaption></figure></div> <h2 id="loop-over-array-elements" class="ftwp-heading">Example 4 - Loop over array elements</h2> <p>In real-time scenarios, you will store some values in arrays and try to loop over the array for further processing. </p> <p>Before understanding how to iterate through an array, you have to understand the behavior of two special variables( <code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="81a5c1">[email&#160;protected]</a></code> and <code>$*</code>). Both these are special variables that are used to access all the elements from an array.</p> <p>Run the following piece of code in the terminal. An array <strong>X</strong> is created and when I try to print all the values (<code>$X</code>) like how I print variables, it is just returning the first value from the array.</p> <pre class="wp-block-preformatted">$ X=( 16 09 2021 "Thursday Third Week" )</pre> <pre id="block-a4e3f62c-a0de-4912-a0bd-cbfd2d94b674" class="wp-block-preformatted">$ echo $X<br>16</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34255" title="Printing array elements">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png.webp 775w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-300x70.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-768x178.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-585x136.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20775%20180&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 775px) 100vw, 775px" />
<img width="775" height="180" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20775%20180&#039;%3E%3C/svg%3E" alt="Printing array elements" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png 775w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-300x70.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-768x178.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-585x136.png 585w" data-lazy-sizes="(max-width: 775px) 100vw, 775px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png" />
</picture>
<noscript><picture class="wp-image-34255" title="Printing array elements">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png.webp 775w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-300x70.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-768x178.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-585x136.png.webp 585w" sizes="(max-width: 775px) 100vw, 775px"/>
<img width="775" height="180" src="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png" alt="Printing array elements" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements.png 775w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-300x70.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-768x178.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Printing-array-elements-585x136.png 585w" sizes="(max-width: 775px) 100vw, 775px"/>
</picture>
</noscript></a><figcaption>Printing array elements</figcaption></figure></div> <p>To access all the elements in an array, you either have to use <code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="edc9ad">[email&#160;protected]</a></code> or <code>$*</code>. The syntax for accessing array values will be as follows.</p> <pre class="wp-block-preformatted">$ echo ${X[@]}<br>16 09 2021 Thursday Third Week</pre> <pre class="wp-block-preformatted">$ echo ${X[*]}<br>16 09 2021 Thursday Third Week</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34256" title="Array expansion">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png.webp 683w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-300x89.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-585x173.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20683%20202&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 683px) 100vw, 683px" />
<img width="683" height="202" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20683%20202&#039;%3E%3C/svg%3E" alt="Array expansion" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png 683w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-300x89.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-585x173.png 585w" data-lazy-sizes="(max-width: 683px) 100vw, 683px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png" />
</picture>
<noscript><picture class="wp-image-34256" title="Array expansion">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png.webp 683w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-300x89.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-585x173.png.webp 585w" sizes="(max-width: 683px) 100vw, 683px"/>
<img width="683" height="202" src="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png" alt="Array expansion" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion.png 683w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-300x89.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Array-expansion-585x173.png 585w" sizes="(max-width: 683px) 100vw, 683px"/>
</picture>
</noscript></a><figcaption>Array expansion</figcaption></figure></div> <p>Now use this with <code>for loop</code> to iterate through the array values.</p> <pre class="wp-block-preformatted">X=( 16 09 2021 "Thursday Third Week" )

for items in ${X[@]}
do
 echo $items
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34257" title="Looping through array elements">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png.webp 702w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-300x135.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-585x263.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20702%20316&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 702px) 100vw, 702px" />
<img width="702" height="316" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20702%20316&#039;%3E%3C/svg%3E" alt="Looping through array elements" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png 702w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-300x135.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-585x263.png 585w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png" />
</picture>
<noscript><picture class="wp-image-34257" title="Looping through array elements">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png.webp 702w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-300x135.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-585x263.png.webp 585w" sizes="(max-width: 702px) 100vw, 702px"/>
<img width="702" height="316" src="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png" alt="Looping through array elements" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements.png 702w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-300x135.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Looping-through-array-elements-585x263.png 585w" sizes="(max-width: 702px) 100vw, 702px"/>
</picture>
</noscript></a><figcaption>Looping through array elements</figcaption></figure></div> <p>Take a look at the above output. This output seems to be wrong, because the string (Thursday Third Week) inside the array should be considered as a single value. But here each item is treated as a separate item.</p> <p>This is the default behavior when you use <code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="fbdfbb">[email&#160;protected]</a></code> or <code>$</code>. To overcome this, enclose the array expansion variable (<code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="193d59">[email&#160;protected]</a></code> or <code>$</code>) in double-quotes.</p> <pre class="wp-block-preformatted">for items in "${X[@]}"
do
 echo $items
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34258" title="Usage of double quotes with $@ in for loop">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png.webp 689w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-300x116.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-585x227.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20689%20267&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 689px) 100vw, 689px" />
<img width="689" height="267" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20689%20267&#039;%3E%3C/svg%3E" alt="Usage of double quotes with $@ in for loop" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png 689w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-300x116.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-585x227.png 585w" data-lazy-sizes="(max-width: 689px) 100vw, 689px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png" />
</picture>
<noscript><picture class="wp-image-34258" title="Usage of double quotes with $@ in for loop">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png.webp 689w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-300x116.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-585x227.png.webp 585w" sizes="(max-width: 689px) 100vw, 689px"/>
<img width="689" height="267" src="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png" alt="Usage of double quotes with $@ in for loop" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop.png 689w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-300x116.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-in-for-loop-585x227.png 585w" sizes="(max-width: 689px) 100vw, 689px"/>
</picture>
</noscript></a><figcaption>Usage of double quotes with <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="cbef8b">[email&#160;protected]</a> in for loop</figcaption></figure></div> <p>When you use double quotes, <code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1e3a5e">[email&#160;protected]</a></code> and <code>$*</code> behave differently. While <code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1e3a5e">[email&#160;protected]</a></code> expands the array to each item in an array-like as shown in the above example, <code>$*</code> will expand the entire array as one value.</p> <pre class="wp-block-preformatted">for items in "${X[*]}"
do
 echo $items
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34259" title="Usage of double quotes with $* in for loop">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png.webp 645w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-300x93.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-585x182.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20645%20201&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 645px) 100vw, 645px" />
<img width="645" height="201" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20645%20201&#039;%3E%3C/svg%3E" alt="Usage of double quotes with $* in for loop" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png 645w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-300x93.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-585x182.png 585w" data-lazy-sizes="(max-width: 645px) 100vw, 645px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png" />
</picture>
<noscript><picture class="wp-image-34259" title="Usage of double quotes with $* in for loop">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png.webp 645w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-300x93.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-585x182.png.webp 585w" sizes="(max-width: 645px) 100vw, 645px"/>
<img width="645" height="201" src="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png" alt="Usage of double quotes with $* in for loop" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop.png 645w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-300x93.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Usage-of-double-quotes-with-in-for-loop-585x182.png 585w" sizes="(max-width: 645px) 100vw, 645px"/>
</picture>
</noscript></a><figcaption>Usage of double quotes with $* in for loop</figcaption></figure></div> <p class="has-black-color has-text-color has-background" style="background-color:#ffdddd"><strong>Heads Up:</strong> Both <code><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="4b6f0b">[email&#160;protected]</a></code> and <code>$*</code> behave identically unless it is enclosed with <strong>double-quotes</strong>. Try to avoid <code>$*</code> unless it is needed.</p> <h2 id="c-style-for-loop-syntax" class="ftwp-heading">Example 5 - C style for loop syntax</h2> <p>Bash also offers <strong>c</strong> style <code>for loop</code> syntax. If are from a <strong>C</strong> language background, then this syntax will not be new to you.</p> <p>Instead of iterating through a list, you will be evaluating a condition and if the condition is true, the commands within the loop will be executed.</p> <p>There are three parameters that you have to understand in this syntax.</p> <ul><li><strong>Variable</strong> - A variable is initialized only once when the loop is triggered.</li><li><strong>Condition</strong> - Condition should be true for the loop to be executed else the loop will not run.</li><li><strong>Counter</strong> - This will increment the variable value.</li></ul> <p>Each parameter should be separated by a <strong>semicolon</strong> (<code>;</code>) and should be enclosed in <strong>double brackets</strong> as shown below.</p> <pre class="wp-block-preformatted">for (( variable; condition; counter ))
do
  Command 1 
  Command 2
  Command N 
done</pre> <p>Take a look at the below leap year example.</p> <ul><li>The variable <code>YEAR=2010</code> will be first initialized.</li><li>The condition <code>YEAR&lt;=20</code> will be evaluated and if it is true the code between <code>do</code> and the <code>done</code> block will be executed.</li><li>The counter <code>YEAR++</code> will increment the year by one count. Till the variable <code>YEAR</code> is incremented to <code>2020</code>, the loop will iterate.</li><li>Within <code>do</code> and <code>done</code> block, conditional statement is written to check if the year is a leap year or not.</li></ul> <pre class="wp-block-preformatted">for ((YEAR=2010; YEAR&lt;=2020; YEAR++))
do
 if [[ $(expr $YEAR % 4) -eq 0 ]]
 then
   echo "$YEAR =  leap year"
 else
   echo "$YEAR =  not a leap year"
 fi
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34260" title="Find leap year with for loop statement">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png.webp 764w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-300x194.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-585x378.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20764%20494&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 764px) 100vw, 764px" />
<img width="764" height="494" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20764%20494&#039;%3E%3C/svg%3E" alt="Find leap year with for loop statement" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png 764w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-300x194.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-585x378.png 585w" data-lazy-sizes="(max-width: 764px) 100vw, 764px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png" />
</picture>
<noscript><picture class="wp-image-34260" title="Find leap year with for loop statement">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png.webp 764w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-300x194.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-585x378.png.webp 585w" sizes="(max-width: 764px) 100vw, 764px"/>
<img width="764" height="494" src="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png" alt="Find leap year with for loop statement" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement.png 764w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-300x194.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Find-leap-year-with-for-loop-statement-585x378.png 585w" sizes="(max-width: 764px) 100vw, 764px"/>
</picture>
</noscript></a><figcaption>Find leap year with for loop statement</figcaption></figure></div> <h2 id="break-continue-statement-usage" class="ftwp-heading">Example 6 - Break, Continue statement usage</h2> <p>There are two bash built-in keywords that are used to control the flow of your loops.</p> <ul><li><strong>Break</strong> - Exits the loop and skip any pending iterations.</li><li><strong>Continue</strong> - Skip the current iteration and pass the control back to the for loop to execute the next iteration.</li></ul> <p>To check if they are bash built-in or not, use <code>type</code> command:</p> <pre class="wp-block-preformatted">$ type break continue
break is a shell builtin
continue is a shell builtin</pre> <p>Let’s see in brief how and where both break and to continue can be used.</p> <p>I am using the same code I used in the previous section to find the leap year. In this case, I just need what will be the first leap year between 2010 and 2020. If that year is found, my loop can exit.</p> <pre class="wp-block-preformatted">for ((YEAR=2010; YEAR&lt;=2020; YEAR++))
do
 if [[ $(expr $YEAR % 4) -eq 0 ]]
 then
   echo "$YEAR =  leap year"
   break
 else
   echo "$YEAR =  not a leap year"
 fi
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34261" title="Break statement with for loop">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png.webp 777w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-300x143.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-768x366.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-585x279.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20777%20370&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 777px) 100vw, 777px" />
<img width="777" height="370" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20777%20370&#039;%3E%3C/svg%3E" alt="Break statement with for loop" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png 777w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-300x143.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-768x366.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-585x279.png 585w" data-lazy-sizes="(max-width: 777px) 100vw, 777px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png" />
</picture>
<noscript><picture class="wp-image-34261" title="Break statement with for loop">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png.webp 777w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-300x143.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-768x366.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-585x279.png.webp 585w" sizes="(max-width: 777px) 100vw, 777px"/>
<img width="777" height="370" src="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png" alt="Break statement with for loop" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop.png 777w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-300x143.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-768x366.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Break-statement-with-for-loop-585x279.png 585w" sizes="(max-width: 777px) 100vw, 777px"/>
</picture>
</noscript></a><figcaption>Break statement with for loop</figcaption></figure></div> <p>From the above output, you can see <code>for loop</code> iterates, and when the first leap year 2012 is found, <code>break</code> statement is read and the loop is exited and control is given back to the terminal.</p> <p>Now I am altering the same code for the <code>"continue"</code> statement. The <code>continue</code> statement when it is interpreted it will skip the current iteration i.e whatever code that comes after continue statement and pass the control back to <code>for loop</code> to run the next iteration.</p> <pre class="wp-block-preformatted">for ((YEAR=2010; YEAR&lt;=2020; YEAR++))
do
 if [[ $(expr $YEAR % 4) -eq 0 ]]
 then
   echo "$YEAR =  leap year"
 else
   continue
   echo "$YEAR =  not a leap year"
 fi
done</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34262" title="Continue statement with for loop">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png.webp 783w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-768x352.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-780x359.png.webp 780w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-585x268.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20783%20359&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 783px) 100vw, 783px" />
<img width="783" height="359" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20783%20359&#039;%3E%3C/svg%3E" alt="Continue statement with for loop" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png 783w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-768x352.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-780x359.png 780w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-585x268.png 585w" data-lazy-sizes="(max-width: 783px) 100vw, 783px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png" />
</picture>
<noscript><picture class="wp-image-34262" title="Continue statement with for loop">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png.webp 783w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-768x352.png.webp 768w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-780x359.png.webp 780w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-585x268.png.webp 585w" sizes="(max-width: 783px) 100vw, 783px"/>
<img width="783" height="359" src="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png" alt="Continue statement with for loop" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop.png 783w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-768x352.png 768w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-780x359.png 780w, https://ostechnix.com/wp-content/uploads/2021/09/Continue-statement-with-for-loop-585x268.png 585w" sizes="(max-width: 783px) 100vw, 783px"/>
</picture>
</noscript></a><figcaption>Continue statement with for loop</figcaption></figure></div> <p>From the above image, you can see there is an echo statement that is skipped by the continue statement.</p> <h2 id="true-statement-usage" class="ftwp-heading">Example 7 - True statement usage</h2> <p>When you create loops or conditional statements, you cannot leave the block of code empty. Bash will throw a syntax error.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34263" title="Syntax error">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png.webp 575w, https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error-300x101.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20575%20193&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 575px) 100vw, 575px" />
<img width="575" height="193" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20575%20193&#039;%3E%3C/svg%3E" alt="Syntax error" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png 575w, https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error-300x101.png 300w" data-lazy-sizes="(max-width: 575px) 100vw, 575px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png" />
</picture>
<noscript><picture class="wp-image-34263" title="Syntax error">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png.webp 575w, https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error-300x101.png.webp 300w" sizes="(max-width: 575px) 100vw, 575px"/>
<img width="575" height="193" src="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png" alt="Syntax error" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error.png 575w, https://ostechnix.com/wp-content/uploads/2021/09/Syntax-error-300x101.png 300w" sizes="(max-width: 575px) 100vw, 575px"/>
</picture>
</noscript></a><figcaption>Syntax error</figcaption></figure></div> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34264" title="Empty conditional statements">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png.webp 754w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-585x269.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20754%20347&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 754px) 100vw, 754px" />
<img width="754" height="347" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20754%20347&#039;%3E%3C/svg%3E" alt="Empty conditional statements" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png 754w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-585x269.png 585w" data-lazy-sizes="(max-width: 754px) 100vw, 754px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png" />
</picture>
<noscript><picture class="wp-image-34264" title="Empty conditional statements">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png.webp 754w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-585x269.png.webp 585w" sizes="(max-width: 754px) 100vw, 754px"/>
<img width="754" height="347" src="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png" alt="Empty conditional statements" srcset="https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements.png 754w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/Empty-conditional-statements-585x269.png 585w" sizes="(max-width: 754px) 100vw, 754px"/>
</picture>
</noscript></a><figcaption>Empty conditional statements</figcaption></figure></div> <p>Take a look at both the above images. In the first image, I created a <code>for loop</code> but no commands between <code>do</code> and <code>done</code>. Similarly in the second image, I left the else clause empty. In both cases, bash is not accepting empty blocks and throws syntax errors.</p> <p>You can use bash builtin <code>“true"</code> keyword which will be always set the exit code to <strong>0</strong> (success). </p> <pre class="wp-block-preformatted">$ type true
true is a shell builtin</pre> <p>In this way, you are leaving the code block kind of empty without bash throwing any errors.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png" data-rel="penci-gallery-image-content"><picture class="wp-image-34265" title="True keyword">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png.webp 633w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-300x100.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-585x196.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20633%20212&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 633px) 100vw, 633px" />
<img width="633" height="212" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20633%20212&#039;%3E%3C/svg%3E" alt="True keyword" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png 633w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-300x100.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-585x196.png 585w" data-lazy-sizes="(max-width: 633px) 100vw, 633px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png" />
</picture>
<noscript><picture class="wp-image-34265" title="True keyword">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png.webp 633w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-300x100.png.webp 300w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-585x196.png.webp 585w" sizes="(max-width: 633px) 100vw, 633px"/>
<img width="633" height="212" src="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png" alt="True keyword" srcset="https://ostechnix.com/wp-content/uploads/2021/09/True-keyword.png 633w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-300x100.png 300w, https://ostechnix.com/wp-content/uploads/2021/09/True-keyword-585x196.png 585w" sizes="(max-width: 633px) 100vw, 633px"/>
</picture>
</noscript></a><figcaption>True keyword</figcaption></figure></div> <h2 id="conclusion" class="ftwp-heading">Conclusion</h2> <p>In this Bash for loop guide, we have started with the introduction to loops and syntax of <code>for loop</code> along with C style. We have also seen how to use for loops in different conditions along with loop control statements break and continue. In our next guide, we will look into <code>While</code> and <code>Until</code> loops with examples.</p> <div class="wp-block-group has-black-color has-text-color has-background" style="background-color:#fdf4cf"><div class="wp-block-group__inner-container"> <p><strong>Related read:</strong></p> <ul><li><strong><a href="https://ostechnix.com/bash-functions-shell-scripting/" target="_blank" rel="noreferrer noopener">Bash Scripting – Functions Explained With Examples</a></strong></li><li><strong><a href="https://ostechnix.com/bash-variables-shell-scripting/" target="_blank" rel="noreferrer noopener">Bash Scripting – Variables Explained With Examples</a></strong></li><li><strong><a href="https://ostechnix.com/bash-echo-command-in-linux/" target="_blank" rel="noreferrer noopener">Bash Echo Command Explained With Examples In Linux</a></strong></li><li><strong><a href="https://ostechnix.com/bash-heredoc-tutorial/" target="_blank" rel="noreferrer noopener">Bash Heredoc Tutorial For Beginners</a></strong></li><li><strong><a href="https://ostechnix.com/bash-redirection-explained-with-examples/" target="_blank" rel="noreferrer noopener">Bash Redirection Explained With Examples</a></strong></li><li><strong><a href="https://ostechnix.com/difference-between-defining-bash-variables-with-and-without-export/" target="_blank" rel="noreferrer noopener">Difference Between Defining Bash Variables With And Without export</a></strong></li></ul> </div></div> </div> <div class="penci-single-link-pages"> </div> <div class="post-tags"> <a href="https://ostechnix.com/tag/bash/" rel="tag">BASH</a><a href="https://ostechnix.com/tag/bash-loops/" rel="tag">Bash loops</a><a href="https://ostechnix.com/tag/bash-scripting/" rel="tag">Bash scripting</a><a href="https://ostechnix.com/tag/for-loop/" rel="tag">for loop</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/scripting/" rel="tag">Scripting</a><a href="https://ostechnix.com/tag/shell-scripting/" rel="tag">Shell scripting</a><a href="https://ostechnix.com/tag/shell-scripts/" rel="tag">shell scripts</a> </div> </div> </div> <div class="tags-share-box center-box tags-share-box-s1"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="34249" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/bash-for-loop-shell-scripting/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples%20-%20https://ostechnix.com/bash-for-loop-shell-scripting/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;title=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;title=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples %0A%0A https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fbash-for-loop-shell-scripting%2F&#038;text=Bash%20Scripting%20-%20For%20Loop%20Explained%20With%20Examples"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#a19ed2d4c3cbc4c2d59ce3c0d2c9849391f2c2d3c8d1d5c8cfc68493918c849391e7ced3849391edceced1849391e4d9d1cdc0c8cfc4c5849391f6c8d5c9849391e4d9c0ccd1cdc4d287829192999ae3eee5f89cc9d5d5d1d29b8e8eced2d5c4c2c9cfc8d98fc2cecc8ec3c0d2c98cc7ced38ccdceced18cd2c9c4cdcd8cd2c2d3c8d1d5c8cfc68e"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-author abio-style-1 bioimg-round"> <div class="author-img"> <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' data-lazy-src="https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100'/></noscript> </div> <div class="author-content"> <h5><a href="https://ostechnix.com/author/sk/" title="Author sk" rel="author">sk</a></h5> <p>I am Senthil Kumar, more commonly known as SK to my friends, from India. I love to read, write and explore topics on Linux, Unix and all other technology related stuff.</p> <div class="bio-social"> <a rel="noreferrer" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fas fa-globe"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://facebook.com/ostechnix"><i class="penci-faicon fab fa-facebook-f"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://twitter.com/ostechnix"><i class="penci-faicon fab fa-twitter"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fab fa-linkedin-in"></i></a> </div> </div> </div> <div class="post-pagination"> <div class="prev-post"> <div class="prev-post-inner"> <div class="prev-post-title"> <span>Previous post</span> </div> <a href="https://ostechnix.com/identify-operating-system-ttl-ping/"> <div class="pagi-text"> <h5 class="prev-title">How To Identify Operating System Using TTL Value And Ping Command</h5> </div> </a> </div> </div> </div> <div class="post-related"> <div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div> <div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/09/Bash-variables-explained-in-shell-scripting-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/bash-variables-shell-scripting/" title="Bash Scripting &#8211; Variables Explained With Examples"> </a> <h3><a href="https://ostechnix.com/bash-variables-shell-scripting/">Bash Scripting &#8211; Variables Explained With Examples</a></h3> <span class="date"><time class="entry-date published" datetime="2021-09-13T20:14:24+05:30">September 13, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/08/Bash-Heredoc-Tutorial-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/bash-heredoc-tutorial/" title="Bash Heredoc Tutorial For Beginners"> </a> <h3><a href="https://ostechnix.com/bash-heredoc-tutorial/">Bash Heredoc Tutorial For Beginners</a></h3> <span class="date"><time class="entry-date published" datetime="2021-08-30T16:54:17+05:30">August 30, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/08/Bash-Redirection-Explained-With-Examples-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/bash-redirection-explained-with-examples/" title="Bash Redirection Explained With Examples"> </a> <h3><a href="https://ostechnix.com/bash-redirection-explained-with-examples/">Bash Redirection Explained With Examples</a></h3> <span class="date"><time class="entry-date published" datetime="2021-08-27T16:04:54+05:30">August 27, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/09/Bash-functions-explained-in-shell-scripting-in-Linux-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/bash-functions-shell-scripting/" title="Bash Scripting &#8211; Functions Explained With Examples"> </a> <h3><a href="https://ostechnix.com/bash-functions-shell-scripting/">Bash Scripting &#8211; Functions Explained With Examples</a></h3> <span class="date"><time class="entry-date published" datetime="2021-09-16T17:54:38+05:30">September 16, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/09/Bash-Echo-Command-In-Linux-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/bash-echo-command-in-linux/" title="Bash Echo Command Explained With Examples In Linux"> </a> <h3><a href="https://ostechnix.com/bash-echo-command-in-linux/">Bash Echo Command Explained With Examples In Linux</a></h3> <span class="date"><time class="entry-date published" datetime="2021-09-01T14:14:09+05:30">September 1, 2021</time></span> </div> </div></div> <div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"> <div id="respond" class="comment-respond"> <h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/bash-for-loop-shell-scripting/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" placeholder="Name*" size="30" aria-required='true' /></p> <p class="comment-form-email"><input id="email" name="email" type="text" placeholder="Email*" size="30" aria-required='true' /></p> <p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p> <div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='34249' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="bfad80c8aa" /></p><input type="hidden" id="ak_js" name="ak_js" value="8" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div> <p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> </article> </div> </div> <div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right penci-sticky-sidebar"> <div class="theiaStickySidebar"> <aside id="penci_social_widget-1" class="widget penci_social_widget"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Networks</span></h3> <div class="widget-social pc_aligncenter show-text remove-circle penci-social-textcolored"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 14px"></i><span style="font-size: 14px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 14px"></i><span style="font-size: 14px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 14px"></i><span style="font-size: 14px">Linkedin</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 14px"></i><span style="font-size: 14px">Reddit</span></a> </div> </aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"> <p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p> <p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..." /><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p> <input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6186167963" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside> </div> </div> </div> </div> </div> <div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div> <div class="clear-footer"></div> <div id="widget-area"> <div class="container"> <div class="footer-widget-wrapper footer-widget-style-10"> <aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4> <div class="textwidget"><p><a href="https://ostechnix.com/"><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 340px) 100vw, 340px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" alt="Ostechnix Footer Logo" width="340" height="68" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-lazy-sizes="(max-width: 340px) 100vw, 340px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" />
</picture>
<noscript><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" sizes="(max-width: 340px) 100vw, 340px"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px"/>
</picture>
</noscript></a></p> <p>&nbsp;</p> <p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p> </div> </aside><aside id="penci_social_widget-2" class="widget penci_social_widget"> <div class="widget-social pc_aligncenter remove-circle"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a> <a href="/cdn-cgi/l/email-protection#1b72757d745b74686f7e787375726335787476" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope" style="font-size: 18px"></i><span style="font-size: 13px">Email</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 18px"></i><span style="font-size: 13px">Reddit</span></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">Rss</span></a> </div> </aside> </div> <div class="footer-widget-wrapper footer-widget-style-10 last"> <aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-1955" class="side-newsfeed display-order-numbers"> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">1</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners"> Youtube-dl Tutorial With Examples For Beginners </a> </h4> <div class="grid-post-box-meta penci-side-item-meta"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" title="How To Fix Busybox Initramfs Error On Ubuntu"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu"> How To Fix Busybox Initramfs Error On Ubuntu </a> </h4> <div class="grid-post-box-meta penci-side-item-meta"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/01/Allow-Or-Deny-SSH-Access-To-A-Particular-User-Or-Group-In-Linux-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/allow-deny-ssh-access-particular-user-group-linux/" title="How To Allow Or Deny SSH Access To A Particular User Or Group In Linux"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/allow-deny-ssh-access-particular-user-group-linux/" rel="bookmark" title="How To Allow Or Deny SSH Access To A Particular User Or Group In Linux"> How To Allow Or Deny SSH Access To A Particular User Or Group In Linux </a> </h4> <div class="grid-post-box-meta penci-side-item-meta"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2021-01-13T18:30:02+05:30">January 13, 2021</time></span> </div> </div> </div> </li> </ul> </aside> </div> </div> </div> <footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter"> <div class="container"> <div class="footer-logo-copyright footer-not-logo footer-not-gotop"> <div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li> <li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> <li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li> <li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li> <li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li> </ul> </div> <div id="footer-copyright"> <p>OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p> </div> </div> <div class="penci-go-to-top-floating"><i class="penci-faicon fas fa-angle-up"></i></div> </div> </footer> </div> <a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fas fa-times"></i></a> <nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div id="sidebar-nav-logo"> <a href="https://ostechnix.com/"><picture>
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" />
<img width="250" height="52" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" alt="OSTechNix" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" />
</picture>
<noscript><picture>
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp"/>
<img width="250" height="52" src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" alt="OSTechNix"/>
</picture>
</noscript></a> </div> <div class="header-social sidebar-nav-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#3b52555d547b54484f5e585355524315585456" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> <div class="penci-hbg-search-box penci-vernav-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <ul id="menu-header-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul> </nav> <div class="penci-menu-hbg-overlay"></div> <div class="penci-menu-hbg penci-vernav-hide penci-menu-hbg-left"> <div class="penci-menu-hbg-inner"> <a id="penci-close-hbg"><i class="penci-faicon fas fa-times"></i></a> <div class="penci-hbg-header"> <div class="penci-hbg-logo site-branding"> <a href="https://ostechnix.com/"><picture class="penci-lazy">
<source type="image/webp" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" />
<img width="6" height="4" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" />
</picture>
</a> </div> </div> <div class="penci-hbg-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <div class="penci-hbg-content penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right"> <ul id="menu-top-menu-1" class="menu menu-hgb-main"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul> </div> <div class="penci-hbg-footer"> <div class="penci_menu_hbg_ftext">OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</div> <div class="header-social sidebar-nav-social penci-hbg-social-style-4 penci-social-colored"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#21484f474e614e52554442494f48590f424e4c" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> </div> </div> </div> <div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"> <div class="penci-gprd-law"> <p> This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a> </p> </div> </div> <!--[if lte IE 9]> <script> 'use strict'; (function($) { $(document).ready(function() { $('#ftwp-container').addClass('ftwp-ie9'); }); })(jQuery); </script> <![endif]--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script> <script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/ullavidu\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/ostechnix.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/themes/soledad/js/libs-script.min.js?ver=7.9.6' id='penci-libs-js-js' defer></script> <script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"24ef19fab3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/main.js?ver=1630735633' id='main-scripts-js' defer></script> <script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"24ef19fab3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/post-like.js?ver=1630735633' id='penci_ajax_like_post-js' defer></script> <script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"24ef19fab3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/more-post.js?ver=1630735633' id='penci_ajax_more_posts-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/comment-reply.min.js?ver=ec25dd5b9fcf0d6992c474477cef5bb1' id='comment-reply-js' defer></script> <script type='text/javascript' id='fixedtoc-js-js-extra'>
/* <![CDATA[ */
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js?ver=3.1.22' id='fixedtoc-js-js' defer></script> <script type='text/javascript' src='https://ostechnix.com/wp-includes/js/wp-embed.min.js?ver=ec25dd5b9fcf0d6992c474477cef5bb1' id='wp-embed-js' defer></script> <script type="rocketlazyloadscript" data-minify="1" defer data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/akismet/_inc/form.js?ver=1630735636' id='akismet-form-js'></script> <script src='https://stats.wp.com/e-202138.js' defer></script> <script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.1',blog:'84551477',post:'34249',tz:'5.5',srv:'ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '34249' ]);
</script> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">
	function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(34249, 'https://ostechnix.com');
</script> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">!function(a){"use strict";var b=function(b,c,d){function j(a){if(e.body)return a();setTimeout(function(){j(a)})}function l(){f.addEventListener&&f.removeEventListener("load",l),f.media=d||"all"}var g,e=a.document,f=e.createElement("link");if(c)g=c;else{var h=(e.body||e.getElementsByTagName("head")[0]).childNodes;g=h[h.length-1]}var i=e.styleSheets;f.rel="stylesheet",f.href=b,f.media="only x",j(function(){g.parentNode.insertBefore(f,c?g:g.nextSibling)});var k=function(a){for(var b=f.href,c=i.length;c--;)if(i[c].href===b)return a();setTimeout(function(){k(a)})};return f.addEventListener&&f.addEventListener("load",l),f.onloadcssdefined=k,k(l),f};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this); !function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(a){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ostechnix.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script> <script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-75259810-1');
</script> <script type="rocketlazyloadscript">"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair%20Display%20SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7COpen%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"/><link rel="stylesheet" data-no-minify="" id="wpr-usedcss-css" href="https://ostechnix.com/wp-content/cache/used-css/1/bash-for-loop-shell-scripting/used.min.css?ver=1632228739"></noscript><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6924a49c5c805979","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2021.8.1","si":10}'></script>
</body> </html>
