<!DOCTYPE html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><link rel="dns-prefetch" href="https://fonts.gstatic.com" /><meta charset="UTF-8"><style id="litespeed-ccss">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://ostechnix.com/wp-content/litespeed/css/6eeacd800d0784ef7d078968d0ef41d7.css?ver=6ef5a" /><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/css_async.min.js"></script> <meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"/><link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon"/><link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"><link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/"/><link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/"/><link rel="pingback" href="https://ostechnix.com/xmlrpc.php"/> <!--[if lt IE 9]> [script_0] <![endif]--><link rel='preconnect' href='https://fonts.googleapis.com'/><link rel='preconnect' href='https://fonts.gstatic.com'/><meta http-equiv='x-dns-prefetch-control' content='on'><link rel='dns-prefetch' href='//fonts.googleapis.com'/><link rel='dns-prefetch' href='//fonts.gstatic.com'/><link rel='dns-prefetch' href='//s.gravatar.com'/><link rel='dns-prefetch' href='//www.google-analytics.com'/><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1'/><title>Enable Nested Virtualization In Proxmox VE - OSTechNix</title><meta name="description" content="This guide explains what is nested virtualization and how to enable nested virtualization in Proxmox VE."/><link rel="canonical" href="https://ostechnix.com/enable-nested-virtualization-in-proxmox/"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="Enable Nested Virtualization In Proxmox VE - OSTechNix"/><meta property="og:description" content="This guide explains what is nested virtualization and how to enable nested virtualization in Proxmox VE."/><meta property="og:url" content="https://ostechnix.com/enable-nested-virtualization-in-proxmox/"/><meta property="og:site_name" content="OSTechNix"/><meta property="article:publisher" content="https://www.facebook.com/ostechnix/"/><meta property="article:author" content="ostechnix"/><meta property="article:published_time" content="2022-07-13T12:40:40+00:00"/><meta property="article:modified_time" content="2022-07-13T13:45:47+00:00"/><meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2022/07/Enable-Nested-Virtualization-In-Proxmox-VE.png"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta property="og:image:type" content="image/png"/><meta name="author" content="sk"/><meta name="twitter:card" content="summary"/><meta name="twitter:creator" content="@ostechnix"/><meta name="twitter:site" content="@ostechnix"/><meta name="twitter:label1" content="Written by"/><meta name="twitter:data1" content="sk"/><meta name="twitter:label2" content="Est. reading time"/><meta name="twitter:data2" content="5 minutes"/> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ostechnix.com/#organization","name":"OSTechNix","url":"https://ostechnix.com/","sameAs":["https://www.instagram.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://www.facebook.com/ostechnix/","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ostechnix.com/#/schema/logo/image/","url":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","width":350,"height":73,"caption":"OSTechNix"},"image":{"@id":"https://ostechnix.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://ostechnix.com/#website","url":"https://ostechnix.com/","name":"OSTechNix","description":"Open Source | Technology | Linux And Unix","publisher":{"@id":"https://ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ostechnix.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/#primaryimage","url":"https://ostechnix.com/wp-content/uploads/2022/07/Enable-Nested-Virtualization-In-Proxmox-VE.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2022/07/Enable-Nested-Virtualization-In-Proxmox-VE.png","width":1280,"height":720,"caption":"Enable Nested Virtualization In Proxmox VE"},{"@type":"WebPage","@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/","url":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/","name":"Enable Nested Virtualization In Proxmox VE - OSTechNix","isPartOf":{"@id":"https://ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/#primaryimage"},"datePublished":"2022-07-13T12:40:40+00:00","dateModified":"2022-07-13T13:45:47+00:00","description":"This guide explains what is nested virtualization and how to enable nested virtualization in Proxmox VE.","breadcrumb":{"@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ostechnix.com/enable-nested-virtualization-in-proxmox/"]}]},{"@type":"BreadcrumbList","@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://ostechnix.com/"},{"@type":"ListItem","position":2,"name":"How To Enable Nested Virtualization In Proxmox VE"}]},{"@type":"Article","@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/#article","isPartOf":{"@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/"},"author":{"name":"sk","@id":"https://ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a"},"headline":"How To Enable Nested Virtualization In Proxmox VE","datePublished":"2022-07-13T12:40:40+00:00","dateModified":"2022-07-13T13:45:47+00:00","mainEntityOfPage":{"@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/"},"wordCount":789,"commentCount":0,"publisher":{"@id":"https://ostechnix.com/#organization"},"image":{"@id":"https://ostechnix.com/enable-nested-virtualization-in-proxmox/#primaryimage"},"thumbnailUrl":"https://ostechnix.com/wp-content/uploads/2022/07/Enable-Nested-Virtualization-In-Proxmox-VE.png","keywords":["Linux","Linux administration","Nested virtualization","Open source","Proxmox","Proxmox VE","Proxmox Virtualization Environment","Sysadmin"],"articleSection":["KVM","Linux","Linux Administration","Proxmox","QEMU","Virtualization"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ostechnix.com/enable-nested-virtualization-in-proxmox/#respond"]}]},{"@type":"Person","@id":"https://ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a","name":"sk","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ostechnix.com/#/schema/person/image/","url":"https://ostechnix.com/wp-content/litespeed/avatar/55a4204bd36d71fef2e7f5d7be1b4926.jpg?ver=1657354885","contentUrl":"https://ostechnix.com/wp-content/litespeed/avatar/55a4204bd36d71fef2e7f5d7be1b4926.jpg?ver=1657354885","caption":"sk"},"description":"Senthilkumar Palani (aka SK) is the Founder and Editor in chief of OSTechNix. He is a Linux/Unix enthusiast and FOSS supporter. He lives in Tamilnadu, India.","sameAs":["https://ostechnix.com/","ostechnix","https://www.linkedin.com/in/ostechnix/","https://twitter.com/@ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"],"url":"https://ostechnix.com/author/sk/"}]}</script> <link rel='dns-prefetch' href='//www.youtube.com'/><link rel='dns-prefetch' href='//fonts.googleapis.com'/><link rel='dns-prefetch' href='//s.w.org'/><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/"/><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/"/><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To Enable Nested Virtualization In Proxmox VE Comments Feed" href="https://ostechnix.com/enable-nested-virtualization-in-proxmox/feed/"/><style data-penci-cache='cached' id='soledad_pagespeed-wp-block-library-css'>@charset "UTF-8";.wp-block-archives-dropdown label{display:block;}:where(.wp-block-columns.has-background){padding:1.25em 2.375em;}.wp-block-embed{margin:0 0 1em;overflow-wrap:break-word;}.wp-block-embed figcaption{margin-top:.5em;margin-bottom:1em;}.wp-block-embed__wrapper{position:relative;}.wp-block-group{box-sizing:border-box;}h1.has-background,h2.has-background,h3.has-background,h4.has-background,h5.has-background,h6.has-background{padding:1.25em 2.375em;}.wp-block-image{margin:0 0 1em;}.wp-block-image img{height:auto;max-width:100%;vertical-align:bottom;}.wp-block-image:not(.is-style-rounded)>a,.wp-block-image:not(.is-style-rounded) img{border-radius:inherit;}.wp-block-image.aligncenter{text-align:center;}.wp-block-image.aligncenter,.wp-block-image .aligncenter,.wp-block-image.alignleft,.wp-block-image .alignleft,.wp-block-image.alignright,.wp-block-image .alignright{display:table;}.wp-block-image.aligncenter>figcaption,.wp-block-image .aligncenter>figcaption,.wp-block-image.alignleft>figcaption,.wp-block-image .alignleft>figcaption,.wp-block-image.alignright>figcaption,.wp-block-image .alignright>figcaption{display:table-caption;caption-side:bottom;}.wp-block-image .aligncenter{margin-left:auto;margin-right:auto;}.wp-block-image figcaption{margin-top:.5em;margin-bottom:1em;}.wp-block-image figure{margin:0;}ol,ul{box-sizing:border-box;}ol.has-background,ul.has-background{padding:1.25em 2.375em;}p.has-background{padding:1.25em 2.375em;}:where(p.has-text-color:not(.has-link-color)) a{color:inherit;}.wp-block-preformatted{white-space:pre-wrap;}.wp-block-preformatted.has-background{padding:1.25em 2.375em;}:root{--wp--preset--font-size--normal:16px;--wp--preset--font-size--huge:42px;}.aligncenter{clear:both;}html :where(.has-border-color),html :where([style*=border-width]){border-style:solid;}html :where(img[class*=wp-image-]){height:auto;max-width:100%;}</style><link rel="stylesheet" id="wp-block-library-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css"/><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><style id='wp-block-library-theme-inline-css' type='text/css'>.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}</style><style data-penci-cache='cached' id='soledad_pagespeed-mediaelement-css'>@-webkit-keyframes a{to{-webkit-transform:rotate(1 turn);transform:rotate(1 turn);}}@keyframes a{to{-webkit-transform:rotate(1 turn);transform:rotate(1 turn);}}@-webkit-keyframes b{0%{background-position:0 0;}to{background-position:30px 0;}}@keyframes b{0%{background-position:0 0;}to{background-position:30px 0;}}</style><link rel="stylesheet" id="mediaelement-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css"/><link rel="stylesheet" id="wp-mediaelement-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/cache/soledad_pagespeed/css/f92d8a0290b801f17c9da094d3948718.css"/><style id='global-styles-inline-css' type='text/css'>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</style><link rel="stylesheet" id="penci-soledad-parent-style-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/themes/soledad/style.css"/><link rel="stylesheet" id="penci-fonts-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/cache/soledad_pagespeed/css/b0da753a0b680e2d36d874b5e7170120.css"/><style data-penci-cache='cached' id='soledad_pagespeed-penci-main-style-css'>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</style><link rel="stylesheet" id="penci-main-style-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/themes/soledad/main.css"/><link rel="stylesheet" id="penci_style-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/themes/soledad-child/style.css"/><link rel="stylesheet" id="penci_social_counter-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/cache/soledad_pagespeed/css/cda7755b37e0300a5e19ab20ab2a9eed.css"/><style data-penci-cache='cached' id='soledad_pagespeed-fixedtoc-style-css'>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</style><link rel="stylesheet" id="fixedtoc-style-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css"/><style id='fixedtoc-style-inline-css' type='text/css'>.ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); }</style><style data-penci-cache='cached' id='soledad_pagespeed-penci-soledad-customizer-css'>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</style><link rel="stylesheet" id="penci-soledad-customizer-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/uploads/pencidesign/customizer-style.min.css?version=1656770300"/><style data-penci-cache='cached' id='soledad_pagespeed-jetpack_css-css'>@charset "UTF-8";:root{--swiper-theme-color:#007aff;}:root{--swiper-navigation-size:44px;}:root{--jp-carousel-primary-color:#fff;--jp-carousel-primary-subtle-color:#999;--jp-carousel-bg-color:#000;--jp-carousel-bg-faded-color:#222;--jp-carousel-border-color:#3a3a3a;}[data-carousel-extra]:not(.jp-carousel-wrap) img,[data-carousel-extra]:not(.jp-carousel-wrap) img+figcaption{cursor:pointer;}@keyframes load8{0%{transform:rotate(0deg);}to{transform:rotate(1 turn);}}@keyframes spinner-inner{0%{opacity:1;}to{opacity:0;}}div[class^=gr_custom_container]{background-color:#fff;border:1px solid gray;border-radius:10px;color:#000;padding:10px 5px;}div[class^=gr_custom_container] a{color:#000;}h2[class^=gr_custom_header]{display:none;}div[class^=gr_custom_each_container]{border-bottom:1px solid #a7aaad;clear:both;margin-bottom:10px;overflow:auto;padding-bottom:4px;width:100%;}div[class^=gr_custom_book_container]{float:right;height:60px;margin-left:4px;overflow:hidden;width:39px;}div[class^=gr_custom_author]{font-size:10px;}div[class^=gr_custom_tags]{color:gray;font-size:10px;}div[class^=gr_custom_rating]{display:none;}@keyframes fadeIn{0%{opacity:0;visibility:hidden;}to{opacity:1;visibility:visible;}}</style><link rel="stylesheet" id="jetpack_css-css" media="all" data-soledad_pagespeed-delay data-href="https://ostechnix.com/wp-content/plugins/jetpack/css/jetpack.css"/> <script type="PenciLazyScript" id="jquery-core-js" src="https://ostechnix.com/wp-includes/js/jquery/jquery.min.js" data-pencilazy-type="text/javascript"></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/"/><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/41343"/><link rel='shortlink' href='https://ostechnix.com/?p=41343'/><link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F"/><link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&format=xml"/><style>img#wpstats{display:none}</style> <script type="PenciLazyScript">var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To Enable Nested Virtualization In Proxmox VE",
    "description": "This brief guide explains what is nested virtualization and how to enable nested virtualization in Proxmox VE.",
    "datePublished": "2022-07-13",
    "datemodified": "2022-07-13",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/enable-nested-virtualization-in-proxmox\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2022\/07\/Enable-Nested-Virtualization-In-Proxmox-VE.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk",
        "url": "https:\/\/ostechnix.com\/author\/sk\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/virtualization\/",
                "name": "Virtualization"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/virtualization\/proxmox\/",
                "name": "Proxmox"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/ostechnix.com\/enable-nested-virtualization-in-proxmox\/",
                "name": "How To Enable Nested Virtualization In Proxmox VE"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32"/><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192"/><link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"/><meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"/><link rel="prefetch" href="https://ostechnix.com/wp-content/cache/soledad_pagespeed/css/f92d8a0290b801f17c9da094d3948718.css" as="style" media="all" /><link rel="prefetch" href="https://ostechnix.com/wp-content/themes/soledad/style.css" as="style" media="all" /><link rel="prefetch" href="https://ostechnix.com/wp-content/themes/soledad-child/style.css" as="style" media="all" /><link rel="prefetch" href="https://ostechnix.com/wp-content/cache/soledad_pagespeed/css/cda7755b37e0300a5e19ab20ab2a9eed.css" as="style" media="all" /></head><body data-rsssl=1 class="post-template-default single single-post postid-41343 single-format-standard soledad-ver-8-2-1 pclight-mode pcmn-drdw-style-slide_down pchds-default has-ftoc"> <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627"/><feFuncG type="table" tableValues="0 0.49803921568627"/><feFuncB type="table" tableValues="0 0.49803921568627"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1"/><feFuncG type="table" tableValues="0 1"/><feFuncB type="table" tableValues="0 1"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765"/><feFuncG type="table" tableValues="0 1"/><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1"/><feFuncG type="table" tableValues="0 0.27843137254902"/><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0"/><feFuncG type="table" tableValues="0 0.64705882352941"/><feFuncB type="table" tableValues="0 1"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1"/><feFuncG type="table" tableValues="0 0.94901960784314"/><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745"/><feFuncG type="table" tableValues="0 1"/><feFuncB type="table" tableValues="0.44705882352941 0.4"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "/><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1"/><feFuncG type="table" tableValues="0 0.66274509803922"/><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725"/><feFuncA type="table" tableValues="1 1"/></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"/></filter></defs></svg><div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"><div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"><div class="container"><div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li><li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li><li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></div><div class="pctopbar-item penci-topbar-social"><div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a> <a href="mailto:info@ostechnix.com" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss"></i></a></div></div></div></div></div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="inner-header penci-header-second"><div class="container align-left-logo has-banner"><div id="logo"> <a href="https://ostechnix.com/"><img class="penci-mainlogo" src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix"></a></div><div class="header-banner header-style-3"> <script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" id="0cd73468e920c9cd6270f0fc351b69a6" type="PenciLazyScript"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="9496719407" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="PenciLazyScript">(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><div class="sticky-wrapper"><nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="container"><div class="button-menu-mobile header-3"><svg width=18px height=18px viewBox="0 0 512 384" version=1.1 xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink><g stroke=none stroke-width=1 fill-rule=evenodd><g transform="translate(0.000000, 0.250080)"><rect x=0 y=0 width=512 height=62></rect><rect x=0 y=161 width=512 height=62></rect><rect x=0 y=321 width=512 height=62></rect></g></g></svg></div><ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li><li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li><li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li><li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li><li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li><li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li><li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li><li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li></ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes"> <a class="search-click"> <i class="penciicon-magnifiying-glass"></i> </a><div class="show-search"><form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/"><div class="pc-searchform-inner"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s"/> <i class="penciicon-magnifiying-glass"></i> <input type="submit" class="searchsubmit" value="Search"/></div></form> <a class="search-click close-search"><i class="penciicon-close-button"></i></a></div></div></div></nav></div></header></div><div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt; &lt;!-- New Horizontal Responsive Adv --&gt; &lt;ins class=&quot;adsbygoogle&quot; style=&quot;display:block&quot; data-ad-client=&quot;ca-pub-6701402139964678&quot; data-ad-slot=&quot;9496719407&quot; data-ad-format=&quot;auto&quot; data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt; &lt;script&gt; (adsbygoogle = window.adsbygoogle || []).push({}); &lt;/script&gt;&lt;/div&gt;"><div class="penci-single-block" data-prev-url="https://ostechnix.com/quickgui-a-gui-for-quickemu-to-run-virtual-machines/" data-current-url="https://ostechnix.com/enable-nested-virtualization-in-proxmox/" data-post-title="How To Enable Nested Virtualization In Proxmox VE" data-edit-post="" data-postid="41343"><div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fa fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/virtualization/proxmox/">Proxmox</a></span><i class="penci-faicon fa fa-angle-right"></i> <span>How To Enable Nested Virtualization In Proxmox VE</span></div><div class="container container-single penci_sidebar penci-enable-lightbox"><div id="main" class="penci-main-sticky-sidebar"><div class="theiaStickySidebar"><article id="post-41343" class="post type-post status-publish"><div class="header-standard header-classic single-header"><div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-5624" href="https://ostechnix.com/category/virtualization/proxmox/" rel="category tag">Proxmox</a><a class="penci-cat-name penci-cat-593" href="https://ostechnix.com/category/virtualization/kvm/" rel="category tag">KVM</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/" rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-4752" href="https://ostechnix.com/category/virtualization/qemu/" rel="category tag">QEMU</a><a class="penci-cat-name penci-cat-62" href="https://ostechnix.com/category/virtualization/" rel="category tag">Virtualization</a></span></div><h1 class="post-title single-post-title entry-title">How To Enable Nested Virtualization In Proxmox VE</h1><div class="penci-hide-tagupdated"> <span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/sk/">sk</a></span> <time class="entry-date published" datetime="2022-07-13T18:10:40+05:30">July 13, 2022</time></div><div class="post-box-meta-single"> <span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/sk/">sk</a></span></span> <span><time class="entry-date published" datetime="2022-07-13T18:10:40+05:30">July 13, 2022</time></span> <span><i class="penci-post-countview-number">22</i> views</span></div></div><div class="sstyle-style-1 tags-share-box tags-share-box-top single-post-share tags-share-box-s1 center-box social-align-default post-share"> <span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i>0 comment</span> <span class="post-share-item post-share-plike"><span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="41343" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a></span><a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/enable-nested-virtualization-in-proxmox/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE%20-%20https://ostechnix.com/enable-nested-virtualization-in-proxmox/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&title=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&title=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE %0A%0A https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&text=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE"><i class="penci-faicon fa fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="mailto:?subject=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE&BODY=https://ostechnix.com/enable-nested-virtualization-in-proxmox/"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#"><i class="penci-faicon penciicon-add"></i></a></div><div class="post-entry blockquote-style-2"><div class="inner-post-entry entry-content" id="penci-post-entry-inner"><div id="ftwp-postcontent"><p>Proxmox is my preferred hypervisor to deploy various containers and VMs. Sometimes, I want to create a VM inside another VM. Meaning - I just want to host a guest hypervisor(i.e VM) in my physical Proxmox hypervisor. Have you ever wondered how to setup a guest hypervisor in a host hypervisor? In this guide, I will show you how to <strong>enable nested virtualization in Proxmox</strong> VE and then <strong>enable VT-X in the guest</strong> hypervisor.</p><div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item"><a class="ftwp-anchor" href="#what-is-nested-virtualization"><span class="ftwp-text">What Is Nested Virtualization?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#enable-nested-virtualization-proxmox"><span class="ftwp-text">Enable Nested Virtualization In Proxmox</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#check-if-vt-x-is-enabled-in-virtual-machines"><span class="ftwp-text">Check If VT-X Is Enabled In Virtual Machines</span></a></li><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#enable-vt-x-in-virtual-machines"><span class="ftwp-text">Enable VT-X In Virtual Machines</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#enable-vt-x-for-proxmox-guest-machines-from-command-line"><span class="ftwp-text">Enable VT-X For Proxmox Guest Machines From Command Line</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#enable-vt-x-for-guest-machines-from-proxmox-web-ui"><span class="ftwp-text">Enable VT-X For Guest Machines From Proxmox Web UI</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="what-is-nested-virtualization" class="ftwp-heading">What Is Nested Virtualization?</h2><p><strong>Nested virtualization</strong> is a feature that allows you to run a virtual machine inside another virtual machine while still using the hardware acceleration from the host system.</p><div><div class="penci-custom-html-inside-content"><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" id="0cd73468e920c9cd6270f0fc351b69a6" type="PenciLazyScript"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="PenciLazyScript">(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><p>To put this in other words, nested virtualization is a mechanism of running a hypervisor inside of a virtual machine (VM), which itself runs on a hypervisor.</p><h2 id="enable-nested-virtualization-proxmox" class="ftwp-heading">Enable Nested Virtualization In Proxmox</h2><p>The following steps must be performed in the physical Proxmox host.</p><p>First, let us make sure the nested virtualization feature is enabled in the physical Proxmox hypervisor.</p><p>If your Proxmox hypervisor is <strong>Intel CPU</strong>, run the following command to check if nested virtualization is enabled in it.</p><pre class="wp-block-preformatted"># cat /sys/module/kvm_intel/parameters/nested
<strong>N</strong></pre><p>If it is AMD CPU, run:</p><pre class="wp-block-preformatted"># cat /sys/module/kvm_amd/parameters/nested
<strong>N</strong></pre><p>You may get <strong>"N"</strong> or <strong>"0"</strong> and <strong>"Y"</strong> or <strong>"1"</strong> as output. If the output is <strong>"N"</strong> or <strong>"0"</strong>, it means that the nested virtualization feature is <strong>not enabled</strong>. If the output is <strong>"Y"</strong> or <strong>"1"</strong>, the nested feature is <strong>enabled</strong>.</p><p>In my Proxmox host, the nested virtualization is not yet enabled. So I am going to enable it using the following command as <code><strong>root</strong></code> user:</p><pre class="wp-block-preformatted"># echo "options kvm-intel nested=Y" &gt; /etc/modprobe.d/kvm-intel.conf</pre><p>On AMD Proxmox host, run this command:</p><pre class="wp-block-preformatted"># echo "options kvm-amd nested=1" &gt; /etc/modprobe.d/kvm-amd.conf </pre><p class="has-black-color has-luminous-vivid-amber-background-color has-text-color has-background"><strong>Please note</strong> - We append <strong>Y</strong> for <strong>INTEL CPUs</strong> and <strong>1</strong> for <strong>AMD CPUs</strong> to enable nested feature.</p><p>Now, reboot the system or reload the kernel modules to take effect the changes:</p><pre class="wp-block-preformatted"># modprobe -r kvm_intel</pre><pre class="wp-block-preformatted"># modprobe kvm_intel</pre><p>On AMD Proxmox host, run:</p><pre class="wp-block-preformatted"># modprobe -r kvm_amd</pre><pre class="wp-block-preformatted"># modprobe kvm_amd</pre><p>Now check again if nested virtualization is enabled in the physical Proxmox host:</p><pre class="wp-block-preformatted"># cat /sys/module/kvm_intel/parameters/nested
<strong>Y</strong></pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox.png" data-rel="penci-gallery-image-content"><img width="1074" height="678" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201074%20678'%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox.png" alt="Check If Nested Virtualization Is Enabled In Proxmox" class=" penci-lazy wp-image-41344" title="Check If Nested Virtualization Is Enabled In Proxmox" data-srcset="https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox.png 1074w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox-300x189.png 300w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox-1024x646.png 1024w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox-768x485.png 768w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-Nested-Virtualization-Is-Enabled-In-Proxmox-585x369.png 585w" sizes="(max-width: 1074px) 100vw, 1074px"></a><figcaption>Check If Nested Virtualization Is Enabled In Proxmox</figcaption></figure></div><p>If it is AMD CPU, run:</p><pre class="wp-block-preformatted"># cat /sys/module/kvm_amd/parameters/nested
<strong>Y</strong></pre><p>As you see in the above output, nested virtualization feature is enabled in the Proxmox host.</p><h2 id="check-if-vt-x-is-enabled-in-virtual-machines" class="ftwp-heading">Check If VT-X Is Enabled In Virtual Machines</h2><p>As you may already know, in order to host guest machines in any system, the CPU should support virtualization technology(VT-X) and the VT-X should be enabled.</p><p>There are several ways to check if a CPU supports VT-X. The following tutorial lists a few methods to find if VT-X feature is enabled in a system.</p><blockquote class="wp-block-quote"><p><strong><a href="https://ostechnix.com/how-to-find-if-a-cpu-supports-virtualization-technology-vt/" target="_blank" rel="noreferrer noopener">How To Find If A CPU Supports Virtualization Technology (VT)</a></strong></p></blockquote><p>For the purpose of this guide, I will be using Debian 11 desktop. Let us check if VT-X is enabled in one of our virtual machine.</p><pre class="wp-block-preformatted"># egrep --color -i "svm|vmx" /proc/cpuinfo</pre><p>If you don't see any output, it means that the VT-X is not yet enabled. Let us enable it now.</p><h2 id="enable-vt-x-in-virtual-machines" class="ftwp-heading">Enable VT-X In Virtual Machines</h2><p>After enabling the nested virtualization feature in the Proxmox host, you must enable Virtualization technology(VT-X) in the virtual(guest) machines to make it as a hypervisor.</p><p>You can enable VT-x from CLI or Proxmox web UI.</p><h3 id="enable-vt-x-for-proxmox-guest-machines-from-command-line" class="ftwp-heading">Enable VT-X For Proxmox Guest Machines From Command Line</h3><p><strong>Turn off the virtual machine</strong> in which you want to enable the nested virtualization feature.</p><p>To enable virtualization technology in a virtual amchine, simply set the CPU type of the VM to <strong>"host"</strong> using command:</p><pre class="wp-block-preformatted"># qm set &lt;VMID&gt; --cpu host</pre><p><strong>Example:</strong></p><pre class="wp-block-preformatted"># qm set 105 --cpu host</pre><p>Replace "105" with your virtual machine's ID. Now the Virtual machine has become hypervisor, so you can now create containers and virtual machines inside this VM.</p><h3 id="enable-vt-x-for-guest-machines-from-proxmox-web-ui" class="ftwp-heading">Enable VT-X For Guest Machines From Proxmox Web UI</h3><p>Make sure the VM is turned off.</p><p>Open your Proxmox web UI by visiting to <strong>https://proxmox-ip:8006</strong>. Enter the user name and password to login to Proxmox web dashboard.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI.png" data-rel="penci-gallery-image-content"><img width="1920" height="842" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201920%20842'%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI.png" alt="Login To Proxmox Web UI" class=" penci-lazy wp-image-41346" title="Login To Proxmox Web UI" data-srcset="https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI.png 1920w, https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI-300x132.png 300w, https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI-1024x449.png 1024w, https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI-768x337.png 768w, https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI-1536x674.png 1536w, https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI-1170x513.png 1170w, https://ostechnix.com/wp-content/uploads/2022/07/Login-To-Proxmox-Web-UI-585x257.png 585w" sizes="(max-width: 1920px) 100vw, 1920px"></a><figcaption>Login To Proxmox Web UI</figcaption></figure></div><p>Go to <strong>Virtual machine(i.e. Debian 11) -&gt; Hardware</strong>. Select <strong>"Processors"</strong> and click <strong>Edit</strong> or Double click Processors option.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings.png" data-rel="penci-gallery-image-content"><img width="1920" height="1040" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201920%201040'%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings.png" alt="Edit Processor Settings" class=" penci-lazy wp-image-41347" title="Edit Processor Settings" data-srcset="https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings.png 1920w, https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings-300x163.png 300w, https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings-1024x555.png 1024w, https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings-768x416.png 768w, https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings-1536x832.png 1536w, https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings-1170x634.png 1170w, https://ostechnix.com/wp-content/uploads/2022/07/Edit-Processor-Settings-585x317.png 585w" sizes="(max-width: 1920px) 100vw, 1920px"></a><figcaption>Edit Processor Settings</figcaption></figure></div><p>Choose CPU type as "host".</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/07/Set-CPU-Type-As-Host.png" data-rel="penci-gallery-image-content"><img width="716" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20716%20180'%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2022/07/Set-CPU-Type-As-Host.png" alt="Set CPU Type As Host" class=" penci-lazy wp-image-41348" title="Set CPU Type As Host" data-srcset="https://ostechnix.com/wp-content/uploads/2022/07/Set-CPU-Type-As-Host.png 716w, https://ostechnix.com/wp-content/uploads/2022/07/Set-CPU-Type-As-Host-300x75.png 300w, https://ostechnix.com/wp-content/uploads/2022/07/Set-CPU-Type-As-Host-585x147.png 585w" sizes="(max-width: 716px) 100vw, 716px"></a><figcaption>Set CPU Type As Host</figcaption></figure></div><p>Now start the VM. Once the VM is started, check again if VT-X is enabled in the virtual machine.</p><pre class="wp-block-preformatted">$ egrep --color -i "svm|vmx" /proc/cpuinfo</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled.png" data-rel="penci-gallery-image-content"><img width="1921" height="1040" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201921%201040'%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled.png" alt="Check If VT-X Feature Is Enabled" class=" penci-lazy wp-image-41349" title="Check If VT-X Feature Is Enabled" data-srcset="https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled.png 1921w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled-300x162.png 300w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled-1024x554.png 1024w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled-768x416.png 768w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled-1536x832.png 1536w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled-1170x633.png 1170w, https://ostechnix.com/wp-content/uploads/2022/07/Check-If-VT-X-Feature-Is-Enabled-585x317.png 585w" sizes="(max-width: 1921px) 100vw, 1921px"></a><figcaption>Check If VT-X Feature Is Enabled</figcaption></figure></div><p>If you see <strong>"vmx"</strong> (Intel-VT technology) or <strong>"svm"</strong> (AMD-V support) in the output, congratulations! The VT-X feature is enabled.</p><p>The virtual machine has now become a hypervisor. You can install any hypervisor application such as KVM, Proxmox, Quickemu, Virtualbox, VMware etc., in the virtual machine and start hosting containers and VMs in it.</p><h2 id="conclusion" class="ftwp-heading">Conclusion</h2><p>In this guide, we discussed what is nested virtualization and how to enable nested virtualization in Proxmox. We also learned how to enable VT-X feature in a Proxmox virtual machine in order to run containers and virtual machines in it.</p><div class="wp-container-2 wp-block-group has-black-color has-text-color has-background" style="background-color:#ffffcc"><div class="wp-block-group__inner-container"><p><strong>Related Read:</strong></p><ul><li><strong><a href="https://ostechnix.com/how-to-enable-nested-virtualization-in-kvm-in-linux/" target="_blank" rel="noreferrer noopener">How To Enable Nested Virtualization In KVM In Linux</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-enable-nested-virtualization-in-virtualbox/" target="_blank" rel="noreferrer noopener">How To Enable Nested Virtualization In VirtualBox</a></strong></li></ul></div></div></div><div class="penci-single-link-pages"></div><div class="post-tags"> <a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-administration/" rel="tag">Linux administration</a><a href="https://ostechnix.com/tag/nested-virtualization/" rel="tag">Nested virtualization</a><a href="https://ostechnix.com/tag/open-source/" rel="tag">Open source</a><a href="https://ostechnix.com/tag/proxmox/" rel="tag">Proxmox</a><a href="https://ostechnix.com/tag/proxmox-ve/" rel="tag">Proxmox VE</a><a href="https://ostechnix.com/tag/proxmox-virtualization-environment/" rel="tag">Proxmox Virtualization Environment</a><a href="https://ostechnix.com/tag/sysadmin/" rel="tag">Sysadmin</a></div></div></div><div class="tags-share-box single-post-share tags-share-box-s1 center-box social-align-default post-share"> <span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i>0 comment</span> <span class="post-share-item post-share-plike"> <span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="41343" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a> </span> <a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/enable-nested-virtualization-in-proxmox/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE%20-%20https://ostechnix.com/enable-nested-virtualization-in-proxmox/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&title=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&title=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE %0A%0A https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fenable-nested-virtualization-in-proxmox%2F&text=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE"><i class="penci-faicon fa fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="mailto:?subject=How%20To%20Enable%20Nested%20Virtualization%20In%20Proxmox%20VE&BODY=https://ostechnix.com/enable-nested-virtualization-in-proxmox/"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#"><i class="penci-faicon penciicon-add"></i></a></div><div class="post-author abio-style-1 bioimg-round"><div class="author-img"> <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src='https://ostechnix.com/wp-content/litespeed/avatar/2a1a812a637f5dffead29d74f9de9f12.jpg?ver=1657354885' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/c28e075f78374921e69fc52da9aab01a.jpg?ver=1657354885 2x' class=' penci-lazy avatar avatar-100 photo' height='100' width='100'/></div><div class="author-content"><h5><a href="https://ostechnix.com/author/sk/" title="Author sk" rel="author">sk</a></h5><p>Senthilkumar Palani (aka SK) is the Founder and Editor in chief of OSTechNix. He is a Linux/Unix enthusiast and FOSS supporter. He lives in Tamilnadu, India.</p><div class="bio-social"> <a rel="noreferrer" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fa fa-globe"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://facebook.com/ostechnix"><i class="penci-faicon fa fa-facebook"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://twitter.com/@ostechnix"><i class="penci-faicon fa fa-twitter"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fa fa-linkedin"></i></a> <a rel="noreferrer" target="_blank" class="author-social" href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"><i class="penci-faicon fa fa-youtube-play"></i></a></div></div></div><div class="post-pagination"><div class="prev-post"><div class="prev-post-inner"><div class="prev-post-title"> <span>Previous post</span></div> <a href="https://ostechnix.com/quickgui-a-gui-for-quickemu-to-run-virtual-machines/"><div class="pagi-text"><h5 class="prev-title">Quickgui &#8211; A Graphical Frontend For Quickemu To Run And Manage Virtual Machines In Linux</h5></div> </a></div></div></div><div class="post-related"><div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div><div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"><div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-bgset="https://ostechnix.com/wp-content/uploads/2022/06/Import-QCOW2-Into-Proxmox-1-585x390.png" href="https://ostechnix.com/import-qcow2-into-proxmox/" title="How To Import QCOW2 Image Into Proxmox"> </a><h3> <a href="https://ostechnix.com/import-qcow2-into-proxmox/">How To Import QCOW2 Image Into Proxmox</a></h3> <span class="date"><time class="entry-date published" datetime="2022-06-13T18:42:56+05:30">June 13, 2022</time></span></div><div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-bgset="https://ostechnix.com/wp-content/uploads/2022/03/Create-And-Manage-Linux-Containers-From-Proxmox-VE-Web-Dashboard-585x390.png" href="https://ostechnix.com/create-proxmox-containers/" title="How To Create Proxmox Containers From Proxmox Web UI Dashboard"> </a><h3> <a href="https://ostechnix.com/create-proxmox-containers/">How To Create Proxmox Containers From Proxmox Web...</a></h3> <span class="date"><time class="entry-date published" datetime="2022-03-28T19:24:19+05:30">March 28, 2022</time></span></div><div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-bgset="https://ostechnix.com/wp-content/uploads/2022/03/Fix-Audio-Issue-Dummy-Output-In-Intel-NUC-On-Debian-11-585x390.png" href="https://ostechnix.com/fix-audio-issue-dummy-output-in-intel-nuc-on-debian-11/" title="How To Fix Audio Issue (Dummy Output) In Intel NUC On Debian 11 And Proxmox 7"> </a><h3> <a href="https://ostechnix.com/fix-audio-issue-dummy-output-in-intel-nuc-on-debian-11/">How To Fix Audio Issue (Dummy Output) In...</a></h3> <span class="date"><time class="entry-date published" datetime="2022-03-24T18:43:46+05:30">March 24, 2022</time></span></div><div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-bgset="https://ostechnix.com/wp-content/uploads/2022/03/Create-And-Manage-Virtual-Machines-From-Proxmox-Web-UI-585x390.png" href="https://ostechnix.com/create-proxmox-virtual-machines/" title="How To Create Proxmox Virtual Machines From Proxmox VE Web UI Dashboard"> </a><h3> <a href="https://ostechnix.com/create-proxmox-virtual-machines/">How To Create Proxmox Virtual Machines From Proxmox...</a></h3> <span class="date"><time class="entry-date published" datetime="2022-03-29T18:09:11+05:30">March 29, 2022</time></span></div><div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-bgset="https://ostechnix.com/wp-content/uploads/2022/06/Backup-Proxmox-Containers-And-Virtual-Machines-To-USB-Drive-585x390.jpg" href="https://ostechnix.com/backup-proxmox-to-usb-drive/" title="How To Backup Proxmox Containers And Virtual Machines To USB Drive"> </a><h3> <a href="https://ostechnix.com/backup-proxmox-to-usb-drive/">How To Backup Proxmox Containers And Virtual Machines...</a></h3> <span class="date"><time class="entry-date published" datetime="2022-06-17T18:58:19+05:30">June 17, 2022</time></span></div><div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-bgset="https://ostechnix.com/wp-content/uploads/2022/03/Install-Proxmox-VE-585x390.png" href="https://ostechnix.com/install-proxmox-ve/" title="How To Install Proxmox VE [A Step By Step Guide]"> </a><h3> <a href="https://ostechnix.com/install-proxmox-ve/">How To Install Proxmox VE [A Step By...</a></h3> <span class="date"><time class="entry-date published" datetime="2022-03-10T19:09:17+05:30">March 10, 2022</time></span></div></div></div><div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/enable-nested-virtualization-in-proxmox/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" placeholder="Name*" size="30" aria-required='true'/></p><p class="comment-form-email"><input id="email" name="email" type="text" placeholder="Email*" size="30" aria-required='true'/></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"/><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p><div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit"/> <input type='hidden' name='comment_post_ID' value='41343' id='comment_post_ID'/> <input type='hidden' name='comment_parent' id='comment_parent' value='0'/></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e9e283e10a"/></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="3"/><script type="PenciLazyScript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></article></div></div><div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right penci-sticky-sidebar"><div class="theiaStickySidebar"><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" id="0cd73468e920c9cd6270f0fc351b69a6" type="PenciLazyScript"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="PenciLazyScript">(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p><p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..."/><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p> <input type="hidden" value="Ostechnix" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Sign Up Now"/></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" id="0cd73468e920c9cd6270f0fc351b69a6" type="PenciLazyScript"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6186167963" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="PenciLazyScript">(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside></div></div></div></div></div><div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div><div class="clear-footer"></div><div id="widget-area"><div class="container"><div class="footer-widget-wrapper footer-widget-style-1"><aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4><div class="textwidget"><p><a href="https://ostechnix.com/"><img class=" penci-lazy aligncenter wp-image-25308 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20340%2068'%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px"/></a></p><p>&nbsp;</p><p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><div class="widget-social pc_aligncenter remove-circle"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 18px"></i> <span style="font-size: 13px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 18px"></i> <span style="font-size: 13px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" style="font-size: 18px"></i> <span style="font-size: 13px">Linkedin</span></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 18px"></i> <span style="font-size: 13px">Youtube</span></a> <a href="mailto:info@ostechnix.com" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" style="font-size: 18px"></i> <span style="font-size: 13px">Email</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" style="font-size: 18px"></i> <span style="font-size: 13px">Reddit</span></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" style="font-size: 18px"></i> <span style="font-size: 13px">Rss</span></a></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1"><aside id="block-4" class="widget widget_block widget_archive"><div class=" wp-block-archives-dropdown wp-block-archives"><label for="wp-block-archives-3">Archives</label> <select id="wp-block-archives-3" name="archive-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;"><option>Select Month</option><option value='https://ostechnix.com/2022/07/'> July 2022 &nbsp;(6)</option><option value='https://ostechnix.com/2022/06/'> June 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/05/'> May 2022 &nbsp;(20)</option><option value='https://ostechnix.com/2022/04/'> April 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/03/'> March 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/02/'> February 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2022/01/'> January 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2021/12/'> December 2021 &nbsp;(17)</option><option value='https://ostechnix.com/2021/11/'> November 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/10/'> October 2021 &nbsp;(12)</option><option value='https://ostechnix.com/2021/09/'> September 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/08/'> August 2021 &nbsp;(19)</option><option value='https://ostechnix.com/2021/07/'> July 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/06/'> June 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/05/'> May 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/04/'> April 2021 &nbsp;(11)</option><option value='https://ostechnix.com/2021/03/'> March 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/02/'> February 2021 &nbsp;(16)</option><option value='https://ostechnix.com/2021/01/'> January 2021 &nbsp;(13)</option><option value='https://ostechnix.com/2020/12/'> December 2020 &nbsp;(16)</option><option value='https://ostechnix.com/2020/11/'> November 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/10/'> October 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/09/'> September 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/08/'> August 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/07/'> July 2020 &nbsp;(17)</option><option value='https://ostechnix.com/2020/06/'> June 2020 &nbsp;(24)</option><option value='https://ostechnix.com/2020/05/'> May 2020 &nbsp;(23)</option><option value='https://ostechnix.com/2020/04/'> April 2020 &nbsp;(31)</option><option value='https://ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option><option value='https://ostechnix.com/2020/02/'> February 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option><option value='https://ostechnix.com/2019/12/'> December 2019 &nbsp;(12)</option><option value='https://ostechnix.com/2019/11/'> November 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/10/'> October 2019 &nbsp;(10)</option><option value='https://ostechnix.com/2019/09/'> September 2019 &nbsp;(10)</option><option value='https://ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option><option value='https://ostechnix.com/2019/07/'> July 2019 &nbsp;(16)</option><option value='https://ostechnix.com/2019/06/'> June 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/05/'> May 2019 &nbsp;(11)</option><option value='https://ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option><option value='https://ostechnix.com/2019/03/'> March 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/02/'> February 2019 &nbsp;(8)</option><option value='https://ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2018/12/'> December 2018 &nbsp;(6)</option><option value='https://ostechnix.com/2018/11/'> November 2018 &nbsp;(11)</option><option value='https://ostechnix.com/2018/10/'> October 2018 &nbsp;(17)</option><option value='https://ostechnix.com/2018/09/'> September 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2018/08/'> August 2018 &nbsp;(18)</option><option value='https://ostechnix.com/2018/07/'> July 2018 &nbsp;(15)</option><option value='https://ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option><option value='https://ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/04/'> April 2018 &nbsp;(20)</option><option value='https://ostechnix.com/2018/03/'> March 2018 &nbsp;(21)</option><option value='https://ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/11/'> November 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/10/'> October 2017 &nbsp;(16)</option><option value='https://ostechnix.com/2017/09/'> September 2017 &nbsp;(24)</option><option value='https://ostechnix.com/2017/08/'> August 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/07/'> July 2017 &nbsp;(22)</option><option value='https://ostechnix.com/2017/06/'> June 2017 &nbsp;(13)</option><option value='https://ostechnix.com/2017/05/'> May 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/04/'> April 2017 &nbsp;(24)</option><option value='https://ostechnix.com/2017/03/'> March 2017 &nbsp;(33)</option><option value='https://ostechnix.com/2017/02/'> February 2017 &nbsp;(31)</option><option value='https://ostechnix.com/2017/01/'> January 2017 &nbsp;(24)</option><option value='https://ostechnix.com/2016/12/'> December 2016 &nbsp;(19)</option><option value='https://ostechnix.com/2016/11/'> November 2016 &nbsp;(14)</option><option value='https://ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option><option value='https://ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option><option value='https://ostechnix.com/2016/08/'> August 2016 &nbsp;(22)</option><option value='https://ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option><option value='https://ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option><option value='https://ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option><option value='https://ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option><option value='https://ostechnix.com/2016/02/'> February 2016 &nbsp;(21)</option><option value='https://ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option><option value='https://ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option><option value='https://ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option><option value='https://ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option><option value='https://ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option><option value='https://ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option><option value='https://ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option><option value='https://ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option> </select></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1 last"><aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4><ul id="penci-popularwg-7239" class="side-newsfeed display-order-numbers"><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">1</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-bgset="https://ostechnix.com/wp-content/uploads/2018/08/Switch-Between-Multiple-PHP-Versions-In-Ubuntu-263x175.png" href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/" title="How To Switch Between Multiple PHP Versions In Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post"> <a href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/" rel="bookmark" title="How To Switch Between Multiple PHP Versions In Ubuntu"> How To Switch Between Multiple PHP Versions In Ubuntu </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2018-08-09T16:20:32+05:30">August 9, 2018</time></span></div></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-bgset="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a></div><div class="side-item-text"><h4 class="side-title-post"> <a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners"> Youtube-dl Tutorial With Examples For Beginners </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span></div></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-bgset="https://ostechnix.com/wp-content/uploads/2018/11/Bulk-Rename-Multiple-Files-In-Linux-263x175.png" href="https://ostechnix.com/how-to-rename-multiple-files-at-once-in-linux/" title="8 Methods To Rename Multiple Files At Once In Linux"></a></div><div class="side-item-text"><h4 class="side-title-post"> <a href="https://ostechnix.com/how-to-rename-multiple-files-at-once-in-linux/" rel="bookmark" title="8 Methods To Rename Multiple Files At Once In Linux"> 8 Methods To Rename Multiple Files At Once In Linux </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2021-11-14T12:15:00+05:30">November 14, 2021</time></span></div></div></div></li></ul></aside></div></div></div><footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter"><div class="container"><div class="footer-logo-copyright footer-not-logo footer-not-gotop"><div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li><li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li><li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li><li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li></ul></div><div id="footer-copyright"><p>OSTechNix © 2022. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p></div></div></div></footer></div><div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div> <a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fa fa-close"></i></a><nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div id="sidebar-nav-logo"> <a href="https://ostechnix.com/"><img class=" penci-lazy penci-lazy" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%203%202&#039;%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" alt="OSTechNix"/></a></div><div class="header-social sidebar-nav-social"><div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a> <a href="mailto:info@ostechnix.com" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss"></i></a></div></div><div class="penci-hbg-search-box penci-vernav-search-box"><form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"><div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s"/> <i class="penciicon-magnifiying-glass"></i></div></form></div><ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></nav><div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"><div class="penci-gprd-law"><p> This website uses cookies to improve your experience. By using this site, we will assume that you're OK with it. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a></p></div></div><style>.wp-container-1 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-1 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-1 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style><!--[if lte IE 9]> [script_17] <![endif]--><style>.wp-container-2 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-2 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-2 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style> <script type="PenciLazyScript" id="youtube-api-js" src="https://www.youtube.com/iframe_api" data-pencilazy-type="text/javascript"></script> <script type="PenciLazyScript" id="penci-play-js-js" src="https://ostechnix.com/wp-content/plugins/penci-shortcodes/assets/play.js" data-pencilazy-type="text/javascript"></script> <script type="PenciLazyScript" id="penci-libs-js-js" src="https://ostechnix.com/wp-content/themes/soledad/js/libs-script.min.js" data-pencilazy-type="text/javascript"></script> <script id='main-scripts-js-extra' type="litespeed/javascript">var ajax_var_more={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"2baea5bfbf","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script type="PenciLazyScript" id="main-scripts-js" src="https://ostechnix.com/wp-content/themes/soledad/js/main.min.js" data-pencilazy-type="text/javascript"></script> <script id='penci_ajax_like_post-js-extra' type="litespeed/javascript">var ajax_var={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"2baea5bfbf","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script type="PenciLazyScript" id="penci_ajax_like_post-js" src="https://ostechnix.com/wp-content/themes/soledad/js/post-like.min.js" data-pencilazy-type="text/javascript"></script> <script id='penci_ajax_more_posts-js-extra' type="litespeed/javascript">var ajax_var_more={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"2baea5bfbf","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script type="PenciLazyScript" id="penci_ajax_more_posts-js" src="https://ostechnix.com/wp-content/themes/soledad/js/more-post.min.js" data-pencilazy-type="text/javascript"></script> <script type="PenciLazyScript" id="comment-reply-js" src="https://ostechnix.com/wp-includes/js/comment-reply.min.js" data-pencilazy-type="text/javascript"></script> <script type="PenciLazyScript" id="litespeed-cache-js" src="https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/instant_click.min.js" data-pencilazy-type="text/javascript"></script> <script id='fixedtoc-js-js-extra' type="litespeed/javascript">var fixedtocOption={"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""}</script> <script type="PenciLazyScript" id="fixedtoc-js-js" src="https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js" data-pencilazy-type="text/javascript"></script> <script src='https://stats.wp.com/e-202228.js' defer></script> <script type="litespeed/javascript">_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:11.1.1',blog:'84551477',post:'41343',tz:'5.5',srv:'ostechnix.com'}]);_stq.push(['clickTrackerInit','84551477','41343'])</script> <script type="PenciLazyScript" data-pencilazy-type="text/javascript">function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(41343, 'https://ostechnix.com');</script> <script type="litespeed/javascript" data-src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="litespeed/javascript">window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag('js',new Date());gtag('config','UA-75259810-1')</script> <script type='text/javascript' id="soledad-pagespeed-header" data-cfasync="false">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</script><script type='text/javascript' id="soledad-pagespeed-footer" data-cfasync="false">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</script> <script data-no-optimize="1" defer>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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"72a43dafafad5b1d","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2022.6.0","si":100}' crossorigin="anonymous"></script>
</body></html>
<!-- Page optimized by LiteSpeed Cache @2022-07-13 13:48:27 -->
<!-- Page generated by LiteSpeed Cache 4.6 on 2022-07-13 19:18:26 -->
<!-- Guest Mode -->