<!DOCTYPE html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script> <meta charset="UTF-8"><style id="litespeed-ccss">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://ostechnix.com/wp-content/litespeed/css/d00f7381c431f53c071d7ed0c053e096.css?ver=f2d0f" /><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/css_async.min.js"></script> <meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"/><link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"
type="image/x-icon"/><link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"><link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed"
href="https://ostechnix.com/feed/"/><link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed"
href="https://ostechnix.com/feed/atom/"/><link rel="pingback" href="https://ostechnix.com/xmlrpc.php"/>
<!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><title>How To Securely Transfer Files With SCP In Linux - OSTechNix</title><meta name="description" content="This guide explains what is SCP and how to securely transfer files between local and remote computers with SCP in Linux and Unix." /><link rel="canonical" href="https://ostechnix.com/securely-transfer-files-with-scp-in-linux/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How To Securely Transfer Files With SCP In Linux - OSTechNix" /><meta property="og:description" content="This guide explains what is SCP and how to securely transfer files between local and remote computers with SCP in Linux and Unix." /><meta property="og:url" content="https://ostechnix.com/securely-transfer-files-with-scp-in-linux/" /><meta property="og:site_name" content="OSTechNix" /><meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /><meta property="article:author" content="ostechnix" /><meta property="article:published_time" content="2022-11-03T12:18:55+00:00" /><meta property="article:modified_time" content="2022-11-03T12:27:22+00:00" /><meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2022/11/Securely-Transfer-Files-With-SCP-In-Linux.png" /><meta property="og:image:width" content="1280" /><meta property="og:image:height" content="720" /><meta property="og:image:type" content="image/png" /><meta name="author" content="sk" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@ostechnix" /><meta name="twitter:site" content="@ostechnix" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="sk" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="15 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To Securely Transfer Files With SCP In Linux Comments Feed" href="https://ostechnix.com/securely-transfer-files-with-scp-in-linux/feed/" /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><style id='wp-block-library-theme-inline-css' type='text/css'>.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-audio{margin:0 0 1em}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.wp-block-embed{margin:0 0 1em}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-image{margin:0 0 1em}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-search__button{border:1px solid #ccc;padding:.375em .625em}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table{margin:"0 0 1em 0"}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video{margin:0 0 1em}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}</style><style id='global-styles-inline-css' type='text/css'>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</style><style id='fixedtoc-style-inline-css' type='text/css'>.ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); }</style> <script type="litespeed/javascript" data-src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/44200" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ostechnix.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ostechnix.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://ostechnix.com/?p=44200' /><link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F" /><link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;format=xml" /><style>img#wpstats{display:none}</style> <script type="litespeed/javascript">var penciBlocksArray=[];var portfolioDataJs=portfolioDataJs||[];var PENCILOCALCACHE={};(function(){"use strict";PENCILOCALCACHE={data:{},remove:function(ajaxFilterItem){delete PENCILOCALCACHE.data[ajaxFilterItem]},exist:function(ajaxFilterItem){return PENCILOCALCACHE.data.hasOwnProperty(ajaxFilterItem)&&PENCILOCALCACHE.data[ajaxFilterItem]!==null},get:function(ajaxFilterItem){return PENCILOCALCACHE.data[ajaxFilterItem]},set:function(ajaxFilterItem,cachedData){PENCILOCALCACHE.remove(ajaxFilterItem);PENCILOCALCACHE.data[ajaxFilterItem]=cachedData}}})();function penciBlock(){this.atts_json='';this.content=''}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To Securely Transfer Files With SCP In Linux",
    "description": "In this guide, we will look at what is SCP and how to securely transfer files between local and remote computers with SCP in Linux and Unix-like operating systems.",
    "datePublished": "2022-11-03",
    "datemodified": "2022-11-03",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/securely-transfer-files-with-scp-in-linux\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2022\/11\/Securely-Transfer-Files-With-SCP-In-Linux.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk",
        "url": "https:\/\/ostechnix.com\/author\/sk\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/file-transfer\/",
                "name": "File Transfer"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/securely-transfer-files-with-scp-in-linux\/",
                "name": "How To Securely Transfer Files With SCP In Linux"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /><meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /></head><body data-rsssl=1 class="post-template-default single single-post postid-44200 single-format-standard soledad-ver-8-2-8 pclight-mode pcmn-drdw-style-slide_down pchds-default has-ftoc">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"><div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"><div class="container"><div class="penci-headline" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li><li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li><li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></div><div class="pctopbar-item penci-topbar-social"><div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
<a href="mailto:info@ostechnix.com" aria-label="Email"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" ></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" ></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div></div></div></div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="inner-header penci-header-second"><div class="container align-left-logo has-banner"><div id="logo">
<a href="https://ostechnix.com/"><img
class="penci-mainlogo penci-limg"             src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix"
width="350"
height="73"></a></div><div class="header-banner header-style-3"> <script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="9496719407"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script> </div></div></div><div class="sticky-wrapper"><nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="container"><div class="button-menu-mobile header-3"><svg width=18px height=18px viewBox="0 0 512 384" version=1.1 xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink><g stroke=none stroke-width=1 fill-rule=evenodd><g transform="translate(0.000000, 0.250080)"><rect x=0 y=0 width=512 height=62></rect><rect x=0 y=161 width=512 height=62></rect><rect x=0 y=321 width=512 height=62></rect></g></g></svg></div><ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li><li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li><li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li><li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li><li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li><li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li><li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li><li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li></ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes">
<a class="search-click">
<i class="penciicon-magnifiying-glass"></i>
</a><div class="show-search pcbds-default"><form role="search" method="get" class="pc-searchform"
action="https://ostechnix.com/"><div class="pc-searchform-inner">
<input type="text" class="search-input"
placeholder="Type and hit enter..." name="s"/>
<i class="penciicon-magnifiying-glass"></i>
<button type="submit"
class="searchsubmit">Search</button></div></form>
<a class="search-click close-search"><i class="penciicon-close-button"></i></a></div></div></div></nav></div></header></div><div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt;
&lt;!-- New Horizontal Responsive Adv --&gt;
&lt;ins class=&quot;adsbygoogle&quot;
style=&quot;display:block&quot;
data-ad-client=&quot;ca-pub-6701402139964678&quot;
data-ad-slot=&quot;9496719407&quot;
data-ad-format=&quot;auto&quot;
data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt;
&lt;script&gt;
(adsbygoogle = window.adsbygoogle || []).push({});
&lt;/script&gt;&lt;/div&gt;"><div class="penci-single-block"         data-prev-url="https://ostechnix.com/monitor-file-changes-using-fswatch-linux/"
data-current-url="https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"
data-post-title="How To Securely Transfer Files With SCP In Linux"
data-edit-post=""
data-postid="44200"><div class="container penci-breadcrumb single-breadcrumb">
<span><a class="crumb"
href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fa fa-angle-right" ></i>					<span><a class="crumb" href="https://ostechnix.com/category/file-transfer/">File Transfer</a></span><i class="penci-faicon fa fa-angle-right" ></i>                    <span>How To Securely Transfer Files With SCP In Linux</span></div><div class="container container-single penci_sidebar  penci-enable-lightbox"><div id="main" class="penci-main-sticky-sidebar"><div class="theiaStickySidebar"><article id="post-44200" class="post type-post status-publish"><div class="header-standard header-classic single-header"><div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-4456" href="https://ostechnix.com/category/file-transfer/"  rel="category tag">File Transfer</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/"  rel="category tag">Linux</a><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/"  rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-27" href="https://ostechnix.com/category/linux-basics/"  rel="category tag">Linux Basics</a><a class="penci-cat-name penci-cat-1055" href="https://ostechnix.com/category/linux-commands/"  rel="category tag">Linux Commands</a><a class="penci-cat-name penci-cat-5774" href="https://ostechnix.com/category/linux-security/"  rel="category tag">Linux Security</a><a class="penci-cat-name penci-cat-4157" href="https://ostechnix.com/category/secure-shell-ssh/"  rel="category tag">Secure Shell (SSH)</a><a class="penci-cat-name penci-cat-59" href="https://ostechnix.com/category/unix/"  rel="category tag">Unix</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/"  rel="category tag">Unix/Linux Beginners</a></span></div><h1 class="post-title single-post-title entry-title">How To Securely Transfer Files With SCP In Linux</h1><h2 class="penci-psub-title ">SCP Command Examples To Securely Copy Files Between Local And Remote Computers In Linux</h2><div class="penci-hide-tagupdated">
<span class="author-italic author vcard">By                                         <a class="author-url url fn n"
href="https://ostechnix.com/author/sk/">sk</a>
</span>
<time class="entry-date published" datetime="2022-11-03T17:48:55+05:30">November 3, 2022</time></div><div class="post-box-meta-single">
<span class="author-post byline"><span
class="author vcard">Written by                                     <a class="author-url url fn n"
href="https://ostechnix.com/author/sk/">sk</a>
</span></span>
<span><time class="entry-date published" datetime="2022-11-03T17:48:55+05:30">November 3, 2022</time></span>
<span><i class="penci-post-countview-number">26</i> views</span></div></div><div class="sstyle-style-1 tags-share-box tags-share-box-top single-post-share tags-share-box-s1  center-box  social-align-default post-share">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>0 comment</span>
<span class="post-share-item post-share-plike"><span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="44200" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a></span><a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank"  rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank"  rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux%20-%20https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank"  rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;title=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank"  rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;title=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux"><i class="penci-faicon fa fa-reddit-alien" ></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank"  rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F"><i class="penci-faicon fa fa-whatsapp" ></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank"  rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;text=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux"><i class="penci-faicon fa fa-telegram" ></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email"  rel="noreferrer" href="mailto:?subject=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux&#038;BODY=https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#"><i class="penci-faicon penciicon-add" ></i></a></div><div class="post-entry blockquote-style-2"><div class="inner-post-entry entry-content" id="penci-post-entry-inner"><div id="ftwp-postcontent"><p>File transfer over a network can be done in various ways and using different protocols. The most commonly used protocols for <strong>copying files remotely</strong> are <strong>Rsync</strong>, <strong>SCP</strong> and <strong>SFTP</strong>. In this guide, we will look at <strong>what is SCP</strong> and how to <strong>securely transfer files between local and remote computers with SCP</strong> in Linux and Unix-like operating systems.</p><div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#what-is-scp"><span class="ftwp-text">What is SCP?</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#a-word-of-caution"><span class="ftwp-text">A word of caution:</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#scp-command-syntax"><span class="ftwp-text">SCP Command Syntax</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#scp-command-options"><span class="ftwp-text">SCP Command Options</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#important-notes-to-remember-before-you-begin"><span class="ftwp-text">Important Notes to Remember before You Begin</span></a></li><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#transfer-files-with-scp-in-linux"><span class="ftwp-text">Transfer Files With SCP in Linux</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#1-copy-files-with-scp-from-local-system-to-remote-system"><span class="ftwp-text">1 Copy Files with SCP from Local System to Remote System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#2-copy-multiple-files-with-scp-from-local-system-to-remote-system"><span class="ftwp-text">2. Copy Multiple Files with SCP from Local System to Remote System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#3-recursively-copy-directories-with-scp-from-local-system-to-remote-system"><span class="ftwp-text">3. Recursively Copy Directories with SCP from Local System to Remote System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#4-transfer-files-with-scp-from-remote-system-to-local-system"><span class="ftwp-text">4. Transfer Files with SCP from Remote System to Local System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#5-transfer-multiple-files-using-scp-from-remote-system-to-local-system"><span class="ftwp-text">5. Transfer Multiple Files using SCP from Remote System to Local System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#6-recursively-copy-directories-from-remote-system-to-local-system"><span class="ftwp-text">6. Recursively Copy Directories from Remote System to Local System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#7-copy-files-using-scp-between-two-remote-computers"><span class="ftwp-text">7. Copy Files using SCP between Two Remote Computers</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#8-enable-compression-while-copying-files-with-scp"><span class="ftwp-text">8. Enable Compression while Copying Files with SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#9-limit-bandwidth-while-transferring-files-using-scp"><span class="ftwp-text">9. Limit Bandwidth while Transferring Files using SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#10-use-different-port-while-copying-files-using-scp"><span class="ftwp-text">10. Use Different Port while Copying Files using SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#11-use-different-cipher-while-copying-files-with-scp"><span class="ftwp-text">11. Use Different Cipher while Copying Files with SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#12-copying-files-with-scp-in-verbose-mode"><span class="ftwp-text">12. Copying Files with SCP in Verbose Mode</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#13-transferring-files-with-scp-in-quiet-mode"><span class="ftwp-text">13. Transferring Files with SCP in Quiet Mode</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#14-preserve-file-attributes-when-transferring-files-with-scp"><span class="ftwp-text">14. Preserve File Attributes when Transferring Files with SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#15-use-identity-file-when-copying-files-with-scp"><span class="ftwp-text">15. Use Identity File when Copying Files with SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#16-use-different-ssh_config-file-when-transferring-files-with-scp"><span class="ftwp-text">16. Use Different ssh_config File when Transferring Files with SCP</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#17-copy-files-with-scp-using-ipv4-or-ipv6"><span class="ftwp-text">17. Copy files with SCP using IPv4 or IPv6</span></a></li></ol></li><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#frequently-asked-questions"><span class="ftwp-text">Frequently Asked Questions</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#question-1-what-is-scp"><span class="ftwp-text">Question 1: What is SCP?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-2-how-to-copy-a-file-from-the-local-computer-to-remote-computer-using-scp"><span class="ftwp-text">Question 2: How to copy a file from the local computer to remote computer using SCP?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-3-how-to-copy-recursively-copy-files-and-directories"><span class="ftwp-text">Question 3: How to copy recursively copy files and directories?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-4-can-i-transfer-multiple-files-using-scp"><span class="ftwp-text">Question 4: Can I transfer multiple files using SCP?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-5-how-to-transfer-all-files-in-a-directory"><span class="ftwp-text">Question 5: How to transfer all files in a directory?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-6-can-i-compress-files"><span class="ftwp-text">Question 6: Can I compress files?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-7-can-i-preserve-file-attributes"><span class="ftwp-text">Question 7: Can I preserve file attributes?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-8-can-i-use-different-port"><span class="ftwp-text">Question 8: Can I use different port?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-9-can-i-use-different-cipher"><span class="ftwp-text">Question 9: Can I use different cipher?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-10-how-do-i-list-the-supported-ciphers-by-ssh"><span class="ftwp-text">Question 10: How do I list the supported ciphers by SSH?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-11-is-scp-really-secure"><span class="ftwp-text">Question 11: Is SCP really secure?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#question-12-can-i-transfer-files-from-a-windows-system-to-a-linux-system"><span class="ftwp-text">Question 12: Can I transfer files from a Windows system to a Linux system?</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="what-is-scp" class="ftwp-heading">What is SCP?</h2><p>SCP, stands for <strong>Secure Copy</strong>, is a command line program to copy files and directories between a local and a remote system or between two remote systems in a secure way in Linux and Unix-like operating systems.</p><div><div class="penci-custom-html-inside-content"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></div><p>Using <code>scp</code> command, you can securely copy a file or a directory,</p><ul><li>from your local system to a remote system,</li><li>from a remote system to your local system,</li><li>between remote systems from your local system.</li></ul><p>When transferring data with the scp command, the files and directories are both encrypted. So even if your network is compromised, the perpetrators can't get any meaningful data.</p><p>SCP is a component of the openSSH program and it uses the SSH protocol to securely transfer files. OpenSSH comes pre-installed with almost all modern Linux and Unix distributions, so don't bother installing it.</p><h3 id="a-word-of-caution" class="ftwp-heading"><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color">A word of caution:</mark></strong></h3><p>According to the <strong>official announcement</strong> from the openSSH developers,</p><blockquote class="wp-block-quote"><p>The <strong>scp protocol is outdated</strong>, inflexible and not readily fixed. We recommend the use of more modern protocols like sftp and rsync for file transfer instead.</p>
<cite>Link - <a href="https://lists.mindrot.org/pipermail/openssh-unix-dev/2019-March/037672.html" target="_blank" rel="noreferrer noopener">https://lists.mindrot.org/pipermail/openssh-unix-dev/2019-March/037672.html</a></cite></blockquote><p>However, the majority of the users still prefer SCP over other protocols. Because, SCP handles remote-to-remote file transfers more efficiently than its counterparts such as SFTP and Rsync.</p><p>And also, SCP works exactly like <code>cp</code> command, while <code>rsync</code> changes its behavior based on whether the source directory has a <strong>trailing slash</strong> or not. Take a look at the following commands:</p><ul><li><code>rsync source destination/</code> - would copy the source into the destination folder.</li><li><code>rsync source/ destination/</code> - would copy the contents of the source folder into the destination folder.</li></ul><p>So you must always double check if you've put the trailing slash in the path.</p><p>I personally use <strong><a href="https://ostechnix.com/linux-rsync-command-examples-for-beginners/" target="_blank" rel="noreferrer noopener">Rsync</a></strong> for copying large size files between two hosts and SCP for copying single files over a network.</p><h2 id="scp-command-syntax" class="ftwp-heading">SCP Command Syntax</h2><p>The general syntax for SCP command is given below:</p><pre class="wp-block-preformatted">scp [-346ABCpqrTv] [-c cipher] [-F ssh_config] [-i identity_file] [-J destination] [-l limit] [-o ssh_option] [-P port] [-S program] source ... target</pre><p>Depending upon the file transfer path, the syntax will differ. Here I have included some example syntax format.</p><p>Copy a file from your local system to a remote system:</p><pre class="wp-block-preformatted">scp &lt;options&gt; SourceFile User@RemoteHost:RemotePath</pre><p>Similarly, to copy a directory from your local system to a remote system, use <code>-r</code> flag:</p><pre class="wp-block-preformatted">scp -r SourceDirectory User@RemoteHost:RemotePath</pre><p>Copy multiple files to a remote system:</p><pre class="wp-block-preformatted">scp &lt;options&gt; SourceFile1 SourceFile2 User@RemoteHost:RemotePath</pre><p>Copy a file from remote system to your local system:</p><pre class="wp-block-preformatted">scp &lt;options&gt; User@RemoteHost:RemoteFilePath DestinationFile</pre><p>Copy a directory from remote system to local system:</p><pre class="wp-block-preformatted">scp -r User@RemoteHost:RemoteDirectoryPath DestinationDirectory</pre><p>Copy a file from one remote system to another remote system from your local system:</p><pre class="wp-block-preformatted">scp &lt;options&gt; User@RemoteHost1:RemoteFile1 User@RemoteHost2:RemotePath</pre><p>Please note that when you copy files between two remote systems, the traffic will not pass through the local system. The operation takes place directly between two remote systems. You can, however, pass the traffic from the system on which you run scp command using <code>-3</code> option.</p><p>Copy a directory from one remote system to another remote system from your local system:</p><pre class="wp-block-preformatted">scp -r User@RemoteHost1:RemoteDirectory User@RemoteHost2:DestinationPath</pre><h2 id="scp-command-options" class="ftwp-heading">SCP Command Options</h2><p>The most commonly used options of SCP command are:</p><ul><li><strong><code>-C</code></strong> : Enable compression. Here, C stands for Compression. When you use this option, the data transfer speed will be faster, because the data is compressed. SCP will automatically enable the compression at the source system and decompression at the destination system.</li><li><strong>-c &lt;cipher&gt;</strong> : c stands for cipher. By default, SCP uses <strong>'AES-128'</strong> encryption method for encrypting data. You can change the encryption method using <code>-c</code> option.</li><li><strong><code>-i &lt;identity_file&gt;</code></strong> : i stands for Identity file or Private key. As you already know, there are password-based and key-based authentication used in SSH. If you want to use key-based authentication while transferring files, you can use the -i option to specify the Identity file or Private key.</li><li><strong><code>-l limit</code></strong> : l stands for limit bandwidth. Using this option, you can set the maximum bandwidth used for transferring data. The limit should be specified in <strong><code>Kbit/s</code></strong>.</li><li><strong>-F &lt;ssh_config&gt;</strong> : Some times, you may need to use different networks to connect to your Linux systems. Or you may be behind a proxy server. In such situations, you can use different <code>ssh_config</code> file using <code>-F</code> option.</li><li><strong><code>-P port</code></strong> - P stands for Port. Please note that it is uppercase P. By default, SSH uses port number 22. You might have changed the port number in the destination host for security reasons. In that case, you should explicitly mention the new port number using <code>-P</code> option.</li><li><strong>-p</strong> : if you want to preserve modification times, access times, and modes from the original file, you need to use -p option while copying files. Please note that it is lowercase p.</li><li><strong><code>-r</code></strong> : Recursively copy entire directories.</li><li><strong><code>-B</code></strong> : B stands for batch mode. It is used for selecting batch mode while transferring files. It prevents asking for passwords or passphrases.</li><li><strong><code>-S program</code></strong> : Name of the program to use for the encrypted connection.</li><li><strong>-v</strong> : v stands for verbose. When using the <code>-v</code> option, the command will print the progress in your Terminal screen. So, you will see the what exactly is going on when the files are being transferred. It is useful in debugging connection, authentication, and configuration problems.</li></ul><p>SCP has so many options. You can check the man pages of SCP command to learn about other options. Let us see some <strong>useful scp command examples</strong>.</p><h2 id="important-notes-to-remember-before-you-begin" class="ftwp-heading">Important Notes to Remember before You Begin</h2><ul><li>The <code>scp</code> command relies on <code>ssh</code> for secure file transfer. So you must have either a <strong>ssh key</strong> or <strong>password</strong> to authenticate to the remote systems.</li><li>To be able to transfer files, you must have <strong>read permission on the source files</strong> and <strong>write permission on the destination</strong> location.</li><li>The <code>scp</code> command will not check the destination location before writing. Any files in the destination with the same name will be <strong>overwritten without notification</strong>.</li><li>To be able to distinguish between local and remote locations, use a <strong>colon</strong> (<strong><code>:</code></strong>).</li><li>When transferring large files, it is recommended to start the task inside a <strong><a href="https://ostechnix.com/screen-command-examples-to-manage-multiple-terminal-sessions/" target="_blank" rel="noreferrer noopener">Screen</a></strong> or <strong><a href="https://ostechnix.com/tmux-command-examples-to-manage-multiple-terminal-sessions/" target="_blank" rel="noreferrer noopener">Tmux</a></strong> session.</li></ul><h2 id="transfer-files-with-scp-in-linux" class="ftwp-heading">Transfer Files With SCP in Linux</h2><p>As I already mentioned, we can use <code>scp</code> command to copy a file or a directory from a local system to a remote system and vice versa and copy files and folders between one remote computer to another remote computer.</p><h3 id="1-copy-files-with-scp-from-local-system-to-remote-system" class="ftwp-heading">1 Copy Files with SCP from Local System to Remote System</h3><p>To copy a file from a local system to a remote system using <code>scp</code> command, run:</p><pre class="wp-block-preformatted">$ scp File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p><strong>Sample Output:</strong></p><pre class="wp-block-preformatted">ostechnix@192.168.1.40's password: 
File1.txt                                                    100%  104   814.0KB/s   00:00 </pre><p>Let us break down the above command and see what each option does.</p><ul><li><code><strong>File1.txt</strong></code> - The source file to be copied to the destination.</li><li><code><strong>ostechnix</strong></code> - The username of the remote system.</li><li><code><strong>192.168.1.40</strong></code> - The IP address of the remote system.</li><li><code><strong>/home/ostechnix/</strong></code> - The destination directory in the remote system. This is the absolute path where we want to transfer the source file i.e. <code>File.txt</code>.</li></ul><p>You can also copy the file and rename it as well. The following command transfers the <strong><code>File1.txt</code></strong> to the destination and saves the file with different name <strong><code>myfile.txt</code></strong>.</p><pre class="wp-block-preformatted">$ scp File1.txt ostechnix@192.168.1.40:/home/ostechnix/myfile.txt</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjY5IiBoZWlnaHQ9IjY3OCIgdmlld0JveD0iMCAwIDEyNjkgNjc4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1269" height="678" data-src="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System.png" alt="Copy Files From Local System To Remote System" class="wp-image-44293" title="Copy Files From Local System To Remote System" data-srcset="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System.png 1269w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System-300x160.png 300w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System-1024x547.png 1024w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System-768x410.png 768w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System-1170x625.png 1170w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Files-from-Local-System-to-Remote-System-585x313.png 585w" data-sizes="(max-width: 1269px) 100vw, 1269px"></a><figcaption class="wp-element-caption">Copy Files from Local System to Remote System</figcaption></figure></div><h3 id="2-copy-multiple-files-with-scp-from-local-system-to-remote-system" class="ftwp-heading">2. Copy Multiple Files with SCP from Local System to Remote System</h3><p>To transfer multiple files from a local system to a remote system with <code>scp</code> command, run:</p><pre class="wp-block-preformatted">$ scp File1.txt File2.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p><strong>Sample Output:</strong></p><pre class="wp-block-preformatted">ostechnix@192.168.1.40's password: 
File1.txt                                                    100%  104   689.4KB/s   00:00    
File2.txt                                                    100%  496     6.3MB/s   00:00   </pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjY5IiBoZWlnaHQ9IjY3OCIgdmlld0JveD0iMCAwIDEyNjkgNjc4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1269" height="678" data-src="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System.png" alt="Copy Multiple Files from Local System to Remote System" class="wp-image-44294" title="Copy Multiple Files from Local System to Remote System" data-srcset="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System.png 1269w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System-300x160.png 300w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System-1024x547.png 1024w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System-768x410.png 768w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System-1170x625.png 1170w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Multiple-Files-from-Local-System-to-Remote-System-585x313.png 585w" data-sizes="(max-width: 1269px) 100vw, 1269px"></a><figcaption class="wp-element-caption">Copy Multiple Files from Local System to Remote System</figcaption></figure></div><p>Here,</p><ul><li><code><strong>File1.txt</strong></code> and <strong><code>File2.txt</code></strong> - The name of the sources that will be copied to the specified destination.</li><li><code><strong>ostechnix@192.168.1.40</strong></code> - The username and IP address of the remote system.</li><li><code><strong>/home/ostechnix</strong></code> - The destination path where we want to put the copied files.</li></ul><p>If the files have same extension, you can use the following alternative commands to achieve the same goal.</p><pre class="wp-block-preformatted">$ scp {File1,File2}.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p>Or,</p><pre class="wp-block-preformatted">$ scp *.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h3 id="3-recursively-copy-directories-with-scp-from-local-system-to-remote-system" class="ftwp-heading">3. Recursively Copy Directories with SCP from Local System to Remote System</h3><p>To recursively copy an entire directory including the sub-directories and its contents from your local system to a remote system, use <strong><code>-r</code></strong> flag like below.</p><pre class="wp-block-preformatted">$ scp -r Documents/ ostechnix@192.168.1.40:/home/ostechnix/</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjY5IiBoZWlnaHQ9IjY3OCIgdmlld0JveD0iMCAwIDEyNjkgNjc4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1269" height="678" data-src="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System.png" alt="Copy a Directory from Local System to Remote System" class="wp-image-44295" title="Copy a Directory from Local System to Remote System" data-srcset="https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System.png 1269w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System-300x160.png 300w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System-1024x547.png 1024w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System-768x410.png 768w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System-1170x625.png 1170w, https://ostechnix.com/wp-content/uploads/2022/11/Copy-Directory-from-Local-System-to-Remote-System-585x313.png 585w" data-sizes="(max-width: 1269px) 100vw, 1269px"></a><figcaption class="wp-element-caption">Copy a Directory from Local System to Remote System</figcaption></figure></div><p>The above command will copy the entire directory <strong>'<code>Documents</code>'</strong> including its contents to the destination system.</p><p>Here,</p><ul><li><strong><code>-r</code></strong> : Copy files and directories recursively including the sub-directories and its contents.</li><li><strong><code>Documents</code></strong> : The name of the source directory that we want to copy to the destination.</li><li><code><strong>ostechnix@192.168.1.40</strong></code> : The username and IP address of the remote system.</li><li><code><strong>/home/ostechnix</strong></code> : The destination path where we want to put the copied directory.</li></ul><h3 id="4-transfer-files-with-scp-from-remote-system-to-local-system" class="ftwp-heading">4. Transfer Files with SCP from Remote System to Local System</h3><p>Remember we copied <code>FIle1.txt</code> to the remote system from our local system. Let us copy it back to the local system.</p><p>To copy a file from a remote system to your local system with <code>scp</code>, run:</p><pre class="wp-block-preformatted">$ scp ostechnix@192.168.1.40:/home/ostechnix/File1.txt Downloads/</pre><p>Here,</p><ul><li><code><strong>ostechnix@192.168.1.40</strong></code> : The username and IP address of the remote system.</li><li><strong><code>/home/ostechnix/File.txt</code></strong> : The absolute path of file that we want to copy to the local system.</li><li><strong><code>Downloads</code></strong> - The location where to save the copied file.</li></ul><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzM0IiBoZWlnaHQ9IjY3OCIgdmlld0JveD0iMCAwIDEzMzQgNjc4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1334" height="678" data-src="https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System.png" alt="Transfer Files from Remote System to Local System" class="wp-image-44296" title="Transfer Files from Remote System to Local System" data-srcset="https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System.png 1334w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System-300x152.png 300w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System-1024x520.png 1024w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System-768x390.png 768w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System-1170x595.png 1170w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Files-from-Remote-System-to-Local-System-585x297.png 585w" data-sizes="(max-width: 1334px) 100vw, 1334px"></a><figcaption class="wp-element-caption">Transfer Files from Remote System to Local System</figcaption></figure></div><h3 id="5-transfer-multiple-files-using-scp-from-remote-system-to-local-system" class="ftwp-heading">5. Transfer Multiple Files using SCP from Remote System to Local System</h3><p>To copy multiple files from a remote system to your local system, mention the absolute path of the files that you want to copy <strong>within the curly braces</strong> as shown below.</p><pre class="wp-block-preformatted">$ scp ostechnix@192.168.1.40:/home/ostechnix/\{File1.txt,File2.txt\} Downloads/</pre><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzYwIiBoZWlnaHQ9IjY3OCIgdmlld0JveD0iMCAwIDEzNjAgNjc4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" decoding="async" width="1360" height="678" data-src="https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System.png" alt="Transfer Multiple Files from Remote System to Local System" class="wp-image-44297" title="Transfer Multiple Files from Remote System to Local System" data-srcset="https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System.png 1360w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System-300x150.png 300w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System-1024x510.png 1024w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System-768x383.png 768w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System-1170x583.png 1170w, https://ostechnix.com/wp-content/uploads/2022/11/Transfer-Multiple-Files-from-Remote-System-to-Local-System-585x292.png 585w" data-sizes="(max-width: 1360px) 100vw, 1360px"></a><figcaption class="wp-element-caption">Transfer Multiple Files from Remote System to Local System</figcaption></figure></div><p>The above command will copy the <code>File1.txt</code> and <code>File2.txt</code> from the <code>/home/ostechnix/</code> directory of the remote system to the <code>Downloads</code> directory of the local system.</p><p>Please note that there is <strong>no spaces after the commas within the curly braces</strong>.</p><h3 id="6-recursively-copy-directories-from-remote-system-to-local-system" class="ftwp-heading">6. Recursively Copy Directories from Remote System to Local System</h3><p>To copy an entire directory including the sub-directories and its contents recursively from a remote computer to your local system using <code>scp</code>, use <strong><code>-r</code></strong> flag.</p><pre class="wp-block-preformatted">$ scp -r ostechnix@192.168.1.40:/home/ostechnix/Documents Downloads/</pre><p>The above command will copy the entire <strong><code>Documents</code></strong> from the remote system to the <strong><code>Downloads</code></strong> directory in your local system.</p><h3 id="7-copy-files-using-scp-between-two-remote-computers" class="ftwp-heading">7. Copy Files using SCP between Two Remote Computers</h3><p>To copy files directly from one remote system to another remote system with <code>scp</code>, run:</p><pre class="wp-block-preformatted">$ scp senthil@192.168.1.40:/home/senthil/File1.txt kumar@192.168.1.20:/home/kumar/</pre><p>You will be asked to enter the password of the both remote systems.</p><p>Here,</p><ul><li><strong><code>senthil@192.168.1.40</code></strong> - The username and IP address of the remote system from the file is currently located.</li><li><strong><code>/home/senthil/File1.txt</code></strong> - The name the file1 that is being copied and its location.</li><li><code><strong>kumar@192.168.1.20</strong></code> - The username and IP address of the remote system where we want to copy the file.</li><li><strong><code>/home/kumar</code></strong> - The location where to save the copied file on the remote system.</li></ul><p>The above command will copy the <code>/home/senthil/File1.txt</code> from the remote host <code>192.168.1.40</code> to <code>/home/kumar/</code> directory on the remote host <code>192.168.1.20</code>.</p><p>In this method, the data will be transferred directly from one remote system to another remote system. If you want to route the traffic through the machine on which the command is run, use <code><strong>-3</strong></code> flag like below.</p><pre class="wp-block-preformatted">$ scp -3 senthil@192.168.1.40:/home/senthil/File1.txt kumar@192.168.1.20:/home/kumar/</pre><h3 id="8-enable-compression-while-copying-files-with-scp" class="ftwp-heading">8. Enable Compression while Copying Files with SCP</h3><p>So far we have transferred files without compressing them. Now we will enable compression while transferring files using <strong><code>-C</code></strong> flag.</p><pre class="wp-block-preformatted">$ scp -C File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p>The <code>-C</code> flag will enable compression of data at the source and automatically decompress the data at destination side.</p><p>By enabling compression, you can increase the file copy or transfer speed significantly.</p><h3 id="9-limit-bandwidth-while-transferring-files-using-scp" class="ftwp-heading">9. Limit Bandwidth while Transferring Files using SCP</h3><p>We can limit the bandwidth while copying files with SCP using <code>-l</code> flag. Please note that the maximum bandwidth is specified in Kbits/s. 1 byte=8 bits. So if you want to limit bandwidth to 200 KB/s, the value for <code>-l</code> would be <strong>1600</strong> (200*8).</p><pre class="wp-block-preformatted">$ scp -l 1600 File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p>This is useful when transferring large files to prevent SCP from throttling the bandwidth.</p><h3 id="10-use-different-port-while-copying-files-using-scp" class="ftwp-heading">10. Use Different Port while Copying Files using SCP</h3><p>As a system admin, you might <strong><a href="https://ostechnix.com/how-to-change-apache-ftp-and-ssh-default-port-to-a-custom-port-part-3/" target="_blank" rel="noreferrer noopener">have changed the default port of your SSH protocol</a></strong> on the remote servers for security reasons. In such cases, you can specify the port number with <code>-P</code> flag when transferring files. Please note that this is <strong>uppercase P</strong>.</p><pre class="wp-block-preformatted">$ scp -P 2022 File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h3 id="11-use-different-cipher-while-copying-files-with-scp" class="ftwp-heading">11. Use Different Cipher while Copying Files with SCP</h3><p>By default, SCP uses <strong>'<code>AES-128</code>'</strong> for encrypting files. If you want to use different cipher, use <strong><code>-c</code></strong> flag followed by the cipher name.</p><p>For example, if you want to use <strong>'<code>3des-cbc</code>'</strong> cipher, the command would be like below:</p><pre class="wp-block-preformatted">$ scp -c 3des-cbc File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p>To view the list of supported ciphers, run:</p><pre class="wp-block-preformatted">$ ssh -Q cipher localhost | paste -d, -s -</pre><p><strong>Sample Output:</strong></p><pre class="wp-block-preformatted">3des-cbc,aes128-cbc,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com</pre><h3 id="12-copying-files-with-scp-in-verbose-mode" class="ftwp-heading">12. Copying Files with SCP in Verbose Mode</h3><p>if you want to know what's going on behind the scenes while copying files with scp, you can use <code><strong>-v</strong></code> flag. When transferring files with SCP in Verbose mode, the step by step process of the SCP command execution will be displayed in the terminal. This comes in handy when troubleshooting times.</p><pre class="wp-block-preformatted">$ scp -v File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><p>You will see a whole lot of output when sending files in Verbose mode as shown in the following output.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode.png" data-rel="penci-gallery-image-content"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxOTIwIiBoZWlnaHQ9IjEwNDAiIHZpZXdCb3g9IjAgMCAxOTIwIDEwNDAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" decoding="async" width="1920" height="1040" data-src="https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode.png" alt="Copying Files with SCP in Verbose Mode" class="wp-image-44325" title="Copying Files with SCP in Verbose Mode" data-srcset="https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode.png 1920w, https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode-300x163.png 300w, https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode-1024x555.png 1024w, https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode-768x416.png 768w, https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode-1536x832.png 1536w, https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode-1170x634.png 1170w, https://ostechnix.com/wp-content/uploads/2022/11/Copying-Files-with-SCP-in-Verbose-Mode-585x317.png 585w" data-sizes="(max-width: 1920px) 100vw, 1920px"></a><figcaption class="wp-element-caption">Copying Files with SCP in Verbose Mode</figcaption></figure></div><h3 id="13-transferring-files-with-scp-in-quiet-mode" class="ftwp-heading">13. Transferring Files with SCP in Quiet Mode</h3><p>We can transfer files in quiet mode with <strong><code>-q</code></strong> flag. When sharing files in quiet mode, it will not show the copy progress, warning or diagnostic message in the output.</p><pre class="wp-block-preformatted">$ scp -q File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h3 id="14-preserve-file-attributes-when-transferring-files-with-scp" class="ftwp-heading">14. Preserve File Attributes when Transferring Files with SCP</h3><p>To preserve file attributes such as file modification times, access times, and modes when copying files with SCP, use <strong><code>-p</code></strong> flag. Please note that this is <strong>lowercase p</strong>.</p><pre class="wp-block-preformatted">$ scp -p File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h3 id="15-use-identity-file-when-copying-files-with-scp" class="ftwp-heading">15. Use Identity File when Copying Files with SCP</h3><p>SSH supports both password-based and key-based authentication. Key-based authentication is most widely used authentication method in Linux environments.</p><p>If you want to use key-based authentication while transferring files, use the <strong><code>-i</code></strong> option to specify the Identity file or Private key.</p><pre class="wp-block-preformatted">$ scp -i my_private_key.pem File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h3 id="16-use-different-ssh_config-file-when-transferring-files-with-scp" class="ftwp-heading">16. Use Different ssh_config File when Transferring Files with SCP</h3><p>There are situations where you need to use different networks to connect to your Linux systems. Or you may be behind a proxy server. In such situations, you can use different <code>ssh_config</code> file using <code><strong>-F</strong></code> option.</p><pre class="wp-block-preformatted">$ scp -F /home/ostechnix/my_ssh_config File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h3 id="17-copy-files-with-scp-using-ipv4-or-ipv6" class="ftwp-heading">17. Copy files with SCP using IPv4 or IPv6</h3><p>We can force SCP to only use IPv4 or IPv6 addresses when copying files. This can be achieved by adding <strong><code>-4</code></strong> for IPv4 networks and <strong><code>-6</code></strong> for IPv6 networks.</p><pre class="wp-block-preformatted">$ scp -6 File1.txt ostechnix@192.168.1.40:/home/ostechnix/</pre><h2 id="frequently-asked-questions" class="ftwp-heading">Frequently Asked Questions</h2><h3 id="question-1-what-is-scp" class="ftwp-heading">Question 1: What is SCP?</h3><p><strong>Answer:</strong> SCP is a command line program to securely transfer files and directories from a local system to a remote system and vice versa, or between two remote systems directly.</p><h3 id="question-2-how-to-copy-a-file-from-the-local-computer-to-remote-computer-using-scp" class="ftwp-heading">Question 2: How to copy a file from the local computer to remote computer using SCP?</h3><p>To copy a file from your local system to a remote system, the command would be:</p><pre class="wp-block-preformatted">scp SourceFile.txt User@RemoteHost:/some/remote/directory</pre><h3 id="question-3-how-to-copy-recursively-copy-files-and-directories" class="ftwp-heading">Question 3: How to copy recursively copy files and directories?</h3><p>To recursively copy a directory including the sub-directories, use <code>-r</code> flag.</p><pre class="wp-block-preformatted">scp -r /some/local/directory User@RemoteHost:/some/remote/directory</pre><h3 id="question-4-can-i-transfer-multiple-files-using-scp" class="ftwp-heading">Question 4: Can I transfer multiple files using SCP?</h3><p>Yes, you can. Just mention the source file names with space separated.</p><p>Copy multiple files from local to remote:</p><pre class="wp-block-preformatted">scp file1.txt file2.txt file3.txt User@RemoteHost:/some/remote/directory
scp {file1,file2,file3}.txt User@RemoteHost:/some/remote/directory
scp *.txt User@RemoteHost:/some/remote/directory</pre><p>Copy multiple files from remote to local:</p><pre class="wp-block-preformatted">scp User@RemoteHost:/some/remote/directory/\{file1.txt,file2.txt,file3.txt\} /some/local/directory</pre><p>Copy multiple files from remote to remote:</p><pre class="wp-block-preformatted">$ scp User@RemoteHost1:/some/remote/directory/\{file1.txt,file2.txt,file3.txt\} User@RemoteHost2:/some/remote/directory/</pre><h3 id="question-5-how-to-transfer-all-files-in-a-directory" class="ftwp-heading">Question 5: How to transfer all files in a directory?</h3><p>To transfer all files in a directory, switch to that directory:</p><pre class="wp-block-preformatted">cd dir_name</pre><pre class="wp-block-preformatted">scp *.txt User@RemoteHost:/some/remote/directory</pre><h3 id="question-6-can-i-compress-files" class="ftwp-heading">Question 6: Can I compress files?</h3><p>Yes, you can. Use <strong><code>-C</code></strong> to compress files. The files are compressed at source and decompress at destination automatically.</p><pre class="wp-block-preformatted">scp -C /some/large/file User@RemoteHost:/some/remote/directory</pre><h3 id="question-7-can-i-preserve-file-attributes" class="ftwp-heading">Question 7: Can I preserve file attributes?</h3><p>To preserve file attributes such as modification times, access times, and modes from the original file, use <code>-p</code> flag.</p><pre class="wp-block-preformatted">scp -p file.txt User@RemoteHost:/some/remote/directory</pre><h3 id="question-8-can-i-use-different-port" class="ftwp-heading">Question 8: Can I use different port?</h3><p>Yes. SCP allows you to use different port with <code>-P</code> flag.</p><pre class="wp-block-preformatted">scp -P 2022 file.txt User@RemoteHost:/some/remote/directory</pre><h3 id="question-9-can-i-use-different-cipher" class="ftwp-heading">Question 9: Can I use different cipher?</h3><p>Yes, you can. Use -c flag to use different cipher.</p><pre class="wp-block-preformatted">scp -c 3des-cbc User@RemoteHost:/some/remote/directory</pre><h3 id="question-10-how-do-i-list-the-supported-ciphers-by-ssh" class="ftwp-heading">Question 10: How do I list the supported ciphers by SSH?</h3><p>To view the list of supported ciphers by SSH and SCP, use the following command</p><pre class="wp-block-preformatted">ssh -Q cipher localhost | paste -d, -s -</pre><h3 id="question-11-is-scp-really-secure" class="ftwp-heading">Question 11: Is SCP really secure?</h3><p>Yes, it is completely secure to use. SCP uses the same SSH mechanism used by openSSH. The data in transit is encrypted at the source side and decrypted at destination.</p><h3 id="question-12-can-i-transfer-files-from-a-windows-system-to-a-linux-system" class="ftwp-heading">Question 12: Can I transfer files from a Windows system to a Linux system?</h3><p>Yes, you can. Use either <strong>PSCP</strong> program to transfer files from windows platform to Linux platform. You can also use <strong>WinSCP</strong>.</p><h2 id="conclusion" class="ftwp-heading">Conclusion</h2><p>In this comprehensive guide, we learned what is SCP, and how to <strong>securely transfer files with SCP</strong> in Linux. We provided <strong>17 SCP command examples</strong>. We also looked at the commonly asked questions about SCP.</p><p>Whether you're a Linux Admin, or a Developer or a Regular user, you will have to copy files to and from a remote system at some point. Knowing how to <strong>use SCP to securely copy files</strong> will be definitely useful.</p><ul></ul><div class="is-layout-constrained wp-block-group has-black-color has-text-color has-background" style="background-color:#ffdddd"><div class="wp-block-group__inner-container"><p><strong>Related Read:</strong></p><ul><li><strong><a href="https://ostechnix.com/transfer-files-and-folders-between-computers-with-croc/" target="_blank" rel="noreferrer noopener">Transfer Files And Folders Between Computers With Croc</a></strong></li><li><strong><a href="https://ostechnix.com/share-files-between-linux-desktops-with-warpinator/" target="_blank" rel="noreferrer noopener">Share Files Between Linux Desktops With Warpinator</a></strong></li><li><strong><a href="https://ostechnix.com/share-files-between-multiple-devices-using-snapdrop-via-web-browser/" target="_blank" rel="noreferrer noopener">Share Files Between Multiple Devices Using Snapdrop Via Web Browser</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-securely-share-files-over-internet-with-firefox-send/" target="_blank" rel="noreferrer noopener">How To Securely Share Files Over Internet With Firefox Send</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-securely-share-files-from-commandline-with-ffsend-in-linux/" target="_blank" rel="noreferrer noopener">How To Securely Share Files From Commandline With ffsend In Linux</a></strong></li><li><strong><a href="https://ostechnix.com/psitransfer-simple-open-source-self-hosted-file-sharing-solution/" target="_blank" rel="noreferrer noopener">PSiTransfer – A Simple Open Source Self-hosted File Sharing Solution</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-setup-a-file-server-in-minutes-using-python/" target="_blank" rel="noreferrer noopener">How to Setup A Basic File server Using simpleHTTPserver</a></strong></li><li><strong><a href="https://ostechnix.com/easy-fast-way-share-files-internet-command-line/" target="_blank" rel="noreferrer noopener">An Easy And Fast Way To Share Files Over Internet From Command Line</a></strong></li><li><strong><a href="https://ostechnix.com/onionshare-share-files-of-any-size-securely-and-anonymously/" target="_blank" rel="noreferrer noopener">OnionShare – Share Files Of Any Size Securely And Anonymously</a></strong></li></ul></div></div></div><div class="penci-single-link-pages"></div><div class="post-tags">
<a href="https://ostechnix.com/tag/cli/" rel="tag">CLI</a><a href="https://ostechnix.com/tag/command-line/" rel="tag">Command line</a><a href="https://ostechnix.com/tag/file-transfer/" rel="tag">File transfer</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-basics/" rel="tag">Linux basics</a><a href="https://ostechnix.com/tag/linux-commands/" rel="tag">Linux commands</a><a href="https://ostechnix.com/tag/linux-howto/" rel="tag">Linux howto</a><a href="https://ostechnix.com/tag/scp/" rel="tag">scp</a><a href="https://ostechnix.com/tag/secure-copy/" rel="tag">Secure Copy</a><a href="https://ostechnix.com/tag/secure-shell/" rel="tag">Secure Shell</a><a href="https://ostechnix.com/tag/ssh/" rel="tag">SSH</a></div></div></div><div class="tags-share-box single-post-share tags-share-box-s1  center-box  social-align-default post-share">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>0 comment</span>
<span class="post-share-item post-share-plike">
<span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="44200" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a>					</span>
<a class="new-ver-share post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank"  rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="new-ver-share post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank"  rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux%20-%20https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="new-ver-share post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank"  rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;title=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="new-ver-share post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank"  rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;title=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux"><i class="penci-faicon fa fa-reddit-alien" ></i><span class="dt-share">Reddit</span></a><a class="new-ver-share post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank"  rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F"><i class="penci-faicon fa fa-whatsapp" ></i><span class="dt-share">Whatsapp</span></a><a class="new-ver-share post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank"  rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fsecurely-transfer-files-with-scp-in-linux%2F&#038;text=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux"><i class="penci-faicon fa fa-telegram" ></i><span class="dt-share">Telegram</span></a><a class="new-ver-share post-share-item post-share-email" target="_blank" aria-label="Share via Email"  rel="noreferrer" href="mailto:?subject=How%20To%20Securely%20Transfer%20Files%20With%20SCP%20In%20Linux&#038;BODY=https://ostechnix.com/securely-transfer-files-with-scp-in-linux/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a><a class="post-share-item post-share-expand" href="#"><i class="penci-faicon penciicon-add" ></i></a></div><div class="post-author abio-style-1 bioimg-round"><div class="author-img">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" alt='' data-src='https://ostechnix.com/wp-content/litespeed/avatar/2a1a812a637f5dffead29d74f9de9f12.jpg?ver=1667031889' data-srcset='https://ostechnix.com/wp-content/litespeed/avatar/c28e075f78374921e69fc52da9aab01a.jpg?ver=1667031889 2x' class='avatar avatar-100 photo' height='100' width='100' decoding='async'/></div><div class="author-content"><h5><a href="https://ostechnix.com/author/sk/" title="Author sk" rel="author">sk</a></h5><p>Senthilkumar Palani (aka SK) is the Founder and Editor in chief of OSTechNix. He is a Linux/Unix enthusiast and FOSS supporter. He lives in Tamilnadu, India.</p><div class="bio-social">
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://ostechnix.com/"><i class="penci-faicon fa fa-globe" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://facebook.com/ostechnix"><i class="penci-faicon fa fa-facebook" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://twitter.com/@ostechnix"><i class="penci-faicon fa fa-twitter" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a  rel="noreferrer" target="_blank" class="author-social"
href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"><i class="penci-faicon fa fa-youtube-play" ></i></a></div></div></div><div class="post-pagination"><div class="prev-post"><div class="prev-post-inner"><div class="prev-post-title">
<span>Previous post</span></div>
<a href="https://ostechnix.com/monitor-file-changes-using-fswatch-linux/"><div class="pagi-text"><h5 class="prev-title">How To Monitor File Changes Using fswatch In Linux</h5></div>
</a></div></div></div><div class="post-related"><div class="post-title-box"><h4
class="post-box-title">You May Also Like</h4></div><div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel"
data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2"
data-auto="false"
data-speed="300" data-dots="true"><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2020/10/Synchronize-Files-With-Unison-On-Linux-585x390.png"
href="https://ostechnix.com/how-to-synchronize-files-with-unison-on-linux/" title="How To Synchronize Files With Unison On Linux">
</a><h3>
<a href="https://ostechnix.com/how-to-synchronize-files-with-unison-on-linux/">How To Synchronize Files With Unison On Linux</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-10-03T18:43:43+05:30">October 3, 2020</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2020/02/Securely-Share-Files-Over-Internet-With-Firefox-Send.png"
href="https://ostechnix.com/how-to-securely-share-files-over-internet-with-firefox-send/" title="How To Securely Share Files Over Internet With Firefox Send">
</a><h3>
<a href="https://ostechnix.com/how-to-securely-share-files-over-internet-with-firefox-send/">How To Securely Share Files Over Internet With...</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-02-28T20:21:56+05:30">February 28, 2020</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2021/09/Sync-Android-Phone-With-Linux-Using-KDE-Connect-585x390.png"
href="https://ostechnix.com/kde-connect-access-files-notifications-android-devices/" title="Sync Android Phone With Linux Using KDE Connect">
</a><h3>
<a href="https://ostechnix.com/kde-connect-access-files-notifications-android-devices/">Sync Android Phone With Linux Using KDE Connect</a></h3>
<span class="date"><time class="entry-date published" datetime="2021-09-04T17:30:00+05:30">September 4, 2021</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2017/04/Share-Files-Over-Internet-From-Command-Line.jpg"
href="https://ostechnix.com/easy-fast-way-share-files-internet-command-line/" title="Share Files Over Internet From Command Line Using Transfer.sh">
</a><h3>
<a href="https://ostechnix.com/easy-fast-way-share-files-internet-command-line/">Share Files Over Internet From Command Line Using...</a></h3>
<span class="date"><time class="entry-date published" datetime="2017-04-08T18:55:30+05:30">April 8, 2017</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2017/08/file-browser.png"
href="https://ostechnix.com/filemanager-cross-platform-stylish-web-file-manager/" title="File Browser &#8211; A Cross-platform Stylish Web File Manager">
</a><h3>
<a href="https://ostechnix.com/filemanager-cross-platform-stylish-web-file-manager/">File Browser &#8211; A Cross-platform Stylish Web File...</a></h3>
<span class="date"><time class="entry-date published" datetime="2017-08-01T19:00:20+05:30">August 1, 2017</time></span></div><div class="item-related">
<a class="related-thumb penci-image-holder penci-lazy"
data-bgset="https://ostechnix.com/wp-content/uploads/2020/12/Transfer-Files-Between-Any-Devices-With-Piping-Server-585x390.png"
href="https://ostechnix.com/transfer-files-between-any-devices-using-piping-server/" title="Transfer Files Between Any Devices Using Piping Server">
</a><h3>
<a href="https://ostechnix.com/transfer-files-between-any-devices-using-piping-server/">Transfer Files Between Any Devices Using Piping Server</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-12-08T20:08:09+05:30">December 8, 2020</time></span></div></div></div><div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/securely-transfer-files-with-scp-in-linux/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p><p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p><div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='44200' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5532962728" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="155"/><script type="litespeed/javascript">document.getElementById("ak_js_1").setAttribute("value",(new Date()).getTime())</script></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></article></div></div><div id="sidebar"
class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left  pciconp-right pcicon-right penci-sticky-sidebar"><div class="theiaStickySidebar"><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="5990223580"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p><p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..."/><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p>
<input type="hidden" value="Ostechnix" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="litespeed/javascript" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6701402139964678"
data-ad-slot="6186167963"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script type="litespeed/javascript">(adsbygoogle=window.adsbygoogle||[]).push({})</script></div></aside></div></div></div></div></div><div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div><div class="clear-footer"></div><div id="widget-area"><div class="container"><div class="footer-widget-wrapper footer-widget-style-1"><aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4><div class="textwidget"><p><a href="https://ostechnix.com/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzNDAiIGhlaWdodD0iNjgiIHZpZXdCb3g9IjAgMCAzNDAgNjgiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" decoding="async" class="aligncenter wp-image-25308 size-full" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-sizes="(max-width: 340px) 100vw, 340px" /></a></p><p>&nbsp;</p><p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><div class="widget-social pc_aligncenter remove-circle">
<a href="https://www.facebook.com/ostechnix/"
aria-label="Facebook"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-facebook"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/ostechnix"
aria-label="Twitter"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-twitter"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix"
aria-label="Linkedin"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-linkedin"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g"
aria-label="Youtube"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-youtube-play"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Youtube</span></a>
<a href="mailto:info@ostechnix.com"
aria-label="Email"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-envelope"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Email</span></a>
<a href="https://www.reddit.com/r/OSTechNix/"
aria-label="Reddit"  rel="noreferrer"                           target="_blank"><i class="penci-faicon fa fa-reddit-alien"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Reddit</span></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss"  style="font-size: 18px"></i>                            <span style="font-size: 13px">Rss</span></a></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1"><aside id="block-4" class="widget widget_block widget_archive"><div class=" wp-block-archives-dropdown wp-block-archives"><label for="wp-block-archives-3" class="wp-block-archives__label">Archives</label>
<select id="wp-block-archives-3" name="archive-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;"><option value="">Select Month</option><option value='https://ostechnix.com/2022/11/'> November 2022 &nbsp;(1)</option><option value='https://ostechnix.com/2022/10/'> October 2022 &nbsp;(6)</option><option value='https://ostechnix.com/2022/09/'> September 2022 &nbsp;(12)</option><option value='https://ostechnix.com/2022/08/'> August 2022 &nbsp;(12)</option><option value='https://ostechnix.com/2022/07/'> July 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/06/'> June 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/05/'> May 2022 &nbsp;(20)</option><option value='https://ostechnix.com/2022/04/'> April 2022 &nbsp;(14)</option><option value='https://ostechnix.com/2022/03/'> March 2022 &nbsp;(11)</option><option value='https://ostechnix.com/2022/02/'> February 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2022/01/'> January 2022 &nbsp;(9)</option><option value='https://ostechnix.com/2021/12/'> December 2021 &nbsp;(17)</option><option value='https://ostechnix.com/2021/11/'> November 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/10/'> October 2021 &nbsp;(12)</option><option value='https://ostechnix.com/2021/09/'> September 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/08/'> August 2021 &nbsp;(19)</option><option value='https://ostechnix.com/2021/07/'> July 2021 &nbsp;(15)</option><option value='https://ostechnix.com/2021/06/'> June 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/05/'> May 2021 &nbsp;(18)</option><option value='https://ostechnix.com/2021/04/'> April 2021 &nbsp;(10)</option><option value='https://ostechnix.com/2021/03/'> March 2021 &nbsp;(14)</option><option value='https://ostechnix.com/2021/02/'> February 2021 &nbsp;(16)</option><option value='https://ostechnix.com/2021/01/'> January 2021 &nbsp;(13)</option><option value='https://ostechnix.com/2020/12/'> December 2020 &nbsp;(16)</option><option value='https://ostechnix.com/2020/11/'> November 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/10/'> October 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/09/'> September 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/08/'> August 2020 &nbsp;(14)</option><option value='https://ostechnix.com/2020/07/'> July 2020 &nbsp;(17)</option><option value='https://ostechnix.com/2020/06/'> June 2020 &nbsp;(23)</option><option value='https://ostechnix.com/2020/05/'> May 2020 &nbsp;(23)</option><option value='https://ostechnix.com/2020/04/'> April 2020 &nbsp;(31)</option><option value='https://ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option><option value='https://ostechnix.com/2020/02/'> February 2020 &nbsp;(18)</option><option value='https://ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option><option value='https://ostechnix.com/2019/12/'> December 2019 &nbsp;(11)</option><option value='https://ostechnix.com/2019/11/'> November 2019 &nbsp;(6)</option><option value='https://ostechnix.com/2019/10/'> October 2019 &nbsp;(10)</option><option value='https://ostechnix.com/2019/09/'> September 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option><option value='https://ostechnix.com/2019/07/'> July 2019 &nbsp;(16)</option><option value='https://ostechnix.com/2019/06/'> June 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/05/'> May 2019 &nbsp;(11)</option><option value='https://ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option><option value='https://ostechnix.com/2019/03/'> March 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2019/02/'> February 2019 &nbsp;(8)</option><option value='https://ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option><option value='https://ostechnix.com/2018/12/'> December 2018 &nbsp;(6)</option><option value='https://ostechnix.com/2018/11/'> November 2018 &nbsp;(11)</option><option value='https://ostechnix.com/2018/10/'> October 2018 &nbsp;(17)</option><option value='https://ostechnix.com/2018/09/'> September 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2018/08/'> August 2018 &nbsp;(18)</option><option value='https://ostechnix.com/2018/07/'> July 2018 &nbsp;(14)</option><option value='https://ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option><option value='https://ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/04/'> April 2018 &nbsp;(20)</option><option value='https://ostechnix.com/2018/03/'> March 2018 &nbsp;(21)</option><option value='https://ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option><option value='https://ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option><option value='https://ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/11/'> November 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/10/'> October 2017 &nbsp;(16)</option><option value='https://ostechnix.com/2017/09/'> September 2017 &nbsp;(24)</option><option value='https://ostechnix.com/2017/08/'> August 2017 &nbsp;(21)</option><option value='https://ostechnix.com/2017/07/'> July 2017 &nbsp;(22)</option><option value='https://ostechnix.com/2017/06/'> June 2017 &nbsp;(12)</option><option value='https://ostechnix.com/2017/05/'> May 2017 &nbsp;(19)</option><option value='https://ostechnix.com/2017/04/'> April 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2017/03/'> March 2017 &nbsp;(32)</option><option value='https://ostechnix.com/2017/02/'> February 2017 &nbsp;(31)</option><option value='https://ostechnix.com/2017/01/'> January 2017 &nbsp;(23)</option><option value='https://ostechnix.com/2016/12/'> December 2016 &nbsp;(19)</option><option value='https://ostechnix.com/2016/11/'> November 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option><option value='https://ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option><option value='https://ostechnix.com/2016/08/'> August 2016 &nbsp;(22)</option><option value='https://ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option><option value='https://ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option><option value='https://ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option><option value='https://ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option><option value='https://ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option><option value='https://ostechnix.com/2016/02/'> February 2016 &nbsp;(21)</option><option value='https://ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option><option value='https://ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option><option value='https://ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option><option value='https://ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option><option value='https://ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option><option value='https://ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option><option value='https://ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option><option value='https://ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option><option value='https://ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option><option value='https://ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option>
</select></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1 last"><aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4><ul id="penci-popularwg-4327"
data-settings='{"title":"Popular Posts","hide_thumb":"","movemeta":"","dotstyle":"","ptype":"","taxonomy":"","tax_ids":"","sticky":"on","show_author":"","show_comment":"","show_postviews":"","showborder":"","row_gap":"","imgwidth":"","ptfsfe":"","ptfs":"","pmfs":"","image_type":"default","type":"week","title_length":"","number":"3","offset":"","categories":"","featured":"","allfeatured":"","thumbright":"","twocolumn":"","featured2":"","ordernum":"","postdate":"","icon":"","cats_id":false,"tags_id":false}' data-paged="1"
data-action="penci_popular_news_ajax"
data-mes="Sorry, No more posts"
data-max="440"
class="side-newsfeed display-order-numbers"><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">1</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2018/08/Switch-Between-Multiple-PHP-Versions-In-Ubuntu-263x175.png"
href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/"
title="How To Switch Between Multiple PHP Versions In Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-switch-between-multiple-php-versions-in-ubuntu/" rel="bookmark" title="How To Switch Between Multiple PHP Versions In Ubuntu">
How To Switch Between Multiple PHP Versions In Ubuntu                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2018-08-09T16:20:32+05:30">August 9, 2018</time></span></div></div></div></li><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">2</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png"
href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/"
title="How To Fix Busybox Initramfs Error On Ubuntu"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu">
How To Fix Busybox Initramfs Error On Ubuntu                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span></div></div></div></li><li class="penci-feed">
<span class="order-border-number">
<span class="number-post">3</span>
</span><div class="side-item"><div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark"
data-bgset="https://ostechnix.com/wp-content/uploads/2022/10/Monitor-File-Changes-With-fswatch-In-Linux-263x175.jpg"
href="https://ostechnix.com/monitor-file-changes-using-fswatch-linux/"
title="How To Monitor File Changes Using fswatch In Linux"></a></div><div class="side-item-text"><h4 class="side-title-post">
<a href="https://ostechnix.com/monitor-file-changes-using-fswatch-linux/" rel="bookmark" title="How To Monitor File Changes Using fswatch In Linux">
How To Monitor File Changes Using fswatch In Linux                                        </a></h4><div class="grid-post-box-meta penci-side-item-meta pcsnmt-below">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2022-10-26T17:29:00+05:30">October 26, 2022</time></span></div></div></div></li></ul></aside></div></div></div><footer id="footer-section"
class="penci-footer-social-media penci-lazy"		        itemscope itemtype="https://schema.org/WPFooter"><div class="container"><div class="footer-logo-copyright footer-not-logo footer-not-gotop"><div class="footer-menu-wrap" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li><li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li><li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li><li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li></ul></div><div id="footer-copyright"><p>OSTechNix © 2022. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p></div></div></div></footer></div><div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div>
<a id="close-sidebar-nav"
class="header-3"><i class="penci-faicon fa fa-close" ></i></a><nav id="sidebar-nav" class="header-3" role="navigation"
itemscope
itemtype="https://schema.org/SiteNavigationElement"><div id="sidebar-nav-logo">
<a href="https://ostechnix.com/"><img class="penci-lazy sidebar-nav-logo penci-limg"                                                                     src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E"
width="250"
height="52"
data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png"
data-lightlogo="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png"
alt="OSTechNix"/></a></div><div class="header-social sidebar-nav-social"><div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
<a href="mailto:info@ostechnix.com" aria-label="Email"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-envelope" ></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit"  rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-reddit-alien" ></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div><div class="penci-hbg-search-box penci-vernav-search-box"><form role="search" method="get" class="pc-searchform penci-hbg-search-form"
action="https://ostechnix.com/"><div class="inner-hbg-search-form">
<input type="text" class="search-input"
placeholder="Type and hit enter..." name="s"/>
<i class="penciicon-magnifiying-glass"></i></div></form></div><ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li></ul></nav><div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"><div class="penci-gprd-law"><p>
This website uses cookies to improve your experience. By using this site, we will assume that you're OK with it.				<a class="penci-gprd-accept" href="#">Accept</a>				<a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a></p></div></div><!--[if lte IE 9]> <script>'use strict';
            (function($) {
                $(document).ready(function() {
                    $('#ftwp-container').addClass('ftwp-ie9');
                });
            })(jQuery);</script> <![endif]--> <script id='main-scripts-js-extra' type="litespeed/javascript">var ajax_var_more={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"f6048f8a73","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script id='penci_ajax_like_post-js-extra' type="litespeed/javascript">var ajax_var={"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"f6048f8a73","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"}</script> <script type='text/javascript' src='https://ostechnix.com/wp-content/plugins/litespeed-cache/assets/js/instant_click.min.js' id='litespeed-cache-js'></script> <script id='fixedtoc-js-js-extra' type="litespeed/javascript">var fixedtocOption={"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""}</script> <script src='https://stats.wp.com/e-202244.js' defer></script> <script type="litespeed/javascript">_stq=window._stq||[];_stq.push(['view',{v:'ext',blog:'84551477',post:'44200',tz:'5.5',srv:'ostechnix.com',j:'1:11.5.1'}]);_stq.push(['clickTrackerInit','84551477','44200'])</script><script type="litespeed/javascript">function PenciSimplePopularPosts_AddCount(id,endpoint){var xmlhttp;var params="/?penci_spp_count=1&penci_spp_post_id="+id+"&cachebuster="+Math.floor((Math.random()*100000));if(window.XMLHttpRequest){xmlhttp=new XMLHttpRequest()}else{xmlhttp=new ActiveXObject("Microsoft.XMLHTTP")}
xmlhttp.onreadystatechange=function(){if(xmlhttp.readyState==4&&xmlhttp.status==200){var data=JSON.parse(xmlhttp.responseText);document.getElementsByClassName("penci-post-countview-number")[0].innerHTML=data.visits}}
xmlhttp.open("GET",endpoint+params,!0);xmlhttp.send()}
PenciSimplePopularPosts_AddCount(44200,'https://ostechnix.com')</script>  <script type="litespeed/javascript" data-src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="litespeed/javascript">window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag('js',new Date());gtag('config','UA-75259810-1')</script> <script data-no-optimize="1">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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script data-optimized="1" type="litespeed/javascript" data-src="https://ostechnix.com/wp-content/litespeed/js/1ced98752453d6d5f9e00905918a78f5.js?ver=f2d0f"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/vaafb692b2aea4879b33c060e79fe94621666317369993" integrity="sha512-0ahDYl866UMhKuYcW078ScMalXqtFJggm7TmlUtp0UlD4eQk0Ixfnm5ykXKvGJNFjLMoortdseTfsRT8oCfgGA==" data-cf-beacon='{"rayId":"764543dd0db6597f","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2022.11.0","si":100}' crossorigin="anonymous"></script>
</body></html>
<!-- Page optimized by LiteSpeed Cache @2022-11-03 18:25:32 -->
<!-- Page generated by LiteSpeed Cache 5.3 on 2022-11-03 18:25:32 -->
<!-- Guest Mode -->