<!DOCTYPE html> <html lang="en-US"> <head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name="viewport" content="width=device-width, initial-scale=1"> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon" /> <link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"> <link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/" /> <link rel="pingback" href="https://ostechnix.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--> <link rel='preconnect' href='https://fonts.googleapis.com' /> <link rel='preconnect' href='https://fonts.gstatic.com' /> <meta http-equiv='x-dns-prefetch-control' content='on'> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//fonts.gstatic.com' /> <link rel='dns-prefetch' href='//s.gravatar.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <title>Add Worker Nodes To Amazon EKS Cluster - OSTechNix</title><style id="rocket-critical-css">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</style><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"/></noscript> <meta name="description" content="This step by step tutorial walk you through the details to add node groups and worker nodes to Amazon EKS cluster with screenshots." /> <link rel="canonical" href="https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/" /> <meta property="og:locale" content="en_US" /> <meta property="og:type" content="article" /> <meta property="og:title" content="Add Worker Nodes To Amazon EKS Cluster - OSTechNix" /> <meta property="og:description" content="This step by step tutorial walk you through the details to add node groups and worker nodes to Amazon EKS cluster with screenshots." /> <meta property="og:url" content="https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/" /> <meta property="og:site_name" content="OSTechNix" /> <meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /> <meta property="article:published_time" content="2022-02-24T12:00:58+00:00" /> <meta property="article:modified_time" content="2022-02-24T12:36:52+00:00" /> <meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2022/02/Add-Worker-Nodes-To-Amazon-EKS-Cluster.png" /> <meta property="og:image:width" content="1280" /> <meta property="og:image:height" content="720" /> <meta property="og:image:type" content="image/png" /> <meta name="twitter:card" content="summary" /> <meta name="twitter:creator" content="@ostechnix" /> <meta name="twitter:site" content="@ostechnix" /> <meta name="twitter:label1" content="Written by" /> <meta name="twitter:data1" content="M.S.M. Sivam" /> <meta name="twitter:label2" content="Est. reading time" /> <meta name="twitter:data2" content="8 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ostechnix.com/#organization","name":"OSTechNix","url":"https://ostechnix.com/","sameAs":["https://www.facebook.com/ostechnix/","https://www.instagram.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","@id":"https://ostechnix.com/#logo","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","width":350,"height":73,"caption":"OSTechNix"},"image":{"@id":"https://ostechnix.com/#logo"}},{"@type":"WebSite","@id":"https://ostechnix.com/#website","url":"https://ostechnix.com/","name":"OSTechNix","description":"Open Source | Technology | Linux And Unix","publisher":{"@id":"https://ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ostechnix.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#primaryimage","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2022/02/Add-Worker-Nodes-To-Amazon-EKS-Cluster.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2022/02/Add-Worker-Nodes-To-Amazon-EKS-Cluster.png","width":1280,"height":720,"caption":"Add Worker Nodes To EKS Cluster"},{"@type":"WebPage","@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#webpage","url":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/","name":"Add Worker Nodes To Amazon EKS Cluster - OSTechNix","isPartOf":{"@id":"https://ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#primaryimage"},"datePublished":"2022-02-24T12:00:58+00:00","dateModified":"2022-02-24T12:36:52+00:00","description":"This step by step tutorial walk you through the details to add node groups and worker nodes to Amazon EKS cluster with screenshots.","breadcrumb":{"@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/"]}]},{"@type":"BreadcrumbList","@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://ostechnix.com/"},{"@type":"ListItem","position":2,"name":"How To Add Worker Nodes To Amazon EKS Cluster"}]},{"@type":"Article","@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#article","isPartOf":{"@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#webpage"},"author":{"@id":"https://ostechnix.com/#/schema/person/48902bd259e38bbdcc999507aa0ac82c"},"headline":"How To Add Worker Nodes To Amazon EKS Cluster","datePublished":"2022-02-24T12:00:58+00:00","dateModified":"2022-02-24T12:36:52+00:00","mainEntityOfPage":{"@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#webpage"},"wordCount":709,"commentCount":0,"publisher":{"@id":"https://ostechnix.com/#organization"},"image":{"@id":"https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#primaryimage"},"thumbnailUrl":"https://ostechnix.com/wp-content/uploads/2022/02/Add-Worker-Nodes-To-Amazon-EKS-Cluster.png","keywords":["Add worker nodes to EKS Cluster","Amazon EC2","Amazon EKS","Amazon Elastic Kubernetes Service","Amazon Web Services","AWS","AWS CLI","AWS Cloud","Cloud","DevOps","EC2","EKS","Elastic Kubernetes Service","IT Automation","K8s","Kube","Kubectl","Kubernetes","Kubernetes cluster","Kubernetes series","Kubernetes tutorial","Linux"],"articleSection":["Amazon EC2","Amazon EKS","AWS","Cloud","Containers","DevOps","IT Automation","Kubernetes","Linux","Linux Administration","Linux Containers","Virtualization"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/#respond"]}]},{"@type":"Person","@id":"https://ostechnix.com/#/schema/person/48902bd259e38bbdcc999507aa0ac82c","name":"M.S.M. Sivam","image":{"@type":"ImageObject","@id":"https://ostechnix.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/5ac6dfad85a7f07d5ce175ae36d17c18?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/5ac6dfad85a7f07d5ce175ae36d17c18?s=96&d=mm&r=g","caption":"M.S.M. Sivam"},"description":"Solution Architect - BigData Infrastructure in one of the Leading MNC. Highly passionate about BigData and Cloud Technologies.","sameAs":["https://ostechnix.com/"],"url":"https://ostechnix.com/author/mohansivam/"}]}</script> <link rel='dns-prefetch' href='//www.youtube.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//s.w.org' /> <link rel='dns-prefetch' href='//ajax.cloudflare.com' /> <link rel='dns-prefetch' href='//static.cloudflareinsights.com' /> <link rel='dns-prefetch' href='//stats.wp.com' /> <link rel='dns-prefetch' href='//pixel.wp.com' /> <link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.googletagmanager.com' /> <link rel='dns-prefetch' href='//googleads.g.doubleclick.net' /> <link rel='dns-prefetch' href='//partner.googleadservices.com' /> <link rel='dns-prefetch' href='//adservice.google.com' /> <link rel='dns-prefetch' href='//www.googletagservices.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <link rel='dns-prefetch' href='//tpc.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To Add Worker Nodes To Amazon EKS Cluster Comments Feed" href="https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/feed/" /> <link rel='preload' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <style id='wp-block-library-inline-css' type='text/css'> .has-text-align-justify{text-align:justify;} </style> <style id='wp-block-library-theme-inline-css' type='text/css'> .wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code>code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group:where(.has-background){padding:1.25em 2.375em}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0} </style> <link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <style id='global-styles-inline-css' type='text/css'>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</style> <link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad/style.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/social-counter.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <style id='fixedtoc-style-inline-css' type='text/css'> .ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); } </style> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js' defer></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/37852" /> <link rel='shortlink' href='https://ostechnix.com/?p=37852' /> <link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;format=xml" /> <style type='text/css'>img#wpstats{display:none}</style> <style id="penci-custom-style" type="text/css">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</style><script type="rocketlazyloadscript">
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To Add Worker Nodes To Amazon EKS Cluster",
    "description": "This step by step tutorial walk you through the details to add node groups and worker nodes to Amazon EKS cluster with screenshots.",
    "datePublished": "2022-02-24",
    "datemodified": "2022-02-24",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/add-worker-nodes-to-amazon-eks-cluster\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2022\/02\/Add-Worker-Nodes-To-Amazon-EKS-Cluster.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-MSMSivam",
        "name": "M.S.M. Sivam",
        "url": "https:\/\/ostechnix.com\/author\/mohansivam\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/virtualization\/",
                "name": "Virtualization"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/virtualization\/kubernetes\/",
                "name": "Kubernetes"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/ostechnix.com\/add-worker-nodes-to-amazon-eks-cluster\/",
                "name": "How To Add Worker Nodes To Amazon EKS Cluster"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /> <link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /> <link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script>
</head> <body data-rsssl=1 class="post-template-default single single-post postid-37852 single-format-standard soledad-ver-8-1-2 pclight-mode pcmn-drdw-style-slide_down penci-fawesome-ver5 has-ftoc"> <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"> <div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"> <div class="container"> <div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li> <li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li> <li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li> <li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li> <li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul></div><div class="pctopbar-item penci-topbar-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#d9b0b7bfb699b6aaadbcbab1b7b0a1f7bab6b4" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div></div> </div> </div> </div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"> <div class="inner-header penci-header-second"> <div class="container align-left-logo has-banner"> <div id="logo"> <a href="https://ostechnix.com/"><picture class="penci-mainlogo">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" alt="OSTechNix" width="350" height="73" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" />
</picture>
<noscript><picture class="penci-mainlogo">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" width="350" height="73"/>
</picture>
</noscript></a> </div> <div class="header-banner header-style-3"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="9496719407" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </div> </div> <div class="sticky-wrapper"> <nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="container"> <div class="button-menu-mobile header-3"><svg width=18px height=18px viewBox="0 0 512 384" version=1.1 xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink><g stroke=none stroke-width=1 fill-rule=evenodd><g transform="translate(0.000000, 0.250080)"><rect x=0 y=0 width=512 height=62></rect><rect x=0 y=161 width=512 height=62></rect><rect x=0 y=321 width=512 height=62></rect></g></g></svg></div> <ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes"> <a class="search-click"> <i class="penciicon-magnifiying-glass"></i> </a> <div class="show-search"> <form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/"> <div class="pc-searchform-inner"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> <input type="submit" class="searchsubmit" value="Search" /> </div> </form> <a class="search-click close-search"><i class="penciicon-close-button"></i></a> </div> </div> <div class="penci-menuhbg-wapper penci-menu-toggle-wapper"> <a href="#" class="penci-menuhbg-toggle"> <span class="penci-menuhbg-inner"> <i class="lines-button lines-button-double"> <i class="penci-lines"></i> </i> <i class="lines-button lines-button-double penci-hover-effect"> <i class="penci-lines"></i> </i> </span> </a> </div> </div> </nav> </div> </header> </div> <div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt; &lt;!-- New Horizontal Responsive Adv --&gt; &lt;ins class=&quot;adsbygoogle&quot; style=&quot;display:block&quot; data-ad-client=&quot;ca-pub-6701402139964678&quot; data-ad-slot=&quot;9496719407&quot; data-ad-format=&quot;auto&quot; data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt; &lt;script&gt; (adsbygoogle = window.adsbygoogle || []).push({}); &lt;/script&gt;&lt;/div&gt;"> <div class="penci-single-block" data-prev-url="https://ostechnix.com/create-gui-dialog-boxes-in-bash-scripts-with-whiptail/" data-current-url="https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/" data-post-title="How To Add Worker Nodes To Amazon EKS Cluster" data-edit-post="" data-postid="37852"> <div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fas fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/virtualization/kubernetes/">Kubernetes</a></span><i class="penci-faicon fas fa-angle-right"></i> <span>How To Add Worker Nodes To Amazon EKS Cluster</span> </div> <div class="container container-single penci_sidebar penci-enable-lightbox"> <div id="main" class="penci-main-sticky-sidebar"> <div class="theiaStickySidebar"> <article id="post-37852" class="post type-post status-publish"> <div class="header-standard header-classic single-header"> <div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-5473" href="https://ostechnix.com/category/virtualization/kubernetes/" rel="category tag">Kubernetes</a><a class="penci-cat-name penci-cat-5522" href="https://ostechnix.com/category/aws/amazon-ec2/" rel="category tag">Amazon EC2</a><a class="penci-cat-name penci-cat-5600" href="https://ostechnix.com/category/aws/amazon-eks/" rel="category tag">Amazon EKS</a><a class="penci-cat-name penci-cat-5521" href="https://ostechnix.com/category/aws/" rel="category tag">AWS</a><a class="penci-cat-name penci-cat-7" href="https://ostechnix.com/category/cloud/" rel="category tag">Cloud</a><a class="penci-cat-name penci-cat-4301" href="https://ostechnix.com/category/virtualization/containers/" rel="category tag">Containers</a><a class="penci-cat-name penci-cat-4793" href="https://ostechnix.com/category/devops/" rel="category tag">DevOps</a><a class="penci-cat-name penci-cat-5205" href="https://ostechnix.com/category/it-automation/" rel="category tag">IT Automation</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/" rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-902" href="https://ostechnix.com/category/linux-containers/" rel="category tag">Linux Containers</a><a class="penci-cat-name penci-cat-62" href="https://ostechnix.com/category/virtualization/" rel="category tag">Virtualization</a></span></div> <h1 class="post-title single-post-title entry-title">How To Add Worker Nodes To Amazon EKS Cluster</h1> <div class="penci-hide-tagupdated"> <span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/mohansivam/">M.S.M. Sivam</a></span> <time class="entry-date published" datetime="2022-02-24T17:30:58+05:30">February 24, 2022</time> </div> <div class="post-box-meta-single"> <span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/mohansivam/">M.S.M. Sivam</a></span></span> <span><time class="entry-date published" datetime="2022-02-24T17:30:58+05:30">February 24, 2022</time></span> <span><i class="penci-post-countview-number">7</i> Views</span> </div> </div> <div class="tags-share-box tags-share-box-top single-post-share tags-share-box-s1 center-box social-align-default"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="37852" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster%20-%20https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;title=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;title=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster %0A%0A https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;text=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#6a55191f08000f091e5722051d4f585a3e054f585a2b0e0e4f585a3d0518010f184f585a24050e0f194f585a3e054f585a2b070b1005044f585a2f21394f585a29061f191e0f184c495a59525128252e3357021e1e1a1950454505191e0f090204031244090507450b0e0e471d0518010f184704050e0f19471e05470b070b100504470f01194709061f191e0f1845"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-entry blockquote-style-2"> <div class="inner-post-entry entry-content" id="penci-post-entry-inner"> <div id="ftwp-postcontent"><p>In this article, we are going to learn about how to add Node Group/Worker nodes into the Amazon EKS Cluster. Before getting into this guide, refer to the below guide to learn about how to create Kubernetes Cluster (Amazon EKS) in AWS cloud.</p> <ul><li><strong><a href="https://ostechnix.com/deploy-kubernetes-cluster-on-aws-with-amazon-eks/" target="_blank" rel="noreferrer noopener">How To Deploy Kubernetes Cluster On AWS With Amazon EKS</a></strong></li></ul> <div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#1-add-node-group-in-eks-cluster"><span class="ftwp-text">1. Add Node Group in EKS Cluster</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#1-1-create-iam-role-for-eks-worker-nodes"><span class="ftwp-text">1.1. Create IAM role for EKS Worker Nodes</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#1-2-add-worker-nodes"><span class="ftwp-text">1.2. Add worker Nodes</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#2-delete-the-cluster"><span class="ftwp-text">2. Delete the Cluster</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="1-add-node-group-in-eks-cluster" class="ftwp-heading">1. Add Node Group in EKS Cluster</h2> <p>You can provision worker nodes from Amazon EC2 instances by adding Node Group in EKS Cluster. For that, you need to create an IAM role for Worker nodes.</p> <div><div class="penci-custom-html-inside-content"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><h3 id="1-1-create-iam-role-for-eks-worker-nodes" class="ftwp-heading">1.1. Create IAM role for EKS Worker Nodes</h3> <p>Get into the IAM Console and create a role as we did for Master node.</p> <p>Amazon Console 🡪 IAM Console 🡪 Roles 🡪 Create role.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37853" title="Create role">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1024x496.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-768x372.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1170x566.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-585x283.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20661&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="661" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20661&#039;%3E%3C/svg%3E" alt="Create role" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1024x496.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-768x372.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1170x566.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-585x283.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png" />
</picture>
<noscript><picture class="wp-image-37853" title="Create role">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1024x496.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-768x372.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1170x566.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-585x283.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="661" src="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png" alt="Create role" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1024x496.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-768x372.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-1170x566.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Create-role-1-585x283.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a><figcaption>Create role</figcaption></figure></div> <p>Select AWS Service and select EC2 in use cases.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37854" title="Select trusted entity type">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1024x493.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-768x370.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1170x564.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-585x282.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20658&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="658" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20658&#039;%3E%3C/svg%3E" alt="Select trusted entity type" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1024x493.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-768x370.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1170x564.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-585x282.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png" />
</picture>
<noscript><picture class="wp-image-37854" title="Select trusted entity type">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1024x493.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-768x370.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1170x564.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-585x282.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="658" src="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png" alt="Select trusted entity type" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1024x493.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-768x370.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-1170x564.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-trusted-entity-type-585x282.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a><figcaption>Select trusted entity type</figcaption></figure></div> <p>We need to have 3 policies selected for provisioning worker nodes from Amazon EC2.</p> <ul><li>AmazonEKSWorkerNodePolicy</li><li>AmazonEKS_CNI_Policy</li><li>AmazonEC2ContainerRegistryReadOnly</li></ul> <p>Search these policies by the keywords 'AmazonEKS' and 'AmazonEC2' and select those policies.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37855" title="Permissions policies for role">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-300x146.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1024x499.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-768x374.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1170x570.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-585x285.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20666&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="666" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20666&#039;%3E%3C/svg%3E" alt="Permissions policies for role" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-300x146.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1024x499.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-768x374.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1170x570.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-585x285.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png" />
</picture>
<noscript><picture class="wp-image-37855" title="Permissions policies for role">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-300x146.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1024x499.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-768x374.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1170x570.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-585x285.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="666" src="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png" alt="Permissions policies for role" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-300x146.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1024x499.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-768x374.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-1170x570.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Permissions-policies-for-role-585x285.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a><figcaption>Permissions policies for role</figcaption></figure></div> <p>Search for 'Amazon EC2' and choose 'AmazonEC2ContainerRegistryReadOnly' as well.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37856" title="Choose permissions policies for role">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png.webp 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1024x472.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-768x354.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1170x539.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-585x270.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201365%20629&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1365px) 100vw, 1365px" />
<img width="1365" height="629" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201365%20629&#039;%3E%3C/svg%3E" alt="Choose permissions policies for role" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1024x472.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-768x354.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1170x539.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-585x270.png 585w" data-lazy-sizes="(max-width: 1365px) 100vw, 1365px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png" />
</picture>
<noscript><picture class="wp-image-37856" title="Choose permissions policies for role">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png.webp 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-300x138.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1024x472.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-768x354.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1170x539.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-585x270.png.webp 585w" sizes="(max-width: 1365px) 100vw, 1365px"/>
<img width="1365" height="629" src="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png" alt="Choose permissions policies for role" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role.png 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-300x138.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1024x472.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-768x354.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-1170x539.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-permissions-policies-for-role-585x270.png 585w" sizes="(max-width: 1365px) 100vw, 1365px"/>
</picture>
</noscript></a><figcaption>Choose permissions policies for role</figcaption></figure></div> <p>In the next page, you need to name the Role and Review. Here, we are naming as 'ostechnix_workers'.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37857" title="Enter role details">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png.webp 1330w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-300x143.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1024x489.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-768x367.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1170x559.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-585x279.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201330%20635&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1330px) 100vw, 1330px" />
<img width="1330" height="635" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201330%20635&#039;%3E%3C/svg%3E" alt="Enter role details" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png 1330w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-300x143.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1024x489.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-768x367.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1170x559.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-585x279.png 585w" data-lazy-sizes="(max-width: 1330px) 100vw, 1330px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png" />
</picture>
<noscript><picture class="wp-image-37857" title="Enter role details">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png.webp 1330w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-300x143.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1024x489.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-768x367.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1170x559.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-585x279.png.webp 585w" sizes="(max-width: 1330px) 100vw, 1330px"/>
<img width="1330" height="635" src="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png" alt="Enter role details" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details.png 1330w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-300x143.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1024x489.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-768x367.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-1170x559.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-role-details-585x279.png 585w" sizes="(max-width: 1330px) 100vw, 1330px"/>
</picture>
</noscript></a><figcaption>Enter role details</figcaption></figure></div> <p>Ensure the above mentioned 3 policies are selected and create the role.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37859" title="Verify and create IAM role">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1024x495.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-768x371.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1170x565.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-585x283.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20660&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="660" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20660&#039;%3E%3C/svg%3E" alt="Verify and create IAM role" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1024x495.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-768x371.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1170x565.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-585x283.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png" />
</picture>
<noscript><picture class="wp-image-37859" title="Verify and create IAM role">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1024x495.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-768x371.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1170x565.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-585x283.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="660" src="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png" alt="Verify and create IAM role" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1024x495.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-768x371.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-1170x565.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Verify-and-create-IAM-role-585x283.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a><figcaption>Verify and create IAM role</figcaption></figure></div> <h3 id="1-2-add-worker-nodes" class="ftwp-heading">1.2. Add worker Nodes</h3> <p>To add worker nodes, get into the EKS cluster that we created.</p> <p>AWS Console 🡪 EKS 🡪 Clusters 🡪 ostechnix.</p> <p>There are no nodes available right now. Navigate to Configuration for adding nodes.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37860" title="EKS Cluster Configuration">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1024x496.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-768x372.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1170x567.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-585x284.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20662&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" />
<img width="1366" height="662" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201366%20662&#039;%3E%3C/svg%3E" alt="EKS Cluster Configuration" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1024x496.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-768x372.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1170x567.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-585x284.png 585w" data-lazy-sizes="(max-width: 1366px) 100vw, 1366px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png" />
</picture>
<noscript><picture class="wp-image-37860" title="EKS Cluster Configuration">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png.webp 1366w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1024x496.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-768x372.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1170x567.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-585x284.png.webp 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
<img width="1366" height="662" src="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png" alt="EKS Cluster Configuration" srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration.png 1366w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1024x496.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-768x372.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-1170x567.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Configuration-585x284.png 585w" sizes="(max-width: 1366px) 100vw, 1366px"/>
</picture>
</noscript></a><figcaption>EKS Cluster Configuration</figcaption></figure></div> <p>Click the 'Add Node Group' to configure the worker nodes.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37861" title="Click &#039;Add Node Group&#039;">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png.webp 1354w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-300x146.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1024x500.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-768x375.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1170x571.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-585x286.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201354%20661&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1354px) 100vw, 1354px" />
<img width="1354" height="661" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201354%20661&#039;%3E%3C/svg%3E" alt="Click &#039;Add Node Group&#039;" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png 1354w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-300x146.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1024x500.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-768x375.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1170x571.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-585x286.png 585w" data-lazy-sizes="(max-width: 1354px) 100vw, 1354px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png" />
</picture>
<noscript><picture class="wp-image-37861" title="Click &#039;Add Node Group&#039;">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png.webp 1354w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-300x146.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1024x500.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-768x375.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1170x571.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-585x286.png.webp 585w" sizes="(max-width: 1354px) 100vw, 1354px"/>
<img width="1354" height="661" src="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png" alt="Click &#039;Add Node Group&#039;" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group.png 1354w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-300x146.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1024x500.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-768x375.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-1170x571.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-Add-Node-Group-585x286.png 585w" sizes="(max-width: 1354px) 100vw, 1354px"/>
</picture>
</noscript></a><figcaption>Click 'Add Node Group'</figcaption></figure></div> <p>In the 'Configure Node Group' page, we are naming the node group as 'ostechnix_workers'. Select the IAM role; if not created the IAM role for worker nodes, get into the IAM console and create.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37862" title="Select IAM role">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png.webp 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-300x141.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1024x482.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-768x361.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1170x550.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-585x275.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201346%20633&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1346px) 100vw, 1346px" />
<img width="1346" height="633" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201346%20633&#039;%3E%3C/svg%3E" alt="Select IAM role" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-300x141.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1024x482.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-768x361.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1170x550.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-585x275.png 585w" data-lazy-sizes="(max-width: 1346px) 100vw, 1346px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png" />
</picture>
<noscript><picture class="wp-image-37862" title="Select IAM role">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png.webp 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-300x141.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1024x482.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-768x361.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1170x550.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-585x275.png.webp 585w" sizes="(max-width: 1346px) 100vw, 1346px"/>
<img width="1346" height="633" src="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png" alt="Select IAM role" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role.png 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-300x141.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1024x482.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-768x361.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-1170x550.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Select-IAM-role-585x275.png 585w" sizes="(max-width: 1346px) 100vw, 1346px"/>
</picture>
</noscript></a><figcaption>Select IAM role</figcaption></figure></div> <p>In the previous step(1.1), we have created the IAM role. Refresh the role and select the role for worker nodes. Click 'next' at the bottom to proceed.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37863" title="Configure Node Group">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png.webp 1349w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-300x143.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1024x489.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-768x367.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1170x559.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-585x279.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201349%20644&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1349px) 100vw, 1349px" />
<img width="1349" height="644" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201349%20644&#039;%3E%3C/svg%3E" alt="Configure Node Group" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png 1349w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-300x143.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1024x489.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-768x367.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1170x559.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-585x279.png 585w" data-lazy-sizes="(max-width: 1349px) 100vw, 1349px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png" />
</picture>
<noscript><picture class="wp-image-37863" title="Configure Node Group">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png.webp 1349w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-300x143.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1024x489.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-768x367.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1170x559.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-585x279.png.webp 585w" sizes="(max-width: 1349px) 100vw, 1349px"/>
<img width="1349" height="644" src="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png" alt="Configure Node Group" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group.png 1349w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-300x143.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1024x489.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-768x367.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-1170x559.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Configure-Node-Group-585x279.png 585w" sizes="(max-width: 1349px) 100vw, 1349px"/>
</picture>
</noscript></a><figcaption>Configure Node Group</figcaption></figure></div> <p>In the next page you will get 'Set compute and scaling configuration' where you can configure the EC2 instance type and scaling options.</p> <p><strong>Node Group Compute Configuration</strong></p> <p>Here I am selecting On-demand Linux 't3.micro' instances with disk size 20GB.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37864" title="Set compute and scaling configuration">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png.webp 1350w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-300x147.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1024x501.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-768x375.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1170x572.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-585x286.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201350%20660&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1350px) 100vw, 1350px" />
<img width="1350" height="660" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201350%20660&#039;%3E%3C/svg%3E" alt="Set compute and scaling configuration" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png 1350w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-300x147.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1024x501.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-768x375.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1170x572.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-585x286.png 585w" data-lazy-sizes="(max-width: 1350px) 100vw, 1350px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png" />
</picture>
<noscript><picture class="wp-image-37864" title="Set compute and scaling configuration">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png.webp 1350w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-300x147.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1024x501.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-768x375.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1170x572.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-585x286.png.webp 585w" sizes="(max-width: 1350px) 100vw, 1350px"/>
<img width="1350" height="660" src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png" alt="Set compute and scaling configuration" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration.png 1350w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-300x147.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1024x501.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-768x375.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-1170x572.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Compute-Configuration-585x286.png 585w" sizes="(max-width: 1350px) 100vw, 1350px"/>
</picture>
</noscript></a><figcaption>Set compute and scaling configuration</figcaption></figure></div> <p><strong>Node Group scaling configuration</strong></p> <p>Here you can configure Minimum size, Maximum size and Desired size of the Nodes.</p> <p><strong>Node Group update configuration</strong></p> <p>Here you can configure the maximum number of nodes in count or percentage that can be tolerated during the node group version update.</p> <p>Once done all the configuration, click 'next' to proceed further.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37865" title="Node Group Configuration">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png.webp 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-300x142.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1024x484.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-768x363.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1170x553.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-585x276.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201346%20636&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1346px) 100vw, 1346px" />
<img width="1346" height="636" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201346%20636&#039;%3E%3C/svg%3E" alt="Node Group Configuration" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-300x142.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1024x484.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-768x363.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1170x553.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-585x276.png 585w" data-lazy-sizes="(max-width: 1346px) 100vw, 1346px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png" />
</picture>
<noscript><picture class="wp-image-37865" title="Node Group Configuration">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png.webp 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-300x142.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1024x484.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-768x363.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1170x553.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-585x276.png.webp 585w" sizes="(max-width: 1346px) 100vw, 1346px"/>
<img width="1346" height="636" src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png" alt="Node Group Configuration" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration.png 1346w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-300x142.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1024x484.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-768x363.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-1170x553.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Configuration-585x276.png 585w" sizes="(max-width: 1346px) 100vw, 1346px"/>
</picture>
</noscript></a><figcaption>Node Group Configuration</figcaption></figure></div> <p>In this page, review all the configuration we set up in the previous steps and click 'create' at the bottom to confirm Node group creation.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37866" title="Node Group Created">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png.webp 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1024x496.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-768x372.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1170x566.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-585x283.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201353%20655&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1353px) 100vw, 1353px" />
<img width="1353" height="655" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201353%20655&#039;%3E%3C/svg%3E" alt="Node Group Created" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1024x496.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-768x372.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1170x566.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-585x283.png 585w" data-lazy-sizes="(max-width: 1353px) 100vw, 1353px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png" />
</picture>
<noscript><picture class="wp-image-37866" title="Node Group Created">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png.webp 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-300x145.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1024x496.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-768x372.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1170x566.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-585x283.png.webp 585w" sizes="(max-width: 1353px) 100vw, 1353px"/>
<img width="1353" height="655" src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png" alt="Node Group Created" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created.png 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-300x145.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1024x496.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-768x372.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-1170x566.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Created-585x283.png 585w" sizes="(max-width: 1353px) 100vw, 1353px"/>
</picture>
</noscript></a><figcaption>Node Group Created</figcaption></figure></div> <p>Node Group creation will take a few minutes to complete.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37867" title="Node Group Creation in progress">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png.webp 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-300x146.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1024x498.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-768x374.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1170x569.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-585x285.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201352%20658&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1352px) 100vw, 1352px" />
<img width="1352" height="658" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201352%20658&#039;%3E%3C/svg%3E" alt="Node Group Creation in progress" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-300x146.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1024x498.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-768x374.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1170x569.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-585x285.png 585w" data-lazy-sizes="(max-width: 1352px) 100vw, 1352px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png" />
</picture>
<noscript><picture class="wp-image-37867" title="Node Group Creation in progress">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png.webp 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-300x146.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1024x498.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-768x374.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1170x569.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-585x285.png.webp 585w" sizes="(max-width: 1352px) 100vw, 1352px"/>
<img width="1352" height="658" src="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png" alt="Node Group Creation in progress" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress.png 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-300x146.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1024x498.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-768x374.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-1170x569.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Node-Group-Creation-in-progress-585x285.png 585w" sizes="(max-width: 1352px) 100vw, 1352px"/>
</picture>
</noscript></a><figcaption>Node Group Creation in progress</figcaption></figure></div> <p>Once created, you can verify the Node Group and nodes available in that group.</p> <p>Go to Amazon console 🡪 EKS 🡪 Clusters 🡪 ostechnix 🡪 Configuration 🡪 Compute 🡪 Node Group 🡪 Nodes.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37868" title="EKS Cluster Worker Nodes">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png.webp 1345w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-300x142.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1024x483.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-768x363.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1170x552.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-585x276.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201345%20635&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1345px) 100vw, 1345px" />
<img width="1345" height="635" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201345%20635&#039;%3E%3C/svg%3E" alt="EKS Cluster Worker Nodes" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png 1345w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-300x142.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1024x483.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-768x363.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1170x552.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-585x276.png 585w" data-lazy-sizes="(max-width: 1345px) 100vw, 1345px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png" />
</picture>
<noscript><picture class="wp-image-37868" title="EKS Cluster Worker Nodes">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png.webp 1345w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-300x142.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1024x483.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-768x363.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1170x552.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-585x276.png.webp 585w" sizes="(max-width: 1345px) 100vw, 1345px"/>
<img width="1345" height="635" src="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png" alt="EKS Cluster Worker Nodes" srcset="https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes.png 1345w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-300x142.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1024x483.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-768x363.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-1170x552.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/EKS-Cluster-Worker-Nodes-585x276.png 585w" sizes="(max-width: 1345px) 100vw, 1345px"/>
</picture>
</noscript></a><figcaption>EKS Cluster Worker Nodes</figcaption></figure></div> <p>Verify the same in the CLI using kubectl command.</p> <pre class="wp-block-preformatted">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="67150808132708141302040f090e1f">[email&#160;protected]</a> ~]# kubectl get nodes
NAME                                          STATUS   ROLES    AGE     VERSION
<strong><mark style="background-color:#fcb900" class="has-inline-color">ip-172-31-15-64.ap-south-1.compute.internal</mark></strong>   Ready    &lt;none&gt;   2m11s   v1.21.5-eks-9017834
<mark style="background-color:#fcb900" class="has-inline-color"><strong>ip-172-31-27-30.ap-south-1.compute.internal</strong></mark>   Ready    &lt;none&gt;   115s    v1.21.5-eks-9017834</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37869" title="Get node list">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png.webp 725w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-300x52.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-585x102.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20725%20126&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 725px) 100vw, 725px" />
<img width="725" height="126" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20725%20126&#039;%3E%3C/svg%3E" alt="Get node list" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png 725w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-300x52.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-585x102.png 585w" data-lazy-sizes="(max-width: 725px) 100vw, 725px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png" />
</picture>
<noscript><picture class="wp-image-37869" title="Get node list">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png.webp 725w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-300x52.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-585x102.png.webp 585w" sizes="(max-width: 725px) 100vw, 725px"/>
<img width="725" height="126" src="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png" alt="Get node list" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list.png 725w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-300x52.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Get-node-list-585x102.png 585w" sizes="(max-width: 725px) 100vw, 725px"/>
</picture>
</noscript></a><figcaption>Get node list</figcaption></figure></div> <h2 id="2-delete-the-cluster" class="ftwp-heading">2. Delete the Cluster</h2> <p>Go to Amazon Console 🡪 EKS🡪 Clusters.</p> <p>Click the cluster name that you want to delete.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37870" title="Click EKS cluster name">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png.webp 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1024x524.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-768x393.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1170x598.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-585x299.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201365%20698&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1365px) 100vw, 1365px" />
<img width="1365" height="698" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201365%20698&#039;%3E%3C/svg%3E" alt="Click EKS cluster name" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1024x524.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-768x393.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-585x299.png 585w" data-lazy-sizes="(max-width: 1365px) 100vw, 1365px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png" />
</picture>
<noscript><picture class="wp-image-37870" title="Click EKS cluster name">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png.webp 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-300x153.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1024x524.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-768x393.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1170x598.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-585x299.png.webp 585w" sizes="(max-width: 1365px) 100vw, 1365px"/>
<img width="1365" height="698" src="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png" alt="Click EKS cluster name" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name.png 1365w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1024x524.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-768x393.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Click-EKS-cluster-name-585x299.png 585w" sizes="(max-width: 1365px) 100vw, 1365px"/>
</picture>
</noscript></a><figcaption>Click EKS cluster name</figcaption></figure></div> <p>Before deleting the cluster, you need to delete the node groups associated with that cluster.</p> <p>Once you get into the cluster, click 'Configuration' and then click 'Compute'. Select the Node Group and click 'Delete'.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37871" title="Choose And Delete Node Groups">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png.webp 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-300x147.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1024x501.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-768x376.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1170x573.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-585x286.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201352%20662&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1352px) 100vw, 1352px" />
<img width="1352" height="662" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201352%20662&#039;%3E%3C/svg%3E" alt="Choose And Delete Node Groups" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-300x147.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1024x501.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-768x376.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1170x573.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-585x286.png 585w" data-lazy-sizes="(max-width: 1352px) 100vw, 1352px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png" />
</picture>
<noscript><picture class="wp-image-37871" title="Choose And Delete Node Groups">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png.webp 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-300x147.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1024x501.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-768x376.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1170x573.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-585x286.png.webp 585w" sizes="(max-width: 1352px) 100vw, 1352px"/>
<img width="1352" height="662" src="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png" alt="Choose And Delete Node Groups" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups.png 1352w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-300x147.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1024x501.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-768x376.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-1170x573.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Choose-Node-Groups-585x286.png 585w" sizes="(max-width: 1352px) 100vw, 1352px"/>
</picture>
</noscript></a><figcaption>Choose And Delete Node Groups</figcaption></figure></div> <p>You will get this confirmation page to delete the Node Group. Type the name of the Group and Delete.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37872" title="Delete Node Group Confirmation">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png.webp 491w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation-276x300.png.webp 276w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20491%20533&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 491px) 100vw, 491px" />
<img width="491" height="533" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20491%20533&#039;%3E%3C/svg%3E" alt="Delete Node Group Confirmation" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png 491w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation-276x300.png 276w" data-lazy-sizes="(max-width: 491px) 100vw, 491px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png" />
</picture>
<noscript><picture class="wp-image-37872" title="Delete Node Group Confirmation">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png.webp 491w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation-276x300.png.webp 276w" sizes="(max-width: 491px) 100vw, 491px"/>
<img width="491" height="533" src="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png" alt="Delete Node Group Confirmation" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation.png 491w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Node-Group-Confirmation-276x300.png 276w" sizes="(max-width: 491px) 100vw, 491px"/>
</picture>
</noscript></a><figcaption>Delete Node Group Confirmation</figcaption></figure></div> <p>Once you deleted the Node Group, verify no Node Group is available and proceed deleting the Cluster.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37874" title="Delete Cluster">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png.webp 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-300x147.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1024x501.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-768x376.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1170x572.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-585x286.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201353%20662&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1353px) 100vw, 1353px" />
<img width="1353" height="662" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201353%20662&#039;%3E%3C/svg%3E" alt="Delete Cluster" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-300x147.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1024x501.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-768x376.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1170x572.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-585x286.png 585w" data-lazy-sizes="(max-width: 1353px) 100vw, 1353px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png" />
</picture>
<noscript><picture class="wp-image-37874" title="Delete Cluster">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png.webp 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-300x147.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1024x501.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-768x376.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1170x572.png.webp 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-585x286.png.webp 585w" sizes="(max-width: 1353px) 100vw, 1353px"/>
<img width="1353" height="662" src="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png" alt="Delete Cluster" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster.png 1353w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-300x147.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1024x501.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-768x376.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-1170x572.png 1170w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-585x286.png 585w" sizes="(max-width: 1353px) 100vw, 1353px"/>
</picture>
</noscript></a><figcaption>Delete Cluster</figcaption></figure></div> <p>Once you click the Delete Cluster, you will get this confirmation page, enter the cluster name and hit Delete button.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37876" title="Delete Cluster Confirmation Box">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png.webp 485w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box-300x158.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20485%20256&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 485px) 100vw, 485px" />
<img width="485" height="256" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20485%20256&#039;%3E%3C/svg%3E" alt="Delete Cluster Confirmation Box" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png 485w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box-300x158.png 300w" data-lazy-sizes="(max-width: 485px) 100vw, 485px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png" />
</picture>
<noscript><picture class="wp-image-37876" title="Delete Cluster Confirmation Box">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png.webp 485w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box-300x158.png.webp 300w" sizes="(max-width: 485px) 100vw, 485px"/>
<img width="485" height="256" src="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png" alt="Delete Cluster Confirmation Box" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box.png 485w, https://ostechnix.com/wp-content/uploads/2022/02/Delete-Cluster-Confirmation-Box-300x158.png 300w" sizes="(max-width: 485px) 100vw, 485px"/>
</picture>
</noscript></a><figcaption>Delete Cluster Confirmation Box</figcaption></figure></div> <h2 id="conclusion" class="ftwp-heading">Conclusion</h2> <p>In this article, we have gone through in detail about the EKS cluster provisioning in AWS cloud. We will have a detailed procedure of EKS cluster provisioning through EKS CLI in the next article.</p> <p><strong>Resource:</strong></p> <ul><li><strong><a href="https://docs.aws.amazon.com/eks/latest/userguide/create-managed-node-group.html" target="_blank" rel="noreferrer noopener">https://docs.aws.amazon.com/eks/latest/userguide/create-managed-node-group.html</a></strong></li></ul> </div> <div class="penci-single-link-pages"> </div> <div class="post-tags"> <a href="https://ostechnix.com/tag/add-worker-nodes-to-eks-cluster/" rel="tag">Add worker nodes to EKS Cluster</a><a href="https://ostechnix.com/tag/amazon-ec2/" rel="tag">Amazon EC2</a><a href="https://ostechnix.com/tag/amazon-eks/" rel="tag">Amazon EKS</a><a href="https://ostechnix.com/tag/amazon-elastic-kubernetes-service/" rel="tag">Amazon Elastic Kubernetes Service</a><a href="https://ostechnix.com/tag/amazon-web-services/" rel="tag">Amazon Web Services</a><a href="https://ostechnix.com/tag/aws/" rel="tag">AWS</a><a href="https://ostechnix.com/tag/aws-cli/" rel="tag">AWS CLI</a><a href="https://ostechnix.com/tag/aws-cloud/" rel="tag">AWS Cloud</a><a href="https://ostechnix.com/tag/cloud/" rel="tag">Cloud</a><a href="https://ostechnix.com/tag/devops/" rel="tag">DevOps</a><a href="https://ostechnix.com/tag/ec2/" rel="tag">EC2</a><a href="https://ostechnix.com/tag/eks/" rel="tag">EKS</a><a href="https://ostechnix.com/tag/elastic-kubernetes-service/" rel="tag">Elastic Kubernetes Service</a><a href="https://ostechnix.com/tag/it-automation/" rel="tag">IT Automation</a><a href="https://ostechnix.com/tag/k8s/" rel="tag">K8s</a><a href="https://ostechnix.com/tag/kube/" rel="tag">Kube</a><a href="https://ostechnix.com/tag/kubectl/" rel="tag">Kubectl</a><a href="https://ostechnix.com/tag/kubernetes/" rel="tag">Kubernetes</a><a href="https://ostechnix.com/tag/kubernetes-cluster/" rel="tag">Kubernetes cluster</a><a href="https://ostechnix.com/tag/kubernetes-series/" rel="tag">Kubernetes series</a><a href="https://ostechnix.com/tag/kubernetes-tutorial/" rel="tag">Kubernetes tutorial</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a> </div> </div> </div> <div class="tags-share-box single-post-share tags-share-box-s1 center-box social-align-default"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">1</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="37852" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster%20-%20https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;title=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;title=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster %0A%0A https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fadd-worker-nodes-to-amazon-eks-cluster%2F&#038;text=How%20To%20Add%20Worker%20Nodes%20To%20Amazon%20EKS%20Cluster"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#0d327e786f67686e793045627a283f3d5962283f3d4c6969283f3d5a627f66687f283f3d436269687e283f3d5962283f3d4c606c776263283f3d48465e283f3d4e61787e79687f2b2e3d3e35364f424954306579797d7e372222627e79686e65636475236e6260226c6969207a627f66687f20636269687e207962206c606c7762632068667e206e61787e79687f22"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-author abio-style-1 bioimg-round"> <div class="author-img"> <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/5ac6dfad85a7f07d5ce175ae36d17c18?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' data-lazy-src="https://secure.gravatar.com/avatar/5ac6dfad85a7f07d5ce175ae36d17c18?s=100&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/5ac6dfad85a7f07d5ce175ae36d17c18?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/5ac6dfad85a7f07d5ce175ae36d17c18?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100'/></noscript> </div> <div class="author-content"> <h5><a href="https://ostechnix.com/author/mohansivam/" title="Author M.S.M. Sivam" rel="author">M.S.M. Sivam</a></h5> <p>Solution Architect - BigData Infrastructure in one of the Leading MNC. Highly passionate about BigData and Cloud Technologies.</p> <div class="bio-social"> <a rel="noreferrer" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fas fa-globe"></i></a> </div> </div> </div> <div class="post-pagination"> <div class="prev-post"> <div class="prev-post-inner"> <div class="prev-post-title"> <span>Previous post</span> </div> <a href="https://ostechnix.com/create-gui-dialog-boxes-in-bash-scripts-with-whiptail/"> <div class="pagi-text"> <h5 class="prev-title">How To Create GUI Dialog Boxes In Bash Scripts With Whiptail In Linux</h5> </div> </a> </div> </div> </div> <div class="post-related"> <div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div> <div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/12/Install-Kubernetes-Cluster-Using-Kubeadm-585x390.jpg" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/install-kubernetes-cluster-using-kubeadm/" title="Install Kubernetes Cluster Using Kubeadm In RHEL, CentOS, AlmaLinux, Rocky Linux"> </a> <h3> <a href="https://ostechnix.com/install-kubernetes-cluster-using-kubeadm/">Install Kubernetes Cluster Using Kubeadm In RHEL, CentOS,...</a> </h3> <span class="date"><time class="entry-date published" datetime="2021-12-27T18:18:03+05:30">December 27, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/11/Introduction-to-Kubernetes-585x390.jpg" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/introduction-to-kubernetes/" title="Introduction to Kubernetes | What is Kubernetes"> </a> <h3> <a href="https://ostechnix.com/introduction-to-kubernetes/">Introduction to Kubernetes | What is Kubernetes</a> </h3> <span class="date"><time class="entry-date published" datetime="2021-11-23T17:37:42+05:30">November 23, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2022/02/Kubernetes-Pods-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/kubernetes-pods/" title="How To Create And Manage Kubernetes Pods In Linux"> </a> <h3> <a href="https://ostechnix.com/kubernetes-pods/">How To Create And Manage Kubernetes Pods In...</a> </h3> <span class="date"><time class="entry-date published" datetime="2022-02-04T18:52:36+05:30">February 4, 2022</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2022/02/Introduction-To-Amazon-EKS-Elastic-Kubernetes-Service-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/introduction-to-amazon-eks-elastic-kubernetes-service/" title="Introduction To Amazon EKS (Elastic Kubernetes Service)"> </a> <h3> <a href="https://ostechnix.com/introduction-to-amazon-eks-elastic-kubernetes-service/">Introduction To Amazon EKS (Elastic Kubernetes Service)</a> </h3> <span class="date"><time class="entry-date published" datetime="2022-02-16T14:14:50+05:30">February 16, 2022</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/12/Kubernetes-Features-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/kubernetes-features/" title="Kubernetes Features Explained In Detail"> </a> <h3> <a href="https://ostechnix.com/kubernetes-features/">Kubernetes Features Explained In Detail</a> </h3> <span class="date"><time class="entry-date published" datetime="2021-12-09T16:14:22+05:30">December 9, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2022/02/Deploy-Kubernetes-Cluster-With-Amazon-EKS-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/deploy-kubernetes-cluster-on-aws-with-amazon-eks/" title="How To Deploy Kubernetes Cluster On AWS With Amazon EKS"> </a> <h3> <a href="https://ostechnix.com/deploy-kubernetes-cluster-on-aws-with-amazon-eks/">How To Deploy Kubernetes Cluster On AWS With...</a> </h3> <span class="date"><time class="entry-date published" datetime="2022-02-21T13:21:31+05:30">February 21, 2022</time></span> </div> </div></div> <div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"> <div id="respond" class="comment-respond"> <h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/add-worker-nodes-to-amazon-eks-cluster/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" placeholder="Name*" size="30" aria-required='true' /></p> <p class="comment-form-email"><input id="email" name="email" type="text" placeholder="Email*" size="30" aria-required='true' /></p> <p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p> <div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='37852' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="201195d990" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="222" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div> <p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> </article> </div> </div> <div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right penci-sticky-sidebar"> <div class="theiaStickySidebar"> <aside id="penci_social_widget-1" class="widget penci_social_widget"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Networks</span></h3> <div class="widget-social pc_aligncenter show-text remove-circle penci-social-textcolored"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 14px"></i> <span style="font-size: 14px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 14px"></i> <span style="font-size: 14px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 14px"></i> <span style="font-size: 14px">Linkedin</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 14px"></i> <span style="font-size: 14px">Reddit</span></a> </div> </aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"> <p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p> <p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..." /><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p> <input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6186167963" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside> </div> </div> </div> </div> </div> <div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div> <div class="clear-footer"></div> <div id="widget-area"> <div class="container"> <div class="footer-widget-wrapper footer-widget-style-10"> <aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4> <div class="textwidget"><p><a href="https://ostechnix.com/"><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 340px) 100vw, 340px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" alt="Ostechnix Footer Logo" width="340" height="68" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-lazy-sizes="(max-width: 340px) 100vw, 340px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" />
</picture>
<noscript><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" sizes="(max-width: 340px) 100vw, 340px"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px"/>
</picture>
</noscript></a></p> <p>&nbsp;</p> <p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p> </div> </aside><aside id="penci_social_widget-2" class="widget penci_social_widget"> <div class="widget-social pc_aligncenter remove-circle"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 18px"></i> <span style="font-size: 13px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 18px"></i> <span style="font-size: 13px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 18px"></i> <span style="font-size: 13px">Linkedin</span></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube" style="font-size: 18px"></i> <span style="font-size: 13px">Youtube</span></a> <a href="/cdn-cgi/l/email-protection#0a63646c654a65797e6f696264637224696567" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope" style="font-size: 18px"></i> <span style="font-size: 13px">Email</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 18px"></i> <span style="font-size: 13px">Reddit</span></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss" style="font-size: 18px"></i> <span style="font-size: 13px">Rss</span></a> </div> </aside> </div> <div class="footer-widget-wrapper footer-widget-style-10 last"> <aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-8554" class="side-newsfeed display-order-numbers"> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">1</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" title="How To Fix Busybox Initramfs Error On Ubuntu"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu"> How To Fix Busybox Initramfs Error On Ubuntu </a> </h4> <div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/01/Allow-Or-Deny-SSH-Access-To-A-Particular-User-Or-Group-In-Linux-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/allow-deny-ssh-access-particular-user-group-linux/" title="How To Allow Or Deny SSH Access To A Particular User Or Group In Linux"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/allow-deny-ssh-access-particular-user-group-linux/" rel="bookmark" title="How To Allow Or Deny SSH Access To A Particular User Or Group In Linux"> How To Allow Or Deny SSH Access To A Particular User Or Group In Linux </a> </h4> <div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2021-01-13T18:30:02+05:30">January 13, 2021</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners"> Youtube-dl Tutorial With Examples For Beginners </a> </h4> <div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span> </div> </div> </div> </li> </ul> </aside> </div> </div> </div> <footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter"> <div class="container"> <div class="footer-logo-copyright footer-not-logo footer-not-gotop"> <div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li> <li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> <li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li> <li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li> <li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li> </ul> </div> <div id="footer-copyright"> <p>OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p> </div> </div> </div> </footer> </div> <div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div> <a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fas fa-times"></i></a> <nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div id="sidebar-nav-logo"> <a href="https://ostechnix.com/"><picture>
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" width="250" height="52" alt="OSTechNix" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" />
</picture>
<noscript><picture>
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" width="250" height="52" alt="OSTechNix"/>
</picture>
</noscript></a> </div> <div class="header-social sidebar-nav-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#244d4a424b644b575041474c4a4d5c0a474b49" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> <div class="penci-hbg-search-box penci-vernav-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <ul id="menu-header-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul> </nav> <div class="penci-menu-hbg-overlay"></div> <div class="penci-menu-hbg penci-vernav-hide penci-menu-hbg-left"> <div class="penci-menu-hbg-inner"> <a id="penci-close-hbg"><i class="penci-faicon fas fa-times"></i></a> <div class="penci-hbg-header"> <div class="penci-hbg-logo site-branding"> <a href="https://ostechnix.com/"><picture class="penci-lazy">
<source type="image/webp" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img width="350" height="73" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" />
</picture>
</a> </div> </div> <div class="penci-hbg-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <div class="penci-hbg-content penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right"> <ul id="menu-top-menu-1" class="menu menu-hgb-main"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul> </div> <div class="penci-hbg-footer"> <div class="penci_menu_hbg_ftext">OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</div> <div class="header-social sidebar-nav-social penci-hbg-social-style-4 penci-social-colored"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#741d1a121b341b070011171c1a1d0c5a171b19" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> </div> </div> </div> <div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"> <div class="penci-gprd-law"> <p> This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a> </p> </div> </div> <!--[if lte IE 9]> <script> 'use strict'; (function($) { $(document).ready(function() { $('#ftwp-container').addClass('ftwp-ie9'); }); })(jQuery); </script> <![endif]--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.youtube.com/iframe_api' id='youtube-api-js' defer></script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/penci-shortcodes/assets/play.js?ver=1645613043' id='penci-play-js-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script> <script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/ullavidu\/|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/ostechnix.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/penci-lazy.js?ver=1645613043' id='pc-lazy-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/themes/soledad/js/libs-script.min.js' id='penci-libs-js-js' defer></script> <script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"338175f2a6","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/main.js?ver=1645613043' id='main-scripts-js' defer></script> <script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"338175f2a6","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/post-like.js?ver=1645613043' id='penci_ajax_like_post-js' defer></script> <script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"338175f2a6","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/more-post.js?ver=1645613043' id='penci_ajax_more_posts-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script> <script type='text/javascript' id='fixedtoc-js-js-extra'>
/* <![CDATA[ */
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js' id='fixedtoc-js-js' defer></script> <script src='https://stats.wp.com/e-202208.js' defer></script> <script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6',blog:'84551477',post:'37852',tz:'5.5',srv:'ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '37852' ]);
</script> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">
	function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(37852, 'https://ostechnix.com');
</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ostechnix.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script> <script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-75259810-1');
</script> <script type="rocketlazyloadscript">"use strict";function wprRemoveCPCSS(){var preload_stylesheets=document.querySelectorAll('link[data-rocket-async="style"][rel="preload"]');if(preload_stylesheets&&0<preload_stylesheets.length)for(var stylesheet_index=0;stylesheet_index<preload_stylesheets.length;stylesheet_index++){var media=preload_stylesheets[stylesheet_index].getAttribute("media")||"all";if(window.matchMedia(media).matches)return void setTimeout(wprRemoveCPCSS,200)}var elem=document.getElementById("rocket-critical-css");elem&&"remove"in elem&&elem.remove()}window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel='stylesheet' id='wp-block-library-css' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all'/><link rel='stylesheet' id='mediaelement-css' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all'/><link rel='stylesheet' id='wp-mediaelement-css' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all'/><link rel='stylesheet' id='penci-soledad-parent-style-css' href='https://ostechnix.com/wp-content/themes/soledad/style.css' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-main-style-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-awesomeold-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-awesome-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci_icon-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1645613043' type='text/css' media='all'/><link rel='stylesheet' id='penci_style-css' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci_social_counter-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/social-counter.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='fixedtoc-style-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='jetpack_css-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1645613043' type='text/css' media='all'/></noscript>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6e2a8d51ad1d5722","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body> </html>
