<!DOCTYPE html> <html lang="en-US"> <head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name="viewport" content="width=device-width, initial-scale=1"> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon" /> <link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png"> <link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/" /> <link rel="pingback" href="https://ostechnix.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--> <link rel='preconnect' href='https://fonts.googleapis.com' /> <link rel='preconnect' href='https://fonts.gstatic.com' /> <meta http-equiv='x-dns-prefetch-control' content='on'> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//fonts.gstatic.com' /> <link rel='dns-prefetch' href='//s.gravatar.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <title>Move Home Directory To New Partition Or Drive In Linux - OSTechNix</title><style id="rocket-critical-css">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</style><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%26amp%3Bsubset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"/></noscript> <meta name="description" content="This step by step article will walk you through the procedure to move home directory to new partition or drive in Linux." /> <link rel="canonical" href="https://ostechnix.com/move-home-directory-to-new-partition-in-linux/" /> <meta property="og:locale" content="en_US" /> <meta property="og:type" content="article" /> <meta property="og:title" content="Move Home Directory To New Partition Or Drive In Linux - OSTechNix" /> <meta property="og:description" content="This step by step article will walk you through the procedure to move home directory to new partition or drive in Linux." /> <meta property="og:url" content="https://ostechnix.com/move-home-directory-to-new-partition-in-linux/" /> <meta property="og:site_name" content="OSTechNix" /> <meta property="article:publisher" content="https://www.facebook.com/ostechnix/" /> <meta property="article:published_time" content="2022-02-28T13:56:04+00:00" /> <meta property="article:modified_time" content="2022-02-28T16:14:25+00:00" /> <meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2022/02/Move-Home-Directory-To-New-Partition-In-Linux.png" /> <meta property="og:image:width" content="1280" /> <meta property="og:image:height" content="720" /> <meta property="og:image:type" content="image/png" /> <meta name="twitter:card" content="summary" /> <meta name="twitter:creator" content="@ostechnix" /> <meta name="twitter:site" content="@ostechnix" /> <meta name="twitter:label1" content="Written by" /> <meta name="twitter:data1" content="Karthick" /> <meta name="twitter:label2" content="Est. reading time" /> <meta name="twitter:data2" content="8 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ostechnix.com/#organization","name":"OSTechNix","url":"https://ostechnix.com/","sameAs":["https://www.facebook.com/ostechnix/","https://www.instagram.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","@id":"https://ostechnix.com/#logo","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png","width":350,"height":73,"caption":"OSTechNix"},"image":{"@id":"https://ostechnix.com/#logo"}},{"@type":"WebSite","@id":"https://ostechnix.com/#website","url":"https://ostechnix.com/","name":"OSTechNix","description":"Open Source | Technology | Linux And Unix","publisher":{"@id":"https://ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ostechnix.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#primaryimage","inLanguage":"en-US","url":"https://ostechnix.com/wp-content/uploads/2022/02/Move-Home-Directory-To-New-Partition-In-Linux.png","contentUrl":"https://ostechnix.com/wp-content/uploads/2022/02/Move-Home-Directory-To-New-Partition-In-Linux.png","width":1280,"height":720,"caption":"Move Home Directory To New Partition In Linux"},{"@type":"WebPage","@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#webpage","url":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/","name":"Move Home Directory To New Partition Or Drive In Linux - OSTechNix","isPartOf":{"@id":"https://ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#primaryimage"},"datePublished":"2022-02-28T13:56:04+00:00","dateModified":"2022-02-28T16:14:25+00:00","description":"This step by step article will walk you through the procedure to move home directory to new partition or drive in Linux.","breadcrumb":{"@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ostechnix.com/move-home-directory-to-new-partition-in-linux/"]}]},{"@type":"BreadcrumbList","@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://ostechnix.com/"},{"@type":"ListItem","position":2,"name":"How To Move Home Directory To New Partition Or Disk In Linux"}]},{"@type":"Article","@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#article","isPartOf":{"@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#webpage"},"author":{"@id":"https://ostechnix.com/#/schema/person/6a244ab2f41f7b0c256c4c7f41df2c03"},"headline":"How To Move Home Directory To New Partition Or Disk In Linux","datePublished":"2022-02-28T13:56:04+00:00","dateModified":"2022-02-28T16:14:25+00:00","mainEntityOfPage":{"@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#webpage"},"wordCount":1077,"commentCount":0,"publisher":{"@id":"https://ostechnix.com/#organization"},"image":{"@id":"https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#primaryimage"},"thumbnailUrl":"https://ostechnix.com/wp-content/uploads/2022/02/Move-Home-Directory-To-New-Partition-In-Linux.png","keywords":["Linux","Linux administration","Linux basics","Linux commands","Linux howto","Linux partitions","Linux tips","Move HOME directory"],"articleSection":["Almalinux","Linux","Linux Administration","Linux Basics","Linux Commands","Linux Tips &amp; Tricks","Linux troubleshooting","Red Hat Enterprise Linux","Rocky Linux","Unix/Linux Beginners"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ostechnix.com/move-home-directory-to-new-partition-in-linux/#respond"]}]},{"@type":"Person","@id":"https://ostechnix.com/#/schema/person/6a244ab2f41f7b0c256c4c7f41df2c03","name":"Karthick","image":{"@type":"ImageObject","@id":"https://ostechnix.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8ae060a2307a7fc4ebf8920042c1be73?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/8ae060a2307a7fc4ebf8920042c1be73?s=96&d=mm&r=g","caption":"Karthick"},"description":"Karthick is a passionate software engineer who loves to explore new technologies. He is a public speaker and loves writing about technology especially about Linux and opensource.","sameAs":["https://ostechnix.com/"],"url":"https://ostechnix.com/author/karthick/"}]}</script> <link rel='dns-prefetch' href='//www.youtube.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//s.w.org' /> <link rel='dns-prefetch' href='//ajax.cloudflare.com' /> <link rel='dns-prefetch' href='//static.cloudflareinsights.com' /> <link rel='dns-prefetch' href='//stats.wp.com' /> <link rel='dns-prefetch' href='//pixel.wp.com' /> <link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.googletagmanager.com' /> <link rel='dns-prefetch' href='//googleads.g.doubleclick.net' /> <link rel='dns-prefetch' href='//partner.googleadservices.com' /> <link rel='dns-prefetch' href='//adservice.google.com' /> <link rel='dns-prefetch' href='//www.googletagservices.com' /> <link rel='dns-prefetch' href='//www.google-analytics.com' /> <link rel='dns-prefetch' href='//tpc.googlesyndication.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To Move Home Directory To New Partition Or Disk In Linux Comments Feed" href="https://ostechnix.com/move-home-directory-to-new-partition-in-linux/feed/" /> <link rel='preload' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <style id='wp-block-library-inline-css' type='text/css'> .has-text-align-justify{text-align:justify;} </style> <style id='wp-block-library-theme-inline-css' type='text/css'> .wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code>code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group:where(.has-background){padding:1.25em 2.375em}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0} </style> <link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <style id='global-styles-inline-css' type='text/css'>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</style> <link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad/style.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/social-counter.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <style id='fixedtoc-style-inline-css' type='text/css'> .ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); } </style> <link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1645613043' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')" type='text/css' media='all' /> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js' defer></script> <link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/37921" /> <link rel='shortlink' href='https://ostechnix.com/?p=37921' /> <link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;format=xml" /> <style type='text/css'>img#wpstats{display:none}</style> <style id="penci-custom-style" type="text/css">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</style><script type="rocketlazyloadscript">
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "How To Move Home Directory To New Partition Or Disk In Linux",
    "description": "This step by step article will walk you through the procedure to move home directory to new partition or drive in Linux.",
    "datePublished": "2022-02-28",
    "datemodified": "2022-02-28",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/move-home-directory-to-new-partition-in-linux\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2022\/02\/Move-Home-Directory-To-New-Partition-In-Linux.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-Karthick",
        "name": "Karthick",
        "url": "https:\/\/ostechnix.com\/author\/karthick\/"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/linux-administration\/",
                "name": "Linux Administration"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/move-home-directory-to-new-partition-in-linux\/",
                "name": "How To Move Home Directory To New Partition Or Disk In Linux"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" /> <link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" /> <link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script>
</head> <body data-rsssl=1 class="post-template-default single single-post postid-37921 single-format-standard soledad-ver-8-1-2 pclight-mode pcmn-drdw-style-slide_down penci-fawesome-ver5 has-ftoc"> <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="wrapper-boxed header-style-header-3 penci-hlogo-center header-search-style-default"> <div class="penci-header-wrap"><div class="penci-top-bar topbar-menu"> <div class="container"> <div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li> <li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li> <li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li> <li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li> <li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul></div><div class="pctopbar-item penci-topbar-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#4c25222a230c233f38292f24222534622f2321" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div></div> </div> </div> </div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"> <div class="inner-header penci-header-second"> <div class="container align-left-logo has-banner"> <div id="logo"> <a href="https://ostechnix.com/"><picture class="penci-mainlogo">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" alt="OSTechNix" width="350" height="73" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" />
</picture>
<noscript><picture class="penci-mainlogo">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" width="350" height="73"/>
</picture>
</noscript></a> </div> <div class="header-banner header-style-3"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="9496719407" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </div> </div> <div class="sticky-wrapper"> <nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div class="container"> <div class="button-menu-mobile header-3"><svg width=18px height=18px viewBox="0 0 512 384" version=1.1 xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink><g stroke=none stroke-width=1 fill-rule=evenodd><g transform="translate(0.000000, 0.250080)"><rect x=0 y=0 width=512 height=62></rect><rect x=0 y=161 width=512 height=62></rect><rect x=0 y=321 width=512 height=62></rect></g></g></svg></div> <ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul><div id="top-search" class="penci-top-search pcheader-icon top-search-classes"> <a class="search-click"> <i class="penciicon-magnifiying-glass"></i> </a> <div class="show-search"> <form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/"> <div class="pc-searchform-inner"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> <input type="submit" class="searchsubmit" value="Search" /> </div> </form> <a class="search-click close-search"><i class="penciicon-close-button"></i></a> </div> </div> <div class="penci-menuhbg-wapper penci-menu-toggle-wapper"> <a href="#" class="penci-menuhbg-toggle"> <span class="penci-menuhbg-inner"> <i class="lines-button lines-button-double"> <i class="penci-lines"></i> </i> <i class="lines-button lines-button-double penci-hover-effect"> <i class="penci-lines"></i> </i> </span> </a> </div> </div> </nav> </div> </header> </div> <div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt; &lt;!-- New Horizontal Responsive Adv --&gt; &lt;ins class=&quot;adsbygoogle&quot; style=&quot;display:block&quot; data-ad-client=&quot;ca-pub-6701402139964678&quot; data-ad-slot=&quot;9496719407&quot; data-ad-format=&quot;auto&quot; data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt; &lt;script&gt; (adsbygoogle = window.adsbygoogle || []).push({}); &lt;/script&gt;&lt;/div&gt;"> <div class="penci-single-block" data-prev-url="https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/" data-current-url="https://ostechnix.com/move-home-directory-to-new-partition-in-linux/" data-post-title="How To Move Home Directory To New Partition Or Disk In Linux" data-edit-post="" data-postid="37921"> <div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fas fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/linux-administration/">Linux Administration</a></span><i class="penci-faicon fas fa-angle-right"></i> <span>How To Move Home Directory To New Partition Or Disk In Linux</span> </div> <div class="container container-single penci_sidebar penci-enable-lightbox"> <div id="main" class="penci-main-sticky-sidebar"> <div class="theiaStickySidebar"> <article id="post-37921" class="post type-post status-publish"> <div class="header-standard header-classic single-header"> <div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-1145" href="https://ostechnix.com/category/linux-administration/" rel="category tag">Linux Administration</a><a class="penci-cat-name penci-cat-4977" href="https://ostechnix.com/category/linux_distributions/almalinux/" rel="category tag">Almalinux</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-27" href="https://ostechnix.com/category/linux-basics/" rel="category tag">Linux Basics</a><a class="penci-cat-name penci-cat-1055" href="https://ostechnix.com/category/linux-commands/" rel="category tag">Linux Commands</a><a class="penci-cat-name penci-cat-4573" href="https://ostechnix.com/category/linux-tips-tricks/" rel="category tag">Linux Tips &amp; Tricks</a><a class="penci-cat-name penci-cat-5154" href="https://ostechnix.com/category/linux-troubleshooting/" rel="category tag">Linux troubleshooting</a><a class="penci-cat-name penci-cat-45" href="https://ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/" rel="category tag">Red Hat Enterprise Linux</a><a class="penci-cat-name penci-cat-5155" href="https://ostechnix.com/category/linux_distributions/rocky-linux/" rel="category tag">Rocky Linux</a><a class="penci-cat-name penci-cat-1206" href="https://ostechnix.com/category/unixlinux-beginners/" rel="category tag">Unix/Linux Beginners</a></span></div> <h1 class="post-title single-post-title entry-title">How To Move Home Directory To New Partition Or Disk In Linux</h1> <div class="penci-hide-tagupdated"> <span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/karthick/">Karthick</a></span> <time class="entry-date published" datetime="2022-02-28T19:26:04+05:30">February 28, 2022</time> </div> <div class="post-box-meta-single"> <span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/karthick/">Karthick</a></span></span> <span><time class="entry-date published" datetime="2022-02-28T19:26:04+05:30">February 28, 2022</time></span> <span><i class="penci-post-countview-number">133</i> Views</span> </div> </div> <div class="tags-share-box tags-share-box-top single-post-share tags-share-box-s1 center-box social-align-default"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="37921" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/move-home-directory-to-new-partition-in-linux/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux%20-%20https://ostechnix.com/move-home-directory-to-new-partition-in-linux/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;title=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;title=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;text=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#bc83cfc9ded6d9dfc881f4d3cb998e8ce8d3998e8cf1d3cad9998e8cf4d3d1d9998e8cf8d5ced9dfc8d3cec5998e8ce8d3998e8cf2d9cb998e8cecddcec8d5c8d5d3d2998e8cf3ce998e8cf8d5cfd7998e8cf5d2998e8cf0d5d2c9c49a9f8c8f8487fef3f8e581d4c8c8cccf869393d3cfc8d9dfd4d2d5c492dfd3d193d1d3cad991d4d3d1d991d8d5ced9dfc8d3cec591c8d391d2d9cb91ccddcec8d5c8d5d3d291d5d291d0d5d2c9c493"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-entry blockquote-style-2"> <div class="inner-post-entry entry-content" id="penci-post-entry-inner"> <div id="ftwp-postcontent"><p>If you are new to Linux or someone who plans to ditch windows and switch to Linux, then this article will be of great use to you. This step by step article will walk you through the procedure to move home directory to new partition or drive in Linux.</p> <div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item"><a class="ftwp-anchor" href="#introduction"><span class="ftwp-text">Introduction</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#get-partition-information"><span class="ftwp-text">Get Partition Information</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#create-new-partition"><span class="ftwp-text">Create New Partition</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#format-and-mount-the-partition"><span class="ftwp-text">Format and mount the Partition</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#move-home-directory-to-new-partition-in-linux"><span class="ftwp-text">Move Home Directory To New Partition In Linux</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#persistent-mount-using-fstab"><span class="ftwp-text">Persistent Mount Using Fstab</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#partition-home-directory-during-os-installation"><span class="ftwp-text">Partition Home Directory During OS Installation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">Conclusion</span></a></li></ol></nav></div></div><h2 id="introduction" class="ftwp-heading">Introduction</h2> <p>Most beginners when installing Linux operating systems will not care to create different partitions.</p> <div><div class="penci-custom-html-inside-content"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><p>The newbies will usually choose to stick with the default partition where all your file systems (<code>/home</code>, <code>/var</code>, <code>/boot/</code>, <code>/opt</code>, etc.) will be mounted under a single partition. </p> <p>In fact, I also chose the default partition scheme in my early days as a newbie to Linux. When my operating system is crashed I lost all my personal data sitting in <code>/home</code> directory. This is because I just created one partition for my whole disk and mounted everything in that partition.</p> <p>Lesson learned, the best way to protect the data is to create a separate partition for the home directory. So If your machine crashes for any reason, the partition will not be affected unless the entire disk is faulty. </p> <p>Along with separate partitions, it is a best practice to <strong>backup your data</strong> to an external drive. There are many backup tools available for Linux platform. We have published many guides on <strong><a href="https://ostechnix.com/category/backup-tools/" target="_blank" rel="noreferrer noopener">Linux Backup</a></strong> topic. Check the following links and choose the one that suits for your requirement.</p> <div class="wp-container-621d8d3a570ec wp-block-group has-black-color has-text-color has-background" style="background-color:#f4f2d4"><div class="wp-block-group__inner-container"> <p><strong>Linux backup guides:</strong></p> <ul><li><strong><a href="https://ostechnix.com/backup-entire-linux-system-using-rsync/" target="_blank" rel="noreferrer noopener">How To Backup Your Entire Linux System Using Rsync</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-backup-files-and-directories-using-rsync-in-linux/" target="_blank" rel="noreferrer noopener">How To Backup Files And Directories Using Rsync In Linux</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-backup-and-restore-linux-system-with-timeshift/" target="_blank" rel="noreferrer noopener">How To Backup And Restore Linux System With Timeshift</a></strong></li><li><strong><a href="https://ostechnix.com/backup-restore-files-borg-linux/" target="_blank" rel="noreferrer noopener">How To Backup And Restore Files Using BorgBackup In Linux</a></strong></li><li><strong><a href="https://ostechnix.com/vorta-graphical-frontend-for-borgbackup/" target="_blank" rel="noreferrer noopener">Vorta – A Graphical Frontend For BorgBackup</a></strong></li><li><strong><a href="https://ostechnix.com/how-to-backup-and-restore-files-using-deja-dup-in-linux/" target="_blank" rel="noreferrer noopener">How To Backup And Restore Files Using Deja Dup In Linux</a></strong></li><li><strong><a href="https://ostechnix.com/setup-backup-server-using-rsnapshot-linux/" target="_blank" rel="noreferrer noopener">How To Setup Backup Server Using Rsnapshot</a></strong></li><li><strong><a href="https://ostechnix.com/cya-system-snapshot-and-restore-utility-for-linux/" target="_blank" rel="noreferrer noopener">CYA – System Snapshot And Restore Utility For Linux</a></strong></li><li><strong><a href="https://ostechnix.com/restic-fast-secure-efficient-backup-application/" target="_blank" rel="noreferrer noopener">Restic – A Fast, Secure And Efficient Backup Application</a></strong></li><li><strong><a href="https://ostechnix.com/install-rclone-in-linux/" target="_blank" rel="noreferrer noopener">How To Install Rclone In Linux And Unix</a></strong></li></ul> </div></div> <p>For the purpose of this guide, I will be using <strong><a href="https://ostechnix.com/how-to-install-rocky-linux-8/" target="_blank" rel="noreferrer noopener">Rocky Linux</a></strong> virtual machine running in Virtualbox.</p> <h2 id="get-partition-information" class="ftwp-heading">Get Partition Information</h2> <p>We can <strong><a href="https://ostechnix.com/how-to-list-disk-partitions-in-linux/" target="_blank" rel="noreferrer noopener">list disk partition details</a></strong> using various tools in Linux. In this guide, we will use lsblk and fdisk command.</p> <p>To get the block device information using the <code>lsblk</code> command, run:</p> <pre class="wp-block-preformatted">$ lsblk</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37926" title="Display Block Device Information">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png.webp 643w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-300x92.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-585x180.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20643%20198&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 643px) 100vw, 643px" />
<img width="643" height="198" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20643%20198&#039;%3E%3C/svg%3E" alt="Display Block Device Information" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png 643w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-300x92.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-585x180.png 585w" data-lazy-sizes="(max-width: 643px) 100vw, 643px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png" />
</picture>
<noscript><picture class="wp-image-37926" title="Display Block Device Information">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png.webp 643w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-300x92.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-585x180.png.webp 585w" sizes="(max-width: 643px) 100vw, 643px"/>
<img width="643" height="198" src="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png" alt="Display Block Device Information" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information.png 643w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-300x92.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Display-Block-Device-Information-585x180.png 585w" sizes="(max-width: 643px) 100vw, 643px"/>
</picture>
</noscript></a><figcaption>Display Block Device Information</figcaption></figure></div> <p>In my machine I have a 50GB drive (sda). I opted for a default partitioning scheme, so there are two partitions (sda1,sda2) created by the OS installer.</p> <p class="has-black-color has-text-color has-background" style="background-color:#ffdddd"><strong>NOTE:</strong> The drive naming scheme will vary depending upon the type of drive attached to your machine.</p> <p>As stated earlier, we can also use the <code>fdisk</code> command to get the block device information.</p> <pre class="wp-block-preformatted">$ sudo fdisk -l</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37927" title="Check Block Device Information Using Fdisk">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png.webp 828w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-300x178.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-768x454.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-585x346.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20828%20490&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 828px) 100vw, 828px" />
<img width="828" height="490" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20828%20490&#039;%3E%3C/svg%3E" alt="Check Block Device Information Using Fdisk" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png 828w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-300x178.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-768x454.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-585x346.png 585w" data-lazy-sizes="(max-width: 828px) 100vw, 828px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png" />
</picture>
<noscript><picture class="wp-image-37927" title="Check Block Device Information Using Fdisk">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png.webp 828w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-300x178.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-768x454.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-585x346.png.webp 585w" sizes="(max-width: 828px) 100vw, 828px"/>
<img width="828" height="490" src="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png" alt="Check Block Device Information Using Fdisk" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk.png 828w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-300x178.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-768x454.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Check-Block-Device-Information-Using-Fdisk-585x346.png 585w" sizes="(max-width: 828px) 100vw, 828px"/>
</picture>
</noscript></a><figcaption>Check Block Device Information Using Fdisk</figcaption></figure></div> <p>To check under which partition the home directory is mounted, use the <code>df</code> command. In my case, it is mounted under <strong>/</strong>.</p> <pre class="wp-block-preformatted">$ df -h /home

Filesystem           Size  Used Avail Use% Mounted on
<mark style="background-color:#fcb900" class="has-inline-color"><strong>/dev/mapper/rl-root</strong></mark>   46G  2.8G   43G   7% <mark style="background-color:#fcb900" class="has-inline-color"><strong>/</strong></mark></pre> <h2 id="create-new-partition" class="ftwp-heading">Create New Partition</h2> <p>I have inserted one more drive with size 20GB into the virtualbox. The drive is known as <strong>sdb</strong>.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37928" title="View Block Device Details">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png.webp 697w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-300x91.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-585x177.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20697%20211&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 697px) 100vw, 697px" />
<img width="697" height="211" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20697%20211&#039;%3E%3C/svg%3E" alt="View Block Device Details" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png 697w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-300x91.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-585x177.png 585w" data-lazy-sizes="(max-width: 697px) 100vw, 697px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png" />
</picture>
<noscript><picture class="wp-image-37928" title="View Block Device Details">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png.webp 697w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-300x91.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-585x177.png.webp 585w" sizes="(max-width: 697px) 100vw, 697px"/>
<img width="697" height="211" src="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png" alt="View Block Device Details" srcset="https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details.png 697w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-300x91.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/View-Block-Device-Details-585x177.png 585w" sizes="(max-width: 697px) 100vw, 697px"/>
</picture>
</noscript></a><figcaption>View Block Device Details</figcaption></figure></div> <p>Let’s create a new partition from the new drive where the home partition will be mounted. I will be using the <code>fdisk</code> utility to create a partition.</p> <pre class="wp-block-preformatted">$ sudo fdisk /dev/sdb</pre> <p>Type "<code>n</code>" to create a new partition.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37929" title="Create New Partition">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png.webp 746w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-300x88.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-585x173.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20746%20220&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 746px) 100vw, 746px" />
<img width="746" height="220" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20746%20220&#039;%3E%3C/svg%3E" alt="Create New Partition" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png 746w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-300x88.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-585x173.png 585w" data-lazy-sizes="(max-width: 746px) 100vw, 746px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png" />
</picture>
<noscript><picture class="wp-image-37929" title="Create New Partition">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png.webp 746w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-300x88.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-585x173.png.webp 585w" sizes="(max-width: 746px) 100vw, 746px"/>
<img width="746" height="220" src="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png" alt="Create New Partition" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition.png 746w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-300x88.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Create-New-Partition-585x173.png 585w" sizes="(max-width: 746px) 100vw, 746px"/>
</picture>
</noscript></a><figcaption>Create New Partition</figcaption></figure></div> <p>It will prompt you to choose the partition type, partition number, first sector, and last sector. In the last sector, you can give input in terms of GB, PB, TB, etc. I am creating a 10 GB partition, so give input as +10G.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37930" title="Enter Partition Type And Size">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png.webp 870w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-300x68.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-768x173.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-585x132.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20870%20196&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 870px) 100vw, 870px" />
<img width="870" height="196" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20870%20196&#039;%3E%3C/svg%3E" alt="Enter Partition Type And Size" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png 870w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-300x68.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-768x173.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-585x132.png 585w" data-lazy-sizes="(max-width: 870px) 100vw, 870px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png" />
</picture>
<noscript><picture class="wp-image-37930" title="Enter Partition Type And Size">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png.webp 870w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-300x68.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-768x173.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-585x132.png.webp 585w" sizes="(max-width: 870px) 100vw, 870px"/>
<img width="870" height="196" src="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png" alt="Enter Partition Type And Size" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size.png 870w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-300x68.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-768x173.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Enter-Partition-Type-And-Size-585x132.png 585w" sizes="(max-width: 870px) 100vw, 870px"/>
</picture>
</noscript></a><figcaption>Enter Partition Type And Size</figcaption></figure></div> <p>Type "<code>w</code>" and it will write the changes to the partition table.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37931" title="Save Partition Changes">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png.webp 630w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-300x49.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-585x95.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20630%20102&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 630px) 100vw, 630px" />
<img width="630" height="102" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20630%20102&#039;%3E%3C/svg%3E" alt="Save Partition Changes" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png 630w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-300x49.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-585x95.png 585w" data-lazy-sizes="(max-width: 630px) 100vw, 630px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png" />
</picture>
<noscript><picture class="wp-image-37931" title="Save Partition Changes">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png.webp 630w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-300x49.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-585x95.png.webp 585w" sizes="(max-width: 630px) 100vw, 630px"/>
<img width="630" height="102" src="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png" alt="Save Partition Changes" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes.png 630w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-300x49.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Save-Partition-Changes-585x95.png 585w" sizes="(max-width: 630px) 100vw, 630px"/>
</picture>
</noscript></a><figcaption>Save Partition Changes</figcaption></figure></div> <p>Now verify if the new partition (i.e. sdb1 -&gt; 10G) is created by listing the block device information with the <code>lsblk</code> command:</p> <pre class="wp-block-preformatted">$ lsblk /dev/sdb
NAME   MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
<mark style="background-color:#fcb900" class="has-inline-color">sdb      8:16   0  20G  0 disk 
└─sdb1   8:17   0  10G  0 part  </mark></pre> <h2 id="format-and-mount-the-partition" class="ftwp-heading">Format and mount the Partition</h2> <p>Let’s format the newly created partition with the ext4 file system using <code>mkfs</code> command:</p> <pre class="wp-block-preformatted">$ sudo mkfs.ext4 /dev/sdb1</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37934" title="Format Partition With Ext4 File System">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png.webp 799w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-300x88.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-768x225.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-585x171.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20799%20234&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 799px) 100vw, 799px" />
<img width="799" height="234" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20799%20234&#039;%3E%3C/svg%3E" alt="Format Partition With Ext4 File System" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png 799w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-300x88.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-768x225.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-585x171.png 585w" data-lazy-sizes="(max-width: 799px) 100vw, 799px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png" />
</picture>
<noscript><picture class="wp-image-37934" title="Format Partition With Ext4 File System">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png.webp 799w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-300x88.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-768x225.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-585x171.png.webp 585w" sizes="(max-width: 799px) 100vw, 799px"/>
<img width="799" height="234" src="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png" alt="Format Partition With Ext4 File System" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System.png 799w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-300x88.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-768x225.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Format-Partition-With-Ext4-File-System-585x171.png 585w" sizes="(max-width: 799px) 100vw, 799px"/>
</picture>
</noscript></a><figcaption>Format Partition With Ext4 File System</figcaption></figure></div> <p>Now the partition can be mounted to any directory as you wish. Since we are going to mount this directory temporarily, I am choosing <code>/mnt</code> directory.</p> <pre class="wp-block-preformatted">$ sudo mkdir /mnt/home_move/<br>$ sudo mount /dev/sdb1 /mnt/home_move/</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37935" title="Mount Partition">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png.webp 792w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-300x79.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-768x202.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-585x154.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20792%20208&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 792px) 100vw, 792px" />
<img width="792" height="208" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20792%20208&#039;%3E%3C/svg%3E" alt="Mount Partition" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png 792w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-300x79.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-768x202.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-585x154.png 585w" data-lazy-sizes="(max-width: 792px) 100vw, 792px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png" />
</picture>
<noscript><picture class="wp-image-37935" title="Mount Partition">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png.webp 792w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-300x79.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-768x202.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-585x154.png.webp 585w" sizes="(max-width: 792px) 100vw, 792px"/>
<img width="792" height="208" src="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png" alt="Mount Partition" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition.png 792w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-300x79.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-768x202.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Mount-Partition-585x154.png 585w" sizes="(max-width: 792px) 100vw, 792px"/>
</picture>
</noscript></a><figcaption>Mount Partition</figcaption></figure></div> <h2 id="move-home-directory-to-new-partition-in-linux" class="ftwp-heading">Move Home Directory To New Partition In Linux</h2> <p>Now all the directory and files from the home directory should be copied to the newly created partition mounted under <code>/mnt/home_move</code>. </p> <p>I use the following <code>rsync</code> command to copy the data to the new partition. Replace the destination directory path name with your own.</p> <pre class="wp-block-preformatted">$ rsync -av /home/* /mnt/home_move/</pre> <p>Once the data is copied to the new partition, <strong>do not remove the home directory</strong> yet. Just move it so in case of any mishaps you can revert back.</p> <pre class="wp-block-preformatted">$ sudo mv /home /home_old</pre> <pre class="wp-block-preformatted">$ ls -l /home<br>ls: cannot access '/home': No such file or directory</pre> <p>Create a new <code>/home</code> directory to mount <code>/dev/sdb1</code>.</p> <pre class="wp-block-preformatted">$ sudo mkdir /home</pre> <p>Remember the partition <code>/dev/sdb1</code> is already mounted under <code>/mnt/home_move/</code>. It should be unmounted first, so it can be mounted under <code>/home</code> directory.</p> <pre class="wp-block-preformatted">$ sudo umount /dev/sdb1<br>$ sudo mount /dev/sdb1 /home</pre> <p>Now the new partition <code>/dev/sdb1</code> is successfully mounted under <code>/home</code> directory. You can run the <code>lsblk</code> and <code>df</code> command to verify it.</p> <pre class="wp-block-preformatted">$ lsblk /dev/sdb
sdb           8:16   0   20G  0 disk 
└─<strong><mark style="background-color:#fcb900" class="has-inline-color">sdb1</mark></strong>        8:17   0   10G  0 part <mark style="background-color:#fcb900" class="has-inline-color"><strong>/home</strong></mark></pre> <pre class="wp-block-preformatted">$ df -h /home/
Filesystem      Size  Used Avail Use% Mounted on
<strong><mark style="background-color:#fcb900" class="has-inline-color">/dev/sdb1</mark></strong>       9.8G   37M  9.3G   1% <strong><mark style="background-color:#fcb900" class="has-inline-color">/home</mark></strong></pre> <h2 id="persistent-mount-using-fstab" class="ftwp-heading">Persistent Mount Using Fstab</h2> <p>Add entry to the <code>fstab</code> file so the newly created partitions will automount during system startup. Take the backup of the <code>fstab</code> file as a safety measure.</p> <pre class="wp-block-preformatted">$ sudo cp /etc/fstab /etc/fstab_old</pre> <p>Open the fstab and add the following entries to the bottom of the fstab file. Replace <code>/dev/sdb1</code> with your drive partition name.</p> <pre class="wp-block-preformatted">/dev/sdb1 /home ext4 defaults 0 0</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37936" title="Fstab Entry">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png.webp 1140w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-300x87.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-1024x298.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-768x224.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-585x170.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201140%20332&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1140px) 100vw, 1140px" />
<img width="1140" height="332" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201140%20332&#039;%3E%3C/svg%3E" alt="Fstab Entry" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png 1140w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-300x87.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-1024x298.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-768x224.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-585x170.png 585w" data-lazy-sizes="(max-width: 1140px) 100vw, 1140px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png" />
</picture>
<noscript><picture class="wp-image-37936" title="Fstab Entry">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png.webp 1140w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-300x87.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-1024x298.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-768x224.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-585x170.png.webp 585w" sizes="(max-width: 1140px) 100vw, 1140px"/>
<img width="1140" height="332" src="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png" alt="Fstab Entry" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry.png 1140w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-300x87.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-1024x298.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-768x224.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Fstab-Entry-585x170.png 585w" sizes="(max-width: 1140px) 100vw, 1140px"/>
</picture>
</noscript></a><figcaption>Fstab Entry</figcaption></figure></div> <p>You can also use the UUID of a block device to mount the partition. To find the UUID for a block device, run the following commands.</p> <pre class="wp-block-preformatted">$ lsblk -f /dev/sdb1<br>$ blkid | grep -i sdb1</pre> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37937" title="Find UUID">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png.webp 1117w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-300x47.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-1024x160.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-768x120.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-585x92.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201117%20175&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1117px) 100vw, 1117px" />
<img width="1117" height="175" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%201117%20175&#039;%3E%3C/svg%3E" alt="Find UUID" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png 1117w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-300x47.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-1024x160.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-768x120.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-585x92.png 585w" data-lazy-sizes="(max-width: 1117px) 100vw, 1117px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png" />
</picture>
<noscript><picture class="wp-image-37937" title="Find UUID">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png.webp 1117w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-300x47.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-1024x160.png.webp 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-768x120.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-585x92.png.webp 585w" sizes="(max-width: 1117px) 100vw, 1117px"/>
<img width="1117" height="175" src="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png" alt="Find UUID" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID.png 1117w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-300x47.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-1024x160.png 1024w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-768x120.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Find-UUID-585x92.png 585w" sizes="(max-width: 1117px) 100vw, 1117px"/>
</picture>
</noscript></a><figcaption>Find UUID</figcaption></figure></div> <p>Reboot the machine, log in back, and check where the /home directory is mounted by running the <code>df</code> command.</p> <pre class="wp-block-preformatted">$ df -h /home/
Filesystem      Size  Used Avail Use% Mounted on
<mark style="background-color:#fcb900" class="has-inline-color"><strong>/dev/sdb1</strong></mark>       9.8G   37M  9.3G   1% <mark style="background-color:#fcb900" class="has-inline-color"><strong>/home</strong></mark></pre> <h2 id="partition-home-directory-during-os-installation" class="ftwp-heading">Partition Home Directory During OS Installation</h2> <p>You can skip all the steps discussed in previous sections if you have created a separate partition for home directory during the os installation. Every installer will have a step to configure the disk. </p> <p>You will be prompted with an auto partition scheme or custom partition scheme. You should choose a custom partition scheme and create separate partitions. </p> <p>Below is a sample image from my RHEL 8.4 custom partition where a separate home partition with 15GB is created.</p> <div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png" data-rel="penci-gallery-image-content"><picture class="wp-image-37938" title="Manual Partitioning">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png.webp 802w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-300x227.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-768x580.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-585x442.png.webp 585w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20802%20606&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 802px) 100vw, 802px" />
<img width="802" height="606" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20802%20606&#039;%3E%3C/svg%3E" alt="Manual Partitioning" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png 802w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-300x227.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-768x580.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-585x442.png 585w" data-lazy-sizes="(max-width: 802px) 100vw, 802px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png" />
</picture>
<noscript><picture class="wp-image-37938" title="Manual Partitioning">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png.webp 802w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-300x227.png.webp 300w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-768x580.png.webp 768w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-585x442.png.webp 585w" sizes="(max-width: 802px) 100vw, 802px"/>
<img width="802" height="606" src="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png" alt="Manual Partitioning" srcset="https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning.png 802w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-300x227.png 300w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-768x580.png 768w, https://ostechnix.com/wp-content/uploads/2022/02/Manual-Partitioning-585x442.png 585w" sizes="(max-width: 802px) 100vw, 802px"/>
</picture>
</noscript></a><figcaption>Manual Partitioning</figcaption></figure></div> <h2 id="conclusion" class="ftwp-heading">Conclusion</h2> <p>In this article, we have discussed how to move the home directory from one partition to another partition in Linux. The procedure is same if you wanted to move the HOME directory to a new drive. </p> <p>Just create a new partition, format with you filesystem of your choice, and mount it. After mounting the partition, move the data to newly created Move the data from old partition to new one. Finally, add the fstab entry to make it persistent.</p> <p>If you have any suggestions or feedback, please post them in the comment section and we would be happy to respond back.</p> <div class="wp-container-621d8d3a57a3d wp-block-group has-black-color has-text-color has-background" style="background-color:#ffdddd"><div class="wp-block-group__inner-container"> <p><strong>Related Read:</strong></p> <ul><li><strong><a href="https://ostechnix.com/create-home-directory-for-existing-user-in-linux/" target="_blank" rel="noreferrer noopener">Create Home Directory For Existing User In Linux</a></strong></li></ul> </div></div> <p><em>Featured image by <a href="https://pixabay.com/vectors/linux-wallpaper-text-153455/" target="_blank" rel="noreferrer noopener">Pixabay</a>.</em></p> </div> <div class="penci-single-link-pages"> </div> <div class="post-tags"> <a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/linux-administration/" rel="tag">Linux administration</a><a href="https://ostechnix.com/tag/linux-basics/" rel="tag">Linux basics</a><a href="https://ostechnix.com/tag/linux-commands/" rel="tag">Linux commands</a><a href="https://ostechnix.com/tag/linux-howto/" rel="tag">Linux howto</a><a href="https://ostechnix.com/tag/linux-partitions/" rel="tag">Linux partitions</a><a href="https://ostechnix.com/tag/linux-tips/" rel="tag">Linux tips</a><a href="https://ostechnix.com/tag/move-home-directory/" rel="tag">Move HOME directory</a> </div> </div> </div> <div class="tags-share-box single-post-share tags-share-box-s1 center-box social-align-default"> <span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span> <div class="post-share"> <span class="post-share-item post-share-plike"> <span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="37921" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span> <div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/move-home-directory-to-new-partition-in-linux/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux%20-%20https://ostechnix.com/move-home-directory-to-new-partition-in-linux/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;title=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;title=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fmove-home-directory-to-new-partition-in-linux%2F&#038;text=How%20To%20Move%20Home%20Directory%20To%20New%20Partition%20Or%20Disk%20In%20Linux"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#b788c4c2d5ddd2d4c38affd8c0928587e3d8928587fad8c1d2928587ffd8dad2928587f3dec5d2d4c3d8c5ce928587e3d8928587f9d2c0928587e7d6c5c3dec3ded8d9928587f8c5928587f3dec4dc928587fed9928587fbded9c2cf919487848f8cf5f8f3ee8adfc3c3c7c48d9898d8c4c3d2d4dfd9decf99d4d8da98dad8c1d29adfd8dad29ad3dec5d2d4c3d8c5ce9ac3d89ad9d2c09ac7d6c5c3dec3ded8d99aded99adbded9c2cf98"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div> </div> <div class="post-author abio-style-1 bioimg-round"> <div class="author-img"> <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/8ae060a2307a7fc4ebf8920042c1be73?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' data-lazy-src="https://secure.gravatar.com/avatar/8ae060a2307a7fc4ebf8920042c1be73?s=100&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/8ae060a2307a7fc4ebf8920042c1be73?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8ae060a2307a7fc4ebf8920042c1be73?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100'/></noscript> </div> <div class="author-content"> <h5><a href="https://ostechnix.com/author/karthick/" title="Author Karthick" rel="author">Karthick</a></h5> <p>Karthick is a passionate software engineer who loves to explore new technologies. He is a public speaker and loves writing about technology especially about Linux and opensource.</p> <div class="bio-social"> <a rel="noreferrer" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fas fa-globe"></i></a> </div> </div> </div> <div class="post-pagination"> <div class="prev-post"> <div class="prev-post-inner"> <div class="prev-post-title"> <span>Previous post</span> </div> <a href="https://ostechnix.com/add-worker-nodes-to-amazon-eks-cluster/"> <div class="pagi-text"> <h5 class="prev-title">How To Add Worker Nodes To Amazon EKS Cluster</h5> </div> </a> </div> </div> </div> <div class="post-related"> <div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div> <div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/06/Fix-W-Some-index-files-failed-to-download.-Error-In-Ubuntu.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/fix-w-some-index-files-failed-to-download-error-in-ubuntu/" title="Fix &#8220;W: Some index files failed to download.&#8221; Error In Ubuntu"> </a> <h3> <a href="https://ostechnix.com/fix-w-some-index-files-failed-to-download-error-in-ubuntu/">Fix &#8220;W: Some index files failed to download.&#8221;...</a> </h3> <span class="date"><time class="entry-date published" datetime="2020-06-29T16:12:35+05:30">June 29, 2020</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/07/How-To-View-The-Contents-Of-An-Archive-Or-Compressed-File-585x390.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/how-to-view-the-contents-of-an-archive-or-compressed-file-without-extracting-it/" title="How To View The Contents Of An Archive Or Compressed File In Linux"> </a> <h3> <a href="https://ostechnix.com/how-to-view-the-contents-of-an-archive-or-compressed-file-without-extracting-it/">How To View The Contents Of An Archive...</a> </h3> <span class="date"><time class="entry-date published" datetime="2021-06-27T18:30:00+05:30">June 27, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2017/08/Clean-The-Package-Cache-In-Arch-Linux-585x390.jpg" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/recommended-way-clean-package-cache-arch-linux/" title="The Recommended Way To Clean The Package Cache In Arch Linux"> </a> <h3> <a href="https://ostechnix.com/recommended-way-clean-package-cache-arch-linux/">The Recommended Way To Clean The Package Cache...</a> </h3> <span class="date"><time class="entry-date published" datetime="2017-08-09T17:37:17+05:30">August 9, 2017</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/12/Install-Kubernetes-Cluster-Using-Kubeadm-585x390.jpg" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/install-kubernetes-cluster-using-kubeadm/" title="Install Kubernetes Cluster Using Kubeadm In RHEL, CentOS, AlmaLinux, Rocky Linux"> </a> <h3> <a href="https://ostechnix.com/install-kubernetes-cluster-using-kubeadm/">Install Kubernetes Cluster Using Kubeadm In RHEL, CentOS,...</a> </h3> <span class="date"><time class="entry-date published" datetime="2021-12-27T18:18:03+05:30">December 27, 2021</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/10/Docker-Networking-Concepts.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/explaining-docker-networking-concepts/" title="Explaining Docker Networking Concepts"> </a> <h3> <a href="https://ostechnix.com/explaining-docker-networking-concepts/">Explaining Docker Networking Concepts</a> </h3> <span class="date"><time class="entry-date published" datetime="2019-10-28T16:50:09+05:30">October 28, 2019</time></span> </div> <div class="item-related"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/01/Move-Multiple-File-Types.png" class="related-thumb penci-image-holder rocket-lazyload" href="https://ostechnix.com/how-to-move-multiple-file-types-simultaneously-from-commandline/" title="How To Move Multiple File Types Simultaneously From Commandline"> </a> <h3> <a href="https://ostechnix.com/how-to-move-multiple-file-types-simultaneously-from-commandline/">How To Move Multiple File Types Simultaneously From...</a> </h3> <span class="date"><time class="entry-date published" datetime="2019-01-14T19:41:47+05:30">January 14, 2019</time></span> </div> </div></div> <div class="post-comments no-comment-yet penci-comments-hide-1" id="comments"> <div id="respond" class="comment-respond"> <h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/move-home-directory-to-new-partition-in-linux/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" placeholder="Name*" size="30" aria-required='true' /></p> <p class="comment-form-email"><input id="email" name="email" type="text" placeholder="Email*" size="30" aria-required='true' /></p> <p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p> <div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='37921' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="eb09465f66" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="245" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div> <p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> </article> </div> </div> <div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right penci-sticky-sidebar"> <div class="theiaStickySidebar"> <aside id="penci_social_widget-1" class="widget penci_social_widget"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Networks</span></h3> <div class="widget-social pc_aligncenter show-text remove-circle penci-social-textcolored"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 14px"></i> <span style="font-size: 14px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 14px"></i> <span style="font-size: 14px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 14px"></i> <span style="font-size: 14px">Linkedin</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 14px"></i> <span style="font-size: 14px">Reddit</span></a> </div> </aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"> <p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p> <p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..." /><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p> <input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6186167963" data-ad-format="auto" data-full-width-responsive="true"></ins> <script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside> </div> </div> </div> </div> </div> <div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div> <div class="clear-footer"></div> <div id="widget-area"> <div class="container"> <div class="footer-widget-wrapper footer-widget-style-10"> <aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4> <div class="textwidget"><p><a href="https://ostechnix.com/"><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 340px) 100vw, 340px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" alt="Ostechnix Footer Logo" width="340" height="68" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-lazy-sizes="(max-width: 340px) 100vw, 340px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" />
</picture>
<noscript><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" sizes="(max-width: 340px) 100vw, 340px"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px"/>
</picture>
</noscript></a></p> <p>&nbsp;</p> <p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p> </div> </aside><aside id="penci_social_widget-2" class="widget penci_social_widget"> <div class="widget-social pc_aligncenter remove-circle"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 18px"></i> <span style="font-size: 13px">Facebook</span></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 18px"></i> <span style="font-size: 13px">Twitter</span></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 18px"></i> <span style="font-size: 13px">Linkedin</span></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube" style="font-size: 18px"></i> <span style="font-size: 13px">Youtube</span></a> <a href="/cdn-cgi/l/email-protection#f29b9c949db29d818697919a9c9b8adc919d9f" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope" style="font-size: 18px"></i> <span style="font-size: 13px">Email</span></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 18px"></i> <span style="font-size: 13px">Reddit</span></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss" style="font-size: 18px"></i> <span style="font-size: 13px">Rss</span></a> </div> </aside> </div> <div class="footer-widget-wrapper footer-widget-style-10 last"> <aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-7665" class="side-newsfeed display-order-numbers"> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">1</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners"> Youtube-dl Tutorial With Examples For Beginners </a> </h4> <div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" title="How To Fix Busybox Initramfs Error On Ubuntu"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu"> How To Fix Busybox Initramfs Error On Ubuntu </a> </h4> <div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span> </div> </div> </div> </li> <li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span> <div class="side-item"> <div class="side-image"> <a data-bg="https://ostechnix.com/wp-content/uploads/2021/01/Allow-Or-Deny-SSH-Access-To-A-Particular-User-Or-Group-In-Linux-263x175.png" class="penci-image-holder small-fix-size rocket-lazyload" rel="bookmark" href="https://ostechnix.com/allow-deny-ssh-access-particular-user-group-linux/" title="How To Allow Or Deny SSH Access To A Particular User Or Group In Linux"></a> </div> <div class="side-item-text"> <h4 class="side-title-post"> <a href="https://ostechnix.com/allow-deny-ssh-access-particular-user-group-linux/" rel="bookmark" title="How To Allow Or Deny SSH Access To A Particular User Or Group In Linux"> How To Allow Or Deny SSH Access To A Particular User Or Group In Linux </a> </h4> <div class="grid-post-box-meta penci-side-item-meta pcsnmt-below"> <span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2021-01-13T18:30:02+05:30">January 13, 2021</time></span> </div> </div> </div> </li> </ul> </aside> </div> </div> </div> <footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter"> <div class="container"> <div class="footer-logo-copyright footer-not-logo footer-not-gotop"> <div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li> <li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li> <li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li> <li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li> <li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li> </ul> </div> <div id="footer-copyright"> <p>OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p> </div> </div> </div> </footer> </div> <div class="penci-go-to-top-floating"><i class="penciicon-up-chevron"></i></div> <a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fas fa-times"></i></a> <nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"> <div id="sidebar-nav-logo"> <a href="https://ostechnix.com/"><picture>
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20250%2052&#039;%3E%3C/svg%3E" width="250" height="52" alt="OSTechNix" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" />
</picture>
<noscript><picture>
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" width="250" height="52" alt="OSTechNix"/>
</picture>
</noscript></a> </div> <div class="header-social sidebar-nav-social"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#6801060e0728071b1c0d0b00060110460b0705" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> <div class="penci-hbg-search-box penci-vernav-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <ul id="menu-header-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li> </ul> </nav> <div class="penci-menu-hbg-overlay"></div> <div class="penci-menu-hbg penci-vernav-hide penci-menu-hbg-left"> <div class="penci-menu-hbg-inner"> <a id="penci-close-hbg"><i class="penci-faicon fas fa-times"></i></a> <div class="penci-hbg-header"> <div class="penci-hbg-logo site-branding"> <a href="https://ostechnix.com/"><picture class="penci-lazy">
<source type="image/webp" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img width="350" height="73" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" />
</picture>
</a> </div> </div> <div class="penci-hbg-search-box"> <form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/"> <div class="inner-hbg-search-form"> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" /> <i class="penciicon-magnifiying-glass"></i> </div> </form> </div> <div class="penci-hbg-content penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right"> <ul id="menu-top-menu-1" class="menu menu-hgb-main"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li> </ul> </div> <div class="penci-hbg-footer"> <div class="penci_menu_hbg_ftext">OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</div> <div class="header-social sidebar-nav-social penci-hbg-social-style-4 penci-social-colored"> <div class="inner-header-social"> <a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a> <a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a> <a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a> <a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a> <a href="/cdn-cgi/l/email-protection#8ce5e2eae3cce3fff8e9efe4e2e5f4a2efe3e1" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a> <a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a> <a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a> </div> </div> </div> </div> </div> <div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all"> <div class="penci-gprd-law"> <p> This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a> </p> </div> </div> <style>.wp-container-621d8d3a13602 .alignleft { float: left; margin-right: 2em; }.wp-container-621d8d3a13602 .alignright { float: right; margin-left: 2em; }</style> <style>.wp-container-621d8d3a140d2 .alignleft { float: left; margin-right: 2em; }.wp-container-621d8d3a140d2 .alignright { float: right; margin-left: 2em; }</style> <!--[if lte IE 9]> <script> 'use strict'; (function($) { $(document).ready(function() { $('#ftwp-container').addClass('ftwp-ie9'); }); })(jQuery); </script> <![endif]--> <style>.wp-container-621d8d3a570ec .alignleft { float: left; margin-right: 2em; }.wp-container-621d8d3a570ec .alignright { float: right; margin-left: 2em; }</style> <style>.wp-container-621d8d3a57a3d .alignleft { float: left; margin-right: 2em; }.wp-container-621d8d3a57a3d .alignright { float: right; margin-left: 2em; }</style> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.youtube.com/iframe_api' id='youtube-api-js' defer></script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/penci-shortcodes/assets/play.js?ver=1645613043' id='penci-play-js-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script> <script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/ullavidu\/|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/ostechnix.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/penci-lazy.js?ver=1645613043' id='pc-lazy-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/themes/soledad/js/libs-script.min.js' id='penci-libs-js-js' defer></script> <script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"35061a36be","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/main.js?ver=1645613043' id='main-scripts-js' defer></script> <script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"35061a36be","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/post-like.js?ver=1645613043' id='penci_ajax_like_post-js' defer></script> <script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"35061a36be","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password","headerstyle":"default"};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/more-post.js?ver=1645613043' id='penci_ajax_more_posts-js' defer></script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script> <script type='text/javascript' id='fixedtoc-js-js-extra'>
/* <![CDATA[ */
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""};
/* ]]> */
</script> <script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js' id='fixedtoc-js-js' defer></script> <script src='https://stats.wp.com/e-202209.js' defer></script> <script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6',blog:'84551477',post:'37921',tz:'5.5',srv:'ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '37921' ]);
</script> <script type="rocketlazyloadscript" data-rocket-type="text/javascript">
	function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(37921, 'https://ostechnix.com');
</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ostechnix.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script> <script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script> <script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-75259810-1');
</script> <script type="rocketlazyloadscript">"use strict";function wprRemoveCPCSS(){var preload_stylesheets=document.querySelectorAll('link[data-rocket-async="style"][rel="preload"]');if(preload_stylesheets&&0<preload_stylesheets.length)for(var stylesheet_index=0;stylesheet_index<preload_stylesheets.length;stylesheet_index++){var media=preload_stylesheets[stylesheet_index].getAttribute("media")||"all";if(window.matchMedia(media).matches)return void setTimeout(wprRemoveCPCSS,200)}var elem=document.getElementById("rocket-critical-css");elem&&"remove"in elem&&elem.remove()}window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel='stylesheet' id='wp-block-library-css' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all'/><link rel='stylesheet' id='mediaelement-css' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all'/><link rel='stylesheet' id='wp-mediaelement-css' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all'/><link rel='stylesheet' id='penci-soledad-parent-style-css' href='https://ostechnix.com/wp-content/themes/soledad/style.css' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-main-style-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-awesomeold-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci-font-awesome-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci_icon-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1645613043' type='text/css' media='all'/><link rel='stylesheet' id='penci_style-css' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='penci_social_counter-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/social-counter.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='fixedtoc-style-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1645613043' type='text/css' media='all'/><link data-minify="1" rel='stylesheet' id='jetpack_css-css' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1645613043' type='text/css' media='all'/></noscript>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6e50e6e838728299","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body> </html>
