<!DOCTYPE html>
<html lang="en-US">
<head><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png">
<link rel="alternate" type="application/rss+xml" title="OSTechNix RSS Feed" href="https://ostechnix.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="OSTechNix Atom Feed" href="https://ostechnix.com/feed/atom/" />
<link rel="pingback" href="https://ostechnix.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://ostechnix.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Setup Local WordPress Development Environment In Linux - OSTechNix</title><style id="rocket-critical-css">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</style>
<meta name="description" content="This tutorial explains what is LocalWP, and how to install LocalWP to deploy and setup local WordPress development environment in Linux." />
<link rel="canonical" href="https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Setup Local WordPress Development Environment In Linux - OSTechNix" />
<meta property="og:description" content="This tutorial explains what is LocalWP, and how to install LocalWP to deploy and setup local WordPress development environment in Linux." />
<meta property="og:url" content="https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/" />
<meta property="og:site_name" content="OSTechNix" />
<meta property="article:publisher" content="https://www.facebook.com/ostechnix/" />
<meta property="article:author" content="ostechnix" />
<meta property="article:published_time" content="2021-07-26T15:38:56+00:00" />
<meta property="article:modified_time" content="2021-07-26T15:41:19+00:00" />
<meta property="og:image" content="https://ostechnix.com/wp-content/uploads/2021/07/Setup-Local-WordPress-Development-Environment-With-LocalWP-In-Linux.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="682" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@ostechnix" />
<meta name="twitter:site" content="@ostechnix" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="sk" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="12 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//googletagmanager.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//static.cloudflareinsights.com' />
<link rel='dns-prefetch' href='//ajax.cloudflare.com' />
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//pixel.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://ostechnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://ostechnix.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Setup Local WordPress Development Environment In Linux Comments Feed" href="https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/feed/" />
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ostechnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=c73594908fc6a581c289f9d0c796dd19"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='preload' href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css?ver=c73594908fc6a581c289f9d0c796dd19' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link rel='preload' href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=c73594908fc6a581c289f9d0c796dd19' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad/style.css?ver=c73594908fc6a581c289f9d0c796dd19' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link rel='preload' href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap&#038;ver=1.0' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1627317724' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1627317724' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/weather-icon.swap.css?ver=1627317724' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1627317724' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1627317724' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link rel='preload' href='https://ostechnix.com/wp-content/themes/soledad-child/style.css?ver=7.9.5' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1627317728' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<style id='fixedtoc-style-inline-css' type='text/css'>
.ftwp-in-post#ftwp-container-outer { height: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-none #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 5.6px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 7px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(253,244,207,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #fdf4cf; } #ftwp-container.ftwp-wrap #ftwp-list { color: #000000; background: rgba(244,242,212,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f4f2d4; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #2196f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(33,150,243,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); }
</style>
<link data-minify="1" rel='preload' href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1627317724' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<script type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<link rel="https://api.w.org/" href="https://ostechnix.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ostechnix.com/wp-json/wp/v2/posts/32764" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ostechnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ostechnix.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://ostechnix.com/?p=32764' />
<link rel="alternate" type="application/json+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.37.0" /><style type='text/css'>img#wpstats{display:none}</style>
<style id="penci-custom-style" type="text/css">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</style><script type="rocketlazyloadscript">
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
    },
    "url": "https:\/\/ostechnix.com\/",
    "name": "OSTechNix",
    "description": "Open Source | Technology | Linux And Unix"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "OSTechNix",
    "alternateName": "Open Source | Technology | Linux And Unix",
    "url": "https:\/\/ostechnix.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Setup Local WordPress Development Environment In Linux",
    "description": "This tutorial explains what is LocalWP, benefits of using LocalWP, how to install LocalWP to deploy and setup local WordPress development environment in Linux.",
    "datePublished": "2021-07-26",
    "datemodified": "2021-07-26",
    "mainEntityOfPage": "https:\/\/ostechnix.com\/setup-local-wordpress-development-environment-in-linux\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2021\/07\/Setup-Local-WordPress-Development-Environment-With-LocalWP-In-Linux.jpg",
        "width": 1280,
        "height": 682
    },
    "publisher": {
        "@type": "Organization",
        "name": "OSTechNix",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/ostechnix.com\/wp-content\/uploads\/2020\/08\/ostechnix-header-new-logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-sk",
        "name": "sk"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/ostechnix.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/cms\/",
                "name": "CMS"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/ostechnix.com\/category\/cms\/wordpress\/",
                "name": "Wordpress"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/ostechnix.com\/setup-local-wordpress-development-environment-in-linux\/",
                "name": "Setup Local WordPress Development Environment In Linux"
            }
        }
    ]
}</script><link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="32x32" />
<link rel="icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" />
<meta name="msapplication-TileImage" content="https://ostechnix.com/wp-content/uploads/2020/08/64x64Favicon-02.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>
<body data-rsssl=1 class="post-template-default single single-post postid-32764 single-format-standard soledad-ver-7-9-5 pclight-mode penci-fawesome-ver5 has-ftoc">
<div class="wrapper-boxed header-style-header-3 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar topbar-menu">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="pctopbar-item penci-wtopbar-menu"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/opensource/">Open Source</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/technology/">Technology</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/linux/">Linux</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" rel="noopener" href="https://ostechnix.com/category/unix/">Unix</a></li>
<li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li>
<li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener" href="https://ostechnix.com/donate/">Donate</a></li>
<li id="menu-item-24643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li>
</ul></div><div class="pctopbar-item penci-topbar-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a>
<a href="/cdn-cgi/l/email-protection#137a7d757c537c606776707b7d7a6b3d707c7e" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a>
</div></div> </div>
</div>
</div><header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container align-left-logo has-banner">
<div id="logo">
<a href="https://ostechnix.com/"><picture class="penci-mainlogo">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20350%2073&#039;%3E%3C/svg%3E" alt="OSTechNix" width="350" height="73" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" />
</picture>
<noscript><picture class="penci-mainlogo">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" width="350" height="73"/>
</picture>
</noscript></a> </div>
<div class="header-banner header-style-3">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="9496719407" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div>
</div>
<div class="sticky-wrapper"> <nav id="navigation" class="header-layout-bottom header-3 menu-style-2 menu-item-padding penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container">
<div class="button-menu-mobile header-3"><i class="penci-faicon fas fa-bars"></i></div>
<ul id="menu-header-menu" class="menu"><li id="menu-item-25071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li>
<li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li id="menu-item-32273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li>
<li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li>
<li id="menu-item-32270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li>
<li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li>
<li id="menu-item-32271" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li>
<li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li>
<li id="menu-item-32272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li>
</ul><div id="top-search" class="pcheader-icon penci-top-search">
<a class="search-click"><i class="penciicon-magnifiying-glass"></i></a>
<div class="show-search">
<form role="search" method="get" class="pc-searchform" action="https://ostechnix.com/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" />
<i class="penciicon-magnifiying-glass"></i>
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fas fa-times"></i></a>
</div>
</div><div class="penci-menuhbg-wapper penci-menu-toggle-wapper">
<a href="#pencimenuhbgtoggle" class="penci-menuhbg-toggle">
<span class="penci-menuhbg-inner">
<i class="lines-button lines-button-double">
<i class="penci-lines"></i>
</i>
<i class="lines-button lines-button-double penci-hover-effect">
<i class="penci-lines"></i>
</i>
</span>
</a>
</div>
</div>
</nav>
</div>
</header>
</div>
<div class="penci-single-wrapper penci-single-infiscroll" data-infiads="&lt;div class=&quot;penci-single-infiads&quot;&gt;&lt;script async src=&quot;https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js&quot;&gt;&lt;/script&gt;
&lt;!-- New Horizontal Responsive Adv --&gt;
&lt;ins class=&quot;adsbygoogle&quot;
     style=&quot;display:block&quot;
     data-ad-client=&quot;ca-pub-6701402139964678&quot;
     data-ad-slot=&quot;9496719407&quot;
     data-ad-format=&quot;auto&quot;
     data-full-width-responsive=&quot;true&quot;&gt;&lt;/ins&gt;
&lt;script&gt;
     (adsbygoogle = window.adsbygoogle || []).push({});
&lt;/script&gt;&lt;/div&gt;">
<div class="penci-single-block" data-prev-url="https://ostechnix.com/setup-backup-server-using-rsnapshot-linux/" data-current-url="https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/" data-post-title="Setup Local WordPress Development Environment In Linux" data-edit-post="" data-postid="32764">
<div class="container penci-breadcrumb single-breadcrumb">
<span><a class="crumb" href="https://ostechnix.com/">Home</a></span><i class="penci-faicon fas fa-angle-right"></i> <span><a class="crumb" href="https://ostechnix.com/category/cms/wordpress/">Wordpress</a></span><i class="penci-faicon fas fa-angle-right"></i> <span>Setup Local WordPress Development Environment In Linux</span>
</div>
<div class="container container-single penci_sidebar  penci-enable-lightbox">
<div id="main" class="penci-main-sticky-sidebar">
<div class="theiaStickySidebar">
<article id="post-32764" class="post type-post status-publish">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-65" href="https://ostechnix.com/category/cms/wordpress/" rel="category tag">Wordpress</a><a class="penci-cat-name penci-cat-67" href="https://ostechnix.com/category/webserver/apache/" rel="category tag">Apache</a><a class="penci-cat-name penci-cat-8" href="https://ostechnix.com/category/cms/" rel="category tag">CMS</a><a class="penci-cat-name penci-cat-4416" href="https://ostechnix.com/category/lamp-stack/" rel="category tag">LAMP Stack</a><a class="penci-cat-name penci-cat-4665" href="https://ostechnix.com/category/lemp-stack/" rel="category tag">LEMP Stack</a><a class="penci-cat-name penci-cat-26" href="https://ostechnix.com/category/linux/" rel="category tag">Linux</a><a class="penci-cat-name penci-cat-38" href="https://ostechnix.com/category/database/mysql/" rel="category tag">MySQL</a><a class="penci-cat-name penci-cat-76" href="https://ostechnix.com/category/webserver/nginx/" rel="category tag">Nginx</a><a class="penci-cat-name penci-cat-4415" href="https://ostechnix.com/category/programming/php/" rel="category tag">PHP</a><a class="penci-cat-name penci-cat-60" href="https://ostechnix.com/category/utilities/" rel="category tag">Utilities</a><a class="penci-cat-name penci-cat-63" href="https://ostechnix.com/category/webserver/" rel="category tag">Webserver</a></span></div>
<h1 class="post-title single-post-title entry-title">Setup Local WordPress Development Environment In Linux</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">By <a class="url fn n" href="https://ostechnix.com/author/sk/">sk</a></span>
<time class="entry-date published" datetime="2021-07-26T21:08:56+05:30">July 26, 2021</time> </div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">Written by <a class="author-url url fn n" href="https://ostechnix.com/author/sk/">sk</a></span></span>
<span><time class="entry-date published" datetime="2021-07-26T21:08:56+05:30">July 26, 2021</time></span>
<span><i class="penci-post-countview-number">9</i> Views</span>
</div>
</div>
<div class="tags-share-box tags-share-box-top center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="32764" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux%20-%20https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;title=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;title=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;text=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#251a5650474f404651187640515055001715694a464449001715724a5741755740565600171561405340494a5548404b51001715604b534c574a4b48404b510017156c4b001715694c4b505d030615161d1e676a617c184d515155561f0a0a4a565140464d4b4c5d0b464a480a564051505508494a46444908524a574155574056560841405340494a5548404b5108404b534c574a4b48404b51084c4b08494c4b505d0a"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-entry blockquote-style-2">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<div id="ftwp-postcontent"><p>This detailed tutorial explains what is LocalWP, benefits of using LocalWP, how to install LocalWP to deploy and setup local WordPress development environment in Linux and Unix-like operating systems.</p>
<div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-none"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-left"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-round ftwp-border-thin"><header id="ftwp-header" class="ftwp-header-clickable"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-circle-o ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item"><a class="ftwp-anchor" href="#intro"><span class="ftwp-text">1. Introduction</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#what-is-localwp"><span class="ftwp-text">2. What is LocalWP?</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#localwp-features"><span class="ftwp-text">3. LocalWP features</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#install-localwp-in-linux"><span class="ftwp-text">4. Install LocalWP in Linux</span></a></li><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#setup-local-wordpress-development-environment-with-localwp"><span class="ftwp-text">5. Setup local WordPress development environment in Linux using LocalWP</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#create-new-wordpress-in-local"><span class="ftwp-text">5.1. Create new wordpress in Local</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#access-wordpress-site-admin-dashboard"><span class="ftwp-text">5.2. Access WordPress site admin dashboard</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#configure-wordpress-settings"><span class="ftwp-text">5.3. Configure WordPress settings</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#enable-live-link"><span class="ftwp-text">5.4. Enable Live link</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#access-adminer-dashboard"><span class="ftwp-text">5.5. Access Adminer dashboard</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#troubleshooting"><span class="ftwp-text">6. Troubleshooting</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#conclusion"><span class="ftwp-text">7. Conclusion</span></a></li></ol></nav></div></div><h2 id="intro" class="ftwp-heading">1. Introduction</h2>
<p>If you're WordPress developer, you will have a few options to deploy and setup WordPress websites.</p>
<div><div class="penci-custom-html-inside-content"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6620160421" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><p>You could directly build and work on the live site. But it is NOT RECOMMENDED and dangerous. You can create a staging site and deploy, test the wordpress installations before pushing them into production.</p>
<p>The another recommenced way is setup a local WordPress development environment to deploy wordpress sites on your local system. This is the safest way to do all sorts of wordpress testing.</p>
<p>From the local WordPress development site, you can test various plugins and customize the site as the way you want it. If you're a beginner, you also use the local wordpress development environment for learning purposes as well.</p>
<p>There are many ways to create a local wordpress development environment. You can install <strong><a href="https://ostechnix.com/category/lamp-stack/" target="_blank" rel="noreferrer noopener">LAMP</a></strong> or <strong><a href="https://ostechnix.com/category/lemp-stack/" target="_blank" rel="noreferrer noopener">LEMP</a></strong> stacks and deploy WordPress on top of it. But this will require some manual work from your side.</p>
<p>Also setting up multiple WordPress sites on LAMP/LEMP stack is not so convenient and time-consuming task.</p>
<p>The easiest, quickest and probably the best way to setup development environment for WordPress is by using a tool named <strong>LocalWP</strong>.</p>
<h2 id="what-is-localwp" class="ftwp-heading">2. What is LocalWP?</h2>
<p>LocalWP, or just Local, is an application to deploy and develop wordpress sites locally. </p>
<p>You don't need to manually install web server (Apache or Nginx), database server (E.g. MySQL), and PHP. Local takes care of everything!</p>
<p>Using Local, you can easily install WordPress on your system and create as many as wordpress sites you want with a couple mouse clicks!</p>
<p>Local allows you to effortlessly setup single or multi-site WordPress installation. If everything works as the way you expected, you can push your local site to live.</p>
<p>You can clone your site, and even backup your site files to cloud storages such as Google drive or Dropbox.</p>
<p>Local is created by <strong>Flywheel</strong>, a company that provides affordable managed wordpress hosting. Local supports Linux, macOS and Windows platforms. It is completely free to use!</p>
<h2 id="localwp-features" class="ftwp-heading">3. LocalWP features</h2>
<p>Local has everything you need to install WordPress, develop wordpress sites, and troubleshoot sites on your local system.</p>
<p>Here is the list of benefits of using Local on your system:</p>
<ul><li>One-click automatic wordpress installation.</li><li>Single and multi-site wordpress installation. </li><li>Support for both subdomain and subdirectory installations.</li><li>SSL support. Self-signed certificates are automatically created for new sites.</li><li>Local gives you the ability to SSH into your Local wordpress sites.</li><li>Includes WP-CLI, the command-line interface to manage wordpress sites from command line.</li><li>Push and pull Local wordpress sites to Flywheel or WP Engine.</li><li>Create live links to your wordpress sites, so your client or colleagues can access and test the sites from anywhere.</li><li>No need to create and manage multiple user. Local one-click admin feature allows you to access the WP admin page with just one click!</li><li>Hot-swap environments. You can instantly switch to different versions of Apache or Nginx, MySQL and PHP. You can even switch to different webserver, for example Apache to Nginx and Vice versa.</li><li>Backup site files to Google drive and Dropbox.</li><li>Create blueprint of a site to re-use it later.</li><li>Import and export site files, databases, configuration files, log files, and Local settings.</li><li>Test outgoing email with MailHog</li><li>Enhance your local site with tools like Image Optimizer, Link Checker and Instant Reload.</li><li>Cross-platform support.</li><li>Completely FREE to use!</li></ul>
<h2 id="install-localwp-in-linux" class="ftwp-heading">4. Install LocalWP in Linux</h2>
<p>As stated already, Local can be installed in Linux, macOS and Microsoft Windows operating systems.</p>
<p>Go to <strong><a href="https://localwp.com/" target="_blank" rel="noreferrer noopener">LocalWP website</a></strong> and click the Download button. A new pop-up window will open. Choose your operating system type and fill up the other details such as your name and Email id and click <strong>Get it now</strong> button.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP.png" data-rel="penci-gallery-image-content"><img width="429" height="609" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20429%20609'%3E%3C/svg%3E" alt="Download LocalWP" class="wp-image-32766" title="Download LocalWP" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP.png 429w, https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP-211x300.png 211w" data-lazy-sizes="(max-width: 429px) 100vw, 429px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP.png"><noscript><img width="429" height="609" src="https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP.png" alt="Download LocalWP" class="wp-image-32766" title="Download LocalWP" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP.png 429w, https://ostechnix.com/wp-content/uploads/2021/07/Download-LocalWP-211x300.png 211w" sizes="(max-width: 429px) 100vw, 429px"></noscript></a><figcaption>Download LocalWP</figcaption></figure></div>
<p>Go to the download location and install it using your distribution's package manager. I downloaded the <code>.rpm</code> file, so I installed LocalWP using <code>rpm</code> command like below:</p>
<pre class="wp-block-preformatted">$ sudo rpm -Uvh local-6.0.0-linux.rpm</pre>
<p>If you downloaded the <code>.deb</code> file, you can install it using using <code>dpkg</code> command:</p>
<pre class="wp-block-preformatted">$ sudo dpkg -i -Uvh local-6.0.0-linux.deb</pre>
<pre class="wp-block-preformatted">$ sudo apt install -f</pre>
<h2 id="setup-local-wordpress-development-environment-with-localwp" class="ftwp-heading">5. Setup local WordPress development environment in Linux using LocalWP</h2>
<p>Launch Local from Menu or Dash. It will be usually found under "Programming" section in your application menu.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement.png" data-rel="penci-gallery-image-content"><img width="638" height="602" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20638%20602'%3E%3C/svg%3E" alt="Accept Local license agreement" class="wp-image-32767" title="Accept Local license agreement" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement.png 638w, https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement-300x283.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement-585x552.png 585w" data-lazy-sizes="(max-width: 638px) 100vw, 638px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement.png"><noscript><img width="638" height="602" src="https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement.png" alt="Accept Local license agreement" class="wp-image-32767" title="Accept Local license agreement" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement.png 638w, https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement-300x283.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Accept-Local-license-agreement-585x552.png 585w" sizes="(max-width: 638px) 100vw, 638px"></noscript></a><figcaption>Accept Local license agreement</figcaption></figure></div>
<p>You will be prompted to create a new account in LocalWP. It is required to backup files to cloud and create live links, so create account if you don't have one already.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Create free Local account" class="wp-image-32768" title="Create free Local account" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account.png" alt="Create free Local account" class="wp-image-32768" title="Create free Local account" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Create-free-Local-account-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Create free Local account</figcaption></figure></div>
<p>You will be redirected to LocalWP website. Follow the on-screen steps to create a new account.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website.png" data-rel="penci-gallery-image-content"><img width="1368" height="569" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20569'%3E%3C/svg%3E" alt="Create new account in LocalWP website" class="wp-image-32769" title="Create new account in LocalWP website" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-300x125.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-1024x426.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-768x319.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-1170x487.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-585x243.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website.png"><noscript><img width="1368" height="569" src="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website.png" alt="Create new account in LocalWP website" class="wp-image-32769" title="Create new account in LocalWP website" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-300x125.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-1024x426.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-768x319.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-1170x487.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-account-in-LocalWP-website-585x243.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Create new account in LocalWP website</figcaption></figure></div>
<p>Once the account is created, close the browser window and go back to the Local application dashboard window. </p>
<p>This is how your Local dashboard looks like:</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Local dashboard" class="wp-image-32770" title="Local dashboard" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard.png" alt="Local dashboard" class="wp-image-32770" title="Local dashboard" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Local-dashboard-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Local dashboard</figcaption></figure></div>
<p>There are many options to choose from. You can create a new WordPress site, or connect to managed hosting services or change your settings and preferences. First, let us start from creating a new WordPress site.</p>
<h3 id="create-new-wordpress-in-local" class="ftwp-heading">5.1. Create new wordpress in Local</h3>
<p>Click the "CREATE A NEW SITE" button or click the plus <strong>(+)</strong> sign on the bottom left corner to create a new wordpress site in Local.</p>
<p>Enter the WordPress site's name. A new domain URL for your WordPress will be automatically generated. You can view it under the <strong>Advanced options</strong> section. By default, all Local sites will have an <code>.local</code> extension. You can change it if you want to.</p>
<p>You can also view the path of your site in Local site path section. By default, it will be saved in a directory named <code><strong>"Local Sites"</strong></code> in your <code>$HOME</code> directory. If you're okay with the default options, click Continue.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Create new wordpress site in Local" class="wp-image-32771" title="Create new wordpress site in Local" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local.png" alt="Create new wordpress site in Local" class="wp-image-32771" title="Create new wordpress site in Local" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Create-new-wordpress-site-in-Local-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Create new wordpress site in Local</figcaption></figure></div>
<p>Next choose your environment. Here, you will be given two options, namely <strong>Preferred</strong> and <strong>Custom</strong>. </p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-1024x523.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Choose Local environment for WordPress site" class="wp-image-32772" title="Choose Local environment for WordPress site" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site.png" alt="Choose Local environment for WordPress site" class="wp-image-32772" title="Choose Local environment for WordPress site" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-Local-environment-for-Wordpress-site-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Choose Local environment for WordPress site</figcaption></figure></div>
<p>You can choose the Preferred option to use a set of recommended tools for your Local site. Local will automatically choose Nginx, PHP and latest MySQL version if you select Preferred option. </p>
<p>Alternatively, you can choose the Custom option to select the tools of your choice.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Choose custom Local environment for WordPress site" class="wp-image-32773" title="Choose custom Local environment for WordPress site" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site.png" alt="Choose custom Local environment for WordPress site" class="wp-image-32773" title="Choose custom Local environment for WordPress site" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Choose-custom-Local-environment-for-Wordpress-site-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Choose custom Local environment for WordPress site</figcaption></figure></div>
<p>Once you made the selection, click Continue.</p>
<p>Next enter the administrative user name for your WordPress site, password and the Email. Under Advanced options, you can choose if you want this installation to be a multisite.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-large"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password.png" data-rel="penci-gallery-image-content"><img width="1024" height="523" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20523'%3E%3C/svg%3E" alt="Enter WordPress admin username and password" class="wp-image-32775" title="Enter WordPress admin username and password" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-585x299.png 585w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password.png 1368w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-1024x523.png"><noscript><img width="1024" height="523" src="https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-1024x523.png" alt="Enter WordPress admin username and password" class="wp-image-32775" title="Enter WordPress admin username and password" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password-585x299.png 585w, https://ostechnix.com/wp-content/uploads/2021/07/Enter-Wordpress-admin-username-and-password.png 1368w" sizes="(max-width: 1024px) 100vw, 1024px"></noscript></a><figcaption>Enter WordPress admin username and password</figcaption></figure></div>
<p>After a few minutes, you will see the newly installed WordPress site is listed in the Local dashboard, along with all its information.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Setup local WordPress development environment using LocalWP" class="wp-image-32777" title="Setup local WordPress development environment using LocalWP" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP.png" alt="Setup local WordPress development environment using LocalWP" class="wp-image-32777" title="Setup local WordPress development environment using LocalWP" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Setup-local-WordPress-development-environment-using-LocalWP-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Setup local WordPress development environment using LocalWP</figcaption></figure></div>
<p>Congratulations! You just installed WordPress using Local in your Linux machine!</p>
<p>You can click the <strong>"OPEN SITE"</strong> button to view how your new WordPress looks like!</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="New WordPress site" class="wp-image-32778" title="New WordPress site" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site.png" alt="New WordPress site" class="wp-image-32778" title="New WordPress site" srcset="https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/New-Wordpress-site-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>New WordPress site</figcaption></figure></div>
<p>It is time to work on the newly created wordpress site!</p>
<h3 id="access-wordpress-site-admin-dashboard" class="ftwp-heading">5.2. Access WordPress site admin dashboard</h3>
<p>From the Local dashboard, Click the <strong>Admin</strong> button:</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Access WordPress Admin page" class="wp-image-32780" title="Access WordPress Admin page" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page.png" alt="Access WordPress Admin page" class="wp-image-32780" title="Access WordPress Admin page" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Access-Wordpress-Admin-page-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Access WordPress Admin page</figcaption></figure></div>
<p>Your wordpress site's login page will open in a new browser window. Enter the admin user and its password to login to WP admin page.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Log in to WordPress" class="wp-image-32781" title="Log in to WordPress" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress.png" alt="Log in to WordPress" class="wp-image-32781" title="Log in to WordPress" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Log-in-to-Wordpress-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Log in to WordPress</figcaption></figure></div>
<p>Start working on your new WordPress site!</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Wp Admin page" class="wp-image-32782" title="Wp Admin page" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page.png" alt="Wp Admin page" class="wp-image-32782" title="Wp Admin page" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Wp-Admin-page-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Wp Admin page</figcaption></figure></div>
<h3 id="configure-wordpress-settings" class="ftwp-heading">5.3. Configure WordPress settings</h3>
<p>In the Local dashboard, you will see the following tabs to configure and tweak various settings.</p>
<ol><li>Overview</li><li>Database</li><li>Utilities</li><li>Tools</li></ol>
<p>The <strong>Overview</strong> section displays the details of your WordPress site. Here, you can find your wordpress site URL, web server (Apache or Nginx), PHP and MySQL versions, WordPress version and the option to enable self-signed SSL certificate.</p>
<p>In the <strong>Database</strong> section, you will see the option to connect to <strong>Adminer</strong> management tool, database name, database user name and password.</p>
<p>From the <strong>Utilities</strong> section, you can configure configure and test outbound E-mail.</p>
<p>The last section is <strong>Tools</strong> the section where you will find the Live link URL and the username and password to access the live link.</p>
<h3 id="enable-live-link" class="ftwp-heading">5.4. Enable Live link</h3>
<p>One of the best feature of Local is <strong>Live Link</strong>. It will convert your locally-built wordpress site into a shareable test environment, so any authorized person will able to access the Local site from anywhere. This comes in handy when you want to show your local site to your clients. </p>
<p>To create a live link for your local site, click <strong>Enable</strong> button in the bottom of the Local dashboard.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Enable Live Link in LocalWP" class="wp-image-32783" title="Enable Live Link in LocalWP" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP.png" alt="Enable Live Link in LocalWP" class="wp-image-32783" title="Enable Live Link in LocalWP" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Enable-Live-Link-in-LocalWP-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Enable Live Link in LocalWP</figcaption></figure></div>
<p>Once you enabled the Live Link option, a publicly accessible URL will be generated. Also the shareable link is protected with an username and password. </p>
<p>You can view view the details of the link and credentials by clicking on the Live Link button or under the Tools section.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Live Link details for Local WordPress site" class="wp-image-32784" title="Live Link details for Local WordPress site" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site.png" alt="Live Link details for Local WordPress site" class="wp-image-32784" title="Live Link details for Local WordPress site" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Live-Link-details-for-Local-Wordpress-site-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Live Link details for Local WordPress site</figcaption></figure></div>
<p>Just send this URL along with the username and password to your clients. They can access your Local site from anywhere using the shared URL.</p>
<p>Please note that the live links are viewable only when your computer is turned on and connected to Internet.</p>
<h3 id="access-adminer-dashboard" class="ftwp-heading">5.5. Access Adminer dashboard</h3>
<p>Adminier is a web-based database management tool. LocalWP includes it to make the database management easier.</p>
<p>To launch Adminer, click <strong>"OPEN ADMINER"</strong> button under the Database section from your Local dashboard.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-1024x523.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Open Adminer" class="wp-image-32785" title="Open Adminer" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer.png" alt="Open Adminer" class="wp-image-32785" title="Open Adminer" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Open-Adminer-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Open Adminer</figcaption></figure></div>
<p>The Adminer dashboard will open in a new browser window.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-1024x523.png" data-rel="penci-gallery-image-content"><img width="1368" height="699" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201368%20699'%3E%3C/svg%3E" alt="Adminer dashboard" class="wp-image-32786" title="Adminer dashboard" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-585x299.png 585w" data-lazy-sizes="(max-width: 1368px) 100vw, 1368px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard.png"><noscript><img width="1368" height="699" src="https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard.png" alt="Adminer dashboard" class="wp-image-32786" title="Adminer dashboard" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard.png 1368w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-300x153.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-1024x523.png 1024w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-768x392.png 768w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-1170x598.png 1170w, https://ostechnix.com/wp-content/uploads/2021/07/Adminer-dashboard-585x299.png 585w" sizes="(max-width: 1368px) 100vw, 1368px"></noscript></a><figcaption>Adminer dashboard</figcaption></figure></div>
<p>Here, you can view, configure and manage databases.</p>
<p>By default, Local will create database named "local". You can check all table content of the database and play around with running SQL queries from Adminer.</p>
<h2 id="troubleshooting" class="ftwp-heading">6. Troubleshooting</h2>
<p>When you create a new WordPress site, you will probably face the following error in Fedora.</p>
<pre class="wp-block-preformatted">Error: Command failed: /opt/Local/resources/extraResources/lightning-services/php-7.3.5+10/bin/linux/bin/php /opt/Local/resources/extraResources/bin/wp-cli/wp-cli.phar --path=/home/sk/Local Sites/ostechnix-testing-site/app/public --require=/opt/Local/resources/extraResources/bin/wp-cli/local-wpcli-error-reporting.php core config --skip-check --dbname=local --dbuser=root --dbpass=root --skip-salts
/opt/Local/resources/extraResources/lightning-services/php-7.3.5+10/bin/linux/bin/php-original: error while loading shared libraries: libnettle.so.6: cannot open shared object file: No such file or directory</pre>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-full"><a href="https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries.png" data-rel="penci-gallery-image-content"><img width="595" height="329" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20595%20329'%3E%3C/svg%3E" alt="Localwp error while loading shared libraries" class="wp-image-32790" title="Localwp error while loading shared libraries" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries.png 595w, https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries-300x166.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries-585x323.png 585w" data-lazy-sizes="(max-width: 595px) 100vw, 595px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries.png"><noscript><img width="595" height="329" src="https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries.png" alt="Localwp error while loading shared libraries" class="wp-image-32790" title="Localwp error while loading shared libraries" srcset="https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries.png 595w, https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries-300x166.png 300w, https://ostechnix.com/wp-content/uploads/2021/07/Localwp-error-while-loading-shared-libraries-585x323.png 585w" sizes="(max-width: 595px) 100vw, 595px"></noscript></a><figcaption>Localwp error while loading shared libraries</figcaption></figure></div>
<p>If you encounter with <strong><code>error while loading shared libraries: libnettle.so.6</code></strong> while creating new sites, you need to download the <strong>exact missing library</strong> and move it to your <code>/usr/lib64/</code> directory.</p>
<p>In my case, the missing library is <strong><code>libnettle.so.6</code></strong>, so I fixed it as described in <strong><a href="https://localwp.com/community/t/error-creating-new-sites-due-to-missing-shared-libraries-on-linux/15073/37" target="_blank" rel="noreferrer noopener">this link.</a></strong></p>
<p>Close the Local application and run the following commands one by one:</p>
<pre class="wp-block-preformatted">$ cd ~/Downloads</pre>
<pre class="wp-block-preformatted">$ sudo dnf install wget</pre>
<pre class="wp-block-preformatted">$ wget https://kojipkgs.fedoraproject.org//packages/nettle/3.4.1rc1/3.fc31/x86_64/nettle-3.4.1rc1-3.fc31.x86_64.rpm</pre>
<pre class="wp-block-preformatted">$ rpm2cpio nettle-3.4.1rc1-3.fc31.x86_64.rpm | cpio -idmv</pre>
<pre class="wp-block-preformatted">$ sudo cp usr/lib64/libhogweed.so.4 /usr/lib64/</pre>
<pre class="wp-block-preformatted">$ sudo cp usr/lib64/libnettle.so.6 /usr/lib64/</pre>
<p>Now open Local and try to create new site. It should work now.</p>
<h2 id="conclusion" class="ftwp-heading">7. Conclusion</h2>
<p>In this guide, we discussed what is LocalWP, and how to install wordpress using LocalWP in Linux. Setting up Local wordpress development environment gives you a safer and stress-free development experience. Using Local, you can deploy, build and test single or multiple WordPress sites faster in your local system.</p>
<p><strong>Further reading:</strong></p>
<ul><li><strong><a href="https://localwp.com/help-docs/" target="_blank" rel="noreferrer noopener">LocalWP documentation</a></strong></li></ul>
<p><em>Featured image by <a href="https://pixabay.com/users/doki7-646987/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=581849" target="_blank" rel="noreferrer noopener nofollow">Dok Sev</a> from <a href="https://pixabay.com/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=581849" target="_blank" rel="noreferrer noopener nofollow">Pixabay</a>.</em></p>
</div>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://ostechnix.com/tag/apache/" rel="tag">Apache</a><a href="https://ostechnix.com/tag/cms/" rel="tag">CMS</a><a href="https://ostechnix.com/tag/flywheel/" rel="tag">Flywheel</a><a href="https://ostechnix.com/tag/install-wordpress/" rel="tag">Install Wordpress</a><a href="https://ostechnix.com/tag/lamp-stack/" rel="tag">LAMP Stack</a><a href="https://ostechnix.com/tag/lemp-stack/" rel="tag">LEMP Stack</a><a href="https://ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://ostechnix.com/tag/mailhog/" rel="tag">MailHog</a><a href="https://ostechnix.com/tag/nginx/" rel="tag">nginx</a><a href="https://ostechnix.com/tag/php/" rel="tag">PHP</a><a href="https://ostechnix.com/tag/wordpress/" rel="tag">Wordpress</a><a href="https://ostechnix.com/tag/wp-engine/" rel="tag">Wp Engine</a><a href="https://ostechnix.com/tag/wp-cli/" rel="tag">WP-CLI</a> </div>
</div>
</div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon far fa-comment"></i>0 comment</span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">2</span><a href="#" aria-label="Like this post" class="penci-post-like single-like-button" data-post_id="32764" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon far fa-heart"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" aria-label="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/"><i class="penci-faicon fab fa-facebook-f"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" aria-label="Share on Twitter" target="_blank" rel="noreferrer" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux%20-%20https://ostechnix.com/setup-local-wordpress-development-environment-in-linux/"><i class="penci-faicon fab fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" aria-label="Share on LinkedIn" target="_blank" rel="noreferrer" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;title=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux"><i class="penci-faicon fab fa-linkedin-in"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" aria-label="Share on Reddit" target="_blank" rel="noreferrer" href="https://reddit.com/submit?url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;title=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux"><i class="penci-faicon fab fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" aria-label="Share on Whatsapp" target="_blank" rel="noreferrer" href="https://api.whatsapp.com/send?text=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux %0A%0A https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F"><i class="penci-faicon fab fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-telegram" aria-label="Share on Telegram" target="_blank" rel="noreferrer" href="https://telegram.me/share/url?url=https%3A%2F%2Fostechnix.com%2Fsetup-local-wordpress-development-environment-in-linux%2F&#038;text=Setup%20Local%20WordPress%20Development%20Environment%20In%20Linux"><i class="penci-faicon fab fa-telegram"></i><span class="dt-share">Telegram</span></a><a class="post-share-item post-share-email" target="_blank" aria-label="Share via Email" rel="noreferrer" href="/cdn-cgi/l/email-protection#a699d5d3c4ccc3c5d29bf5c3d2d3d6839496eac9c5c7ca839496f1c9d4c2f6d4c3d5d5839496e2c3d0c3cac9d6cbc3c8d2839496e3c8d0cfd4c9c8cbc3c8d2839496efc8839496eacfc8d3de808596959e9de4e9e2ff9bced2d2d6d59c8989c9d5d2c3c5cec8cfde88c5c9cb89d5c3d2d3d68bcac9c5c7ca8bd1c9d4c2d6d4c3d5d58bc2c3d0c3cac9d6cbc3c8d28bc3c8d0cfd4c9c8cbc3c8d28bcfc88bcacfc8d3de89"><i class="penci-faicon fas fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author abio-style-1 bioimg-round">
<div class="author-img">
<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' data-lazy-src="https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></noscript> </div>
<div class="author-content">
<h5><a href="https://ostechnix.com/author/sk/" title="Author sk" rel="author">sk</a></h5>
<p>I am Senthil Kumar, more commonly known as SK to my friends, from India. I love to read, write and explore topics on Linux, Unix and all other technology related stuff.</p>
<div class="bio-social">
<a rel="noreferrer" target="_blank" class="author-social" href="https://ostechnix.com/"><i class="penci-faicon fas fa-globe"></i></a>
<a rel="noreferrer" target="_blank" class="author-social" href="https://facebook.com/ostechnix"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a rel="noreferrer" target="_blank" class="author-social" href="https://twitter.com/ostechnix"><i class="penci-faicon fab fa-twitter"></i></a>
<a rel="noreferrer" target="_blank" class="author-social" href="https://www.linkedin.com/in/ostechnix/"><i class="penci-faicon fab fa-linkedin-in"></i></a>
</div>
</div>
</div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>Previous post</span>
</div>
<a href="https://ostechnix.com/setup-backup-server-using-rsnapshot-linux/">
<div class="pagi-text">
<h5 class="prev-title">How To Setup Backup Server Using Rsnapshot In Linux</h5>
</div>
</a>
</div>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">You May Also Like</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-loop="false" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true">
<div class="item-related">
<a class="related-thumb penci-image-holder owl-lazy" data-src="https://ostechnix.com/wp-content/uploads/2016/08/Install-Wordpress-4.5-1.png" href="https://ostechnix.com/install-wordpress-4-5-ubuntu-16-04-using-lamp/" title="Install WordPress 4.6 in Ubuntu 16.04 with LAMP stack [Updated]">
</a>
<h3><a href="https://ostechnix.com/install-wordpress-4-5-ubuntu-16-04-using-lamp/">Install WordPress 4.6 in Ubuntu 16.04 with LAMP...</a></h3>
<span class="date"><time class="entry-date published" datetime="2016-08-27T19:40:43+05:30">August 27, 2016</time></span>
</div>
</div></div>
<div class="post-comments no-comment-yet penci-comments-hide-1" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/setup-local-wordpress-development-environment-in-linux/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p>
<div class="penci-gdpr-message">* By using this form you agree with the storage and handling of your data by this website.</div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='32764' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ae5bd0b789" /></p><input type="hidden" id="ak_js" name="ak_js" value="137" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> 
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-2 pcalign-left  pciconp-right pcicon-right penci-sticky-sidebar">
<div class="theiaStickySidebar">
<aside id="penci_social_widget-1" class="widget penci_social_widget"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Networks</span></h3>
<div class="widget-social pc_aligncenter show-text remove-circle penci-social-textcolored">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 14px"></i><span style="font-size: 14px">Facebook</span></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 14px"></i><span style="font-size: 14px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 14px"></i><span style="font-size: 14px">Linkedin</span></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 14px"></i><span style="font-size: 14px">Reddit</span></a>
</div>
</aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="5990223580" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h3><div class="textwidget custom-html-widget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
<p style="text-align: center">Subscribe our Newsletter for new posts. Stay updated from your inbox!</p>
<p style="text-align: center; font-size:12px; text-transform: uppercase; margin-top:12px"><input type="text" name="email" placeholder="Email..." /><span style="display:block; margin-top:-15px; margin-bottom:15px">We Respect your Privacy.</span></p>
<input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /></form></div></aside><aside id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="6186167963" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside> </div>
</div> </div>
</div>
</div>
<div class="penci-ldsingle"><div class="penci-ldspinner"><div class="bounce1"></div><div class="bounce2"></div><div class="bounce3"></div></div></div>
<div class="clear-footer"></div>
<div id="widget-area">
<div class="container">
<div class="footer-widget-wrapper footer-widget-style-10">
<aside id="text-8" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About OSTechNix</span></h4> <div class="textwidget"><p><a href="https://ostechnix.com/"><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 340px) 100vw, 340px" />
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20340%2068&#039;%3E%3C/svg%3E" alt="Ostechnix Footer Logo" width="340" height="68" data-lazy-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" data-lazy-sizes="(max-width: 340px) 100vw, 340px" data-lazy-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" />
</picture>
<noscript><picture class="aligncenter wp-image-25308 size-full">
<source type="image/webp" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png.webp 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png.webp 300w" sizes="(max-width: 340px) 100vw, 340px"/>
<img src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png" alt="Ostechnix Footer Logo" width="340" height="68" srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo.png 340w, https://ostechnix.com/wp-content/uploads/2020/08/ostechnixcom-footer-new-logo-300x60.png 300w" sizes="(max-width: 340px) 100vw, 340px"/>
</picture>
</noscript></a></p>
<p>&nbsp;</p>
<p style="text-align: justify;">OSTechNix (Open Source, Technology, Nix*) regularly publishes the latest news, how-to articles, tutorials and tips &amp; tricks about free and opensource software and technology.</p>
</div>
</aside><aside id="penci_social_widget-2" class="widget penci_social_widget">
<div class="widget-social pc_aligncenter remove-circle">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="/cdn-cgi/l/email-protection#caa3a4aca58aa5b9beafa9a2a4a3b2e4a9a5a7" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope" style="font-size: 18px"></i><span style="font-size: 13px">Email</span></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien" style="font-size: 18px"></i><span style="font-size: 13px">Reddit</span></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">Rss</span></a>
</div>
</aside> </div>
<div class="footer-widget-wrapper footer-widget-style-10 last">
<aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4> <ul id="penci-popularwg-1080" class="side-newsfeed display-order-numbers">
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">1</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2020/08/Fix-Busybox-Initramfs-Error-On-Ubuntu-263x175.png" href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" title="How To Fix Busybox Initramfs Error On Ubuntu"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/" rel="bookmark" title="How To Fix Busybox Initramfs Error On Ubuntu">
How To Fix Busybox Initramfs Error On Ubuntu </a>
</h4>
<div class="grid-post-box-meta penci-side-item-meta">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-08-06T19:48:38+05:30">August 6, 2020</time></span>
</div>
</div>
</div>
</li>
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">2</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2019/06/youtube-dl.png" href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" title="Youtube-dl Tutorial With Examples For Beginners"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/youtube-dl-tutorial-with-examples-for-beginners/" rel="bookmark" title="Youtube-dl Tutorial With Examples For Beginners">
Youtube-dl Tutorial With Examples For Beginners </a>
</h4>
<div class="grid-post-box-meta penci-side-item-meta">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2019-06-26T20:31:58+05:30">June 26, 2019</time></span>
</div>
</div>
</div>
</li>
<li class="penci-feed">
<span class="order-border-number">
<span class="number-post">3</span>
</span>
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://ostechnix.com/wp-content/uploads/2018/12/Fix-Broken-Ubuntu-OS.jpg" href="https://ostechnix.com/how-to-fix-broken-ubuntu-os-without-reinstalling-it/" title="How To Fix Broken Ubuntu OS Without Reinstalling It"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://ostechnix.com/how-to-fix-broken-ubuntu-os-without-reinstalling-it/" rel="bookmark" title="How To Fix Broken Ubuntu OS Without Reinstalling It">
How To Fix Broken Ubuntu OS Without Reinstalling It </a>
</h4>
<div class="grid-post-box-meta penci-side-item-meta">
<span class="side-item-meta side-wdate"><time class="entry-date published" datetime="2020-04-25T18:00:42+05:30">April 25, 2020</time></span>
</div>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-logo-copyright footer-not-logo footer-not-gotop">
<div class="footer-menu-wrap" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-5200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5200"><a title="About Us" target="_blank" rel="noopener" href="https://ostechnix.com/about/">About</a></li>
<li id="menu-item-5199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5199"><a target="_blank" rel="noopener" href="https://ostechnix.com/contact-us/">Contact Us</a></li>
<li id="menu-item-5201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5201"><a target="_blank" rel="noopener" href="https://ostechnix.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5203"><a target="_blank" rel="noopener" href="https://ostechnix.com/sitemap/">Sitemap</a></li>
<li id="menu-item-5202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5202"><a target="_blank" rel="noopener" href="https://ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul> </div>
<div id="footer-copyright">
<p>OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</p>
</div>
</div>
<div class="penci-go-to-top-floating"><i class="penci-faicon fas fa-angle-up"></i></div>
</div>
</footer>
</div>
<a id="close-sidebar-nav" class="header-3"><i class="penci-faicon fas fa-times"></i></a>
<nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://ostechnix.com/"><picture class="penci-lazy">
<source type="image/webp" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png.webp" srcset="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" />
<img width="6" height="4" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-mobile-logo.png" alt="OSTechNix" />
</picture>
</a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a>
<a href="/cdn-cgi/l/email-protection#0960676f6649667a7d6c6a61676071276a6664" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a>
</div> </div>
<div class="penci-hbg-search-box penci-vernav-search-box">
<form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/">
<div class="inner-hbg-search-form">
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" />
<i class="penciicon-magnifiying-glass"></i>
</div>
</form>
</div>
<ul id="menu-header-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25071"><a href="https://ostechnix.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32273"><a href="https://ostechnix.com/category/command-line-utilities/">Command line utilities</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-941"><a target="_blank" href="https://ostechnix.com/category/database/">Database</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32270"><a href="https://ostechnix.com/category/devops/">DevOps</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-944"><a target="_blank" href="https://ostechnix.com/category/mobile/">Mobile</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-32271"><a href="https://ostechnix.com/category/programming/">Programming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-932"><a target="_blank" href="https://ostechnix.com/category/security/">Security</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32272"><a href="https://ostechnix.com/category/virtualization/">Virtualization</a></li>
</ul> </nav>
<div class="penci-menu-hbg-overlay"></div>
<div class="penci-menu-hbg penci-vernav-hide penci-menu-hbg-left">
<div class="penci-menu-hbg-inner">
<a id="penci-close-hbg"><i class="penci-faicon fas fa-times"></i></a>
<div class="penci-hbg-header">
<div class="penci-hbg-logo site-branding">
<a href="https://ostechnix.com/"><picture class="penci-lazy">
<source type="image/webp" data-srcset="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png.webp" srcset="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" />
<img width="6" height="4" src="https://ostechnix.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://ostechnix.com/wp-content/uploads/2020/08/ostechnix-header-new-logo.png" alt="OSTechNix" />
</picture>
</a>
</div>
</div>
<div class="penci-hbg-search-box">
<form role="search" method="get" class="pc-searchform penci-hbg-search-form" action="https://ostechnix.com/">
<div class="inner-hbg-search-form">
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" />
<i class="penciicon-magnifiying-glass"></i>
</div>
</form>
</div>
<div class="penci-hbg-content penci-sidebar-content style-2 pcalign-left pciconp-right pcicon-right">
<ul id="menu-top-menu-1" class="menu menu-hgb-main"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://ostechnix.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" href="https://ostechnix.com/category/opensource/">Open Source</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://ostechnix.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a target="_blank" href="https://ostechnix.com/category/linux/">Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a target="_blank" href="https://ostechnix.com/category/unix/">Unix</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="https://ostechnix.tradepub.com/category/information-technology/1207/">Free Ebooks And Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://ostechnix.com/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24643"><a target="_blank" href="https://ostechnix.com/contact-us/">Contact Us</a></li>
</ul> </div>
<div class="penci-hbg-footer">
<div class="penci_menu_hbg_ftext">OSTechNix © 2021. All Rights Reserved. This site is licensed under <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank">CC BY-NC 4.0</a>.</div> <div class="header-social sidebar-nav-social penci-hbg-social-style-4 penci-social-colored">
<div class="inner-header-social">
<a href="https://www.facebook.com/ostechnix/" aria-label="Facebook" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-facebook-f"></i></a>
<a href="https://twitter.com/ostechnix" aria-label="Twitter" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-twitter"></i></a>
<a href="https://in.linkedin.com/in/ostechnix" aria-label="Linkedin" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-linkedin-in"></i></a>
<a href="https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g" aria-label="Youtube" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-youtube"></i></a>
<a href="/cdn-cgi/l/email-protection#533a3d353c133c202736303b3d3a2b7d303c3e" aria-label="Email" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-envelope"></i></a>
<a href="https://www.reddit.com/r/OSTechNix/" aria-label="Reddit" rel="noreferrer" target="_blank"><i class="penci-faicon fab fa-reddit-alien"></i></a>
<a href="https://feeds.feedburner.com/Ostechnix" aria-label="Rss" rel="noreferrer" target="_blank"><i class="penci-faicon fas fa-rss"></i></a>
</div> </div>
</div>
</div>
</div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="https://ostechnix.com/terms-and-conditions/">Read More</a> </p>
</div>
</div>
<!--[if lte IE 9]>
        <script>
            'use strict';
            (function($) {
                $(document).ready(function() {
                    $('#ftwp-container').addClass('ftwp-ie9');
                });
            })(jQuery);
        </script>
        <![endif]-->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/ullavidu\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/ostechnix.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://ostechnix.com/wp-content/themes/soledad/js/libs-script.min.js?ver=7.9.5' id='penci-libs-js-js' defer></script>
<script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"045e20123e","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/main.js?ver=1627317724' id='main-scripts-js' defer></script>
<script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"045e20123e","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/post-like.js?ver=1627317724' id='penci_ajax_like_post-js' defer></script>
<script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"045e20123e","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/js/more-post.js?ver=1627317724' id='penci_ajax_more_posts-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-includes/js/comment-reply.min.js?ver=c73594908fc6a581c289f9d0c796dd19' id='comment-reply-js' defer></script>
<script type='text/javascript' id='fixedtoc-js-js-extra'>
/* <![CDATA[ */
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"10","fixedOffsetY":"0","fixedPosition":"middle-left","contentsFixedHeight":"","inPost":"1","contentsFloatInPost":"none","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"thin","triggerSize":"50","isClickableHeader":"1","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js?ver=3.1.22' id='fixedtoc-js-js' defer></script>
<script type='text/javascript' src='https://ostechnix.com/wp-includes/js/wp-embed.min.js?ver=c73594908fc6a581c289f9d0c796dd19' id='wp-embed-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" defer data-rocket-type='text/javascript' src='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/akismet/_inc/form.js?ver=1627317728' id='akismet-form-js'></script>
<script src='https://stats.wp.com/e-202130.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.9.1',blog:'84551477',post:'32764',tz:'5.5',srv:'ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '32764' ]);
</script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
	function PenciSimplePopularPosts_AddCount(id, endpoint)
	{
		var xmlhttp;
		var params = "/?penci_spp_count=1&penci_spp_post_id=" + id + "&cachebuster=" +  Math.floor((Math.random() * 100000));
		// code for IE7+, Firefox, Chrome, Opera, Safari

		if (window.XMLHttpRequest){
			xmlhttp=new XMLHttpRequest();
		}else{
			xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
		}

		xmlhttp.onreadystatechange=function(){
			if ( xmlhttp.readyState == 4 && xmlhttp.status == 200 ) {
				var data = JSON.parse( xmlhttp.responseText );
				document.getElementsByClassName( "penci-post-countview-number" )[0].innerHTML = data.visits;
			}
		}

		xmlhttp.open("GET", endpoint + params, true);
		xmlhttp.send();
	}
	PenciSimplePopularPosts_AddCount(32764, 'https://ostechnix.com');
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ostechnix.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-75259810-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-75259810-1');
</script>
<script type="rocketlazyloadscript">"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://ostechnix.com/wp-includes/css/dist/block-library/style.min.css?ver=c73594908fc6a581c289f9d0c796dd19' type='text/css' media='all' /><link rel='stylesheet' id='mediaelement-css'  href='https://ostechnix.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' /><link rel='stylesheet' id='wp-mediaelement-css'  href='https://ostechnix.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=c73594908fc6a581c289f9d0c796dd19' type='text/css' media='all' /><link rel='stylesheet' id='penci-soledad-parent-style-css'  href='https://ostechnix.com/wp-content/themes/soledad/style.css?ver=c73594908fc6a581c289f9d0c796dd19' type='text/css' media='all' /><link rel='stylesheet' id='penci-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap&#038;ver=1.0' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='penci-main-style-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/main.css?ver=1627317724' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='penci-font-awesomeold-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.4.7.0.swap.min.css?ver=1627317724' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='penci-font-iweather-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/weather-icon.swap.css?ver=1627317724' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='penci-font-awesome-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/font-awesome.5.11.2.swap.min.css?ver=1627317724' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='penci_icon-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/themes/soledad/css/penci-icon.css?ver=1627317724' type='text/css' media='all' /><link rel='stylesheet' id='penci_style-css'  href='https://ostechnix.com/wp-content/themes/soledad-child/style.css?ver=7.9.5' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='fixedtoc-style-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=1627317728' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='jetpack_css-css'  href='https://ostechnix.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1627317724' type='text/css' media='all' /></noscript><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6750cd1a5cd73805","token":"5e2f2ddb82854c1fb0f45e878c5e49ff","version":"2021.7.0","si":10}'></script>
</body>
</html>
